647f2bc640
This fixes op6 display panel support, drm error spam in dmesg, and various other minor things. It also enabled dynamic debugging and ftrace. Signed-off-by: Caleb Connolly <caleb@postmarketos.org>
76 lines
2.3 KiB
Text
76 lines
2.3 KiB
Text
# Maintainer: Caleb Connolly <caleb@connolly.tech>
|
|
# Co-Maintainer: Joel Selvaraj <joelselvaraj.oss@gmail.com>
|
|
# Stable Linux kernel with patches for SDM845 devices
|
|
# Kernel config based on: arch/arm64/configs/defconfig and sdm845.config
|
|
|
|
_flavor="postmarketos-qcom-sdm845"
|
|
pkgname=linux-$_flavor
|
|
pkgver=6.9.0
|
|
pkgrel=2
|
|
pkgdesc="Mainline Kernel fork for SDM845 devices"
|
|
arch="aarch64"
|
|
_carch="arm64"
|
|
url="https://gitlab.com/sdm845-mainline/linux"
|
|
license="GPL-2.0-only"
|
|
options="!check !tracedeps
|
|
pmb:cross-native
|
|
pmb:kconfigcheck-community"
|
|
makedepends="bash bison findutils flex installkernel openssl-dev perl zstd python3"
|
|
|
|
_config="config-$_flavor.$arch"
|
|
_tag="sdm845-6.9.0-r2"
|
|
|
|
# Source
|
|
source="
|
|
linux-$_tag.tar.gz::https://gitlab.com/sdm845-mainline/linux/-/archive/$_tag/linux-$_tag.tar.gz
|
|
$_config
|
|
"
|
|
builddir="$srcdir/linux-$_tag"
|
|
|
|
prepare() {
|
|
default_prepare
|
|
cp "$srcdir/config-$_flavor.$arch" .config
|
|
}
|
|
|
|
build() {
|
|
unset LDFLAGS
|
|
make ARCH="$_carch" CC="${CC:-gcc}" \
|
|
KBUILD_BUILD_VERSION="$((pkgrel + 1 ))-$_flavor"
|
|
}
|
|
|
|
package() {
|
|
if [ -e "$builddir/arch/$_carch/boot/vmlinuz.efi" ]; then
|
|
# ZBOOT EFI decompressor for EFI booting
|
|
install -Dm644 "$builddir/arch/$_carch/boot/vmlinuz.efi" \
|
|
"$pkgdir/boot/linux.efi"
|
|
|
|
# Old GZIP'd kernel image for boot.img compatibility
|
|
install -Dm644 "$builddir/arch/$_carch/boot/vmlinuz" \
|
|
"$pkgdir/boot/vmlinuz"
|
|
else
|
|
echo "WARNING: CONFIG_ZBOOT not enabled!"
|
|
install -Dm644 "$builddir/arch/$_carch/boot/Image.gz" \
|
|
"$pkgdir/boot/vmlinuz"
|
|
fi
|
|
|
|
make modules_install dtbs_install \
|
|
ARCH="$_carch" \
|
|
INSTALL_PATH="$pkgdir"/boot/ \
|
|
INSTALL_MOD_PATH="$pkgdir" \
|
|
INSTALL_MOD_STRIP=1 \
|
|
INSTALL_DTBS_PATH="$pkgdir"/boot/dtbs-tmp
|
|
|
|
mkdir -p "$pkgdir"/boot/dtbs/qcom
|
|
cp -r "$pkgdir"/boot/dtbs-tmp/qcom/sdm8* "$pkgdir"/boot/dtbs/qcom
|
|
rm -rf "$pkgdir"/boot/dtbs-tmp
|
|
|
|
rm -f "$pkgdir"/lib/modules/*/build "$pkgdir"/lib/modules/*/source
|
|
|
|
install -D "$builddir"/include/config/kernel.release \
|
|
"$pkgdir"/usr/share/kernel/$_flavor/kernel.release
|
|
}
|
|
|
|
sha512sums="
|
|
45fb653328776a7b3687b9192979ada93c5ac7c321d54d4b72f47cddc10120982701d4990edc9103f6ec3ffcd2bc917b43ce7fea6ec15a3d3aded2279ecd9226 linux-sdm845-6.9.0-r2.tar.gz
|
|
8a5e7b40e82196bcf7c160a3e6de34b7b0328431af7b4ac636d9687035e40f542f05424dc918443ea020067b900d8b87f62d17827e1d192f2f68917034c43a08 config-postmarketos-qcom-sdm845.aarch64
|
|
"
|