b9271e0a90
- kconfig rebased onto jhovold's defconfig (many things are now modules, but also includes initial camera support and other things) - set CONFIG_FRAMEBUFFER_CONSOLE_DEFERRED_TAKEOVER=y, to try and hide some super early kernel messages printed on console - enabled kconfig options for supporting USB tethering e.g. w/ android [ci:skip-build]: already built successfully in CI
72 lines
1.8 KiB
Text
72 lines
1.8 KiB
Text
# Maintainer: Clayton Craft <clayton@craftyguy.net>
|
|
# Co-Maintainer: jane400 <jane400@postmarketos.org>
|
|
# Contributor: Konrad Dybcio <konradybcio@kernel.org>
|
|
pkgname=linux-lenovo-21bx
|
|
pkgver=6.10
|
|
pkgrel=0
|
|
_commit="f0239008542ebdcd4a94755124b5700649df5c39"
|
|
pkgdesc="Lenovo ThinkPad X13s kernel fork"
|
|
arch="aarch64"
|
|
_carch="arm64"
|
|
_flavor="lenovo-21bx"
|
|
url="https://kernel.org"
|
|
license="GPL-2.0-only"
|
|
options="!strip
|
|
!check
|
|
!tracedeps
|
|
pmb:cross-native
|
|
pmb:kconfigcheck-community
|
|
pmb:kconfigcheck-containers
|
|
pmb:kconfigcheck-uefi
|
|
"
|
|
makedepends="
|
|
bash
|
|
bison
|
|
findutils
|
|
flex
|
|
musl-dev
|
|
openssl-dev
|
|
perl
|
|
python3
|
|
postmarketos-installkernel
|
|
"
|
|
|
|
# Source
|
|
_repository="linux"
|
|
_config="config-$_flavor.$arch"
|
|
source="
|
|
$pkgname-$_commit.tar.gz::https://github.com/jhovold/$_repository/archive/$_commit.tar.gz
|
|
$_config
|
|
"
|
|
builddir="$srcdir/linux-$_commit"
|
|
_outdir="out"
|
|
|
|
prepare() {
|
|
default_prepare
|
|
cp "$srcdir/config-$_flavor.$arch" .config
|
|
}
|
|
|
|
build() {
|
|
unset LDFLAGS
|
|
make ARCH="$_carch" CC="${CC:-gcc}" \
|
|
KBUILD_BUILD_VERSION="$((pkgrel + 1 ))-$_flavor"
|
|
}
|
|
|
|
package() {
|
|
mkdir -p "$pkgdir"/boot
|
|
make zinstall modules_install dtbs_install \
|
|
ARCH="$_carch" \
|
|
INSTALL_PATH="$pkgdir"/boot \
|
|
INSTALL_MOD_PATH="$pkgdir" \
|
|
INSTALL_MOD_STRIP=1 \
|
|
INSTALL_DTBS_PATH="$pkgdir"/boot/dtbs
|
|
rm -f "$pkgdir"/lib/modules/*/build "$pkgdir"/lib/modules/*/source
|
|
|
|
install -D "$builddir"/include/config/kernel.release \
|
|
"$pkgdir"/usr/share/kernel/$_flavor/kernel.release
|
|
}
|
|
|
|
sha512sums="
|
|
efbf5fdaba513098c9c0f8eb2a559e58c6fd1180bcdf897514b2104480f0d2de2065f073d12204989804b61b083c2b3f9d605493ca6e89bb25e0beeae8545273 linux-lenovo-21bx-f0239008542ebdcd4a94755124b5700649df5c39.tar.gz
|
|
4ce995e9f5d71d9e1037072d5f05166cfb1b03d95bfb9a88269e9e2be9960894e9a2ca29f8a25855777291b676e423ce2ee56386372692820ea1722e5b3e9c9e config-lenovo-21bx.aarch64
|
|
"
|