3ed9591e41
This cmdline argument is now a no-op. Drop it everywhere and add a new CI check to enforce this. Adjust the deprecated "minimal" initramfs variant to use pmos.debug-shell to enable logging instead. It doesn't /support/ dropping to a shell, so the variable takes on a different meaning. But that's ok since it's at least more consistent. [ci:ignore-count] [ci:skip-vercheck] Signed-off-by: Caleb Connolly <caleb@postmarketos.org> Tweaked-by: Oliver Smith <ollieparanoid@postmarketos.org> [ci:skip-build]: kernel builds are very likely to go through now
49 lines
1.3 KiB
Text
49 lines
1.3 KiB
Text
# Maintainer: Alejandro Tafalla <alikates@dnyon.com>
|
|
# Reference: <https://postmarketos.org/devicepkg>
|
|
pkgname=device-xiaomi-daisy
|
|
pkgdesc="Xiaomi Mi A2 Lite"
|
|
pkgver=11
|
|
pkgrel=3
|
|
url="https://postmarketos.org"
|
|
license="MIT"
|
|
arch="aarch64"
|
|
options="!check !archcheck"
|
|
depends="
|
|
firmware-qcom-adreno-a530
|
|
firmware-xiaomi-daisy
|
|
linux-postmarketos-qcom-msm8953
|
|
lk2nd-msm8953
|
|
mkbootimg
|
|
msm-firmware-loader
|
|
postmarketos-base
|
|
qbootctl
|
|
soc-qcom-msm8953
|
|
soc-qcom-msm8953-modem
|
|
"
|
|
makedepends="devicepkg-dev"
|
|
subpackages="$pkgname-fake-goodix:fake_goodix"
|
|
|
|
source="
|
|
deviceinfo
|
|
modules-initfs
|
|
90-device-xiaomi-daisy.rules
|
|
"
|
|
|
|
build() {
|
|
devicepkg_build $startdir $pkgname
|
|
}
|
|
|
|
package() {
|
|
devicepkg_package $startdir $pkgname
|
|
}
|
|
|
|
fake_goodix() {
|
|
pkgdesc="Calibration data for replacement goodix touch controllers"
|
|
install -Dm644 90-device-xiaomi-daisy.rules -t "$subpkgdir/etc/udev/rules.d/"
|
|
}
|
|
|
|
sha512sums="
|
|
327d6b49c6bc26725ed566ee968220cd7bbd5c8fd31b91705b6a02635daf5ce02567ba493a5bd431e0438339e004d42c7f4a57d4ed683274b94dc78668771d8d deviceinfo
|
|
7202f0a55dfe43348940412fc38e59c855594b070db8742419feadb2299086d5810107201a228b7137b7cc7a97c94afac95d81c0cd65c52f31dbcb619b0a4279 modules-initfs
|
|
a2608b01b7b6e2dade694af355ff4f0f26cad49cf54bc332c77eb75d19fdc985f7f996fedb72753de447be0391deabf5fcea52406791d1e6e0d165703b63f145 90-device-xiaomi-daisy.rules
|
|
"
|