pmaports/device/community/device-xiaomi-beryllium/APKBUILD
Caleb Connolly 3ed9591e41
treewide: drop PMOS_NO_OUTPUT_REDIRECT (MR 5240)
This cmdline argument is now a no-op. Drop it everywhere and add a new
CI check to enforce this.

Adjust the deprecated "minimal" initramfs variant to use
pmos.debug-shell to enable logging instead. It doesn't /support/
dropping to a shell, so the variable takes on a different meaning. But
that's ok since it's at least more consistent.

[ci:ignore-count]
[ci:skip-vercheck]
Signed-off-by: Caleb Connolly <caleb@postmarketos.org>
Tweaked-by: Oliver Smith <ollieparanoid@postmarketos.org>
[ci:skip-build]: kernel builds are very likely to go through now
2024-06-23 14:48:20 +02:00

80 lines
2.8 KiB
Text

# Maintainer: Joel Selvaraj <joelselvaraj.oss@gmail.com>
# Reference: <https://postmarketos.org/devicepkg>
pkgname=device-xiaomi-beryllium
pkgdesc="Xiaomi Poco F1"
pkgver=11
pkgrel=1
url="https://postmarketos.org"
license="MIT"
arch="aarch64"
options="!check !archcheck"
depends="
postmarketos-base
mkbootimg
soc-qcom-sdm845
soc-qcom-sdm845-ucm
"
makedepends="devicepkg-dev"
subpackages="
$pkgname-nonfree-firmware:nonfree_firmware
$pkgname-kernel-tianma:kernel_tianma
$pkgname-kernel-ebbg:kernel_ebbg
"
source="
deviceinfo
hexagonrpcd.confd
modules-initfs.ebbg
modules-initfs.tianma
q6voiced.conf
81-libssc-xiaomi-beryllium.rules
"
build() {
devicepkg_build $startdir $pkgname
}
package() {
devicepkg_package $startdir $pkgname
}
nonfree_firmware() {
pkgdesc="GPU, venus, modem and sensor firmware"
install="$subpkgname.post-install $subpkgname.post-upgrade"
depends="
firmware-xiaomi-beryllium
soc-qcom-sdm845-nonfree-firmware
soc-qcom-sdm845-modem
hexagonrpcd
"
replaces="hexagonrpcd-openrc"
mkdir "$subpkgdir"
install -Dm644 q6voiced.conf "$subpkgdir"/etc/conf.d/q6voiced
install -Dm644 81-libssc-xiaomi-beryllium.rules \
"$subpkgdir"/etc/udev/rules.d/81-libssc-xiaomi-beryllium.rules
install -Dm644 "$srcdir"/hexagonrpcd.confd "$subpkgdir"/etc/conf.d/hexagonrpcd-sdsp
}
kernel_tianma() {
pkgdesc="Tianma Panel. To know which panel your device use and the status of the port, Visit the Poco F1 wiki page: https://wiki.postmarketos.org/wiki/Xiaomi_Poco_F1_(xiaomi-beryllium)"
depends="linux-postmarketos-qcom-sdm845"
devicepkg_subpackage_kernel $startdir $pkgname $subpkgname
}
kernel_ebbg() {
pkgdesc="EBBG Panel. To know which panel your device use and the status of the port, Visit the Poco F1 wiki page: https://wiki.postmarketos.org/wiki/Xiaomi_Poco_F1_(xiaomi-beryllium)"
depends="linux-postmarketos-qcom-sdm845"
devicepkg_subpackage_kernel $startdir $pkgname $subpkgname
}
sha512sums="
2cb2a7203bd4a758007c41e06f0c0319ff2bd51714798dba91828238615fe668c05ddfd96754afbf7a9bd7822c47608e012c2b891cb9e26b32f2558b9dc69978 deviceinfo
52079045a0c1f48628d891bf8867f5c1802152fce8e2c4bd787630f1f5e4c9b386bfc373e464cb053688350ac678dbc3c407a76a31a1ae700ca67764d0d384f1 hexagonrpcd.confd
cab76675b9c48eb1ce0691b31667d17ee73ecf21439a7f7c9c2ba96344e3bf4ad713ebc685298d6e32ad589ba26f429cd6b0d200338b50d136ad1a29758e4214 modules-initfs.ebbg
175a7d859956a029b91a1105b93c4113b07ab5cfe932294dd369808059ed03471625f64ce90e5146a65c0bb26417470d8f7c02e48dfacf2d016ce5b2c28cee76 modules-initfs.tianma
3a4a9322839d4b3ef9d79668a37840a9f444954759ae3c512e694051d2f9a2573db42ad6c4c1a5c75eeb861232a27ba1a8cef9b503decd54ead25a96e3dd6f98 q6voiced.conf
2c16ba75e0077b2b1eaefa4c73b287475505a1aeb291ec29316d41cc094277320f9d2aaabfd91eb1dc0f488ab2d61a94faef16e7afe0f1e226779113761b9a37 81-libssc-xiaomi-beryllium.rules
"