3ed9591e41
This cmdline argument is now a no-op. Drop it everywhere and add a new CI check to enforce this. Adjust the deprecated "minimal" initramfs variant to use pmos.debug-shell to enable logging instead. It doesn't /support/ dropping to a shell, so the variable takes on a different meaning. But that's ok since it's at least more consistent. [ci:ignore-count] [ci:skip-vercheck] Signed-off-by: Caleb Connolly <caleb@postmarketos.org> Tweaked-by: Oliver Smith <ollieparanoid@postmarketos.org> [ci:skip-build]: kernel builds are very likely to go through now
53 lines
1.6 KiB
Text
53 lines
1.6 KiB
Text
# Reference: <https://postmarketos.org/devicepkg>
|
|
# Maintainer: Nikita Travkin <nikita@trvn.ru>
|
|
pkgname=device-samsung-gt58
|
|
pkgdesc="Samsung Galaxy Tab A 8.0 (2015)"
|
|
pkgver=6
|
|
pkgrel=1
|
|
url="https://postmarketos.org"
|
|
license="MIT"
|
|
arch="aarch64"
|
|
options="!check !archcheck"
|
|
depends="postmarketos-base mkbootimg linux-postmarketos-qcom-msm8916
|
|
soc-qcom-msm8916 soc-qcom-msm8916-rproc"
|
|
makedepends="devicepkg-dev dtbtool"
|
|
source="
|
|
deviceinfo
|
|
modules-initfs
|
|
phoc.ini
|
|
"
|
|
subpackages="
|
|
$pkgname-nonfree-firmware:nonfree_firmware
|
|
$pkgname-phosh
|
|
"
|
|
_pmb_select="soc-qcom-msm8916-rproc"
|
|
|
|
# Backwards compatibility for old kernel variant subpackages
|
|
replaces="$pkgname-kernel-mainline $pkgname-kernel-mainline-modem-lte"
|
|
for pkg in $replaces; do provides="$provides $pkg=$pkgver-r$pkgrel"; done
|
|
|
|
build() {
|
|
devicepkg_build $startdir $pkgname
|
|
}
|
|
|
|
package() {
|
|
devicepkg_package $startdir $pkgname
|
|
}
|
|
|
|
nonfree_firmware() {
|
|
pkgdesc="GPU/WiFi/BT/Modem/Video firmware"
|
|
depends="firmware-qcom-adreno-a300 msm-firmware-loader firmware-samsung-gt58-wcnss-nv"
|
|
mkdir "$subpkgdir"
|
|
}
|
|
|
|
phosh() {
|
|
install_if="$pkgname postmarketos-ui-phosh"
|
|
install -Dm644 "$srcdir"/phoc.ini \
|
|
"$subpkgdir"/etc/phosh/phoc.ini
|
|
}
|
|
|
|
sha512sums="
|
|
2e7363625b58da2fe036fc70538207a490d5b93a99c3d0c2835fab3114fe09b5e90a3b7583b8f62d8eea7af7910f963d0aa994483045d570f062449cc939fb13 deviceinfo
|
|
8071b89c832619c74d3bb50d638653aeaab99fee209cde425a7e8425d46d424bad9e8ab76d2d7360bd4c7ff093a712d51c3ca1b6086e1f70812224bbb115b04f modules-initfs
|
|
ed612b090c1ee512fc257368082fe0c88ca6c98a9d673ece68593739c7a41b4f9dca5d9360de6f84d206f297feba480a9f1982301132e08a14a5ff920a2675a6 phoc.ini
|
|
"
|