pmaports/device/community/device-samsung-a5/APKBUILD
Caleb Connolly 3ed9591e41
treewide: drop PMOS_NO_OUTPUT_REDIRECT (MR 5240)
This cmdline argument is now a no-op. Drop it everywhere and add a new
CI check to enforce this.

Adjust the deprecated "minimal" initramfs variant to use
pmos.debug-shell to enable logging instead. It doesn't /support/
dropping to a shell, so the variable takes on a different meaning. But
that's ok since it's at least more consistent.

[ci:ignore-count]
[ci:skip-vercheck]
Signed-off-by: Caleb Connolly <caleb@postmarketos.org>
Tweaked-by: Oliver Smith <ollieparanoid@postmarketos.org>
[ci:skip-build]: kernel builds are very likely to go through now
2024-06-23 14:48:20 +02:00

47 lines
1.7 KiB
Text

# Reference: <https://postmarketos.org/devicepkg>
# Maintainer: Minecrell <minecrell@minecrell.net>
# Co-Maintainer: Alexey Min <alexey.min@gmail.com>
pkgname=device-samsung-a5
pkgdesc="Samsung Galaxy A5 (2015)"
pkgver=11
pkgrel=1
url="https://postmarketos.org"
license="MIT"
arch="aarch64"
options="!check !archcheck"
depends="postmarketos-base mkbootimg linux-postmarketos-qcom-msm8916
soc-qcom-msm8916 soc-qcom-msm8916-rproc soc-samsung-msm8916-modem-workaround"
makedepends="devicepkg-dev"
source="deviceinfo modules-initfs"
subpackages="
$pkgname-nonfree-firmware:nonfree_firmware
"
_pmb_select="soc-qcom-msm8916-rproc"
# Backwards compatibility for old device package names + kernel variants
_substitutes="device-samsung-a5lte device-samsung-a5ulte"
replaces="$_substitutes $pkgname-kernel-mainline $pkgname-kernel-mainline-modem"
for pkg in $_substitutes; do replaces="$replaces $pkg-kernel-mainline $pkg-kernel-mainline-modem"; done
for pkg in $replaces; do provides="$provides $pkg=$pkgver-r$pkgrel"; done
build() {
devicepkg_build $startdir $pkgname
}
package() {
devicepkg_package $startdir $pkgname
}
nonfree_firmware() {
pkgdesc="GPU/WiFi/BT/Modem/Video firmware"
depends="firmware-qcom-adreno-a300 msm-firmware-loader firmware-samsung-a5-wcnss-nv"
replaces=""
for pkg in $_substitutes; do replaces="$replaces $pkg-nonfree-firmware"; done
for pkg in $replaces; do provides="$provides $pkg=$pkgver-r$pkgrel"; done
mkdir "$subpkgdir"
}
sha512sums="
2fc9ed97981cc439046475eef8eb6d358bfde571242b14763cf4223c076cbda9ee861221e6978056e65a09020bfaeeb7734e22782701a2bcb134ef113467dc9a deviceinfo
13ba472485d757332b46a21fe771ae2779d0c5f1e997b6e51a4c0acce902256f0a2c724828251acf0150d7de919b691053de59041fea0b983569a004dcb75256 modules-initfs
"