pmaports/device/community/device-pine64-rockpro64/APKBUILD
Caleb Connolly 3ed9591e41
treewide: drop PMOS_NO_OUTPUT_REDIRECT (MR 5240)
This cmdline argument is now a no-op. Drop it everywhere and add a new
CI check to enforce this.

Adjust the deprecated "minimal" initramfs variant to use
pmos.debug-shell to enable logging instead. It doesn't /support/
dropping to a shell, so the variable takes on a different meaning. But
that's ok since it's at least more consistent.

[ci:ignore-count]
[ci:skip-vercheck]
Signed-off-by: Caleb Connolly <caleb@postmarketos.org>
Tweaked-by: Oliver Smith <ollieparanoid@postmarketos.org>
[ci:skip-build]: kernel builds are very likely to go through now
2024-06-23 14:48:20 +02:00

32 lines
904 B
Text

# Reference: <https://postmarketos.org/devicepkg>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=device-pine64-rockpro64
pkgver=3
pkgrel=8
pkgdesc="PINE64 ROCKPro64"
url="https://postmarketos.org"
license="MIT"
arch="aarch64"
options="!check !archcheck"
depends="postmarketos-base>=25-r1 linux-postmarketos-rockchip soc-rockchip-rk3399 u-boot-rockchip"
makedepends="devicepkg-dev"
subpackages="$pkgname-nonfree-firmware:nonfree_firmware"
source="deviceinfo"
build() {
devicepkg_build $startdir $pkgname
}
package() {
devicepkg_package $startdir $pkgname
}
nonfree_firmware() {
pkgdesc="Wi-Fi, Bluetooth and video-out firmware"
depends="firmware-pine64-rockpro64 linux-firmware-brcm linux-firmware-rockchip"
mkdir "$subpkgdir"
}
sha512sums="
e215cfae2d0e42ebea9c9425ba50ffdfd96512587b6bd96bbda4f1beca77f22b79b62795818b3635a7d4cdfad120249bf3a04ccfdb4af72d228f0e3c26efee65 deviceinfo
"