3ed9591e41
This cmdline argument is now a no-op. Drop it everywhere and add a new CI check to enforce this. Adjust the deprecated "minimal" initramfs variant to use pmos.debug-shell to enable logging instead. It doesn't /support/ dropping to a shell, so the variable takes on a different meaning. But that's ok since it's at least more consistent. [ci:ignore-count] [ci:skip-vercheck] Signed-off-by: Caleb Connolly <caleb@postmarketos.org> Tweaked-by: Oliver Smith <ollieparanoid@postmarketos.org> [ci:skip-build]: kernel builds are very likely to go through now
68 lines
2.1 KiB
Text
68 lines
2.1 KiB
Text
# Reference: <https://postmarketos.org/devicepkg>
|
|
# Maintainer: Quade Curry <qc8086@qc8086.com>
|
|
pkgname=device-pine64-pinebookpro
|
|
pkgdesc="PINE64 Pinebook Pro"
|
|
pkgver=16
|
|
pkgrel=6
|
|
url="https://postmarketos.org"
|
|
license="MIT"
|
|
arch="aarch64"
|
|
options="!check !archcheck"
|
|
depends="
|
|
alsa-ucm-conf>=1.2.7
|
|
eudev-hwids
|
|
linux-postmarketos-rockchip>=5.14
|
|
nvme-cli
|
|
postmarketos-base>=25-r1
|
|
soc-rockchip-rk3399
|
|
u-boot-pinebookpro
|
|
iw
|
|
"
|
|
makedepends="devicepkg-dev"
|
|
subpackages="$pkgname-nonfree-firmware:nonfree_firmware $pkgname-elogind"
|
|
install="
|
|
$pkgname.post-install
|
|
$pkgname.post-upgrade
|
|
$pkgname-elogind.post-install
|
|
$pkgname-elogind.post-upgrade
|
|
"
|
|
source="
|
|
deviceinfo
|
|
modules-initfs
|
|
nvme-powersave.initd
|
|
wlan-powersave-off.start
|
|
enable-s2idle.conf
|
|
"
|
|
|
|
build() {
|
|
devicepkg_build $startdir $pkgname
|
|
}
|
|
|
|
package() {
|
|
devicepkg_package $startdir $pkgname
|
|
|
|
install -D -m755 "$srcdir"/nvme-powersave.initd \
|
|
"$pkgdir"/etc/init.d/nvme-powersave
|
|
|
|
install -D -m755 "$srcdir"/wlan-powersave-off.start \
|
|
"$pkgdir"/etc/local.d/wlan-powersave-off.start
|
|
}
|
|
|
|
elogind() {
|
|
install_if="$pkgname=$pkgver-r$pkgrel elogind"
|
|
install -D -m644 "$srcdir"/enable-s2idle.conf \
|
|
"$subpkgdir"/usr/lib/elogind/sleep.conf.d/enable-s2idle.conf
|
|
}
|
|
|
|
nonfree_firmware() {
|
|
pkgdesc="Wifi, Bluetooth and video-out firmware"
|
|
depends="linux-firmware-brcm linux-firmware-rockchip"
|
|
mkdir "$subpkgdir"
|
|
}
|
|
sha512sums="
|
|
7b3cd3ff2af954d07e88cca043a9975e74236bb49454bbcff8eaed23d822560ba2200adc88373dc2a0e5f130b8f90fd1c522f7b25171325d8e41e75c4b7bfba5 deviceinfo
|
|
6e3d97855a1f898db46b87ae1eb190d23d841fcb72332fcac4d11cd27c8f7d50eb8fd73007ed0447f106d19ff2e0fc1f34da1baf890e1465135dd692d65df2ba modules-initfs
|
|
2abfa31fa56028339efc6d2b6cb838f310990d7110ac4dd996bc4cfcf90f0a8770e70f28f77f7b6929d110e494bc33731302f16b9717729f991c2732be0731d5 nvme-powersave.initd
|
|
0fd7580e197e409978c219726af627cabe347404ee826e32892b61f3da1775b0fd81f8ed5e9a0f0bfaad87faa434d7a73ddaebf475ed0ad8fdcef6690cd692d3 wlan-powersave-off.start
|
|
811af9c79151f41e25916c0f0bb130e82ebfb7d4d5b63413a3fed6700f829c1c017a12e85da230ed2f47a6bd49ed2bf5da19bbc4576ce485a48a2d3808a3a691 enable-s2idle.conf
|
|
"
|