3ed9591e41
This cmdline argument is now a no-op. Drop it everywhere and add a new CI check to enforce this. Adjust the deprecated "minimal" initramfs variant to use pmos.debug-shell to enable logging instead. It doesn't /support/ dropping to a shell, so the variable takes on a different meaning. But that's ok since it's at least more consistent. [ci:ignore-count] [ci:skip-vercheck] Signed-off-by: Caleb Connolly <caleb@postmarketos.org> Tweaked-by: Oliver Smith <ollieparanoid@postmarketos.org> [ci:skip-build]: kernel builds are very likely to go through now
66 lines
1.5 KiB
Text
66 lines
1.5 KiB
Text
# Reference: <https://postmarketos.org/devicepkg>
|
|
# Maintainer: Jenneron <jenneron@protonmail.com>
|
|
# Co-Maintainer: Jethrob <jeybee@hotmail.com>
|
|
pkgname=device-microsoft-surface-rt
|
|
pkgdesc="Microsoft Surface RT"
|
|
pkgver=7
|
|
pkgrel=1
|
|
url="https://postmarketos.org"
|
|
license="MIT"
|
|
arch="armv7"
|
|
# pmb:strict: avoid grub-related install error during build with pmbootstrap
|
|
options="!check !archcheck pmb:strict"
|
|
depends="
|
|
alsa-ucm-conf
|
|
linux-postmarketos-grate
|
|
postmarketos-base
|
|
"
|
|
makedepends="devicepkg-dev grub grub-efi"
|
|
subpackages="
|
|
$pkgname-nonfree-firmware:nonfree_firmware
|
|
$pkgname-x11
|
|
"
|
|
source="deviceinfo modules-initfs"
|
|
|
|
build() {
|
|
devicepkg_build $startdir $pkgname
|
|
|
|
grub-mkimage \
|
|
--prefix="/grub" \
|
|
--output="bootarm.efi" \
|
|
--format="arm-efi" \
|
|
--compression="xz" \
|
|
\
|
|
disk \
|
|
fat \
|
|
gzio \
|
|
iso9660 \
|
|
linux \
|
|
normal \
|
|
part_gpt \
|
|
part_msdos
|
|
}
|
|
|
|
package() {
|
|
devicepkg_package $startdir $pkgname
|
|
|
|
install -D "$srcdir"/bootarm.efi \
|
|
"$pkgdir"/boot/EFI/Boot/bootarm.efi
|
|
}
|
|
|
|
nonfree_firmware() {
|
|
pkgdesc="WiFi firmware"
|
|
depends="linux-firmware-mrvl"
|
|
mkdir "$subpkgdir"
|
|
}
|
|
|
|
x11() {
|
|
install_if="$pkgname xorg-server"
|
|
depends="xf86-video-opentegra libvdpau-tegra"
|
|
mkdir "$subpkgdir"
|
|
}
|
|
|
|
sha512sums="
|
|
cdaa85adbeff8fe72bc4e4594688937a4bfab20bd3458e2e3b4e8bd2c53f6160c19af3e1de5cf8568f1e6a050d289454c786a50c8480a2e6217ae737b2f53364 deviceinfo
|
|
67ff4306270b7e6e292ddb48ac5fcb1472840d8eaa412f9cd989442fb20139ee3c844fd1ca5c5b923c7980403d945999a77fc6617127059e56e22bdc8dca2bf8 modules-initfs
|
|
"
|