3ed9591e41
This cmdline argument is now a no-op. Drop it everywhere and add a new CI check to enforce this. Adjust the deprecated "minimal" initramfs variant to use pmos.debug-shell to enable logging instead. It doesn't /support/ dropping to a shell, so the variable takes on a different meaning. But that's ok since it's at least more consistent. [ci:ignore-count] [ci:skip-vercheck] Signed-off-by: Caleb Connolly <caleb@postmarketos.org> Tweaked-by: Oliver Smith <ollieparanoid@postmarketos.org> [ci:skip-build]: kernel builds are very likely to go through now
52 lines
1.7 KiB
Text
52 lines
1.7 KiB
Text
# Reference: <https://postmarketos.org/devicepkg>
|
|
# Maintainer: Jenneron <jenneron@protonmail.com>
|
|
# Co-Maintainer: Minecrell <minecrell@minecrell.net>
|
|
pkgname=device-lenovo-a6000
|
|
pkgdesc="Lenovo A6000"
|
|
pkgver=8
|
|
pkgrel=1
|
|
url="https://postmarketos.org"
|
|
license="MIT"
|
|
arch="aarch64"
|
|
options="!check !archcheck"
|
|
depends="postmarketos-base mkbootimg linux-postmarketos-qcom-msm8916
|
|
soc-qcom-msm8916 soc-qcom-msm8916-rproc"
|
|
makedepends="devicepkg-dev"
|
|
source="deviceinfo modules-initfs phoc.ini"
|
|
subpackages="
|
|
$pkgname-nonfree-firmware:nonfree_firmware
|
|
$pkgname-phosh
|
|
"
|
|
_pmb_select="soc-qcom-msm8916-rproc"
|
|
|
|
# Backwards compatibility for old kernel variant subpackages
|
|
replaces="$pkgname-kernel-mainline $pkgname-kernel-mainline-modem"
|
|
for pkg in $replaces; do provides="$provides $pkg=$pkgver-r$pkgrel"; done
|
|
|
|
build() {
|
|
devicepkg_build $startdir $pkgname
|
|
}
|
|
|
|
package() {
|
|
devicepkg_package $startdir $pkgname
|
|
}
|
|
|
|
nonfree_firmware() {
|
|
pkgdesc="GPU/WiFi/BT/Modem/Video firmware"
|
|
depends="firmware-qcom-adreno-a300 msm-firmware-loader
|
|
firmware-qcom-msm8916-wcnss firmware-lenovo-a6000-wcnss-nv
|
|
firmware-qcom-msm8916-venus"
|
|
mkdir "$subpkgdir"
|
|
}
|
|
|
|
phosh() {
|
|
install_if="$pkgname=$pkgver-r$pkgrel postmarketos-ui-phosh"
|
|
install -Dm644 "$srcdir"/phoc.ini \
|
|
"$subpkgdir"/etc/phosh/phoc.ini
|
|
}
|
|
|
|
sha512sums="
|
|
4939c4931addcfc05dbd5ede8083385e554c51c90ce5b375291fc57f245bfccc71054c9ae66c421bd5a39fe8f4449b58450246b667af0cda84399b5d65dc2173 deviceinfo
|
|
d433b8376b6e89daf4eac2073cb33627bdcacdcd48b6d4990cc698627dcf3c951bb1874951bc4631ea6b89d22c6002b9d02b77ff24992106061fcecc22fa5f25 modules-initfs
|
|
10d4ee62e5f7a9e4c368c460dd4c3ef282476e47d8cc40e4e3b83e971d04c493b801e5628ebdfe721f869e2fd68c521cf192cba1a973c8e03a61445534a28811 phoc.ini
|
|
"
|