pmaports/device/archived/linux-samsung-espresso10-downstream/APKBUILD
Stefan Hansson fb7f99efe2
device: rename unmaintained to archived (MR 5046)
Unmaintained is a name which on multiple occasions have seen lead to
confusion with people having the impression that unmaintained is for all
unmaintained devices, which is not how we're really using it. Many
devices in testing do not actually have a maintainer, yet there has been
no push to move these out of there and into unmaintained.

I think this is a result of that unmaintained was introduced not to keep
unmaintained ports but rather a place to store ports that have a better
replacement but where the inferior one still holds some sort of value,
such as for debugging purposes. These ports also are not necessarily
entirely unmaintained and see more fixes than many ports in testing.

While one approach to solving this problem could be to simply moving all
unmaintained ports to unmaintained, I think this comes with some
problems: It would require an initial effort to figure out which ports
are indeed unmaintained and which just don't have a maintained noted in
the package, and given how many ports there are in testing this would be
a big endeavour. It would also require continuous work on moving ports
into unmaintained as the maintainers go silent if we are to keep testing
and unmaintained's state consistent with reality. Additionally, just
because a port doesn't have a maintainer on paper doens't mean that
there aren't people who aren't willing to fix it up if there are issues
that arise.

As such, I think the way to go is renaming unmaintained to better
reflect the original intent. Thanks to Luca Weiss for suggesting
"archive", and to Arnav Singh for suggesting that "archived" would match
the other category names better.
2024-05-15 17:07:51 +02:00

59 lines
2.4 KiB
Text

# Archived: Downstream port, only for testing. Use mainline port (linux-postmarketos-omap)!
# Kernel config based on: arch/arm/configs/espresso_defconfig
pkgname=linux-samsung-espresso10-downstream
pkgver=3.0.101
pkgrel=1
pkgdesc="Samsung Galaxy Tab 2 (10.1 inch) kernel fork"
arch="armv7"
_carch="arm"
_flavor="samsung-espresso10"
url="https://kernel.org"
license="GPL2"
options="!strip !check !tracedeps pmb:cross-native"
makedepends="perl sed installkernel bash gmp-dev bc linux-headers elfutils-dev devicepkg-dev gcc6"
# Compiler: this kernel was only tested with GCC6. Feel free to make a merge
# request if you find out that it is booting working with newer GCCs as
# well. See <https://postmarketos.org/vendorkernel> for instructions.
if [ "${CC:0:5}" != "gcc6-" ]; then
CC="gcc6-$CC"
HOSTCC="gcc6-gcc"
CROSS_COMPILE="gcc6-$CROSS_COMPILE"
fi
# Source - Use unlegacy kernel
_repository="android_kernel_samsung_espresso"
_commit="19d2fd25e2416ed04c287387ade7048047bf7b18"
_config="config-$_flavor.$arch"
source="
$pkgname-$_commit.tar.gz::https://github.com/iamashwin26/$_repository/archive/$_commit.tar.gz
$_config
01_fix_aid_net_on_apn_disable.patch
linux3.0-8933-1-replace-Sun-Solaris-style-flag-on-section.patch
linux3.4-fix-piggy.gzip.S.patch
"
builddir="$srcdir/$_repository-$_commit"
prepare() {
default_prepare
. downstreamkernel_prepare
}
build() {
unset LDFLAGS
make ARCH="$_carch" CC="${CC:-gcc}" \
KBUILD_BUILD_VERSION="$((pkgrel + 1 ))-postmarketOS"
}
package() {
downstreamkernel_package "$builddir" "$pkgdir" "$_carch" "$_flavor"
}
sha512sums="
86d77d7f1004e1b0ec63e95132b853ad6e03d3e55587bbbed91d64d95ba6f9bb82ac5b77162f8e89b16c4f8db491d4e8ce6ed16b7572bb6f99ce46144dac619e linux-samsung-espresso10-downstream-19d2fd25e2416ed04c287387ade7048047bf7b18.tar.gz
6c854151b5297b222062e1ffa92622e80ae8642cbf3d22b2697e61c8ce233076ca8810abf084bca29356f368d329e6c2668aac54fe9260a2761efcdc70782915 config-samsung-espresso10.armv7
1cae09c775d787e877f82cb164b5d68530f4bd9b108b7abaf8192bd85a3d8975456762ce9f563fa766b1c03519e09ef93e177fd6972e439e4aa0c3a5709ea691 01_fix_aid_net_on_apn_disable.patch
66ab793bb1fa50a07f10e2cdb0f49ea05a787c6b1fe5358e69a76e43295ac5be3b68cdf6a882e868bfe6969cac981c5545587cd57eee4b5cec26078ae0ecaa1c linux3.0-8933-1-replace-Sun-Solaris-style-flag-on-section.patch
080745ca4ecaa804ee1df26ea81975ca93b74372e0c08322a6c481e97807495ae6ceb6cc77653afa24f9f2df45da8ebf8e5de6b06037fbb08e0279877ce42188 linux3.4-fix-piggy.gzip.S.patch
"