pmaports/device/archived/firmware-htc-flounder-downstream/APKBUILD
Stefan Hansson fb7f99efe2
device: rename unmaintained to archived (MR 5046)
Unmaintained is a name which on multiple occasions have seen lead to
confusion with people having the impression that unmaintained is for all
unmaintained devices, which is not how we're really using it. Many
devices in testing do not actually have a maintainer, yet there has been
no push to move these out of there and into unmaintained.

I think this is a result of that unmaintained was introduced not to keep
unmaintained ports but rather a place to store ports that have a better
replacement but where the inferior one still holds some sort of value,
such as for debugging purposes. These ports also are not necessarily
entirely unmaintained and see more fixes than many ports in testing.

While one approach to solving this problem could be to simply moving all
unmaintained ports to unmaintained, I think this comes with some
problems: It would require an initial effort to figure out which ports
are indeed unmaintained and which just don't have a maintained noted in
the package, and given how many ports there are in testing this would be
a big endeavour. It would also require continuous work on moving ports
into unmaintained as the maintainers go silent if we are to keep testing
and unmaintained's state consistent with reality. Additionally, just
because a port doesn't have a maintainer on paper doens't mean that
there aren't people who aren't willing to fix it up if there are issues
that arise.

As such, I think the way to go is renaming unmaintained to better
reflect the original intent. Thanks to Luca Weiss for suggesting
"archive", and to Arnav Singh for suggesting that "archived" would match
the other category names better.
2024-05-15 17:07:51 +02:00

34 lines
1.5 KiB
Text

# Archived: Downstream port, only for testing. Use mainline port (htc-flounder)!
pkgname=firmware-htc-flounder-downstream
pkgver=1.0
pkgrel=0
_commit="27024f568d1eee70c4a12f3f46aec33f6ee2f225"
pkgdesc="Firmware for the HTC Google Nexus 9"
url="https://github.com/Alexandroid99/vendor_htc_flounder"
arch="aarch64"
license="proprietary"
source="$pkgname-$_commit.tar.gz::https://github.com/Alexandroid99/vendor_htc_flounder/archive/$_commit.tar.gz"
options="!check !strip !archcheck !spdx !tracedeps pmb:cross-native"
builddir="$srcdir/vendor_htc_flounder-$_commit"
_files1="bcm20795_firmware.ncd bcm4350b1.hcd bcm4350c0.hcd bcm4354.hcd bcmdhd.cal
fw_bcmdhd.bin fw_bcmdhd_apsta.bin maxim_fp35.bin nvavp_aacdec_ucode.bin
nvavp_aud_ucode.bin nvavp_mp3dec_ucode.bin nvavp_os_0ff00000.bin
nvavp_os_8ff00000.bin nvavp_os_eff00000.bin nvavp_os_f7e00000.bin
nvavp_vid_ucode_alt.bin rt5677_elf_vad sar0_CY8C.img sar1_CY8C.img
sensor_hub.img synaptics.img touch_fusion.cfg"
_files2="NETB_img.bin fecs.bin gpccs.bin gpmu_ucode.bin nvhost_msenc031.fw
nvhost_tsec.fw vic03_ucode.bin"
package() {
for _i in $_files1; do
install -Dm644 firmware/"$_i" \
"$pkgdir"/lib/firmware/postmarketos/"$_i"
done
for _i in $_files2; do
install -Dm644 firmware/tegra13x/"$_i" \
"$pkgdir"/lib/firmware/postmarketos/tegra13x/"$_i"
done
}
sha512sums="c6beb210233f938f1bbcb06ff99566a4755959c865978d4897f82ffdfc3c292a075fdb34e332a8965953a4ec7aec7e36ebd142036e3879b70e835d3b0e8a1543 firmware-htc-flounder-downstream-27024f568d1eee70c4a12f3f46aec33f6ee2f225.tar.gz"