3ed9591e41
This cmdline argument is now a no-op. Drop it everywhere and add a new CI check to enforce this. Adjust the deprecated "minimal" initramfs variant to use pmos.debug-shell to enable logging instead. It doesn't /support/ dropping to a shell, so the variable takes on a different meaning. But that's ok since it's at least more consistent. [ci:ignore-count] [ci:skip-vercheck] Signed-off-by: Caleb Connolly <caleb@postmarketos.org> Tweaked-by: Oliver Smith <ollieparanoid@postmarketos.org> [ci:skip-build]: kernel builds are very likely to go through now
31 lines
792 B
Text
31 lines
792 B
Text
# Archived: Downstream port, only for testing. Use mainline port (shift-axolotl)!
|
|
# This kernel is mostly used for bringing up new features on mainline, thus archived
|
|
# Reference: <https://postmarketos.org/devicepkg>
|
|
pkgname=device-shift-axolotl-downstream
|
|
pkgdesc="SHIFT6mq downstream"
|
|
pkgver=1
|
|
pkgrel=2
|
|
url="https://postmarketos.org"
|
|
license="MIT"
|
|
arch="aarch64"
|
|
options="!check !archcheck"
|
|
depends="
|
|
linux-shift-axolotl-downstream
|
|
mkbootimg
|
|
msm-fb-refresher
|
|
postmarketos-base
|
|
"
|
|
makedepends="devicepkg-dev"
|
|
source="deviceinfo"
|
|
|
|
build() {
|
|
devicepkg_build $startdir $pkgname
|
|
}
|
|
|
|
package() {
|
|
devicepkg_package $startdir $pkgname
|
|
}
|
|
|
|
sha512sums="
|
|
75bc9e4b1225f3988bef27763d5961160e3dbdb25260327c0390290827b8e946a27ed7f8b0a810f89d696112ca9d220652c8789cbc86f898d2292dd0ae2f61e4 deviceinfo
|
|
"
|