pmaports/device/archived/device-samsung-on7xelte-downstream/APKBUILD
Stefan Hansson fb7f99efe2
device: rename unmaintained to archived (MR 5046)
Unmaintained is a name which on multiple occasions have seen lead to
confusion with people having the impression that unmaintained is for all
unmaintained devices, which is not how we're really using it. Many
devices in testing do not actually have a maintainer, yet there has been
no push to move these out of there and into unmaintained.

I think this is a result of that unmaintained was introduced not to keep
unmaintained ports but rather a place to store ports that have a better
replacement but where the inferior one still holds some sort of value,
such as for debugging purposes. These ports also are not necessarily
entirely unmaintained and see more fixes than many ports in testing.

While one approach to solving this problem could be to simply moving all
unmaintained ports to unmaintained, I think this comes with some
problems: It would require an initial effort to figure out which ports
are indeed unmaintained and which just don't have a maintained noted in
the package, and given how many ports there are in testing this would be
a big endeavour. It would also require continuous work on moving ports
into unmaintained as the maintainers go silent if we are to keep testing
and unmaintained's state consistent with reality. Additionally, just
because a port doesn't have a maintainer on paper doens't mean that
there aren't people who aren't willing to fix it up if there are issues
that arise.

As such, I think the way to go is renaming unmaintained to better
reflect the original intent. Thanks to Luca Weiss for suggesting
"archive", and to Arnav Singh for suggesting that "archived" would match
the other category names better.
2024-05-15 17:07:51 +02:00

59 lines
1.8 KiB
Text

# Archived: Downstream port, only for testing. Use mainline port (samsung-on7xelte)!
# Reference: <https://postmarketos.org/devicepkg>
pkgname=device-samsung-on7xelte-downstream
pkgdesc="Samsung Galaxy J7 Prime"
pkgver=1
pkgrel=0
url="https://postmarketos.org"
license="MIT"
arch="aarch64"
options="!check !archcheck"
depends="
linux-samsung-on7xelte
mkbootimg
msm-fb-refresher
postmarketos-base
samsungipcd
"
subpackages="$pkgname-nonfree-firmware:nonfree_firmware $pkgname-lightdm"
makedepends="devicepkg-dev"
install="$pkgname.post-install"
source="
deviceinfo
lightdm.conf
mount-efs.rc-init
samsungipcd.rc-conf
"
build() {
devicepkg_build $startdir $pkgname
}
package() {
devicepkg_package $startdir $pkgname
# Mounting EFS Partition
install -Dm755 mount-efs.rc-init "$pkgdir"/etc/init.d/mount-efs
# Modem Configuration - samsungipcd
install -Dm644 samsungipcd.rc-conf "$pkgdir"/etc/conf.d/samsungipcd
}
nonfree_firmware() {
pkgdesc="Proprietary Firmware blobs"
depends="firmware-samsung-on7xelte"
mkdir "$subpkgdir"
}
lightdm() {
install_if="$pkgname=$pkgver-r$pkgrel lightdm"
install -Dm644 lightdm.conf \
"$subpkgdir"/etc/lightdm/lightdm.conf.d/00-on7xelte.conf
}
sha512sums="
d342e7d79922d2e4a313e6c0ad20172e841886aa9517522460699da0dc66cd83cfeab986e468b0427ebcd64d54ffbc39cf3ba56c5d839b560e34cbe6e36526f1 deviceinfo
baee319b6d2f49a15680b0f322ec3e398a071d73fbf7713d14f26a1d027f8950457a482ac3f019605af3dfcf25bbb33ebaa0ffde181f7f96d911d56251c81eef lightdm.conf
efbe3d6217854c0131e61f9f3722100d349cb0673f4923bc3d56dae30a6346b0c33e676a39fc4c080150f6ea9457bf268abf870eea916a7d5daae1a22642a2b8 mount-efs.rc-init
3e5bb764529010d2b6b1f2759a7799f665d140aebcee2dd63433e68cd4282e09b5d3b34fb7c21e737595b406501e7f02ece4592651c60e4c2b9419de4aedb438 samsungipcd.rc-conf
"