fb7f99efe2
Unmaintained is a name which on multiple occasions have seen lead to confusion with people having the impression that unmaintained is for all unmaintained devices, which is not how we're really using it. Many devices in testing do not actually have a maintainer, yet there has been no push to move these out of there and into unmaintained. I think this is a result of that unmaintained was introduced not to keep unmaintained ports but rather a place to store ports that have a better replacement but where the inferior one still holds some sort of value, such as for debugging purposes. These ports also are not necessarily entirely unmaintained and see more fixes than many ports in testing. While one approach to solving this problem could be to simply moving all unmaintained ports to unmaintained, I think this comes with some problems: It would require an initial effort to figure out which ports are indeed unmaintained and which just don't have a maintained noted in the package, and given how many ports there are in testing this would be a big endeavour. It would also require continuous work on moving ports into unmaintained as the maintainers go silent if we are to keep testing and unmaintained's state consistent with reality. Additionally, just because a port doesn't have a maintainer on paper doens't mean that there aren't people who aren't willing to fix it up if there are issues that arise. As such, I think the way to go is renaming unmaintained to better reflect the original intent. Thanks to Luca Weiss for suggesting "archive", and to Arnav Singh for suggesting that "archived" would match the other category names better.
46 lines
1.3 KiB
Text
46 lines
1.3 KiB
Text
# Archived: Downstream port, maybe useful for EPDC performance improvement
|
|
# needs special userspace to show up anything
|
|
# Reference: <https://postmarketos.org/devicepkg>
|
|
pkgname=device-kobo-clara-downstream
|
|
pkgdesc="Kobo Clara HD downstream"
|
|
pkgver=0.1
|
|
pkgrel=0
|
|
url="https://postmarketos.org"
|
|
license="MIT"
|
|
arch="armv7"
|
|
options="!check !archcheck"
|
|
depends="
|
|
postmarketos-base
|
|
u-boot-kobo-clara-downstream
|
|
u-boot-tools
|
|
linux-kobo-clara-downstream
|
|
"
|
|
makedepends="devicepkg-dev"
|
|
subpackages="$pkgname-nonfree-firmware:nonfree_firmware"
|
|
|
|
source="
|
|
deviceinfo
|
|
uboot-script-downstream.cmd
|
|
"
|
|
|
|
build() {
|
|
devicepkg_build $startdir $pkgname
|
|
}
|
|
|
|
package() {
|
|
devicepkg_package $startdir $pkgname
|
|
mkimage -A arm -O linux -T script -n postmarketOS \
|
|
-d "$srcdir"/uboot-script-downstream.cmd "$srcdir/boot-downstream.scr"
|
|
install -Dm644 "$srcdir/boot-downstream.scr" "$pkgdir/boot/boot.scr"
|
|
}
|
|
|
|
nonfree_firmware() {
|
|
pkgdesc="Kobo Clara HD firmware"
|
|
depends="firmware-kobo-clara-downstream"
|
|
mkdir "$subpkgdir"
|
|
}
|
|
|
|
sha512sums="
|
|
84b9e5385b7fd77af6891b31d7e95ec424645f741d54168d3d38f6f703071d622829d9f7cf5a29136bf6eb9ec5b2a50a05efe76ddc3e047bb4a69e197fbfde24 deviceinfo
|
|
4bfc2714a2670efc451860bd97d36ba12559e00aed41afdde1ac3e01b41458390358ac7f6bc96a6dee6be6a34f534da52d845b02df0566b25f4868774ef69b1d uboot-script-downstream.cmd
|
|
"
|