diff --git a/Makefile b/Makefile
index c9c47f7..c320f5b 100644
--- a/Makefile
+++ b/Makefile
@@ -192,8 +192,7 @@ SUBARCH := $(shell uname -m | sed -e s/i.86/x86/ -e s/x86_64/x86/ \
 # "make" in the configured kernel build directory always uses that.
 # Default value for CROSS_COMPILE is not to prefix executables
 # Note: Some architectures assign CROSS_COMPILE in their arch/*/Makefile
-ARCH		=arm
-CROSS_COMPILE	=arm-eabi-
+CROSS_COMPILE	?= $(CONFIG_CROSS_COMPILE:"%":%)
 
 # Architecture as present in compile.h
 UTS_MACHINE 	:= $(ARCH)