pine-pinetab: new device (Pine PineTab) (!528)
Thanks to Martijn Braam for additional patches that were squashed into this one. [ci:skip-build]: won't finish in time
This commit is contained in:
parent
d2492564c4
commit
fef416f198
7 changed files with 178 additions and 950 deletions
49
device/device-pine-pinetab/APKBUILD
Normal file
49
device/device-pine-pinetab/APKBUILD
Normal file
|
@ -0,0 +1,49 @@
|
|||
# Reference: <https://postmarketos.org/devicepkg>
|
||||
pkgname="device-pine-pinetab"
|
||||
pkgdesc="Pine64 Pinetab"
|
||||
pkgver=0.1
|
||||
pkgrel=0
|
||||
url="https://postmarketos.org"
|
||||
license="MIT"
|
||||
arch="aarch64"
|
||||
options="!check !archcheck"
|
||||
depends="postmarketos-base linux-postmarketos-allwinner u-boot-pine64 uboot-tools mesa-git mesa-git-glapi mesa-git-gl mesa-git-egl mesa-git-dri-lima mesa-git-dri-kmsro mesa-git-gbm mesa-git-gles"
|
||||
makedepends="devicepkg-dev"
|
||||
subpackages="$pkgname-sway"
|
||||
source="
|
||||
deviceinfo
|
||||
uboot-script.cmd
|
||||
sway.conf
|
||||
"
|
||||
|
||||
build() {
|
||||
devicepkg_build $startdir $pkgname
|
||||
mkimage \
|
||||
-A arm \
|
||||
-O linux \
|
||||
-T script \
|
||||
-C none \
|
||||
-a 0 \
|
||||
-e 0 \
|
||||
-n postmarketos \
|
||||
-d "$srcdir"/uboot-script.cmd \
|
||||
"$srcdir"/boot.scr
|
||||
}
|
||||
|
||||
sway() {
|
||||
install_if="$pkgname postmarketos-ui-sway"
|
||||
depends="dmenu"
|
||||
install -D -m644 "$srcdir"/sway.conf \
|
||||
"$subpkgdir"/etc/sway/config.d/pinetab
|
||||
}
|
||||
|
||||
package() {
|
||||
devicepkg_package $startdir $pkgname
|
||||
install -Dm644 "$srcdir"/boot.scr \
|
||||
"$pkgdir"/boot/boot.scr
|
||||
}
|
||||
|
||||
|
||||
sha512sums="ae788279ad03c48ae5846b81c0c544ba3da9f17d044d3e74cde8fb0d5b33259bf8ded6507542389d9e506a8ca38f76866a7291458d630d2de11adb6ddf85c5f4 deviceinfo
|
||||
2aabfeff137e6ecbbb2cf9353d6ae69a0c4fe3f75064164c5e9edde750b035b9d7ab9c10000bb93d1a71cc9b357d469c86d7b9b3ffa0466da8ee229ac59e6c56 uboot-script.cmd
|
||||
9e71c61bfa72b60e749c4dc04f17eb59d25de822765e81e65c937d6be5236d3951a652b69a1ab973abe6add9f34705be5dbaa98bbfa25daf7504dd50b28524c2 sway.conf"
|
26
device/device-pine-pinetab/deviceinfo
Normal file
26
device/device-pine-pinetab/deviceinfo
Normal file
|
@ -0,0 +1,26 @@
|
|||
# Reference: <https://postmarketos.org/deviceinfo>
|
||||
# Please use double quotes only. You can source this file in shell scripts.
|
||||
|
||||
deviceinfo_format_version="0"
|
||||
deviceinfo_name="Pine64 Pinetab"
|
||||
deviceinfo_manufacturer="Pine64"
|
||||
deviceinfo_codename="pine-pinetab"
|
||||
deviceinfo_date=""
|
||||
deviceinfo_dtb="allwinner/sun50i-a64-pinetab"
|
||||
deviceinfo_modules_initfs=""
|
||||
deviceinfo_arch="aarch64"
|
||||
|
||||
# Device related
|
||||
deviceinfo_keyboard="true"
|
||||
deviceinfo_external_storage="true"
|
||||
deviceinfo_screen_width="1280"
|
||||
deviceinfo_screen_height="800"
|
||||
deviceinfo_dev_touchscreen=""
|
||||
deviceinfo_dev_touchscreen_calibration=""
|
||||
deviceinfo_dev_keyboard=""
|
||||
|
||||
# Bootloader related
|
||||
deviceinfo_flash_method="none"
|
||||
deviceinfo_generate_legacy_uboot_initfs="true"
|
||||
deviceinfo_sd_embed_firmware="u-boot/pine64-lts/u-boot-sunxi-with-spl.bin:8"
|
||||
|
6
device/device-pine-pinetab/sway.conf
Normal file
6
device/device-pine-pinetab/sway.conf
Normal file
|
@ -0,0 +1,6 @@
|
|||
# Rotate the display so it's usable with the keyboard
|
||||
output DSI-1 transform 90
|
||||
|
||||
# Link the touchscreen to the display
|
||||
input "1046:9271:Goodix_Capacitive_TouchScreen" map_to_output DSI-1
|
||||
|
19
device/device-pine-pinetab/uboot-script.cmd
Normal file
19
device/device-pine-pinetab/uboot-script.cmd
Normal file
|
@ -0,0 +1,19 @@
|
|||
setenv bootargs init=/init.sh rw console=tty0 console=ttyS0,115200 no_console_suspend earlycon=uart,mmio32,0x01c28000 panic=10 consoleblank=0 loglevel=1 cma=256M PMOS_NO_OUTPUT_REDIRECT
|
||||
|
||||
printenv
|
||||
|
||||
echo Loading DTB
|
||||
load mmc ${mmc_bootdev}:1 ${fdt_addr_r} dtb-postmarketos-allwinner.dtb
|
||||
|
||||
echo Loading Initramfs
|
||||
load mmc ${mmc_bootdev}:1 ${ramdisk_addr_r} uInitrd-postmarketos-allwinner
|
||||
|
||||
echo Loading Kernel
|
||||
load mmc ${mmc_bootdev}:1 ${kernel_addr_r} vmlinuz-postmarketos-allwinner
|
||||
|
||||
echo Resizing FDT
|
||||
fdt addr ${fdt_addr_r}
|
||||
fdt resize
|
||||
|
||||
echo Booting kernel
|
||||
booti ${kernel_addr_r} ${ramdisk_addr_r} ${fdt_addr_r}
|
|
@ -4,7 +4,7 @@ _config="config-${_flavor}.${CARCH}"
|
|||
pkgname=linux-${_flavor}
|
||||
|
||||
pkgver=5.3.0_git20190726
|
||||
pkgrel=1
|
||||
pkgrel=2
|
||||
|
||||
arch="aarch64"
|
||||
pkgdesc="Kernel fork with PinePhone Don't be evil patches"
|
||||
|
@ -14,10 +14,13 @@ makedepends="devicepkg-dev perl sed installkernel bash gmp-dev bc linux-headers
|
|||
options="!strip !check !tracedeps"
|
||||
install=
|
||||
_commit="577c793d924a0455b2b555d468cf50f97985b6f6"
|
||||
_commit_rtl8723cs="1c9c0cb9d335626a66d8063399c6e16751ecc1a8"
|
||||
source="
|
||||
${pkgname}-${_commit}.tar.gz::https://gitlab.com/pine64-org/linux/-/archive/${_commit}/linux-${_commit}.tar.gz
|
||||
rtl8723cs-${_commit_rtl8723cs}.tar.gz::https://github.com/Icenowy/rtl8723cs/archive/${_commit_rtl8723cs}.tar.gz
|
||||
config-${_flavor}.aarch64
|
||||
touch-dts.patch
|
||||
rtl8723cs.patch
|
||||
"
|
||||
|
||||
subpackages=""
|
||||
|
@ -40,6 +43,8 @@ builddir="$srcdir/linux-${_commit}"
|
|||
prepare() {
|
||||
default_prepare
|
||||
|
||||
cp -rv "$srcdir"/rtl8723cs-${_commit_rtl8723cs} "$builddir"/drivers/staging/rtl8723cs
|
||||
|
||||
REPLACE_GCCH=0 \
|
||||
downstreamkernel_prepare "$srcdir" "$builddir" "$_config" "$_carch" "$HOSTCC"
|
||||
}
|
||||
|
@ -84,5 +89,7 @@ package() {
|
|||
}
|
||||
|
||||
sha512sums="88aab0956b4bb3a240b40448b46b0edbfefd038759cd4c00fe89357e666e5be054ad3cd9455de2fc5670bd656c9414bbc66580723c8532a744d06ab2a4edbac2 linux-postmarketos-allwinner-577c793d924a0455b2b555d468cf50f97985b6f6.tar.gz
|
||||
9d6034e54fc838001fb53b3b3f03bba8de68c93f1e6cfbfa7e89c0b834aebded3baaa37b019d1bb1b3b64cbb9fe3f9aabdfd05299af27d3a44bcfdb1f70b78fd config-postmarketos-allwinner.aarch64
|
||||
5f2285e4eb262a9429c73599871c3fecbb858a388774bc7cba7631987ed1dc4a14cd7606e8fefc655c5128851fc853132f0a081e3d710c9266739af92f4d37e8 touch-dts.patch"
|
||||
e4e585ce787301eeee07ff8e45a97343456808a47ed237053f0c83a49b4958a75514def4c5263f4507a282ea90bd2bb3f8f468839f7e5fd05ae947a796c8c6b9 rtl8723cs-1c9c0cb9d335626a66d8063399c6e16751ecc1a8.tar.gz
|
||||
e9577f6589366441f41b1a9eaf213500cce64e9307cbf51b38853d40c353baf753f475ae1c3045a700e78a2efb98c38279af0aaebdca1e6c7148fbe549a59835 config-postmarketos-allwinner.aarch64
|
||||
5f2285e4eb262a9429c73599871c3fecbb858a388774bc7cba7631987ed1dc4a14cd7606e8fefc655c5128851fc853132f0a081e3d710c9266739af92f4d37e8 touch-dts.patch
|
||||
bf06f931fb543f4bf2f0567902c3021de237fc9684f92af2ed3e956f869d907c9cff1cf3e11a72eb97bda47c8f8b28aff226634f641bdffa04b08d434f419faa rtl8723cs.patch"
|
||||
|
|
File diff suppressed because it is too large
Load diff
25
main/linux-postmarketos-allwinner/rtl8723cs.patch
Normal file
25
main/linux-postmarketos-allwinner/rtl8723cs.patch
Normal file
|
@ -0,0 +1,25 @@
|
|||
diff --git a/drivers/staging/Kconfig b/drivers/staging/Kconfig
|
||||
index 7c96a01eef6c..e9b849ecbc80 100644
|
||||
--- a/drivers/staging/Kconfig
|
||||
+++ b/drivers/staging/Kconfig
|
||||
@@ -36,6 +36,8 @@ source "drivers/staging/rtl8192e/Kconfig"
|
||||
|
||||
source "drivers/staging/rtl8723bs/Kconfig"
|
||||
|
||||
+source "drivers/staging/rtl8723cs/Kconfig"
|
||||
+
|
||||
source "drivers/staging/rtl8712/Kconfig"
|
||||
|
||||
source "drivers/staging/rtl8188eu/Kconfig"
|
||||
diff --git a/drivers/staging/Makefile b/drivers/staging/Makefile
|
||||
index fcaac9693b83..dfc287028474 100644
|
||||
--- a/drivers/staging/Makefile
|
||||
+++ b/drivers/staging/Makefile
|
||||
@@ -8,6 +8,7 @@ obj-$(CONFIG_FB_OLPC_DCON) += olpc_dcon/
|
||||
obj-$(CONFIG_RTL8192U) += rtl8192u/
|
||||
obj-$(CONFIG_RTL8192E) += rtl8192e/
|
||||
obj-$(CONFIG_RTL8723BS) += rtl8723bs/
|
||||
+obj-$(CONFIG_RTL8723CS) += rtl8723cs/
|
||||
obj-$(CONFIG_R8712U) += rtl8712/
|
||||
obj-$(CONFIG_R8188EU) += rtl8188eu/
|
||||
obj-$(CONFIG_RTS5208) += rts5208/
|
Loading…
Reference in a new issue