Support the Lenovo K6 Power (#942)
This commit is contained in:
parent
d93180dbef
commit
f983270531
9 changed files with 4887 additions and 0 deletions
4
device/device-lenovo-karate/90-android-touch-dev.rules
Normal file
4
device/device-lenovo-karate/90-android-touch-dev.rules
Normal file
|
@ -0,0 +1,4 @@
|
|||
# use 'weston-calibrator' to calibrate the touchscreen!
|
||||
SUBSYSTEM=="input", ATTRS{name}=="fts_ts", \
|
||||
ENV{ID_INPUT}="1", ENV{ID_INPUT_TOUCHSCREEN}="1", \
|
||||
ENV{LIBINPUT_CALIBRATION_MATRIX}="0.975358 0.020484 -20.695250 0.031747 1.034592 -60.641296"
|
21
device/device-lenovo-karate/APKBUILD
Normal file
21
device/device-lenovo-karate/APKBUILD
Normal file
|
@ -0,0 +1,21 @@
|
|||
pkgname="device-lenovo-karate"
|
||||
pkgdesc="Lenovo K6 Power"
|
||||
pkgver=0.1
|
||||
pkgrel=0
|
||||
url="https://postmarketos.org"
|
||||
license="MIT"
|
||||
arch="noarch"
|
||||
options="!check"
|
||||
depends="linux-lenovo-karate firmware-lenovo-karate mkbootimg mdss-fb-init-hack"
|
||||
source="deviceinfo 90-android-touch-dev.rules"
|
||||
install="$pkgname.post-install"
|
||||
|
||||
package() {
|
||||
install -Dm644 "$srcdir"/deviceinfo \
|
||||
"$pkgdir"/etc/deviceinfo
|
||||
install -Dm755 "$srcdir"/90-android-touch-dev.rules \
|
||||
"$pkgdir"/etc/udev/rules.d/90-android-touch-dev.rules
|
||||
}
|
||||
|
||||
sha512sums="4cf920b531e825adab6354b37157686c554c08cff867cd7fcaa477617ec81ccd4d96762d29c987e089c4bf809ebc73496b045306e60cf476ca256209868f0606 deviceinfo
|
||||
25086c95c67c27151112efac1dcf7792589c990cc0a93ee910654445a3f9cc66c4a5ab656b3256224b39c49fe104540757cc36abf9de19f47c28c4fa82c4f552 90-android-touch-dev.rules"
|
17
device/device-lenovo-karate/device-lenovo-karate.post-install
Executable file
17
device/device-lenovo-karate/device-lenovo-karate.post-install
Executable file
|
@ -0,0 +1,17 @@
|
|||
#!/bin/sh
|
||||
|
||||
# Enable networking service (requires /etc/interfaces, which is configured below)
|
||||
rc-update add networking default
|
||||
|
||||
# Create /etc/network/interfaces if this doesn't exist
|
||||
if [ ! -f /etc/network/interfaces ]; then
|
||||
cat << EOF >> /etc/network/interfaces
|
||||
auto lo
|
||||
iface lo inet loopback
|
||||
auto wlan0
|
||||
iface wlan0 inet dhcp
|
||||
EOF
|
||||
|
||||
fi
|
||||
|
||||
exit 0
|
32
device/device-lenovo-karate/deviceinfo
Normal file
32
device/device-lenovo-karate/deviceinfo
Normal file
|
@ -0,0 +1,32 @@
|
|||
# Reference: <https://postmarketos.org/deviceinfo>
|
||||
# Please use double quotes only. You can source this file in shell scripts.
|
||||
|
||||
deviceinfo_format_version="0"
|
||||
deviceinfo_name="K6 Power"
|
||||
deviceinfo_manufacturer="Lenovo"
|
||||
deviceinfo_date=""
|
||||
deviceinfo_dtb=""
|
||||
deviceinfo_modules_initfs=""
|
||||
deviceinfo_external_disk_install="false"
|
||||
deviceinfo_arch="aarch64"
|
||||
|
||||
# Device related
|
||||
deviceinfo_keyboard="false"
|
||||
deviceinfo_external_disk="false"
|
||||
deviceinfo_screen_width="1080"
|
||||
deviceinfo_screen_height="1920"
|
||||
deviceinfo_dev_touchscreen="/dev/input/event1"
|
||||
deviceinfo_dev_keyboard=""
|
||||
|
||||
# Bootloader related
|
||||
deviceinfo_flash_methods="fastboot"
|
||||
deviceinfo_kernel_cmdline="console=tty60,115200,n8 androidboot.console=tty60 androidboot.hardware=qcom msm_rtb.filter=0x237 ehci-hcd.park=3 lpm_levels.sleep_disabled=1 gpt androidboot.bootdevice=7824900.sdhci earlycon=msm_hsl_uart,0x78B0000 androidboot.selinux=permissive buildvariant=userdebug"
|
||||
deviceinfo_generate_bootimg="true"
|
||||
deviceinfo_bootimg_qcdt="false"
|
||||
deviceinfo_flash_offset_base="0x80000000"
|
||||
deviceinfo_flash_offset_kernel="0x00008000"
|
||||
deviceinfo_flash_offset_ramdisk="0x01000000"
|
||||
deviceinfo_flash_offset_second="0x00f00000"
|
||||
deviceinfo_flash_offset_tags="0x00000100"
|
||||
deviceinfo_flash_pagesize="2048"
|
||||
|
68
device/linux-lenovo-karate/01_prima_gcc6.patch
Normal file
68
device/linux-lenovo-karate/01_prima_gcc6.patch
Normal file
|
@ -0,0 +1,68 @@
|
|||
From 44f841be2a223d672eaf9fa3029fd9249aeca583 Mon Sep 17 00:00:00 2001
|
||||
From: MOVZX <movzx@yahoo.com>
|
||||
Date: Tue, 25 Apr 2017 17:04:40 +0300
|
||||
Subject: [PATCH] prima: Fix GCC6 Warnings
|
||||
|
||||
Signed-off-by: MOVZX <movzx@yahoo.com>
|
||||
---
|
||||
drivers/staging/prima/CORE/MAC/src/include/utilsApi.h | 2 +-
|
||||
drivers/staging/prima/CORE/MAC/src/pe/sch/schBeaconGen.c | 2 +-
|
||||
drivers/staging/prima/CORE/SME/src/csr/csrApiScan.c | 2 +-
|
||||
drivers/staging/prima/CORE/VOSS/src/wlan_nv_template_builtin.c | 5 ++---
|
||||
4 files changed, 5 insertions(+), 6 deletions(-)
|
||||
|
||||
diff --git a/drivers/staging/prima/CORE/MAC/src/include/utilsApi.h b/drivers/staging/prima/CORE/MAC/src/include/utilsApi.h
|
||||
index 3a175473378..798a05cd2b4 100644
|
||||
--- a/drivers/staging/prima/CORE/MAC/src/include/utilsApi.h
|
||||
+++ b/drivers/staging/prima/CORE/MAC/src/include/utilsApi.h
|
||||
@@ -705,7 +705,7 @@ halRoundS32(tANI_S32 p)
|
||||
else
|
||||
k = p;
|
||||
|
||||
- return(k);
|
||||
+ return(k);
|
||||
}
|
||||
|
||||
// New functions for endianess conversion
|
||||
diff --git a/drivers/staging/prima/CORE/MAC/src/pe/sch/schBeaconGen.c b/drivers/staging/prima/CORE/MAC/src/pe/sch/schBeaconGen.c
|
||||
index 0fc798995ae..6427a04e108 100644
|
||||
--- a/drivers/staging/prima/CORE/MAC/src/pe/sch/schBeaconGen.c
|
||||
+++ b/drivers/staging/prima/CORE/MAC/src/pe/sch/schBeaconGen.c
|
||||
@@ -60,7 +60,7 @@
|
||||
// Temporarily (maybe for all of Alpha-1), assuming TIM = 0
|
||||
//
|
||||
|
||||
-const tANI_U8 P2pOui[] = {0x50, 0x6F, 0x9A, 0x9};
|
||||
+tANI_U8 P2pOui[] = {0x50, 0x6F, 0x9A, 0x9};
|
||||
|
||||
|
||||
tSirRetStatus schGetP2pIeOffset(tANI_U8 *pExtraIe, tANI_U32 extraIeLen, tANI_U16 *pP2pIeOffset)
|
||||
diff --git a/drivers/staging/prima/CORE/SME/src/csr/csrApiScan.c b/drivers/staging/prima/CORE/SME/src/csr/csrApiScan.c
|
||||
index 23ab858c355..b4f26def1d1 100644
|
||||
--- a/drivers/staging/prima/CORE/SME/src/csr/csrApiScan.c
|
||||
+++ b/drivers/staging/prima/CORE/SME/src/csr/csrApiScan.c
|
||||
@@ -5698,7 +5698,7 @@ static tANI_BOOLEAN csrScanProcessScanResults( tpAniSirGlobal pMac, tSmeCmd *pCo
|
||||
if (eHAL_STATUS_SUCCESS != status)
|
||||
smsLog(pMac, LOGE,
|
||||
FL( "failed to update the supported channel list"));
|
||||
- pMac->scan.defer_update_channel_list = false;
|
||||
+ pMac->scan.defer_update_channel_list = false;
|
||||
}
|
||||
|
||||
#ifdef WLAN_AP_STA_CONCURRENCY
|
||||
diff --git a/drivers/staging/prima/CORE/VOSS/src/wlan_nv_template_builtin.c b/drivers/staging/prima/CORE/VOSS/src/wlan_nv_template_builtin.c
|
||||
index 14c6eadf524..e26b697f793 100644
|
||||
--- a/drivers/staging/prima/CORE/VOSS/src/wlan_nv_template_builtin.c
|
||||
+++ b/drivers/staging/prima/CORE/VOSS/src/wlan_nv_template_builtin.c
|
||||
@@ -587,9 +587,8 @@ _NV_TEMPLATE_TABLE NvTablesBuiltIn[/*TABLES_MAX*/][TABLE_ENTRIES_MAX] = {
|
||||
((char *)&(nvDefaults.tables.hwCalValues.calData.psSlpTimeOvrHdxLNA5G) -
|
||||
(char *)&nvDefaults.tables.hwCalValues.calData),"psSlpTimeOvrHdxLNA5G"},
|
||||
{"ed",_ID_U8,SINGULAR,0,0,0,
|
||||
- (((char *)&(nvDefaults.tables.hwCalValues.calData.psSlpTimeOvrHdxLNA5G) +
|
||||
- sizeof(uint16)) - (char *)&nvDefaults.tables.hwCalValues.calData),
|
||||
- "nv_TxBBFSel9MHz"},
|
||||
+ ((char *)&(nvDefaults.tables.hwCalValues.calData.psSlpTimeOvrHdxLNA5G) -
|
||||
+ (char *)&nvDefaults.tables.hwCalValues.calData),"nv_TxBBFSel9MHz"},
|
||||
{"ee",_ID_U8,SINGULAR,0,0,0,
|
||||
((char *)&(nvDefaults.tables.hwCalValues.calData.hwParam2) -
|
||||
(char *)&nvDefaults.tables.hwCalValues.calData),"hwParam2"},
|
81
device/linux-lenovo-karate/APKBUILD
Normal file
81
device/linux-lenovo-karate/APKBUILD
Normal file
|
@ -0,0 +1,81 @@
|
|||
# Kernel config based on: arch/arm64/configs/karate_defconfig
|
||||
|
||||
pkgname="linux-lenovo-karate"
|
||||
pkgver=3.18.31
|
||||
pkgrel=0
|
||||
pkgdesc="Lenovo K6 Power kernel fork"
|
||||
arch="aarch64"
|
||||
_carch="arm64"
|
||||
_flavor="lenovo-karate"
|
||||
url="https://github.com/karthick111/android_kernel_lenovo_msm8937"
|
||||
license="GPL2"
|
||||
options="!strip !check !tracedeps"
|
||||
makedepends="perl sed installkernel bash gmp-dev bc linux-headers elfutils-dev"
|
||||
HOSTCC="${CC:-gcc}"
|
||||
HOSTCC="${HOSTCC#${CROSS_COMPILE}}"
|
||||
|
||||
# Source
|
||||
_repository="android_kernel_lenovo_msm8937"
|
||||
_commit="d99e6751356d0d310db6a16f3fe7eeaea8041675"
|
||||
_config="config-${_flavor}.${arch}"
|
||||
source="
|
||||
$pkgname-$_commit.tar.gz::https://github.com/karthick111/${_repository}/archive/${_commit}.tar.gz
|
||||
$_config
|
||||
compiler-gcc6.h
|
||||
01_prima_gcc6.patch
|
||||
"
|
||||
builddir="$srcdir/${_repository}-${_commit}"
|
||||
|
||||
prepare() {
|
||||
default_prepare
|
||||
|
||||
# gcc6 support
|
||||
cp -v "$srcdir/compiler-gcc6.h" "$builddir/include/linux/"
|
||||
|
||||
# Remove -Werror from all makefiles
|
||||
find . -type f -name Makefile -print0 | \
|
||||
xargs -0 sed -i 's/-Werror-/-W/g'
|
||||
find . -type f -name Makefile -print0 | \
|
||||
xargs -0 sed -i 's/-Werror//g'
|
||||
|
||||
# Prepare kernel config ('yes ""' for kernels lacking olddefconfig)
|
||||
cp "$srcdir"/$_config "$builddir"/.config
|
||||
yes "" | make ARCH="$_carch" HOSTCC="$HOSTCC" oldconfig
|
||||
}
|
||||
|
||||
menuconfig() {
|
||||
cd "$builddir"
|
||||
make ARCH="$_carch" menuconfig
|
||||
cp .config "$startdir"/$_config
|
||||
}
|
||||
|
||||
build() {
|
||||
unset LDFLAGS
|
||||
make ARCH="$_carch" CC="${CC:-gcc}" \
|
||||
KBUILD_BUILD_VERSION="$((pkgrel + 1 ))-postmarketOS"
|
||||
}
|
||||
|
||||
package() {
|
||||
# kernel.release
|
||||
install -D "$builddir/include/config/kernel.release" \
|
||||
"$pkgdir/usr/share/kernel/$_flavor/kernel.release"
|
||||
|
||||
# zImage (find the right one)
|
||||
cd "$builddir/arch/$_carch/boot"
|
||||
_target="$pkgdir/boot/vmlinuz-$_flavor"
|
||||
for _zimg in zImage-dtb Image.gz-dtb *zImage Image; do
|
||||
[ -e "$_zimg" ] || continue
|
||||
msg "zImage found: $_zimg"
|
||||
install -Dm644 "$_zimg" "$_target"
|
||||
break
|
||||
done
|
||||
if ! [ -e "$_target" ]; then
|
||||
error "Could not find zImage in $PWD!"
|
||||
return 1
|
||||
fi
|
||||
}
|
||||
|
||||
sha512sums="bc362a70215315eee0c63e52701488f9aa31c7e6af8d80f9dcef7c06b1d522f5e5a7a21c80c554575b21568ffb0fc2101407eb33c8d030f326943925275e34f9 linux-lenovo-karate-d99e6751356d0d310db6a16f3fe7eeaea8041675.tar.gz
|
||||
ad91e3e2cf276f4c1d9c155267398d2303577a9f40a1afea3b6403bc873c0b0aa65b06ecb2ff1288ba94ac4d60295f81bf95b48a52bffe6309352c32f424ea36 config-lenovo-karate.aarch64
|
||||
d80980e9474c82ba0ef1a6903b434d8bd1b092c40367ba543e72d2c119301c8b2d05265740e4104ca1ac5d15f6c4aa49e8776cb44264a9a28dc551e0d1850dcc compiler-gcc6.h
|
||||
972e98523d6ef06342e69a09e979bdd86904cf7f9a843b519b37791e531b680182564a2ab537c94629c3589f4e775b2c39de04c64e210a0f8b6f10745c3596f1 01_prima_gcc6.patch"
|
69
device/linux-lenovo-karate/compiler-gcc6.h
Normal file
69
device/linux-lenovo-karate/compiler-gcc6.h
Normal file
|
@ -0,0 +1,69 @@
|
|||
// SOURCE:
|
||||
// https://github.com/NextThingCo/CHIP-u-boot/issues/10#issuecomment-287515505
|
||||
|
||||
#ifndef __LINUX_COMPILER_H
|
||||
#error "Please don't include <linux/compiler-gcc6.h> directly, include <linux/compiler.h> instead."
|
||||
#endif
|
||||
|
||||
#define __used __attribute__((__used__))
|
||||
#define __must_check __attribute__((warn_unused_result))
|
||||
#define __compiler_offsetof(a, b) __builtin_offsetof(a, b)
|
||||
|
||||
/* Mark functions as cold. gcc will assume any path leading to a call
|
||||
to them will be unlikely. This means a lot of manual unlikely()s
|
||||
are unnecessary now for any paths leading to the usual suspects
|
||||
like BUG(), printk(), panic() etc. [but let's keep them for now for
|
||||
older compilers]
|
||||
|
||||
Early snapshots of gcc 4.3 don't support this and we can't detect this
|
||||
in the preprocessor, but we can live with this because they're unreleased.
|
||||
Maketime probing would be overkill here.
|
||||
|
||||
gcc also has a __attribute__((__hot__)) to move hot functions into
|
||||
a special section, but I don't see any sense in this right now in
|
||||
the kernel context */
|
||||
#define __cold __attribute__((__cold__))
|
||||
|
||||
#define __UNIQUE_ID(prefix) __PASTE(__PASTE(__UNIQUE_ID_, prefix), __COUNTER__)
|
||||
|
||||
#ifndef __CHECKER__
|
||||
# define __compiletime_warning(message) __attribute__((warning(message)))
|
||||
# define __compiletime_error(message) __attribute__((error(message)))
|
||||
#endif /* __CHECKER__ */
|
||||
|
||||
/*
|
||||
* Mark a position in code as unreachable. This can be used to
|
||||
* suppress control flow warnings after asm blocks that transfer
|
||||
* control elsewhere.
|
||||
*
|
||||
* Early snapshots of gcc 4.5 don't support this and we can't detect
|
||||
* this in the preprocessor, but we can live with this because they're
|
||||
* unreleased. Really, we need to have autoconf for the kernel.
|
||||
*/
|
||||
#define unreachable() __builtin_unreachable()
|
||||
|
||||
/* Mark a function definition as prohibited from being cloned. */
|
||||
#define __noclone __attribute__((__noclone__))
|
||||
|
||||
/*
|
||||
* Tell the optimizer that something else uses this function or variable.
|
||||
*/
|
||||
#define __visible __attribute__((externally_visible))
|
||||
|
||||
/*
|
||||
* GCC 'asm goto' miscompiles certain code sequences:
|
||||
*
|
||||
* http://gcc.gnu.org/bugzilla/show_bug.cgi?id=58670
|
||||
*
|
||||
* Work it around via a compiler barrier quirk suggested by Jakub Jelinek.
|
||||
*
|
||||
* (asm goto is automatically volatile - the naming reflects this.)
|
||||
*/
|
||||
#define asm_volatile_goto(x...) do { asm goto(x); asm (""); } while (0)
|
||||
|
||||
#ifdef CONFIG_ARCH_USE_BUILTIN_BSWAP
|
||||
#define __HAVE_BUILTIN_BSWAP32__
|
||||
#define __HAVE_BUILTIN_BSWAP64__
|
||||
#define __HAVE_BUILTIN_BSWAP16__
|
||||
#endif /* CONFIG_ARCH_USE_BUILTIN_BSWAP */
|
||||
|
4560
device/linux-lenovo-karate/config-lenovo-karate.aarch64
Normal file
4560
device/linux-lenovo-karate/config-lenovo-karate.aarch64
Normal file
File diff suppressed because it is too large
Load diff
35
firmware/firmware-lenovo-karate/APKBUILD
Normal file
35
firmware/firmware-lenovo-karate/APKBUILD
Normal file
|
@ -0,0 +1,35 @@
|
|||
pkgname=firmware-lenovo-karate
|
||||
pkgver=1
|
||||
pkgrel=0
|
||||
pkgdesc="Firmware files for Lenovo K6 Power"
|
||||
url="https://github.com/postmarketOS"
|
||||
arch="noarch"
|
||||
license="proprietary"
|
||||
depends="wcnss-wlan"
|
||||
options="!strip !check !archcheck"
|
||||
|
||||
# Source
|
||||
_commit="667ae599036c97e3b61d8b6bf5a778aa5bb9fd70"
|
||||
_url="https://github.com/shwsh/vendor_lenovo_karate"
|
||||
source="$pkgname-$_commit.tar.gz::$_url/archive/${_commit}.tar.gz"
|
||||
|
||||
package() {
|
||||
cd "$srcdir/vendor_lenovo_karate-$_commit"
|
||||
|
||||
# /lib/firmware/postmarketos
|
||||
_files="wcnss.b00 wcnss.b01 wcnss.b02 wcnss.b04 wcnss.b06 wcnss.b09
|
||||
wcnss.b10 wcnss.b11 wcnss.b12 wcnss.mdt"
|
||||
for _i in $_files; do
|
||||
install -D -m644 "$_i" "$pkgdir/lib/firmware/postmarketos/$_i"
|
||||
done
|
||||
|
||||
# /lib/firmware/postmarketos/wlan/prima
|
||||
_files="WCNSS_cfg.dat WCNSS_qcom_cfg.ini WCNSS_qcom_wlan_nv.bin
|
||||
WCNSS_wlan_dictionary.dat"
|
||||
for _i in $_files; do
|
||||
install -D -m644 "wlan/prima/$_i" \
|
||||
"$pkgdir/lib/firmware/postmarketos/wlan/prima/$_i"
|
||||
done
|
||||
}
|
||||
|
||||
sha512sums="50d7bb82a5376dac24d77304be7b9443af0d46d2ded0d60975f32749ab829f379a58be90c44919b505a965f168ce4aa8b7a7dc2c10c4e4480d4ed8b762662015 firmware-lenovo-karate-667ae599036c97e3b61d8b6bf5a778aa5bb9fd70.tar.gz"
|
Loading…
Reference in a new issue