hybris/libhybris: updated to the latest 08-05-2018 commit, fixed compilation (!424)
Signed-off-by: Asriel Dreemurr <asriel.danctnix@gmail.com>
This commit is contained in:
parent
97f3092b88
commit
f6e76368c1
3 changed files with 11 additions and 24 deletions
|
@ -22,7 +22,7 @@ them, which might lead to problems depending on how musl/bionic are
|
|||
hybris/common/n/hybris_compat.cpp | 8 ++++
|
||||
hybris/common/n/hybris_compat.h | 22 +++++++++++
|
||||
hybris/include/hybris/common/musl_compat.h | 10 +++++
|
||||
hybris/properties/properties.c | 3 ++
|
||||
hybris/common/legacy_properties/properties.c | 3 ++
|
||||
hybris/tests/test_camera.c | 4 ++
|
||||
17 files changed, 160 insertions(+), 3 deletions(-)
|
||||
create mode 100644 hybris/include/hybris/common/musl_compat.h
|
||||
|
@ -558,10 +558,10 @@ index 0000000..c5f86f2
|
|||
+ while (__result == -1L && errno == EINTR); \
|
||||
+ __result; }))
|
||||
+#endif
|
||||
diff --git a/hybris/properties/properties.c b/hybris/properties/properties.c
|
||||
diff --git a/hybris/common/legacy_properties/properties.c b/hybris/common/legacy_properties/properties.c
|
||||
index 55cdda6..ae8bbbc 100644
|
||||
--- a/hybris/properties/properties.c
|
||||
+++ b/hybris/properties/properties.c
|
||||
--- a/hybris/common/legacy_properties/properties.c
|
||||
+++ b/hybris/common/legacy_properties/properties.c
|
||||
@@ -36,6 +36,9 @@
|
||||
#include <poll.h>
|
||||
|
||||
|
|
|
@ -85,19 +85,6 @@ index 4126752..c52de15 100644
|
|||
|
||||
-
|
||||
+SUBDIRS += x11
|
||||
diff --git a/hybris/egl/platforms/common/eglplatformcommon.cpp b/hybris/egl/platforms/common/eglplatformcommon.cpp
|
||||
index b512dc0..04aed79 100644
|
||||
--- a/hybris/egl/platforms/common/eglplatformcommon.cpp
|
||||
+++ b/hybris/egl/platforms/common/eglplatformcommon.cpp
|
||||
@@ -74,7 +74,7 @@ extern "C" void hybris_dump_buffer_to_file(ANativeWindowBuffer *buf)
|
||||
char b[1024];
|
||||
int bytes_pp = 0;
|
||||
|
||||
- if (buf->format == HAL_PIXEL_FORMAT_RGBA_8888)
|
||||
+ if (buf->format == HAL_PIXEL_FORMAT_RGBA_8888 || buf->format == HAL_PIXEL_FORMAT_BGRA_8888)
|
||||
bytes_pp = 4;
|
||||
else if (buf->format == HAL_PIXEL_FORMAT_RGB_565)
|
||||
bytes_pp = 2;
|
||||
diff --git a/hybris/egl/platforms/x11/Makefile.am b/hybris/egl/platforms/x11/Makefile.am
|
||||
new file mode 100644
|
||||
index 0000000..22eac5e
|
||||
|
@ -230,7 +217,7 @@ index 0000000..001b733
|
|||
+ hw_get_module(GRALLOC_HARDWARE_MODULE_ID, (const hw_module_t **) &gralloc);
|
||||
+ err = gralloc_open((const hw_module_t *) gralloc, &alloc);
|
||||
+ TRACE("++ %lu x11: got gralloc %p err:%s", pthread_self(), gralloc, strerror(-err));
|
||||
+ eglplatformcommon_init(egl_iface, gralloc, alloc);
|
||||
+ eglplatformcommon_init(egl_iface);
|
||||
+}
|
||||
+
|
||||
+static void _init_egl_funcs(EGLDisplay display)
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
pkgname=libhybris
|
||||
pkgver=1.0_git20180212
|
||||
pkgrel=5
|
||||
pkgver=1.0_git20190508
|
||||
pkgrel=0
|
||||
arch="x86 armhf armv7 aarch64"
|
||||
url="https://github.com/libhybris/libhybris"
|
||||
license="Apache"
|
||||
|
@ -8,7 +8,7 @@ makedepends="autoconf automake libtool wayland-dev linux-headers bsd-compat-head
|
|||
libx11-dev libxcb-dev libxext-dev
|
||||
android-headers-7.1 android-headers-4.4"
|
||||
depends_dev="bsd-compat-headers android-headers-7.1"
|
||||
_commit="4a7d95b73bf40bf6d03d12bf270974c3d0278099"
|
||||
_commit="8ddb15b53d6a63b1545bbf97d00ea93827bd68eb"
|
||||
source="$pkgname-$_commit.tar.gz::https://github.com/libhybris/libhybris/archive/$_commit.tar.gz
|
||||
0001-Make-libhybris-compile-with-musl.patch
|
||||
0002-tests-Regression-test-for-EGL-glibc-TLS-conflict.patch
|
||||
|
@ -161,8 +161,8 @@ dev() {
|
|||
ln -s ../hybris/EGL/eglhybris.h .
|
||||
}
|
||||
|
||||
sha512sums="378ad6815f2c17dec7c0043499833e55498f48634aa6dc8d5a5c2e8bfc4281f76690bca6f35e74f47a41b364baab1533ff8d8898d61a9e5b53897deb7d180f97 libhybris-4a7d95b73bf40bf6d03d12bf270974c3d0278099.tar.gz
|
||||
9655816dc3d89f329801a74f4499c3752cbc96f7ba2e052765335a2cbd7e74cdf45064260ab27537bcd9d64673144eac6f89e31af4b4c6b4a4792ad7b398555d 0001-Make-libhybris-compile-with-musl.patch
|
||||
sha512sums="681e8345ba56d5b9684ab3901c9cfdc6d4f48f55ef97611eef14d9471f08f1c0f60803298224df5110f2a3d08da145a61e38ea241585bc07e30cb48a893dc92b libhybris-8ddb15b53d6a63b1545bbf97d00ea93827bd68eb.tar.gz
|
||||
9f7a324f18332e44f8789108e32f0587c268d10adaee0040c42d1bece7ab58e292d68243e7814f34f37b3b5dff590758269e531b4f2fd1991334eda4333f5854 0001-Make-libhybris-compile-with-musl.patch
|
||||
1355a4403d1af8bdf75b9e4502cbfc093b9788224ce7c24a1f6a53dd7996d385d31a3362577a4293db6b6d0dd0ae4e88140b38c658ff0a288d9acfc2753859bb 0002-tests-Regression-test-for-EGL-glibc-TLS-conflict.patch
|
||||
865ad86b297dcd09416a9df4e366d58429f737aeaa380308fd04943451cefd8500a18857e61c8de43cb4595c59d438d3f12855e189932ab7df8a2f354086a21c 0003-Implement-X11-EGL-platform-based-on-wayland-code.patch
|
||||
3915889f243f8232db2b926f9a456b042df61119ada351f27a33888edcc5da605f53d5bd12e4ef30f65ef962cd2371952776655e4eaf67f5d8cb6da2664c85b2 0003-Implement-X11-EGL-platform-based-on-wayland-code.patch
|
||||
eda57804fefa1d586e90fb2198c310f65e6dbc7e09b5d1dd7d15df4ab152c4c8915c212230a92c35ec8a013d3ec7a7b1d289653bedb46b7eb2850a477ccebe16 0004-Build-test-hwcomposer-7-caf.patch"
|
||||
|
|
Loading…
Reference in a new issue