Add the linux-postmarketos-qcom package
This is based on the linux-postmarketos-mainline, uses the fork of <https://github.com/postmarketOS/linux>
This commit is contained in:
parent
e7551a4d33
commit
ef66300eee
3 changed files with 4587 additions and 0 deletions
441
main/linux-postmarketos-qcom/0001-sony-amami-dts.patch
Normal file
441
main/linux-postmarketos-qcom/0001-sony-amami-dts.patch
Normal file
|
@ -0,0 +1,441 @@
|
|||
diff --git a/arch/arm/boot/dts/Makefile b/arch/arm/boot/dts/Makefile
|
||||
index d0381e9caf21..57ec846e005b 100644
|
||||
--- a/arch/arm/boot/dts/Makefile
|
||||
+++ b/arch/arm/boot/dts/Makefile
|
||||
@@ -729,6 +729,7 @@ dtb-$(CONFIG_ARCH_QCOM) += \
|
||||
qcom-msm8960-cdp.dtb \
|
||||
qcom-msm8974-fairphone-fp2.dtb \
|
||||
qcom-msm8974-lge-nexus5-hammerhead.dtb \
|
||||
+ qcom-msm8974-sony-xperia-amami.dtb \
|
||||
qcom-msm8974-sony-xperia-castor.dtb \
|
||||
qcom-msm8974-sony-xperia-honami.dtb \
|
||||
qcom-mdm9615-wp8548-mangoh-green.dtb
|
||||
diff --git a/arch/arm/boot/dts/qcom-msm8974-sony-xperia-amami.dts b/arch/arm/boot/dts/qcom-msm8974-sony-xperia-amami.dts
|
||||
new file mode 100644
|
||||
index 000000000000..fa6beb54f13a
|
||||
--- /dev/null
|
||||
+++ b/arch/arm/boot/dts/qcom-msm8974-sony-xperia-amami.dts
|
||||
@@ -0,0 +1,423 @@
|
||||
+#include "qcom-msm8974.dtsi"
|
||||
+#include "qcom-pm8841.dtsi"
|
||||
+#include "qcom-pm8941.dtsi"
|
||||
+#include <dt-bindings/gpio/gpio.h>
|
||||
+#include <dt-bindings/input/input.h>
|
||||
+#include <dt-bindings/pinctrl/qcom,pmic-gpio.h>
|
||||
+
|
||||
+/ {
|
||||
+ model = "Sony Xperia Z1 Compact";
|
||||
+ compatible = "sony,xperia-amami", "qcom,msm8974";
|
||||
+
|
||||
+ aliases {
|
||||
+ serial0 = &blsp1_uart2;
|
||||
+ };
|
||||
+
|
||||
+ chosen {
|
||||
+ stdout-path = "serial0:115200n8";
|
||||
+ };
|
||||
+
|
||||
+ gpio-keys {
|
||||
+ compatible = "gpio-keys";
|
||||
+ input-name = "gpio-keys";
|
||||
+
|
||||
+ pinctrl-names = "default";
|
||||
+ pinctrl-0 = <&gpio_keys_pin_a>;
|
||||
+
|
||||
+ volume-down {
|
||||
+ label = "volume_down";
|
||||
+ gpios = <&pm8941_gpios 2 GPIO_ACTIVE_LOW>;
|
||||
+ linux,input-type = <1>;
|
||||
+ linux,code = <KEY_VOLUMEDOWN>;
|
||||
+ };
|
||||
+
|
||||
+ camera-snapshot {
|
||||
+ label = "camera_snapshot";
|
||||
+ gpios = <&pm8941_gpios 3 GPIO_ACTIVE_LOW>;
|
||||
+ linux,input-type = <1>;
|
||||
+ linux,code = <KEY_CAMERA>;
|
||||
+ };
|
||||
+
|
||||
+ camera-focus {
|
||||
+ label = "camera_focus";
|
||||
+ gpios = <&pm8941_gpios 4 GPIO_ACTIVE_LOW>;
|
||||
+ linux,input-type = <1>;
|
||||
+ linux,code = <KEY_CAMERA_FOCUS>;
|
||||
+ };
|
||||
+
|
||||
+ volume-up {
|
||||
+ label = "volume_up";
|
||||
+ gpios = <&pm8941_gpios 5 GPIO_ACTIVE_LOW>;
|
||||
+ linux,input-type = <1>;
|
||||
+ linux,code = <KEY_VOLUMEUP>;
|
||||
+ };
|
||||
+ };
|
||||
+
|
||||
+ memory@0 {
|
||||
+ reg = <0 0x40000000>, <0x40000000 0x40000000>;
|
||||
+ device_type = "memory";
|
||||
+ };
|
||||
+
|
||||
+ smd {
|
||||
+ rpm {
|
||||
+ rpm_requests {
|
||||
+ pm8841-regulators {
|
||||
+ s1 {
|
||||
+ regulator-min-microvolt = <675000>;
|
||||
+ regulator-max-microvolt = <1050000>;
|
||||
+ };
|
||||
+
|
||||
+ s2 {
|
||||
+ regulator-min-microvolt = <500000>;
|
||||
+ regulator-max-microvolt = <1050000>;
|
||||
+ };
|
||||
+
|
||||
+ s3 {
|
||||
+ regulator-min-microvolt = <500000>;
|
||||
+ regulator-max-microvolt = <1050000>;
|
||||
+ };
|
||||
+
|
||||
+ s4 {
|
||||
+ regulator-min-microvolt = <500000>;
|
||||
+ regulator-max-microvolt = <1050000>;
|
||||
+ };
|
||||
+ };
|
||||
+
|
||||
+ pm8941-regulators {
|
||||
+ vdd_l1_l3-supply = <&pm8941_s1>;
|
||||
+ vdd_l2_lvs1_2_3-supply = <&pm8941_s3>;
|
||||
+ vdd_l4_l11-supply = <&pm8941_s1>;
|
||||
+ vdd_l5_l7-supply = <&pm8941_s2>;
|
||||
+ vdd_l6_l12_l14_l15-supply = <&pm8941_s2>;
|
||||
+ vdd_l9_l10_l17_l22-supply = <&vreg_boost>;
|
||||
+ vdd_l13_l20_l23_l24-supply = <&vreg_boost>;
|
||||
+ vdd_l21-supply = <&vreg_boost>;
|
||||
+
|
||||
+ s1 {
|
||||
+ regulator-min-microvolt = <1300000>;
|
||||
+ regulator-max-microvolt = <1300000>;
|
||||
+ regulator-always-on;
|
||||
+ regulator-boot-on;
|
||||
+ };
|
||||
+
|
||||
+ s2 {
|
||||
+ regulator-min-microvolt = <2150000>;
|
||||
+ regulator-max-microvolt = <2150000>;
|
||||
+ regulator-boot-on;
|
||||
+ };
|
||||
+
|
||||
+ s3 {
|
||||
+ regulator-min-microvolt = <1800000>;
|
||||
+ regulator-max-microvolt = <1800000>;
|
||||
+ regulator-always-on;
|
||||
+ regulator-boot-on;
|
||||
+ };
|
||||
+
|
||||
+ s4 {
|
||||
+ regulator-min-microvolt = <5000000>;
|
||||
+ regulator-max-microvolt = <5000000>;
|
||||
+ };
|
||||
+
|
||||
+ l1 {
|
||||
+ regulator-min-microvolt = <1225000>;
|
||||
+ regulator-max-microvolt = <1225000>;
|
||||
+
|
||||
+ regulator-always-on;
|
||||
+ regulator-boot-on;
|
||||
+ };
|
||||
+
|
||||
+ l2 {
|
||||
+ regulator-min-microvolt = <1200000>;
|
||||
+ regulator-max-microvolt = <1200000>;
|
||||
+ };
|
||||
+
|
||||
+ l3 {
|
||||
+ regulator-min-microvolt = <1200000>;
|
||||
+ regulator-max-microvolt = <1200000>;
|
||||
+ };
|
||||
+
|
||||
+ l4 {
|
||||
+ regulator-min-microvolt = <1225000>;
|
||||
+ regulator-max-microvolt = <1225000>;
|
||||
+ };
|
||||
+
|
||||
+ l5 {
|
||||
+ regulator-min-microvolt = <1800000>;
|
||||
+ regulator-max-microvolt = <1800000>;
|
||||
+ };
|
||||
+
|
||||
+ l6 {
|
||||
+ regulator-min-microvolt = <1800000>;
|
||||
+ regulator-max-microvolt = <1800000>;
|
||||
+
|
||||
+ regulator-boot-on;
|
||||
+ };
|
||||
+
|
||||
+ l7 {
|
||||
+ regulator-min-microvolt = <1800000>;
|
||||
+ regulator-max-microvolt = <1800000>;
|
||||
+
|
||||
+ regulator-boot-on;
|
||||
+ };
|
||||
+
|
||||
+ l8 {
|
||||
+ regulator-min-microvolt = <1800000>;
|
||||
+ regulator-max-microvolt = <1800000>;
|
||||
+ };
|
||||
+
|
||||
+ l9 {
|
||||
+ regulator-min-microvolt = <1800000>;
|
||||
+ regulator-max-microvolt = <2950000>;
|
||||
+ };
|
||||
+
|
||||
+ l11 {
|
||||
+ regulator-min-microvolt = <1300000>;
|
||||
+ regulator-max-microvolt = <1350000>;
|
||||
+ };
|
||||
+
|
||||
+ l12 {
|
||||
+ regulator-min-microvolt = <1800000>;
|
||||
+ regulator-max-microvolt = <1800000>;
|
||||
+
|
||||
+ regulator-always-on;
|
||||
+ regulator-boot-on;
|
||||
+ };
|
||||
+
|
||||
+ l13 {
|
||||
+ regulator-min-microvolt = <1800000>;
|
||||
+ regulator-max-microvolt = <2950000>;
|
||||
+
|
||||
+ regulator-boot-on;
|
||||
+ };
|
||||
+
|
||||
+ l14 {
|
||||
+ regulator-min-microvolt = <1800000>;
|
||||
+ regulator-max-microvolt = <1800000>;
|
||||
+ };
|
||||
+
|
||||
+ l15 {
|
||||
+ regulator-min-microvolt = <2050000>;
|
||||
+ regulator-max-microvolt = <2050000>;
|
||||
+ };
|
||||
+
|
||||
+ l16 {
|
||||
+ regulator-min-microvolt = <2700000>;
|
||||
+ regulator-max-microvolt = <2700000>;
|
||||
+ };
|
||||
+
|
||||
+ l17 {
|
||||
+ regulator-min-microvolt = <2700000>;
|
||||
+ regulator-max-microvolt = <2700000>;
|
||||
+ };
|
||||
+
|
||||
+ l18 {
|
||||
+ regulator-min-microvolt = <2850000>;
|
||||
+ regulator-max-microvolt = <2850000>;
|
||||
+ };
|
||||
+
|
||||
+ l19 {
|
||||
+ regulator-min-microvolt = <3300000>;
|
||||
+ regulator-max-microvolt = <3300000>;
|
||||
+ };
|
||||
+
|
||||
+ l20 {
|
||||
+ regulator-min-microvolt = <2950000>;
|
||||
+ regulator-max-microvolt = <2950000>;
|
||||
+
|
||||
+ regulator-allow-set-load;
|
||||
+ regulator-boot-on;
|
||||
+ regulator-system-load = <200000>;
|
||||
+ };
|
||||
+
|
||||
+ l21 {
|
||||
+ regulator-min-microvolt = <2950000>;
|
||||
+ regulator-max-microvolt = <2950000>;
|
||||
+
|
||||
+ regulator-boot-on;
|
||||
+ };
|
||||
+
|
||||
+ l22 {
|
||||
+ regulator-min-microvolt = <3000000>;
|
||||
+ regulator-max-microvolt = <3000000>;
|
||||
+ };
|
||||
+
|
||||
+ l23 {
|
||||
+ regulator-min-microvolt = <2800000>;
|
||||
+ regulator-max-microvolt = <2800000>;
|
||||
+ };
|
||||
+
|
||||
+ l24 {
|
||||
+ regulator-min-microvolt = <3075000>;
|
||||
+ regulator-max-microvolt = <3075000>;
|
||||
+
|
||||
+ regulator-boot-on;
|
||||
+ };
|
||||
+ };
|
||||
+ };
|
||||
+ };
|
||||
+ };
|
||||
+};
|
||||
+
|
||||
+&soc {
|
||||
+ sdhci@f9824900 {
|
||||
+ status = "ok";
|
||||
+
|
||||
+ vmmc-supply = <&pm8941_l20>;
|
||||
+ vqmmc-supply = <&pm8941_s3>;
|
||||
+
|
||||
+ bus-width = <8>;
|
||||
+ non-removable;
|
||||
+
|
||||
+ pinctrl-names = "default";
|
||||
+ pinctrl-0 = <&sdhc1_pin_a>;
|
||||
+ };
|
||||
+
|
||||
+ sdhci@f98a4900 {
|
||||
+ status = "ok";
|
||||
+
|
||||
+ bus-width = <4>;
|
||||
+
|
||||
+ vmmc-supply = <&pm8941_l21>;
|
||||
+ vqmmc-supply = <&pm8941_l13>;
|
||||
+
|
||||
+ cd-gpios = <&msmgpio 62 GPIO_ACTIVE_LOW>;
|
||||
+
|
||||
+ pinctrl-names = "default";
|
||||
+ pinctrl-0 = <&sdhc2_pin_a>, <&sdhc2_cd_pin_a>;
|
||||
+ };
|
||||
+
|
||||
+ serial@f991e000 {
|
||||
+ status = "ok";
|
||||
+
|
||||
+ pinctrl-names = "default";
|
||||
+ pinctrl-0 = <&blsp1_uart2_pin_a>;
|
||||
+ };
|
||||
+
|
||||
+
|
||||
+ pinctrl@fd510000 {
|
||||
+ blsp1_uart2_pin_a: blsp1-uart2-pin-active {
|
||||
+ rx {
|
||||
+ pins = "gpio5";
|
||||
+ function = "blsp_uart2";
|
||||
+
|
||||
+ drive-strength = <2>;
|
||||
+ bias-pull-up;
|
||||
+ };
|
||||
+
|
||||
+ tx {
|
||||
+ pins = "gpio4";
|
||||
+ function = "blsp_uart2";
|
||||
+
|
||||
+ drive-strength = <4>;
|
||||
+ bias-disable;
|
||||
+ };
|
||||
+ };
|
||||
+
|
||||
+ i2c2_pins: i2c2 {
|
||||
+ mux {
|
||||
+ pins = "gpio6", "gpio7";
|
||||
+ function = "blsp_i2c2";
|
||||
+
|
||||
+ drive-strength = <2>;
|
||||
+ bias-disable;
|
||||
+ };
|
||||
+ };
|
||||
+
|
||||
+ sdhc1_pin_a: sdhc1-pin-active {
|
||||
+ clk {
|
||||
+ pins = "sdc1_clk";
|
||||
+ drive-strength = <16>;
|
||||
+ bias-disable;
|
||||
+ };
|
||||
+
|
||||
+ cmd-data {
|
||||
+ pins = "sdc1_cmd", "sdc1_data";
|
||||
+ drive-strength = <10>;
|
||||
+ bias-pull-up;
|
||||
+ };
|
||||
+ };
|
||||
+
|
||||
+ sdhc2_cd_pin_a: sdhc2-cd-pin-active {
|
||||
+ pins = "gpio62";
|
||||
+ function = "gpio";
|
||||
+
|
||||
+ drive-strength = <2>;
|
||||
+ bias-disable;
|
||||
+ };
|
||||
+
|
||||
+ sdhc2_pin_a: sdhc2-pin-active {
|
||||
+ clk {
|
||||
+ pins = "sdc2_clk";
|
||||
+ drive-strength = <10>;
|
||||
+ bias-disable;
|
||||
+ };
|
||||
+
|
||||
+ cmd-data {
|
||||
+ pins = "sdc2_cmd", "sdc2_data";
|
||||
+ drive-strength = <6>;
|
||||
+ bias-pull-up;
|
||||
+ };
|
||||
+ };
|
||||
+ };
|
||||
+
|
||||
+ dma-controller@f9944000 {
|
||||
+ qcom,controlled-remotely;
|
||||
+ };
|
||||
+
|
||||
+ usb@f9a55000 {
|
||||
+ status = "ok";
|
||||
+
|
||||
+ phys = <&usb_hs1_phy>;
|
||||
+ phy-select = <&tcsr 0xb000 0>;
|
||||
+ extcon = <&smbb>, <&usb_id>;
|
||||
+ vbus-supply = <&chg_otg>;
|
||||
+
|
||||
+ hnp-disable;
|
||||
+ srp-disable;
|
||||
+ adp-disable;
|
||||
+
|
||||
+ ulpi {
|
||||
+ phy@a {
|
||||
+ status = "ok";
|
||||
+
|
||||
+ v1p8-supply = <&pm8941_l6>;
|
||||
+ v3p3-supply = <&pm8941_l24>;
|
||||
+
|
||||
+ extcon = <&smbb>;
|
||||
+ qcom,init-seq = /bits/ 8 <0x1 0x64>;
|
||||
+ };
|
||||
+ };
|
||||
+ };
|
||||
+};
|
||||
+
|
||||
+&spmi_bus {
|
||||
+ pm8941@0 {
|
||||
+ charger@1000 {
|
||||
+ qcom,fast-charge-safe-current = <1300000>;
|
||||
+ qcom,fast-charge-current-limit = <1300000>;
|
||||
+ qcom,dc-current-limit = <1300000>;
|
||||
+ qcom,fast-charge-safe-voltage = <4400000>;
|
||||
+ qcom,fast-charge-high-threshold-voltage = <4350000>;
|
||||
+ qcom,fast-charge-low-threshold-voltage = <3400000>;
|
||||
+ qcom,auto-recharge-threshold-voltage = <4200000>;
|
||||
+ qcom,minimum-input-voltage = <4300000>;
|
||||
+ };
|
||||
+
|
||||
+ gpios@c000 {
|
||||
+ gpio_keys_pin_a: gpio-keys-active {
|
||||
+ pins = "gpio2", "gpio3", "gpio4", "gpio5";
|
||||
+ function = "normal";
|
||||
+
|
||||
+ bias-pull-up;
|
||||
+ power-source = <PM8941_GPIO_S3>;
|
||||
+ };
|
||||
+ };
|
||||
+
|
||||
+ coincell@2800 {
|
||||
+ status = "ok";
|
||||
+ qcom,rset-ohms = <2100>;
|
||||
+ qcom,vset-millivolts = <3000>;
|
||||
+ };
|
||||
+ };
|
||||
+
|
||||
+};
|
182
main/linux-postmarketos-qcom/APKBUILD
Normal file
182
main/linux-postmarketos-qcom/APKBUILD
Normal file
|
@ -0,0 +1,182 @@
|
|||
_flavor=postmarketos-qcom
|
||||
_config="config-${_flavor}.${CARCH}"
|
||||
|
||||
pkgname=linux-${_flavor}
|
||||
|
||||
pkgver=4.16_rc6
|
||||
pkgrel=0
|
||||
|
||||
arch="armhf"
|
||||
pkgdesc="Kernel close to mainline with extra patches for Qualcomm devices"
|
||||
url="https://kernel.org/"
|
||||
depends=""
|
||||
makedepends="perl sed installkernel bash gmp-dev bc linux-headers elfutils-dev libressl-dev file bison flex"
|
||||
options="!strip !check !tracedeps"
|
||||
install=
|
||||
_commit="e9fc9b4e4a83c8a9fba2230ac91d5c75b9fcd4d8"
|
||||
source="
|
||||
linux-${_commit}.tar.gz::https://github.com/postmarketOS/linux/archive/${_commit}.tar.gz
|
||||
config-${_flavor}.armhf
|
||||
"
|
||||
|
||||
subpackages="$pkgname-dev"
|
||||
|
||||
license="GPL2"
|
||||
_abi_release=$_pkgver
|
||||
_carch=${CARCH}
|
||||
case "$_carch" in
|
||||
aarch64*) _carch="arm64" ;;
|
||||
arm*) _carch="arm" ;;
|
||||
ppc*) _carch="powerpc" ;;
|
||||
s390*) _carch="s390" ;;
|
||||
esac
|
||||
|
||||
HOSTCC="${CC:-gcc}"
|
||||
HOSTCC="${HOSTCC#${CROSS_COMPILE}}"
|
||||
|
||||
builddir="$srcdir/linux-${_commit}"
|
||||
|
||||
prepare() {
|
||||
local _patch_failed=
|
||||
ls "$srcdir"
|
||||
cd "$builddir"
|
||||
# first apply patches in specified order
|
||||
for i in $source; do
|
||||
case $i in
|
||||
*.patch|*.patch::*)
|
||||
_patch=${i%::*}
|
||||
msg "Applying $_patch..."
|
||||
if ! patch -s -p1 -N -i "$srcdir"/$_patch; then
|
||||
echo $_patch >>failed
|
||||
_patch_failed=1
|
||||
fi
|
||||
;;
|
||||
esac
|
||||
done
|
||||
|
||||
if ! [ -z "$_patch_failed" ]; then
|
||||
error "The following patches failed:"
|
||||
cat failed
|
||||
return 1
|
||||
fi
|
||||
|
||||
mkdir -p "$srcdir"/build
|
||||
cp -v "$srcdir"/$_config "$srcdir"/build/.config
|
||||
make -C "$builddir" O="$srcdir"/build ARCH="$_carch" HOSTCC="$HOSTCC" \
|
||||
olddefconfig
|
||||
}
|
||||
|
||||
|
||||
|
||||
# this is so we can do: 'abuild menuconfig' to reconfigure kernel
|
||||
menuconfig() {
|
||||
cd "$srcdir"/build
|
||||
make ARCH="$_carch" menuconfig
|
||||
cp .config "$startdir"/$_config
|
||||
}
|
||||
|
||||
build() {
|
||||
cd "$srcdir"/build
|
||||
unset LDFLAGS
|
||||
make ARCH="$_carch" CC="${CC:-gcc}" \
|
||||
KBUILD_BUILD_VERSION="$((pkgrel + 1 ))-${_flavor}" \
|
||||
CFLAGS_MODULE=-fno-pic
|
||||
}
|
||||
|
||||
package() {
|
||||
cd "$srcdir/build/arch/${_carch}/boot"
|
||||
|
||||
if [ "$CARCH" == "aarch64" ]; then
|
||||
install -Dm644 "$srcdir/build/arch/${_carch}/boot/Image" \
|
||||
"$pkgdir/boot/vmlinuz-$_flavor"
|
||||
else
|
||||
install -Dm644 "$srcdir/build/arch/${_carch}/boot/"*zImage \
|
||||
"$pkgdir/boot/vmlinuz-$_flavor"
|
||||
fi
|
||||
|
||||
install -D "$srcdir/build/include/config/kernel.release" \
|
||||
"$pkgdir/usr/share/kernel/$_flavor/kernel.release"
|
||||
|
||||
cd "$srcdir"/build
|
||||
|
||||
local _install
|
||||
case "$CARCH" in
|
||||
aarch64*|arm*) _install="modules_install dtbs_install" ;;
|
||||
*) _install="modules_install" ;;
|
||||
esac
|
||||
|
||||
make -j1 $_install \
|
||||
ARCH="$_carch" \
|
||||
INSTALL_MOD_PATH="$pkgdir" \
|
||||
INSTALL_DTBS_PATH="$pkgdir/usr/share/dtb"
|
||||
}
|
||||
|
||||
|
||||
dev() {
|
||||
# copy the only the parts that we really need for build 3rd party
|
||||
# kernel modules and install those as /usr/src/linux-headers,
|
||||
# simlar to what ubuntu does
|
||||
#
|
||||
# this way you dont need to install the 300-400 kernel sources to
|
||||
# build a tiny kernel module
|
||||
#
|
||||
pkgdesc="Headers and script for third party modules for postmarketos kernel"
|
||||
depends="gmp-dev bash perl"
|
||||
local dir="$subpkgdir"/usr/src/linux-headers-${_abi_release}
|
||||
|
||||
# first we import config, run prepare to set up for building
|
||||
# external modules, and create the scripts
|
||||
mkdir -p "$dir"
|
||||
cp "$srcdir"/$_config "$dir"/.config
|
||||
make -j1 -C "$builddir" O="$dir" ARCH="$_carch" HOSTCC="$HOSTCC" \
|
||||
olddefconfig prepare modules_prepare scripts
|
||||
|
||||
# needed for 3rd party modules
|
||||
# https://bugzilla.kernel.org/show_bug.cgi?id=11143
|
||||
case "$CARCH" in
|
||||
ppc*) (cd "$dir" && make arch/powerpc/lib/crtsavres.o);;
|
||||
esac
|
||||
|
||||
# remove the stuff that points to real sources. we want 3rd party
|
||||
# modules to believe this is the soruces
|
||||
rm "$dir"/Makefile "$dir"/source
|
||||
|
||||
# copy the needed stuff from real sources
|
||||
#
|
||||
# this is taken from ubuntu kernel build script
|
||||
# http://kernel.ubuntu.com/git/ubuntu/ubuntu-zesty.git/tree/debian/rules.d/3-binary-indep.mk
|
||||
|
||||
cd "$builddir"
|
||||
find . -path './include/*' -prune \
|
||||
-o -path './scripts/*' -prune -o -type f \
|
||||
\( -name 'Makefile*' -o -name 'Kconfig*' -o -name 'Kbuild*' -o \
|
||||
-name '*.sh' -o -name '*.pl' -o -name '*.lds' \) \
|
||||
-print | cpio -pdm "$dir"
|
||||
cp -a scripts include "$dir"
|
||||
find $(find arch -name include -type d -print) -type f \
|
||||
| cpio -pdm "$dir"
|
||||
|
||||
install -Dm644 "$srcdir"/build/Module.symvers \
|
||||
"$dir"/Module.symvers
|
||||
|
||||
mkdir -p "$subpkgdir"/lib/modules/${_abi_release}
|
||||
ln -sf /usr/src/linux-headers-${_abi_release} \
|
||||
"$subpkgdir"/lib/modules/${_abi_release}/build
|
||||
|
||||
# cross-compiling: delete binaries with host arch and replace them with
|
||||
# symlinks to binaries with the target arch (packaged in kernel-scripts)
|
||||
if [ -n "$CROSS_COMPILE" ]; then
|
||||
msg "Symlinking binary scripts..."
|
||||
depends="$depends kernel-scripts"
|
||||
cd "$dir/scripts"
|
||||
local i
|
||||
for i in $(find . -type f); do
|
||||
local type="$(file -b --mime-type "$i")"
|
||||
[ "$type" != "application/x-sharedlib" ] && continue
|
||||
local native="/usr/bin/kernel-scripts/$(echo "$i" | cut -d '/' -f 2-)"
|
||||
ln -svf "$native" "$i"
|
||||
done
|
||||
fi
|
||||
}
|
||||
sha512sums="a77f3906b87cadbd2ce2565123cd7bcd266c18894343c44dd27a04bac6eeaacb0507c20619c73853a19af38b05c4bc70c8c07d16d0b22ebdb7a46ceed71577be linux-e9fc9b4e4a83c8a9fba2230ac91d5c75b9fcd4d8.tar.gz
|
||||
91b90e07608acb02b611263ee5318a8e1c61ca0605023f0ded1a1f403e6e3ee172be5c96734d6d5eddaf5b38762e449b7ab7d5471db5b763c0e1bbb350342b1f config-postmarketos-qcom.armhf"
|
3964
main/linux-postmarketos-qcom/config-postmarketos-qcom.armhf
Normal file
3964
main/linux-postmarketos-qcom/config-postmarketos-qcom.armhf
Normal file
File diff suppressed because it is too large
Load diff
Loading…
Reference in a new issue