temp/gtk+3.0: upgrade to 9999_git20201022

Remove patches:
'0001-gtk-meson.build-add-new-hdy-files.patch' and
'10-Revert-gdkseatdefault-Grab-touch-events-where-applic.patch'
appear in the code downloaded from Purism at precisely the
location of the patches.

[ci:skip-build]: already built successfully in CI
This commit is contained in:
Timothee LF 2020-10-27 15:31:19 -04:00 committed by Oliver Smith
parent ae9fd7f8be
commit e38c7c069a
No known key found for this signature in database
GPG key ID: 5AE7F5513E0885CB
3 changed files with 5 additions and 75 deletions

View file

@ -1,38 +0,0 @@
Upstreaming: https://source.puri.sm/Librem5/gtk/-/merge_requests/17
From 74c44f81ae64605765a03ba65bc413e35690532f Mon Sep 17 00:00:00 2001
From: Oliver Smith <ollieparanoid@postmarketos.org>
Date: Thu, 20 Aug 2020 14:53:06 +0200
Subject: [PATCH] gtk/meson.build: add new hdy-* files
Fix the build with meson.
---
gtk/meson.build | 7 +++++++
1 file changed, 7 insertions(+)
diff --git a/gtk/meson.build b/gtk/meson.build
index 5a0b1547d8..ffbf97b385 100644
--- a/gtk/meson.build
+++ b/gtk/meson.build
@@ -385,11 +385,18 @@ gtk_sources = files(
'gdkpixbufutils.c',
'language-names.c',
'script-names.c',
+ 'hdy-view-switcher-bar.c',
+ 'hdy-view-switcher-button.c',
+ 'hdy-view-switcher.c',
)
gtk_private_type_headers = files(
'gtkcsstypesprivate.h',
'gtktexthandleprivate.h',
+ 'hdy-style-private.h',
+ 'hdy-view-switcher-bar-private.h',
+ 'hdy-view-switcher-button-private.h',
+ 'hdy-view-switcher-private.h',
)
gtk_gir_public_headers = files(
--
2.20.1

View file

@ -1,28 +0,0 @@
diff --git a/gdk/gdkseatdefault.c b/gdk/gdkseatdefault.c
index ce4bdc82d2..9650f4b121 100644
--- a/gdk/gdkseatdefault.c
+++ b/gdk/gdkseatdefault.c
@@ -134,22 +134,9 @@ gdk_seat_default_grab (GdkSeat *seat,
if (capabilities & GDK_SEAT_CAPABILITY_ALL_POINTING)
{
- /* ALL_POINTING spans 3 capabilities; get the mask for the ones we have */
- GdkEventMask pointer_evmask = 0;
-
- /* We let tablet styli take over the pointer cursor */
- if (capabilities & (GDK_SEAT_CAPABILITY_POINTER |
- GDK_SEAT_CAPABILITY_TABLET_STYLUS))
- {
- pointer_evmask |= POINTER_EVENTS;
- }
-
- if (capabilities & GDK_SEAT_CAPABILITY_TOUCH)
- pointer_evmask |= TOUCH_EVENTS;
-
status = gdk_device_grab (priv->master_pointer, window,
GDK_OWNERSHIP_NONE, owner_events,
- pointer_evmask, cursor,
+ POINTER_EVENTS, cursor,
evtime);
}

View file

@ -1,8 +1,8 @@
# Forked from Alpine to apply Purism's patches for responsivness
pkgname=gtk+3.0
pkgver=9999_git20200616
pkgrel=3
_commit="21ecddab70544dc4421cd34247e9c7c2ef551409"
pkgver=9999_git20201022
pkgrel=0
_commit="a3994f140fe20c0bc7c6cd13a60cdf9700461a94"
pkgdesc="The GTK+ Toolkit (v3)"
url="https://www.gtk.org/"
install="$pkgname.post-install $pkgname.post-upgrade $pkgname.post-deinstall"
@ -59,9 +59,7 @@ checkdepends="
gdk-pixbuf
"
source="https://source.puri.sm/Librem5/gtk/-/archive/$_commit/gtk-$_commit.tar.gz
10-Revert-gdkseatdefault-Grab-touch-events-where-applic.patch
check-version.py
0001-gtk-meson.build-add-new-hdy-files.patch
"
builddir="$srcdir/gtk-$_commit"
@ -138,7 +136,5 @@ doc() {
default_doc
}
sha512sums="8d2a85ad058191348927454170c8ab63dfbdfce6a7b3172824aa33b128d17b6f3de7ba85445efa658adb5d7a98d60730e014d1113b19a2f036222f32ae62bf00 gtk-21ecddab70544dc4421cd34247e9c7c2ef551409.tar.gz
e4ea76484b70bd9beb65b2964bbcff3b3f78f5f6fe70b12309a7721ca134e3735e8aaac09803f93b393a6130a703f8f346c0df89ad45d18c580dac1e0e922276 10-Revert-gdkseatdefault-Grab-touch-events-where-applic.patch
b97ccd8fb78d7c32fe91607befd6a7c0dd969fbfc9c242948fc88085133e3461583a0b18ade199b73f9659cae5f5525b940e66535a6ced4b916af9a88b3cc578 check-version.py
2464ee16e0731ad1b3a2c15cb3274bbb4ae55eab34e9c6310712003142c127efe0c342c510fe4edf399d14e33050300702432b5515954ddcb380d08aac0589c2 0001-gtk-meson.build-add-new-hdy-files.patch"
sha512sums="bd573a5d48b5621cb243418f6bb9a5b2954e218d7955f7acb1a340c8b67f363bb1c4fcde24fa7e5314a557aaa00e5e0fb7d6b8d3ffbf79da733c0ce422c608ec gtk-a3994f140fe20c0bc7c6cd13a60cdf9700461a94.tar.gz
b97ccd8fb78d7c32fe91607befd6a7c0dd969fbfc9c242948fc88085133e3461583a0b18ade199b73f9659cae5f5525b940e66535a6ced4b916af9a88b3cc578 check-version.py"