community/linux-postmarketos-omap: upgrade to 6.0.2 (MR 3563)

This commit is contained in:
Mithil Bavishi 2022-10-19 23:06:51 +05:30 committed by Oliver Smith
parent adcc988069
commit e34cce6e0f
No known key found for this signature in database
GPG key ID: 5AE7F5513E0885CB
7 changed files with 356 additions and 1156 deletions

View file

@ -1,21 +1,19 @@
diff --git a/arch/arm/boot/dts/Makefile b/arch/arm/boot/dts/Makefile
index 7e0934180..cdf76c6cd 100644
--- a/arch/arm/boot/dts/Makefile
+++ b/arch/arm/boot/dts/Makefile
@@ -880,6 +880,7 @@ dtb-$(CONFIG_ARCH_OMAP4) += \
omap4-panda.dtb \
omap4-panda-a4.dtb \
omap4-panda-es.dtb \
+ omap4-samsung-espresso3g.dtb \
omap4-sdp.dtb \
omap4-sdp-es23plus.dtb \
omap4-var-dvk-om44.dtb \
diff --git a/arch/arm/boot/dts/omap4-samsung-espresso3g.dts b/arch/arm/boot/dts/omap4-samsung-espresso3g.dts
From 12fb937cc5e72e21a86f32180fd203e6585c2438 Mon Sep 17 00:00:00 2001
From: Mithil Bavishi <bavishimithil@gmail.com>
Date: Thu, 20 Oct 2022 20:46:02 +0530
Subject: [PATCH 1/3] arm/dts: Add common dtsi for espresso
---
.../dts/omap4-samsung-espresso-common.dtsi | 676 ++++++++++++++++++
1 file changed, 676 insertions(+)
create mode 100644 arch/arm/boot/dts/omap4-samsung-espresso-common.dtsi
diff --git a/arch/arm/boot/dts/omap4-samsung-espresso-common.dtsi b/arch/arm/boot/dts/omap4-samsung-espresso-common.dtsi
new file mode 100644
index 000000000..4dbc096ee
index 000000000..b44af61d4
--- /dev/null
+++ b/arch/arm/boot/dts/omap4-samsung-espresso3g.dts
@@ -0,0 +1,632 @@
+++ b/arch/arm/boot/dts/omap4-samsung-espresso-common.dtsi
@@ -0,0 +1,676 @@
+// SPDX-License-Identifier: (GPL-2.0 OR MIT)
+/dts-v1/;
+#include "dt-bindings/gpio/gpio.h"
@ -24,8 +22,8 @@ index 000000000..4dbc096ee
+#include "omap443x.dtsi"
+
+/ {
+ model = "Samsung Galaxy Tab 2 3g 7-inch";
+ compatible = "samsung,espresso3g", "ti,omap4430", "ti,omap4";
+ /*model = "Samsung Galaxy Tab 2 3g 7-inch";
+ compatible = "samsung,espresso3g", "ti,omap4430", "ti,omap4";*/
+
+ memory@80000000 {
+ device_type = "memory";
@ -39,9 +37,7 @@ index 000000000..4dbc096ee
+
+ ramoops_region@A0000000 {
+ no-map;
+
+ reg = <0xA0000000 0x200000>;
+
+ };
+
+ continuous_splash: framebuffer@bef00000{
@ -66,6 +62,15 @@ index 000000000..4dbc096ee
+ #size-cells = <0>;
+ };
+
+ i2c-gpio-6 {
+ compatible = "i2c-gpio";
+ sda-gpios = <&gpio3 2 (GPIO_ACTIVE_HIGH | GPIO_OPEN_DRAIN)>;
+ scl-gpios = <&gpio3 1 (GPIO_ACTIVE_HIGH | GPIO_OPEN_DRAIN)>;
+ i2c-gpio,delay-us = <10>;
+ #address-cells = <1>;
+ #size-cells = <0>;
+ };
+
+ i2c-gpio-7 {
+ compatible = "i2c-gpio";
+ sda-gpios = <&gpio2 30 (GPIO_ACTIVE_HIGH | GPIO_OPEN_DRAIN)>;
@ -88,14 +93,14 @@ index 000000000..4dbc096ee
+ };
+ };
+
+ reg_espresso_vwlan: regulator-espresso-vwlan {
+ reg_espresso_wlan: regulator-espresso-wlan {
+ pinctrl-names = "default";
+ pinctrl-0 = <&wlanen_gpio>;
+ compatible = "regulator-fixed";
+ regulator-name = "vwl1271";
+ regulator-name = "espresso_wlan";
+ regulator-max-microvolt = <2000000>;
+ regulator-min-microvolt = <2000000>;
+ gpio = <&gpio4 8 GPIO_ACTIVE_HIGH>;
+ gpio = <&gpio4 8 GPIO_ACTIVE_HIGH>; /* GPIO_104 */
+ startup-delay-us = <70000>;
+ regulator-always-on;
+ enable-active-high;
@ -106,7 +111,7 @@ index 000000000..4dbc096ee
+ regulator-name = "eMMC_LDO";
+ regulator-max-microvolt = <1800000>;
+ regulator-min-microvolt = <1800000>;
+ gpios = <&gpio2 21 GPIO_ACTIVE_HIGH>;
+ gpios = <&gpio2 21 GPIO_ACTIVE_HIGH>; /* GPIO_63 */
+ startup-delay-us = <100000>;
+ regulator-boot-on;
+ regulator-always-on;
@ -115,10 +120,10 @@ index 000000000..4dbc096ee
+
+ reg_espresso_external: regulator-espresso-external {
+ compatible = "regulator-fixed";
+ regulator-name = "vmmc2";
+ regulator-name = "vmmc1";
+ regulator-max-microvolt = <2800000>;
+ regulator-min-microvolt = <2800000>;
+ gpios = <&gpio2 2 GPIO_ACTIVE_HIGH>;
+ gpios = <&gpio2 2 GPIO_ACTIVE_HIGH>; /* GPIO_34 */
+ regulator-always-on;
+ enable-active-high;
+ };
@ -128,32 +133,33 @@ index 000000000..4dbc096ee
+ regulator-name = "touch_ldo_en";
+ regulator-max-microvolt = <2800000>;
+ regulator-min-microvolt = <2800000>;
+ gpios = <&gpio2 22 GPIO_ACTIVE_HIGH>;
+ gpios = <&gpio2 22 GPIO_ACTIVE_HIGH>; /* GPIO_54 */
+ regulator-always-on;
+ enable-active-high;
+ };
+
+ gpio-keys {
+ compatible = "gpio-keys";
+ //pinctrl-names = "default";
+ //pinctrl-0 = <&gpio_keys>;
+ pinctrl-names = "default";
+ pinctrl-0 = <&gpio_keys>;
+
+ power {
+ label = "power";
+ gpios = <&gpio1 3 GPIO_ACTIVE_HIGH>;
+
+ gpios = <&gpio1 3 GPIO_ACTIVE_HIGH>; /* GPIO_wk3 */
+ linux,code = <KEY_POWER>;
+ wakeup-source;
+ };
+
+ button-volup {
+ linux,code = <KEY_VOLUMEUP>;
+ label = "volume_up"; /* GPIO30 */
+ label = "volume_up"; /* GPIO_wk30 */
+ gpios = <&gpio1 30 GPIO_ACTIVE_LOW>;
+ };
+
+ button-voldown {
+ linux,code = <KEY_VOLUMEDOWN>;
+ label = "volume_down"; /* GPIO8 */
+ label = "volume_down"; /* GPIO_wk8 */
+ gpios = <&gpio1 8 GPIO_ACTIVE_LOW>;
+ };
+ };
@ -161,38 +167,36 @@ index 000000000..4dbc096ee
+ reg_lcd: regulator-lcd {
+ compatible = "regulator-fixed";
+ regulator-name = "lcd_en";
+ gpios = <&gpio5 7 GPIO_ACTIVE_HIGH>;
+ gpios = <&gpio5 7 GPIO_ACTIVE_HIGH>; /* GPIO_135 */
+ regulator-max-microvolt = <3300000>;
+ regulator-min-microvolt = <3300000>;
+ enable-active-high;
+ //regulator-always-on;
+ regulator-boot-on;
+ };
+
+ pwm10: dmtimer-pwm@10 {
+ pinctrl-names = "default";
+ pinctrl-0 = <&pwm10_default>;
+
+ compatible = "ti,omap-dmtimer-pwm";
+ #pwm-cells = <3>;
+ ti,timers = <&timer10>;
+ ti,clock-source = <0x00>;
+ };
+
+ backlight: backlight {
+ /*backlight: backlight {
+ compatible = "pwm-backlight";
+ pinctrl-names = "default";
+ pinctrl-0 = <&backlight_pins>;
+ pwms = <&pwm10 0 1200 0>;
+ power-supply = <&reg_lcd>;
+ enable-gpios = <&gpio3 31 GPIO_ACTIVE_HIGH>;
+ brightness-levels = <0 4 8 16 32 64 128 255>;
+ default-brightness-level = <7>;
+ };
+ enable-gpios = <&gpio3 31 GPIO_ACTIVE_HIGH>; /* GPIO_95 /
+ brightness-levels = <0 4 8 16 32 64 128 255>; //Need interpolation?
+ default-brightness-level = <2>;
+ };*/
+
+ lvds-encoder {
+ compatible = "lvds-encoder", "doestek,dtc34lm85am";
+ powerdown-gpios = <&gpio5 8 GPIO_ACTIVE_LOW>;
+ powerdown-gpios = <&gpio5 8 GPIO_ACTIVE_LOW>; /* GPIO_136 */
+ power-supply = <&reg_lcd>;
+ ports {
+ #address-cells = <1>;
@ -214,16 +218,16 @@ index 000000000..4dbc096ee
+ };
+ };
+
+ panel {
+ /*panel {
+ compatible ="samsung,ltn070nl01", "panel-lvds";
+ power-supply = <&reg_lcd>;
+ width-mm = <154>;
+ height-mm = <90>;
+ data-mapping = "vesa-24";
+ data-mapping = "jeida-24";
+ backlight = <&backlight>;
+
+ panel-timing {
+ clock-frequency = <47255554>;
+ clock-frequency = <47255554>; 56888889 ideally for 60Hz
+
+ hback-porch = <210>;
+ hactive = <1024>;
@ -239,6 +243,7 @@ index 000000000..4dbc096ee
+ vsync-active = <0>;
+ de-active = <1>;
+ pixelclk-active = <1>;
+ syncclk-active = <0>;
+ };
+
+ port {
@ -246,11 +251,11 @@ index 000000000..4dbc096ee
+ remote-endpoint = <&bridge_out>;
+ };
+ };
+ };
+ };*/
+
+ vibrator {
+ compatible = "gpio-vibrator";
+ enable-gpios = <&gpio2 6 GPIO_ACTIVE_HIGH>;
+ enable-gpios = <&gpio2 6 GPIO_ACTIVE_HIGH>; /* GPIO_38 */
+ pinctrl-names = "default";
+ pinctrl-0 = <&vibrator_default>;
+ };
@ -259,21 +264,36 @@ index 000000000..4dbc096ee
+ compatible = "current-sense-shunt";
+ io-channels = <&gpadc 4>;
+ shunt-resistor-micro-ohms = <24000000>; /* 24 ohms */
+ /* https://github.com/LineageOS/android_device_samsung_espressowifi/blob/cm-14.1/libsensors/LightSensor.cpp#L152 */
+ #io-channel-cells = <0>;
+ io-channel-ranges;
+ };
+
+ /* UNTESTED */
+ irled@0 {
+ compatible = "gpio-ir-tx";
+ gpios = <&gpio2 27 GPIO_ACTIVE_HIGH>; /* GPIO_59 */
+ };
+};
+
+&omap4_pmx_wkup {
+ twl6030_wkup_pins: pinmux_twl6030_wkup_pins {
+ pinctrl-single,pins = <
+ OMAP4_IOPAD(0x56, PIN_OUTPUT_PULLUP | MUX_MODE2) /* fref_clk3_req.sys_drm_msecure */
+ OMAP4_IOPAD(0x54, PIN_OUTPUT | MUX_MODE3) /* fref_clk0_out.sys_drm_msecure */
+ >;
+ };
+
+ gpio_keys: pinmux_gpio_keys {
+ pinctrl-single,pins = <
+ OMAP4_IOPAD(0x046, WAKEUP_EN | PIN_INPUT | MUX_MODE3) /* sim_cd.gpio_wk3 - EXT_WAKEUP */
+ OMAP4_IOPAD(0x056, WAKEUP_EN | PIN_INPUT | MUX_MODE3) /* fref_clk3_req.gpio_wk30 - VOL_UP */
+ OMAP4_IOPAD(0x05C, WAKEUP_EN | PIN_INPUT | MUX_MODE3) /* fref_clk4_out.gpio_wk8 - VOL_DN */
+ >;
+ };
+
+ prox_irq: pinmux_prox_irq {
+ pinctrl-single,pins = <
+ OMAP4_IOPAD(0x042, WAKEUP_EN | PIN_INPUT_PULLUP | MUX_MODE3)
+ OMAP4_IOPAD(0x042, WAKEUP_EN | PIN_INPUT_PULLUP | MUX_MODE3) /* sim_clk.gpio_wk1 - PS_VOUT */
+ >;
+ };
+};
@ -282,12 +302,21 @@ index 000000000..4dbc096ee
+ pwm10_default: pinmux_pwm10_default {
+ pinctrl-single,pins = <
+ OMAP4_IOPAD(0X0D6, PIN_OUTPUT | PIN_OFF_OUTPUT_LOW | MUX_MODE1)
+ /* usbb1_ulpitll_dat6.dmtimer10_pwm_evt - LED_BACKLIGHT_PWM */
+ >;
+ };
+
+ backlight_pins: pinmux_backlight_pins {
+ pinctrl-single,pins = <
+ OMAP4_IOPAD(0X0D8, PIN_OUTPUT | PIN_OFF_OUTPUT_LOW | MUX_MODE3)
+ /* usbb1_ulpitll_dat7.gpio_95 - LED_BACKLIGHT_RESET */
+ >;
+ };
+
+ lvds_pins: pinmux_lvds_pins {
+ pinctrl-single,pins = <
+ OMAP4_IOPAD(0X136, PIN_OUTPUT | MUX_MODE3)
+ /* mcspi1_simo.gpio_136 - LVDS_nSHDN */
+ >;
+ };
+
@ -347,7 +376,7 @@ index 000000000..4dbc096ee
+
+ mmc5_pins: pinmux_mmc5_pins {
+ pinctrl-single,pins = <
+ OMAP4_IOPAD(0x148, PIN_INPUT_PULLUP | MUX_MODE0) /* sdmmc5_clk.sdmmc5_clk */
+ OMAP4_IOPAD(0x148, PIN_INPUT_PULLDOWN | MUX_MODE0) /* sdmmc5_clk.sdmmc5_clk */
+ OMAP4_IOPAD(0x14a, PIN_INPUT_PULLUP | MUX_MODE0) /* sdmmc5_cmd.sdmmc5_cmd */
+ OMAP4_IOPAD(0x14c, PIN_INPUT_PULLUP | MUX_MODE0) /* sdmmc5_dat0.sdmmc5_dat0 */
+ OMAP4_IOPAD(0x14e, PIN_INPUT_PULLUP | MUX_MODE0) /* sdmmc5_dat1.sdmmc5_dat1 */
@ -409,13 +438,12 @@ index 000000000..4dbc096ee
+ >;
+ };
+
+ /*gpio_keys: pinmux_gpio_keys {
+ uart3_pins: pinmux_uart3_pins {
+ pinctrl-single,pins = <
+ OMAP4_IOPAD(0x046, WAKEUP_EN | PIN_INPUT | MUX_MODE3)
+ OMAP4_IOPAD(0x056, WAKEUP_EN | PIN_INPUT | MUX_MODE3)
+ OMAP4_IOPAD(0x05C, WAKEUP_EN | PIN_INPUT | MUX_MODE3)
+ OMAP4_IOPAD(0x144, PIN_INPUT | MUX_MODE0) /* uart3_rx_irrx */
+ OMAP4_IOPAD(0x146, PIN_OUTPUT | MUX_MODE0) /* uart3_tx_irtx */
+ >;
+ };*/
+ };
+
+ uart2_pins: pinmux_uart2_pins {
+ pinctrl-single,pins = <
@ -426,45 +454,59 @@ index 000000000..4dbc096ee
+ >;
+ };
+
+ bluetooth_pins: pinmux_bluetooth_pins {
+ pinctrl-single,pins = <
+ OMAP4_IOPAD(0x094, PIN_OUTPUT | MUX_MODE3)
+ OMAP4_IOPAD(0x0be, PIN_OUTPUT | MUX_MODE3)
+ OMAP4_IOPAD(0x0c0, WAKEUP_EN | PIN_INPUT | MUX_MODE3)
+ OMAP4_IOPAD(0x0d4, PIN_OUTPUT | MUX_MODE3)
+ >;
+ };
+
+ wlan_host_wake: pinmux_wlan_host_wake {
+ pinctrl-single,pins = <
+ OMAP4_IOPAD(0x0bc, WAKEUP_EN | PIN_INPUT | MUX_MODE3)
+ /* cam_shutter.gpio_81 - WLAN_HOST_WAKE */
+ >;
+ };
+
+ bluetooth_pins: pinmux_bluetooth_pins {
+ pinctrl-single,pins = <
+ OMAP4_IOPAD(0x094, PIN_OUTPUT | MUX_MODE3)
+ /* gpmc_ncs6.gpio_103 - BT_EN */
+ OMAP4_IOPAD(0x0be, PIN_OUTPUT | MUX_MODE3)
+ /* cam_strobe.gpio_82 - BT_nRST */
+ OMAP4_IOPAD(0x0c0, WAKEUP_EN | PIN_INPUT | MUX_MODE3)
+ /* cam_globalreset.gpio_83 - BT_HOST_WAKE */
+ OMAP4_IOPAD(0x0d4, PIN_OUTPUT | MUX_MODE3)
+ /* usbb1_ulpitll_dat5.gpio_93 - BT_WAKE */
+ >;
+ };
+
+ touch_pins: pinmux_touch_pins {
+ pinctrl-single,pins = <
+ OMAP4_IOPAD(0x06c, PIN_INPUT | MUX_MODE3)
+ /* gpmc_a22.gpio_46 - TSP_INT */
+ >;
+ };
+
+ vibrator_default: pinmux_vibrator_default {
+ pinctrl-single,pins = <
+ OMAP4_IOPAD(0x05c, PIN_INPUT_PULLDOWN | MUX_MODE3)
+ /* gpmc_ad14.gpio_38 - MOTOR_EN */
+ >;
+ };
+
+ gp2a_irq: pinmux_gp2a_irq {
+ pinctrl-single,pins = <
+ OMAP4_IOPAD(0x052, WAKEUP_EN | PIN_INPUT | MUX_MODE3)
+ /* gpmc_ad9.gpio_33 - ALS_INT_18 */
+ >;
+ };
+};
+
+&uart3 {
+ pinctrl-names = "default";
+ pinctrl-0 = <&uart3_pins>;
+
+ interrupts-extended = <&wakeupgen GIC_SPI 74 IRQ_TYPE_LEVEL_HIGH
+ &omap4_pmx_core OMAP4_UART3_RX>;
+};
+
+&i2c1 {
+ // We need i2c1 muxed early on the boot process for pmic
+ // bootloader already done it for us
+ // pinctrl-names = "default";
+ // pinctrl-0 = <&i2c1_pins>;
+ pinctrl-names = "default";
+ pinctrl-0 = <&i2c1_pins>;
+
+ clock-frequency = <400000>;
+
@ -499,7 +541,7 @@ index 000000000..4dbc096ee
+ pinctrl-names = "default";
+ pinctrl-0 = <&i2c3_pins>;
+
+ touchscreen@48 {
+ /*touchscreen@48 {
+ compatible = "melfas,mms136";
+ reg = <0x48>;
+ interrupt-parent = <&gpio2>;
@ -510,7 +552,7 @@ index 000000000..4dbc096ee
+ pinctrl-0 = <&touch_pins>;
+ avdd-supply = <&reg_touch_ldo_en>;
+ vdd-supply = <&vcxio>;
+ };
+ };*/
+};
+
+&i2c4 {
@ -525,8 +567,8 @@ index 000000000..4dbc096ee
+ interrupt-parent = <&gpio4>;
+ interrupts = <25 (IRQ_TYPE_LEVEL_HIGH | IRQ_TYPE_EDGE_RISING)> , <26 (IRQ_TYPE_LEVEL_HIGH | IRQ_TYPE_EDGE_RISING)>;
+ mount-matrix = "-1", "0", "0",
+ "0", "1", "0",
+ "0", "0", "1";
+ "0", "1", "0",
+ "0", "0", "1";
+ };
+
+ magnetometer@2e {
@ -536,7 +578,7 @@ index 000000000..4dbc096ee
+ iovdd-supply = <&ldo5>;
+ reset-gpios = <&gpio5 29 GPIO_ACTIVE_LOW>;
+ interrupts = <&gpio6 10 IRQ_TYPE_EDGE_RISING>;
+ };
+ };
+
+ light-sensor@44 {
+ compatible = "sharp,gp2ap002a00f";
@ -550,7 +592,7 @@ index 000000000..4dbc096ee
+ sharp,proximity-far-hysteresis = /bits/ 8 <0x40>;
+ sharp,proximity-close-hysteresis = /bits/ 8 <0x20>;
+ pinctrl-names = "default";
+ pinctrl-0 = <&gp2a_irq &prox_irq>;
+ pinctrl-0 = <&gp2a_irq &prox_irq>;
+ };
+};
+
@ -615,13 +657,13 @@ index 000000000..4dbc096ee
+
+ non-removable;
+ bus-width = <4>;
+ vmmc-supply = <&reg_espresso_vwlan>;
+ vmmc-supply = <&reg_espresso_wlan>;
+
+ pinctrl-names = "default";
+ pinctrl-0 = <&mmc5_pins>;
+
+ brcmf: wifi@1 {
+ compatible = "brcm,bcm4330-fmac";
+ compatible = "brcm,bcm4330-fmac", "brcm,bcm4329-fmac";
+ reg = <1>;
+
+ interrupt-parent = <&gpio3>;
@ -648,3 +690,6 @@ index 000000000..4dbc096ee
+ interrupts = <19 IRQ_TYPE_EDGE_FALLING>;
+ };
+};
--
2.25.1

View file

@ -0,0 +1,102 @@
From b72698bf16d1b1bb487f82c80e3cd467a674f65d Mon Sep 17 00:00:00 2001
From: Mithil Bavishi <bavishimithil@gmail.com>
Date: Thu, 20 Oct 2022 20:46:21 +0530
Subject: [PATCH 2/3] arm/dts: Add espresso7 support
---
arch/arm/boot/dts/Makefile | 1 +
arch/arm/boot/dts/omap4-samsung-espresso7.dts | 70 +++++++++++++++++++
2 files changed, 71 insertions(+)
create mode 100644 arch/arm/boot/dts/omap4-samsung-espresso7.dts
diff --git a/arch/arm/boot/dts/Makefile b/arch/arm/boot/dts/Makefile
index 6aa7dc4db..c0c55b1a7 100644
--- a/arch/arm/boot/dts/Makefile
+++ b/arch/arm/boot/dts/Makefile
@@ -968,6 +968,7 @@ dtb-$(CONFIG_ARCH_OMAP4) += \
omap4-panda.dtb \
omap4-panda-a4.dtb \
omap4-panda-es.dtb \
+ omap4-samsung-espresso7.dtb \
omap4-sdp.dtb \
omap4-sdp-es23plus.dtb \
omap4-var-dvk-om44.dtb \
diff --git a/arch/arm/boot/dts/omap4-samsung-espresso7.dts b/arch/arm/boot/dts/omap4-samsung-espresso7.dts
new file mode 100644
index 000000000..9d715bd7e
--- /dev/null
+++ b/arch/arm/boot/dts/omap4-samsung-espresso7.dts
@@ -0,0 +1,70 @@
+// SPDX-License-Identifier: (GPL-2.0 OR MIT)
+/dts-v1/;
+
+#include "omap4-samsung-espresso-common.dtsi"
+
+/ {
+ model = "Samsung Galaxy Tab 2 (7 inch)";
+ compatible = "samsung,espresso7", "ti,omap4430", "ti,omap4";
+
+ backlight: backlight {
+ compatible = "pwm-backlight";
+ pinctrl-names = "default";
+ pinctrl-0 = <&backlight_pins>;
+ pwms = <&pwm10 0 1200 0>;
+ power-supply = <&reg_lcd>;
+ enable-gpios = <&gpio3 31 GPIO_ACTIVE_HIGH>;
+ brightness-levels = <0 4 8 16 32 64 128 255>;
+ default-brightness-level = <7>;
+ };
+
+ panel {
+ compatible ="samsung,ltn070nl01", "panel-lvds";
+ power-supply = <&reg_lcd>;
+ width-mm = <154>;
+ height-mm = <90>;
+ data-mapping = "vesa-24";
+ backlight = <&backlight>;
+
+ panel-timing {
+ clock-frequency = <47255554>;
+
+ hback-porch = <210>;
+ hactive = <1024>;
+ hfront-porch = <186>;
+ hsync-len = <50>;
+
+ vback-porch = <11>;
+ vactive = <600>;
+ vfront-porch = <24>;
+ vsync-len = <10>;
+
+ hsync-active = <0>;
+ vsync-active = <0>;
+ de-active = <1>;
+ pixelclk-active = <1>;
+ syncclk-active = <0>;
+ };
+
+ port {
+ panel_in: endpoint {
+ remote-endpoint = <&bridge_out>;
+ };
+ };
+ };
+};
+
+&i2c3 {
+ touchscreen@48 {
+ compatible = "melfas,mms136";
+ reg = <0x48>;
+ interrupt-parent = <&gpio2>;
+ interrupts = <14 IRQ_TYPE_EDGE_FALLING>;
+ touchscreen-size-x = <1023>;
+ touchscreen-size-y = <599>;
+ pinctrl-names = "default";
+ pinctrl-0 = <&touch_pins>;
+ avdd-supply = <&reg_touch_ldo_en>;
+ vdd-supply = <&vcxio>;
+ };
+};
--
2.25.1

View file

@ -0,0 +1,120 @@
From b13fc38acae2bdffc1c4fda9c642276fba0884d3 Mon Sep 17 00:00:00 2001
From: Mithil Bavishi <bavishimithil@gmail.com>
Date: Thu, 20 Oct 2022 20:46:30 +0530
Subject: [PATCH 3/3] arm/dts: Add espresso10 support
---
arch/arm/boot/dts/Makefile | 1 +
.../arm/boot/dts/omap4-samsung-espresso10.dts | 88 +++++++++++++++++++
2 files changed, 89 insertions(+)
create mode 100644 arch/arm/boot/dts/omap4-samsung-espresso10.dts
diff --git a/arch/arm/boot/dts/Makefile b/arch/arm/boot/dts/Makefile
index c0c55b1a7..51f6b70df 100644
--- a/arch/arm/boot/dts/Makefile
+++ b/arch/arm/boot/dts/Makefile
@@ -969,6 +969,7 @@ dtb-$(CONFIG_ARCH_OMAP4) += \
omap4-panda-a4.dtb \
omap4-panda-es.dtb \
omap4-samsung-espresso7.dtb \
+ omap4-samsung-espresso10.dtb \
omap4-sdp.dtb \
omap4-sdp-es23plus.dtb \
omap4-var-dvk-om44.dtb \
diff --git a/arch/arm/boot/dts/omap4-samsung-espresso10.dts b/arch/arm/boot/dts/omap4-samsung-espresso10.dts
new file mode 100644
index 000000000..3fa4b18bd
--- /dev/null
+++ b/arch/arm/boot/dts/omap4-samsung-espresso10.dts
@@ -0,0 +1,88 @@
+// SPDX-License-Identifier: (GPL-2.0 OR MIT)
+/dts-v1/;
+
+#include "omap4-samsung-espresso-common.dtsi"
+
+/ {
+ model = "Samsung Galaxy Tab 2 (10 inch)";
+ compatible = "samsung,espresso10", "ti,omap4430", "ti,omap4";
+
+ backlight: backlight {
+ compatible = "pwm-backlight";
+ pinctrl-names = "default";
+ pinctrl-0 = <&backlight_pins>;
+ pwms = <&pwm10 0 1600 0>;
+ power-supply = <&reg_lcd>;
+ enable-gpios = <&gpio3 31 GPIO_ACTIVE_HIGH>;
+ brightness-levels = <0 4 8 16 32 64 128 255>;
+ default-brightness-level = <7>;
+ };
+
+ panel {
+ compatible ="samsung,ltn070nl01", "panel-lvds";
+ power-supply = <&reg_lcd>;
+ width-mm = <223>;
+ height-mm = <125>;
+ data-mapping = "jeida-24";
+ backlight = <&backlight>;
+
+ panel-timing {
+ clock-frequency = <69818000>;
+
+ hback-porch = <64>;
+ hactive = <1280>;
+ hfront-porch = <16>;
+ hsync-len = <48>;
+
+ vback-porch = <11>;
+ vactive = <800>;
+ vfront-porch = <16>;
+ vsync-len = <3>;
+
+ hsync-active = <0>;
+ vsync-active = <0>;
+ de-active = <1>;
+ pixelclk-active = <1>;
+ };
+
+ port {
+ panel_in: endpoint {
+ remote-endpoint = <&bridge_out>;
+ };
+ };
+ };
+};
+
+&i2c3 {
+ touchscreen: synaptics-rmi4-i2c@20 {
+ compatible = "syna,rmi4-i2c";
+ reg = <0x20>;
+ #address-cells = <1>;
+ #size-cells = <0>;
+
+ interrupt-parent = <&gpio2>;
+ interrupts = <14 IRQ_TYPE_EDGE_FALLING>;
+
+ pinctrl-names = "default";
+ pinctrl-0 = <&touch_pins>;
+
+ avdd-supply = <&reg_touch_ldo_en>;
+ vdd-supply = <&vcxio>;
+
+ syna,reset-delay-ms = <200>;
+ syna,startup-delay-ms = <200>;
+
+ touchscreen-size-x = <1279>;
+ touchscreen-size-y = <799>;
+
+ rmi4-f01@1 {
+ reg = <0x01>;
+ syna,nosleep-mode = <1>;
+ };
+
+ rmi4-f11@11 {
+ reg = <0x11>;
+ syna,sensor-type = <1>;
+ };
+ };
+};
--
2.25.1

View file

@ -83,25 +83,6 @@ index 2ba6646e8..ccdd8efa3 100644
obj-$(CONFIG_TWL6040_CORE) += twl6040.o
obj-$(CONFIG_MFD_MX25_TSADC) += fsl-imx25-tsadc.o
diff --git a/drivers/mfd/twl-core.c b/drivers/mfd/twl-core.c
index 289b556de..880ea446c 100644
--- a/drivers/mfd/twl-core.c
+++ b/drivers/mfd/twl-core.c
@@ -956,6 +956,14 @@ add_children(struct twl4030_platform_data *pdata, unsigned irq_base,
return PTR_ERR(child);
}
+ if (IS_ENABLED(CONFIG_TWL6030_POWER) && pdata->power) {
+ child = add_child(TWL_MODULE_PM_MASTER, "twl6030_power",
+ pdata->power, sizeof(*pdata->power), false,
+ 0, 0);
+ if (IS_ERR(child))
+ return PTR_ERR(child);
+ }
+
return 0;
}
diff --git a/drivers/mfd/twl6030-power.c b/drivers/mfd/twl6030-power.c
new file mode 100644
index 000000000..f6bacdfc3

View file

@ -203,33 +203,6 @@ index b307cca17..9f6081474 100644
MODULE_AUTHOR("Peter De Schrijver <peter.de-schrijver@nokia.com>");
MODULE_AUTHOR("Felipe Balbi <felipe.balbi@nokia.com>");
-
diff --git a/drivers/mfd/twl-core.c b/drivers/mfd/twl-core.c
index 289b556de..04c0b036e 100644
--- a/drivers/mfd/twl-core.c
+++ b/drivers/mfd/twl-core.c
@@ -832,13 +832,20 @@ add_children(struct twl4030_platform_data *pdata, unsigned irq_base,
return PTR_ERR(child);
}
- if (IS_ENABLED(CONFIG_INPUT_TWL4030_PWRBUTTON) && twl_class_is_4030()) {
- child = add_child(TWL_MODULE_PM_MASTER, "twl4030_pwrbutton",
+ if (IS_ENABLED(CONFIG_INPUT_TWL_PWRBUTTON) && twl_class_is_4030()) {
+ child = add_child(TWL_MODULE_PM_MASTER, "twl_pwrbutton",
NULL, 0, true, irq_base + 8 + 0, 0);
if (IS_ERR(child))
return PTR_ERR(child);
}
+ if (IS_ENABLED(CONFIG_INPUT_TWL_PWRBUTTON) && twl_class_is_6030()) {
+ child = add_child(TWL_MODULE_PM_MASTER, "twl_pwrbutton",
+ NULL, 0, true, irq_base + 0, 0);
+ if (IS_ERR(child))
+ return PTR_ERR(child);
+ }
+
if (IS_ENABLED(CONFIG_MFD_TWL4030_AUDIO) && pdata->audio &&
twl_class_is_4030()) {
child = add_child(TWL4030_MODULE_AUDIO_VOICE, "twl4030-audio",
diff --git a/include/linux/mfd/twl.h b/include/linux/mfd/twl.h
index 8871cc518..108138c99 100644
--- a/include/linux/mfd/twl.h

View file

@ -3,8 +3,8 @@
# Kernel config based on: arch/arm64/configs/omap2plus_defconfig
pkgname=linux-postmarketos-omap
pkgver=5.19
pkgrel=1
pkgver=6.0.2
pkgrel=0
pkgdesc="Mainline kernel fork for OMAP devices"
arch="armv7"
url="https://kernel.org/"
@ -27,10 +27,11 @@ source="
$_patch
$_config
0001-Add-TWL6032-dtsi.patch
0002-Add-espresso-dts.patch
0003-Add-espresso10-dts.patch
0004-Add-TWL6030-power-driver-with-minimal-support-for-power-off.patch
0005-Add-TWL6030-power-button-support-to-twl-pwrbutton.patch
0002-arm-dts-Add-common-dtsi-for-espresso.patch
0003-arm-dts-Add-espresso7-support.patch
0004-arm-dts-Add-espresso10-support.patch
0005-Add-TWL6030-power-driver-with-minimal-support-for-power-off.patch
0006-Add-TWL6030-power-button-support-to-twl-pwrbutton.patch
"
builddir="$srcdir/linux-$_kernver"
replaces="linux-samsung-espresso3g"
@ -61,11 +62,13 @@ package() {
sha512sums="
00313b2f9b82d2dc3fb8294007cf7d7599d254b717ed2de23c81fa7a1bbcbc2798ad286cb94e2f7f5bd54132d1d764facd90d30f79dbcc6616cc7f926adc2623 linux-5.19.tar.xz
bac41a7aeb6e809616cee2f13dcd1c45e829dfd1ccf60aee1dc4c46b1e28532f4485c7d819a32940de84fdfbf89db80a4e919bce8a74b2948c5a01551771b714 linux-6.0.tar.xz
10b2c1af9cbf2335a1b449de3ee674c68ae2ae1ac4bdc27b6e7692c5152fb3cd096388044c0e0ee6054b106d6eface9af41d746adf8f8264d738e9c8f73a3784 linux-6.0.2.patch.xz
fb03b18004e8f211015c02e28eac9c45f73acacd5a249006ecbce48fa9cde55c340f814a6957efcb31b47146a9497f4d06c98e2c452826431e7383bd656dce9e config-postmarketos-omap.armv7
727ff96d7d4701e93bf43db5d7bd872b4fbf1a8439edb4d84987a8f89e669d65b7a413740172b4a84df711b990d7e30b7880df5b9365496b7894d129cd4ebfa6 0001-Add-TWL6032-dtsi.patch
0c5be684ebfc94c289becb68d447c61276f2a4a602cb723b1e3c463bb61f0304046c734fe2cde914bbff90e31dc0cabdf8e0d6db1b851089c4505aac102ca5ce 0002-Add-espresso-dts.patch
3fd4ca3f9f12cc71f00346ec6a2859f9f93ae6aa6f6dc9ba1f0120c5866bb3e0126adda1d1b5ac4091e8b510d63da754ff977b4597b96508c2bcebbd8585e814 0003-Add-espresso10-dts.patch
a483b1a322f3fe47c7bb6514f34cca69ad1b806487596ffab69078acb6e83e99ed39ffb4d5b4ecd17035d118a75ce5bac6761b9e42d01608f1e6a53d59b27806 0004-Add-TWL6030-power-driver-with-minimal-support-for-power-off.patch
b3d6114c5c60fc2820856c89ea6f09c369d857ae79a79f0eeb0f83f5401dc2253e11f7dac6869eb1095d3e0b3a68126246762e2f406ffae5b5ef0a60d5563bac 0005-Add-TWL6030-power-button-support-to-twl-pwrbutton.patch
cbabba85dc1e4de5ad2faaea8d87595ceef5af740a9b06f20aeb5ac5bff37747e17a11f77d66e3cde42e3fdb48134a37a98205e32109464a87ac7bb5e91fb34c 0002-arm-dts-Add-common-dtsi-for-espresso.patch
b2c2d81bdfb4095a87d6821342127cc7c74bbc12a70786a81d64fd264b5487d522effab349fc1de2b01752cce494bf782d59021d4e95740aa1e3ff5de12632f7 0003-arm-dts-Add-espresso7-support.patch
61a731933a4f4ef6e4e86007cfa5eafea907ebd2f96629d0abf4c747f15776b5fe571de558d9eb0c9793f7a28d70c4839b6f88332e21515a89df680a06396e1b 0004-arm-dts-Add-espresso10-support.patch
9dc84421cbc2ea7c2c37847d8704ff46dd4a485485bfa4a671167fdef4ac6f53a4e8f787aa774f3748299c374e7c7dc5d36fd4ba9b1a1a9697e0526f2bf3ece4 0005-Add-TWL6030-power-driver-with-minimal-support-for-power-off.patch
fdf62d90b1381541743e9502160854a920c05050cc6f530769071e2eb362ba3c1f5c84afd140533d7aa3f318205e1b0b1c55387edc99a643e1593e634e740c10 0006-Add-TWL6030-power-button-support-to-twl-pwrbutton.patch
"