sony-mango: new device (Sony Ericsson Xperia Mini Pro) (MR 1206)
[ci:skip-build]: already built successfully in CI
This commit is contained in:
parent
853cfaf381
commit
df3196f548
11 changed files with 3881 additions and 0 deletions
28
device/testing/device-sony-mango/APKBUILD
Normal file
28
device/testing/device-sony-mango/APKBUILD
Normal file
|
@ -0,0 +1,28 @@
|
|||
# Reference: <https://postmarketos.org/devicepkg>
|
||||
pkgname=device-sony-mango
|
||||
pkgdesc="Xperia Mini Pro"
|
||||
pkgver=1
|
||||
pkgrel=0
|
||||
url="https://postmarketos.org"
|
||||
license="MIT"
|
||||
arch="armv7"
|
||||
options="!check !archcheck"
|
||||
depends="postmarketos-base linux-sony-mango mkbootimg mesa-dri-swrast msm-fb-refresher"
|
||||
makedepends="devicepkg-dev"
|
||||
source="deviceinfo fb.modes directfbrc"
|
||||
|
||||
build() {
|
||||
devicepkg_build $startdir $pkgname
|
||||
}
|
||||
|
||||
package() {
|
||||
install -Dm644 "$srcdir"/fb.modes \
|
||||
"$pkgdir"/etc/fb.modes
|
||||
install -Dm644 "$srcdir"/directfbrc \
|
||||
"$pkgdir"/etc/directfbrc
|
||||
devicepkg_package $startdir $pkgname
|
||||
}
|
||||
|
||||
sha512sums="008afde858567684630c757241b06f343239bd2493782bf165e9037b885c32122468f6da87e1db49bae140b0abe765253483f4eaf6349b5fe949e95e5f42bc63 deviceinfo
|
||||
246889c74e09d2aeeaea62313f101727f07f9972fb15252cbf1d2e3c07aa850a85a25cc291407d8e560edb49e8bfbdb04eb09c412ed4c366f0b4bbcfbdcbcbb9 fb.modes
|
||||
e2b9a9e88b21ca408d761e8aba16e81df333e55bc57deac9c7a8988dd6dea63b0d809face6b406e0fa2b067487b07cd312d623f349e43ec88616a629ff684c3e directfbrc"
|
32
device/testing/device-sony-mango/deviceinfo
Normal file
32
device/testing/device-sony-mango/deviceinfo
Normal file
|
@ -0,0 +1,32 @@
|
|||
# Reference: <https://postmarketos.org/deviceinfo>
|
||||
# Please use double quotes only. You can source this file in shell scripts.
|
||||
|
||||
deviceinfo_format_version="0"
|
||||
deviceinfo_name="Sony Ericsson Xperia Mini Pro"
|
||||
deviceinfo_manufacturer="Sony Ericsson"
|
||||
deviceinfo_codename="sony-mango"
|
||||
deviceinfo_year="2011"
|
||||
deviceinfo_dtb=""
|
||||
deviceinfo_modules_initfs=""
|
||||
deviceinfo_arch="armv7"
|
||||
|
||||
# Device related
|
||||
deviceinfo_keyboard="true"
|
||||
deviceinfo_external_storage="true"
|
||||
deviceinfo_screen_width="320"
|
||||
deviceinfo_screen_height="480"
|
||||
deviceinfo_dev_touchscreen="/dev/input/event3"
|
||||
|
||||
# Bootloader related
|
||||
deviceinfo_flash_method="fastboot"
|
||||
deviceinfo_kernel_cmdline="console=tty0 console=ttyMSM0,115200n8"
|
||||
deviceinfo_generate_bootimg="true"
|
||||
deviceinfo_bootimg_qcdt="false"
|
||||
deviceinfo_bootimg_dtb_second="false"
|
||||
deviceinfo_flash_offset_base="0x00200000"
|
||||
deviceinfo_flash_offset_kernel="0x00008000"
|
||||
deviceinfo_flash_offset_ramdisk="0x01000000"
|
||||
deviceinfo_flash_offset_second="0x00f00000"
|
||||
deviceinfo_flash_offset_tags="0x00000100"
|
||||
deviceinfo_flash_pagesize="2048"
|
||||
|
2
device/testing/device-sony-mango/directfbrc
Normal file
2
device/testing/device-sony-mango/directfbrc
Normal file
|
@ -0,0 +1,2 @@
|
|||
pixelformat=ARGB
|
||||
|
7
device/testing/device-sony-mango/fb.modes
Normal file
7
device/testing/device-sony-mango/fb.modes
Normal file
|
@ -0,0 +1,7 @@
|
|||
mode "320x480-0"
|
||||
# D: 0.005 MHz, H: 0.016 kHz, V: 0.034 Hz
|
||||
geometry 320 480 320 480 16
|
||||
timings 190000000 0 0 0 0 0 0
|
||||
accel false
|
||||
rgba 8/24,8/16,8/8,8/0
|
||||
endmode
|
|
@ -0,0 +1,34 @@
|
|||
From e41494c15d4df342854ac3d2940f5d6ac3158212 Mon Sep 17 00:00:00 2001
|
||||
From: Bryan Huntsman <bryanh@codeaurora.org>
|
||||
Date: Mon, 3 Jun 2013 18:48:08 -0700
|
||||
Subject: [PATCH] msm: fix in-tree compilation for perf_trace_counters
|
||||
|
||||
In-tree compilation for arch/arm/mach-msm/perf_trace_counters.c was
|
||||
hitting this error:
|
||||
|
||||
In file included from arch/arm/mach-msm/perf_trace_counters.h:127:0,
|
||||
from arch/arm/mach-msm/perf_trace_counters.c:14:
|
||||
include/trace/define_trace.h:79:43: fatal error: ./perf_trace_counters.h: No such file or directory
|
||||
|
||||
Instructions for TRACE_INCLUDE_FILE in include/trace/define_trace.h say
|
||||
"the path is relative to define_trace.h, not the file including it".
|
||||
Fix in-tree compilation by making the path relative to define_trace.h.
|
||||
|
||||
Signed-off-by: Bryan Huntsman <bryanh@codeaurora.org>
|
||||
---
|
||||
arch/arm/mach-msm/perf_trace_counters.h | 3 +--
|
||||
1 file changed, 1 insertion(+), 2 deletions(-)
|
||||
|
||||
diff --git a/arch/arm/mach-msm/perf_trace_counters.h b/arch/arm/mach-msm/perf_trace_counters.h
|
||||
index ce7e336aa40d..8f77badf42ac 100644
|
||||
--- a/arch/arm/mach-msm/perf_trace_counters.h
|
||||
+++ b/arch/arm/mach-msm/perf_trace_counters.h
|
||||
@@ -121,7 +121,6 @@ TRACE_EVENT(sched_switch_with_ctrs,
|
||||
|
||||
#endif
|
||||
#undef TRACE_INCLUDE_PATH
|
||||
-#define TRACE_INCLUDE_PATH .
|
||||
+#define TRACE_INCLUDE_PATH ../../arch/arm/mach-msm
|
||||
#define TRACE_INCLUDE_FILE perf_trace_counters
|
||||
#include <trace/define_trace.h>
|
||||
-
|
|
@ -0,0 +1,33 @@
|
|||
source:
|
||||
https://github.com/ShinySide/HispAsian_Lollipop_G6/commit/b7756b6fc4bb728722b14d2dfdbaf1dc843812e9
|
||||
|
||||
* These need to be static to avoid these errors:
|
||||
|
||||
drivers/built-in.o: In function `.LANCHOR1':
|
||||
msm_iommu_sec.c:(.data+0x9298): undefined reference to `kgsl_iommu_sync_lock'
|
||||
msm_iommu_sec.c:(.data+0x929c): undefined reference to `kgsl_iommu_sync_unlock'
|
||||
Makefile:877: recipe for target '.tmp_vmlinux1' failed
|
||||
make: *** [.tmp_vmlinux1] Error 1
|
||||
|
||||
Signed-off-by: Chet Kener <Cl3Kener@gmail.com>
|
||||
|
||||
--- a/drivers/gpu/msm/kgsl_iommu.c
|
||||
+++ b/drivers/gpu/msm/kgsl_iommu.c
|
||||
@@ -1010,7 +1010,7 @@ static int kgsl_iommu_init_sync_lock(struct kgsl_mmu *mmu)
|
||||
*
|
||||
* Return - int - number of commands.
|
||||
*/
|
||||
-inline unsigned int kgsl_iommu_sync_lock(struct kgsl_mmu *mmu,
|
||||
+static inline unsigned int kgsl_iommu_sync_lock(struct kgsl_mmu *mmu,
|
||||
unsigned int *cmds)
|
||||
{
|
||||
struct kgsl_device *device = mmu->device;
|
||||
@@ -1080,7 +1080,7 @@ inline unsigned int kgsl_iommu_sync_lock(struct kgsl_mmu *mmu,
|
||||
*
|
||||
* Return - int - number of commands.
|
||||
*/
|
||||
-inline unsigned int kgsl_iommu_sync_unlock(struct kgsl_mmu *mmu,
|
||||
+static inline unsigned int kgsl_iommu_sync_unlock(struct kgsl_mmu *mmu,
|
||||
unsigned int *cmds)
|
||||
{
|
||||
struct kgsl_device *device = mmu->device;
|
52
device/testing/linux-sony-mango/APKBUILD
Normal file
52
device/testing/linux-sony-mango/APKBUILD
Normal file
|
@ -0,0 +1,52 @@
|
|||
# Reference: <https://postmarketos.org/vendorkernel>
|
||||
# Kernel config based on: arch/arm/configs/lx_smultron_defconfig
|
||||
pkgname=linux-sony-mango
|
||||
pkgver=3.4.0
|
||||
pkgrel=0
|
||||
pkgdesc="Sony Ericsson Xperia Mini Pro kernel fork"
|
||||
arch="armv7"
|
||||
_carch="arm"
|
||||
_flavor="sony-mango"
|
||||
url="https://kernel.org"
|
||||
license="GPL-2.0-only"
|
||||
options="!strip !check !tracedeps"
|
||||
makedepends="perl sed installkernel bash gmp-dev bc linux-headers elfutils-dev devicepkg-dev xz"
|
||||
|
||||
# Source
|
||||
_repository="android_kernel_semc_msm7x30"
|
||||
_commit="9c6f07f81e2c0bcb2bef75fa9716cc30f8942286"
|
||||
_config="config-$_flavor.$arch"
|
||||
source="
|
||||
$pkgname-$_commit.tar.gz::https://github.com/LegacyXperia/$_repository/archive/$_commit.tar.gz
|
||||
$_config
|
||||
01_msm-fix-perf_trace_counters.patch
|
||||
02_gpu-msm-fix-gcc5-compile.patch
|
||||
gcc7-give-up-on-ilog2-const-optimizations.patch
|
||||
gcc8-fix-put-user.patch
|
||||
kernel-use-the-gnu89-standard-explicitly.patch
|
||||
"
|
||||
builddir="$srcdir/$_repository-$_commit"
|
||||
|
||||
prepare() {
|
||||
default_prepare
|
||||
. downstreamkernel_prepare
|
||||
}
|
||||
|
||||
build() {
|
||||
unset LDFLAGS
|
||||
make ARCH="$_carch" CC="${CC:-gcc}" \
|
||||
KBUILD_BUILD_VERSION="$((pkgrel + 1 ))-postmarketOS"
|
||||
}
|
||||
|
||||
package() {
|
||||
downstreamkernel_package "$builddir" "$pkgdir" "$_carch" "$_flavor" "$_outdir"
|
||||
|
||||
}
|
||||
|
||||
sha512sums="234e8973236e6056c60a312340ef4ccb7598adc43bd1f0c2ca0e89d03f4e16ecfdd5ad4658d76993c7bae24242a7e134a9ed2fda662dfe229b61f3a88ea6c2f0 linux-sony-mango-9c6f07f81e2c0bcb2bef75fa9716cc30f8942286.tar.gz
|
||||
1d0dbb8ea0e9692ffccdb88c8d6994af3699886b6aba13aba560e697e77ef35da17a5c28bd4482689344b27c2f25f4f404692c2f9c046687ad378bc97c4e73f4 config-sony-mango.armv7
|
||||
f85ced49ee2f2461adea68dac0a10452aa809a7d41d869092d94eb085344919a9a385dec0c48011f4601ca4f441700f7fe49075c7eca4fb2d66b01f7d413ccb7 01_msm-fix-perf_trace_counters.patch
|
||||
7be03a9e78b7ac330a54b1f00509caa0621a95c0c55901878ad757f9dd69cc05ba2c8b5ea987063ae1224f92c4d090d515fa5d369e7755181a4871b0d0f82881 02_gpu-msm-fix-gcc5-compile.patch
|
||||
77eba606a71eafb36c32e9c5fe5e77f5e4746caac292440d9fb720763d766074a964db1c12bc76fe583c5d1a5c864219c59941f5e53adad182dbc70bf2bc14a7 gcc7-give-up-on-ilog2-const-optimizations.patch
|
||||
197d40a214ada87fcb2dfc0ae4911704b9a93354b75179cd6b4aadbb627a37ec262cf516921c84a8b1806809b70a7b440cdc8310a4a55fca5d2c0baa988e3967 gcc8-fix-put-user.patch
|
||||
ad0182a483791fc88e058838bc331b2f04a75ba291e763767babdb815efadfc3b4fda97e69e2e3f00a426cabea088e35297a92bd287592597d1e309be68ee92c kernel-use-the-gnu89-standard-explicitly.patch"
|
3690
device/testing/linux-sony-mango/config-sony-mango.armv7
Normal file
3690
device/testing/linux-sony-mango/config-sony-mango.armv7
Normal file
File diff suppressed because it is too large
Load diff
|
@ -0,0 +1 @@
|
|||
../../.shared-patches/linux/gcc7-give-up-on-ilog2-const-optimizations.patch
|
1
device/testing/linux-sony-mango/gcc8-fix-put-user.patch
Symbolic link
1
device/testing/linux-sony-mango/gcc8-fix-put-user.patch
Symbolic link
|
@ -0,0 +1 @@
|
|||
../../.shared-patches/linux/gcc8-fix-put-user.patch
|
|
@ -0,0 +1 @@
|
|||
../../.shared-patches/linux/kernel-use-the-gnu89-standard-explicitly.patch
|
Loading…
Reference in a new issue