linux-pmos: update stable to 4.18.4, mainline to 4.18
[skip ci]
This commit is contained in:
parent
5f01e6c68b
commit
dabc26f1c6
3 changed files with 9 additions and 452 deletions
|
@ -1,441 +0,0 @@
|
|||
diff --git a/arch/arm/boot/dts/Makefile b/arch/arm/boot/dts/Makefile
|
||||
index d0381e9caf21..57ec846e005b 100644
|
||||
--- a/arch/arm/boot/dts/Makefile
|
||||
+++ b/arch/arm/boot/dts/Makefile
|
||||
@@ -729,6 +729,7 @@ dtb-$(CONFIG_ARCH_QCOM) += \
|
||||
qcom-msm8960-cdp.dtb \
|
||||
qcom-msm8974-fairphone-fp2.dtb \
|
||||
qcom-msm8974-lge-nexus5-hammerhead.dtb \
|
||||
+ qcom-msm8974-sony-xperia-amami.dtb \
|
||||
qcom-msm8974-sony-xperia-castor.dtb \
|
||||
qcom-msm8974-sony-xperia-honami.dtb \
|
||||
qcom-mdm9615-wp8548-mangoh-green.dtb
|
||||
diff --git a/arch/arm/boot/dts/qcom-msm8974-sony-xperia-amami.dts b/arch/arm/boot/dts/qcom-msm8974-sony-xperia-amami.dts
|
||||
new file mode 100644
|
||||
index 000000000000..fa6beb54f13a
|
||||
--- /dev/null
|
||||
+++ b/arch/arm/boot/dts/qcom-msm8974-sony-xperia-amami.dts
|
||||
@@ -0,0 +1,423 @@
|
||||
+#include "qcom-msm8974.dtsi"
|
||||
+#include "qcom-pm8841.dtsi"
|
||||
+#include "qcom-pm8941.dtsi"
|
||||
+#include <dt-bindings/gpio/gpio.h>
|
||||
+#include <dt-bindings/input/input.h>
|
||||
+#include <dt-bindings/pinctrl/qcom,pmic-gpio.h>
|
||||
+
|
||||
+/ {
|
||||
+ model = "Sony Xperia Z1 Compact";
|
||||
+ compatible = "sony,xperia-amami", "qcom,msm8974";
|
||||
+
|
||||
+ aliases {
|
||||
+ serial0 = &blsp1_uart2;
|
||||
+ };
|
||||
+
|
||||
+ chosen {
|
||||
+ stdout-path = "serial0:115200n8";
|
||||
+ };
|
||||
+
|
||||
+ gpio-keys {
|
||||
+ compatible = "gpio-keys";
|
||||
+ input-name = "gpio-keys";
|
||||
+
|
||||
+ pinctrl-names = "default";
|
||||
+ pinctrl-0 = <&gpio_keys_pin_a>;
|
||||
+
|
||||
+ volume-down {
|
||||
+ label = "volume_down";
|
||||
+ gpios = <&pm8941_gpios 2 GPIO_ACTIVE_LOW>;
|
||||
+ linux,input-type = <1>;
|
||||
+ linux,code = <KEY_VOLUMEDOWN>;
|
||||
+ };
|
||||
+
|
||||
+ camera-snapshot {
|
||||
+ label = "camera_snapshot";
|
||||
+ gpios = <&pm8941_gpios 3 GPIO_ACTIVE_LOW>;
|
||||
+ linux,input-type = <1>;
|
||||
+ linux,code = <KEY_CAMERA>;
|
||||
+ };
|
||||
+
|
||||
+ camera-focus {
|
||||
+ label = "camera_focus";
|
||||
+ gpios = <&pm8941_gpios 4 GPIO_ACTIVE_LOW>;
|
||||
+ linux,input-type = <1>;
|
||||
+ linux,code = <KEY_CAMERA_FOCUS>;
|
||||
+ };
|
||||
+
|
||||
+ volume-up {
|
||||
+ label = "volume_up";
|
||||
+ gpios = <&pm8941_gpios 5 GPIO_ACTIVE_LOW>;
|
||||
+ linux,input-type = <1>;
|
||||
+ linux,code = <KEY_VOLUMEUP>;
|
||||
+ };
|
||||
+ };
|
||||
+
|
||||
+ memory@0 {
|
||||
+ reg = <0 0x40000000>, <0x40000000 0x40000000>;
|
||||
+ device_type = "memory";
|
||||
+ };
|
||||
+
|
||||
+ smd {
|
||||
+ rpm {
|
||||
+ rpm_requests {
|
||||
+ pm8841-regulators {
|
||||
+ s1 {
|
||||
+ regulator-min-microvolt = <675000>;
|
||||
+ regulator-max-microvolt = <1050000>;
|
||||
+ };
|
||||
+
|
||||
+ s2 {
|
||||
+ regulator-min-microvolt = <500000>;
|
||||
+ regulator-max-microvolt = <1050000>;
|
||||
+ };
|
||||
+
|
||||
+ s3 {
|
||||
+ regulator-min-microvolt = <500000>;
|
||||
+ regulator-max-microvolt = <1050000>;
|
||||
+ };
|
||||
+
|
||||
+ s4 {
|
||||
+ regulator-min-microvolt = <500000>;
|
||||
+ regulator-max-microvolt = <1050000>;
|
||||
+ };
|
||||
+ };
|
||||
+
|
||||
+ pm8941-regulators {
|
||||
+ vdd_l1_l3-supply = <&pm8941_s1>;
|
||||
+ vdd_l2_lvs1_2_3-supply = <&pm8941_s3>;
|
||||
+ vdd_l4_l11-supply = <&pm8941_s1>;
|
||||
+ vdd_l5_l7-supply = <&pm8941_s2>;
|
||||
+ vdd_l6_l12_l14_l15-supply = <&pm8941_s2>;
|
||||
+ vdd_l9_l10_l17_l22-supply = <&vreg_boost>;
|
||||
+ vdd_l13_l20_l23_l24-supply = <&vreg_boost>;
|
||||
+ vdd_l21-supply = <&vreg_boost>;
|
||||
+
|
||||
+ s1 {
|
||||
+ regulator-min-microvolt = <1300000>;
|
||||
+ regulator-max-microvolt = <1300000>;
|
||||
+ regulator-always-on;
|
||||
+ regulator-boot-on;
|
||||
+ };
|
||||
+
|
||||
+ s2 {
|
||||
+ regulator-min-microvolt = <2150000>;
|
||||
+ regulator-max-microvolt = <2150000>;
|
||||
+ regulator-boot-on;
|
||||
+ };
|
||||
+
|
||||
+ s3 {
|
||||
+ regulator-min-microvolt = <1800000>;
|
||||
+ regulator-max-microvolt = <1800000>;
|
||||
+ regulator-always-on;
|
||||
+ regulator-boot-on;
|
||||
+ };
|
||||
+
|
||||
+ s4 {
|
||||
+ regulator-min-microvolt = <5000000>;
|
||||
+ regulator-max-microvolt = <5000000>;
|
||||
+ };
|
||||
+
|
||||
+ l1 {
|
||||
+ regulator-min-microvolt = <1225000>;
|
||||
+ regulator-max-microvolt = <1225000>;
|
||||
+
|
||||
+ regulator-always-on;
|
||||
+ regulator-boot-on;
|
||||
+ };
|
||||
+
|
||||
+ l2 {
|
||||
+ regulator-min-microvolt = <1200000>;
|
||||
+ regulator-max-microvolt = <1200000>;
|
||||
+ };
|
||||
+
|
||||
+ l3 {
|
||||
+ regulator-min-microvolt = <1200000>;
|
||||
+ regulator-max-microvolt = <1200000>;
|
||||
+ };
|
||||
+
|
||||
+ l4 {
|
||||
+ regulator-min-microvolt = <1225000>;
|
||||
+ regulator-max-microvolt = <1225000>;
|
||||
+ };
|
||||
+
|
||||
+ l5 {
|
||||
+ regulator-min-microvolt = <1800000>;
|
||||
+ regulator-max-microvolt = <1800000>;
|
||||
+ };
|
||||
+
|
||||
+ l6 {
|
||||
+ regulator-min-microvolt = <1800000>;
|
||||
+ regulator-max-microvolt = <1800000>;
|
||||
+
|
||||
+ regulator-boot-on;
|
||||
+ };
|
||||
+
|
||||
+ l7 {
|
||||
+ regulator-min-microvolt = <1800000>;
|
||||
+ regulator-max-microvolt = <1800000>;
|
||||
+
|
||||
+ regulator-boot-on;
|
||||
+ };
|
||||
+
|
||||
+ l8 {
|
||||
+ regulator-min-microvolt = <1800000>;
|
||||
+ regulator-max-microvolt = <1800000>;
|
||||
+ };
|
||||
+
|
||||
+ l9 {
|
||||
+ regulator-min-microvolt = <1800000>;
|
||||
+ regulator-max-microvolt = <2950000>;
|
||||
+ };
|
||||
+
|
||||
+ l11 {
|
||||
+ regulator-min-microvolt = <1300000>;
|
||||
+ regulator-max-microvolt = <1350000>;
|
||||
+ };
|
||||
+
|
||||
+ l12 {
|
||||
+ regulator-min-microvolt = <1800000>;
|
||||
+ regulator-max-microvolt = <1800000>;
|
||||
+
|
||||
+ regulator-always-on;
|
||||
+ regulator-boot-on;
|
||||
+ };
|
||||
+
|
||||
+ l13 {
|
||||
+ regulator-min-microvolt = <1800000>;
|
||||
+ regulator-max-microvolt = <2950000>;
|
||||
+
|
||||
+ regulator-boot-on;
|
||||
+ };
|
||||
+
|
||||
+ l14 {
|
||||
+ regulator-min-microvolt = <1800000>;
|
||||
+ regulator-max-microvolt = <1800000>;
|
||||
+ };
|
||||
+
|
||||
+ l15 {
|
||||
+ regulator-min-microvolt = <2050000>;
|
||||
+ regulator-max-microvolt = <2050000>;
|
||||
+ };
|
||||
+
|
||||
+ l16 {
|
||||
+ regulator-min-microvolt = <2700000>;
|
||||
+ regulator-max-microvolt = <2700000>;
|
||||
+ };
|
||||
+
|
||||
+ l17 {
|
||||
+ regulator-min-microvolt = <2700000>;
|
||||
+ regulator-max-microvolt = <2700000>;
|
||||
+ };
|
||||
+
|
||||
+ l18 {
|
||||
+ regulator-min-microvolt = <2850000>;
|
||||
+ regulator-max-microvolt = <2850000>;
|
||||
+ };
|
||||
+
|
||||
+ l19 {
|
||||
+ regulator-min-microvolt = <3300000>;
|
||||
+ regulator-max-microvolt = <3300000>;
|
||||
+ };
|
||||
+
|
||||
+ l20 {
|
||||
+ regulator-min-microvolt = <2950000>;
|
||||
+ regulator-max-microvolt = <2950000>;
|
||||
+
|
||||
+ regulator-allow-set-load;
|
||||
+ regulator-boot-on;
|
||||
+ regulator-system-load = <200000>;
|
||||
+ };
|
||||
+
|
||||
+ l21 {
|
||||
+ regulator-min-microvolt = <2950000>;
|
||||
+ regulator-max-microvolt = <2950000>;
|
||||
+
|
||||
+ regulator-boot-on;
|
||||
+ };
|
||||
+
|
||||
+ l22 {
|
||||
+ regulator-min-microvolt = <3000000>;
|
||||
+ regulator-max-microvolt = <3000000>;
|
||||
+ };
|
||||
+
|
||||
+ l23 {
|
||||
+ regulator-min-microvolt = <2800000>;
|
||||
+ regulator-max-microvolt = <2800000>;
|
||||
+ };
|
||||
+
|
||||
+ l24 {
|
||||
+ regulator-min-microvolt = <3075000>;
|
||||
+ regulator-max-microvolt = <3075000>;
|
||||
+
|
||||
+ regulator-boot-on;
|
||||
+ };
|
||||
+ };
|
||||
+ };
|
||||
+ };
|
||||
+ };
|
||||
+};
|
||||
+
|
||||
+&soc {
|
||||
+ sdhci@f9824900 {
|
||||
+ status = "ok";
|
||||
+
|
||||
+ vmmc-supply = <&pm8941_l20>;
|
||||
+ vqmmc-supply = <&pm8941_s3>;
|
||||
+
|
||||
+ bus-width = <8>;
|
||||
+ non-removable;
|
||||
+
|
||||
+ pinctrl-names = "default";
|
||||
+ pinctrl-0 = <&sdhc1_pin_a>;
|
||||
+ };
|
||||
+
|
||||
+ sdhci@f98a4900 {
|
||||
+ status = "ok";
|
||||
+
|
||||
+ bus-width = <4>;
|
||||
+
|
||||
+ vmmc-supply = <&pm8941_l21>;
|
||||
+ vqmmc-supply = <&pm8941_l13>;
|
||||
+
|
||||
+ cd-gpios = <&msmgpio 62 GPIO_ACTIVE_LOW>;
|
||||
+
|
||||
+ pinctrl-names = "default";
|
||||
+ pinctrl-0 = <&sdhc2_pin_a>, <&sdhc2_cd_pin_a>;
|
||||
+ };
|
||||
+
|
||||
+ serial@f991e000 {
|
||||
+ status = "ok";
|
||||
+
|
||||
+ pinctrl-names = "default";
|
||||
+ pinctrl-0 = <&blsp1_uart2_pin_a>;
|
||||
+ };
|
||||
+
|
||||
+
|
||||
+ pinctrl@fd510000 {
|
||||
+ blsp1_uart2_pin_a: blsp1-uart2-pin-active {
|
||||
+ rx {
|
||||
+ pins = "gpio5";
|
||||
+ function = "blsp_uart2";
|
||||
+
|
||||
+ drive-strength = <2>;
|
||||
+ bias-pull-up;
|
||||
+ };
|
||||
+
|
||||
+ tx {
|
||||
+ pins = "gpio4";
|
||||
+ function = "blsp_uart2";
|
||||
+
|
||||
+ drive-strength = <4>;
|
||||
+ bias-disable;
|
||||
+ };
|
||||
+ };
|
||||
+
|
||||
+ i2c2_pins: i2c2 {
|
||||
+ mux {
|
||||
+ pins = "gpio6", "gpio7";
|
||||
+ function = "blsp_i2c2";
|
||||
+
|
||||
+ drive-strength = <2>;
|
||||
+ bias-disable;
|
||||
+ };
|
||||
+ };
|
||||
+
|
||||
+ sdhc1_pin_a: sdhc1-pin-active {
|
||||
+ clk {
|
||||
+ pins = "sdc1_clk";
|
||||
+ drive-strength = <16>;
|
||||
+ bias-disable;
|
||||
+ };
|
||||
+
|
||||
+ cmd-data {
|
||||
+ pins = "sdc1_cmd", "sdc1_data";
|
||||
+ drive-strength = <10>;
|
||||
+ bias-pull-up;
|
||||
+ };
|
||||
+ };
|
||||
+
|
||||
+ sdhc2_cd_pin_a: sdhc2-cd-pin-active {
|
||||
+ pins = "gpio62";
|
||||
+ function = "gpio";
|
||||
+
|
||||
+ drive-strength = <2>;
|
||||
+ bias-disable;
|
||||
+ };
|
||||
+
|
||||
+ sdhc2_pin_a: sdhc2-pin-active {
|
||||
+ clk {
|
||||
+ pins = "sdc2_clk";
|
||||
+ drive-strength = <10>;
|
||||
+ bias-disable;
|
||||
+ };
|
||||
+
|
||||
+ cmd-data {
|
||||
+ pins = "sdc2_cmd", "sdc2_data";
|
||||
+ drive-strength = <6>;
|
||||
+ bias-pull-up;
|
||||
+ };
|
||||
+ };
|
||||
+ };
|
||||
+
|
||||
+ dma-controller@f9944000 {
|
||||
+ qcom,controlled-remotely;
|
||||
+ };
|
||||
+
|
||||
+ usb@f9a55000 {
|
||||
+ status = "ok";
|
||||
+
|
||||
+ phys = <&usb_hs1_phy>;
|
||||
+ phy-select = <&tcsr 0xb000 0>;
|
||||
+ extcon = <&smbb>, <&usb_id>;
|
||||
+ vbus-supply = <&chg_otg>;
|
||||
+
|
||||
+ hnp-disable;
|
||||
+ srp-disable;
|
||||
+ adp-disable;
|
||||
+
|
||||
+ ulpi {
|
||||
+ phy@a {
|
||||
+ status = "ok";
|
||||
+
|
||||
+ v1p8-supply = <&pm8941_l6>;
|
||||
+ v3p3-supply = <&pm8941_l24>;
|
||||
+
|
||||
+ extcon = <&smbb>;
|
||||
+ qcom,init-seq = /bits/ 8 <0x1 0x64>;
|
||||
+ };
|
||||
+ };
|
||||
+ };
|
||||
+};
|
||||
+
|
||||
+&spmi_bus {
|
||||
+ pm8941@0 {
|
||||
+ charger@1000 {
|
||||
+ qcom,fast-charge-safe-current = <1300000>;
|
||||
+ qcom,fast-charge-current-limit = <1300000>;
|
||||
+ qcom,dc-current-limit = <1300000>;
|
||||
+ qcom,fast-charge-safe-voltage = <4400000>;
|
||||
+ qcom,fast-charge-high-threshold-voltage = <4350000>;
|
||||
+ qcom,fast-charge-low-threshold-voltage = <3400000>;
|
||||
+ qcom,auto-recharge-threshold-voltage = <4200000>;
|
||||
+ qcom,minimum-input-voltage = <4300000>;
|
||||
+ };
|
||||
+
|
||||
+ gpios@c000 {
|
||||
+ gpio_keys_pin_a: gpio-keys-active {
|
||||
+ pins = "gpio2", "gpio3", "gpio4", "gpio5";
|
||||
+ function = "normal";
|
||||
+
|
||||
+ bias-pull-up;
|
||||
+ power-source = <PM8941_GPIO_S3>;
|
||||
+ };
|
||||
+ };
|
||||
+
|
||||
+ coincell@2800 {
|
||||
+ status = "ok";
|
||||
+ qcom,rset-ohms = <2100>;
|
||||
+ qcom,vset-millivolts = <3000>;
|
||||
+ };
|
||||
+ };
|
||||
+
|
||||
+};
|
|
@ -3,13 +3,13 @@ _config="config-${_flavor}.${CARCH}"
|
|||
|
||||
pkgname=linux-${_flavor}
|
||||
|
||||
pkgver=4.16_rc6
|
||||
pkgver=4.18
|
||||
_pkgver=${pkgver/_/-}
|
||||
_kernver=${pkgver%_rc*}
|
||||
_mainver=${_kernver%.*}
|
||||
_patchlevel=${_kernver/$_mainver./}
|
||||
_basever=${_mainver}.$((_patchlevel-1))
|
||||
pkgrel=1
|
||||
pkgrel=0
|
||||
|
||||
arch="x86_64 armhf aarch64"
|
||||
pkgdesc="Linux for pmOS supported chipsets (mainline, more bleeding-edge than stable)"
|
||||
|
@ -24,7 +24,6 @@ source="
|
|||
config-${_flavor}.armhf
|
||||
config-${_flavor}.aarch64
|
||||
config-${_flavor}.x86_64
|
||||
0001-sony-amami-dts.patch
|
||||
"
|
||||
|
||||
subpackages="$pkgname-dev"
|
||||
|
@ -176,9 +175,8 @@ dev() {
|
|||
done
|
||||
fi
|
||||
}
|
||||
sha512sums="c00d92659df815a53dcac7dde145b742b1f20867d380c07cb09ddb3295d6ff10f8931b21ef0b09d7156923a3957b39d74d87c883300173b2e20690d2b4ec35ea linux-4.15.tar.xz
|
||||
3b92a90a0c4e2194971f8ba87f68572ac334d33b682dc98af49c45172621faa6528c930bbd23e237d3ca55f21da2199cd1b7564a083173c6cdc4b85b1e989d0a linux-v4.15-v4.16-rc6.patch
|
||||
sha512sums="4d9de340a26155a89ea8773131c76220cc2057f2b5d031b467b60e8b14c1842518e2d60a863d8c695f0f7640f3f18d43826201984a238dade857b6cef79837db linux-4.17.tar.xz
|
||||
da3d10fd0206e006e0d4448624cb0d5de61dce1e80dcc5272b088fa7284d360e5bac464a369bbf5d06625fc20d73991ee81f09bb1c8c271eb45646d3ce7927e7 linux-v4.17-v4.18.patch
|
||||
581d889683f64fc8d9b31d1f87dc75b7b4f466a17b486ba2cb280b7cfa56003dd7c2e876e02c7e4395b8df28164b1efa4281670fb33aa814c2fa92b36ddfecf8 config-postmarketos-mainline.armhf
|
||||
2257ce6abd1596e46b69cd8622785fdc8bd2e6b5d6448520b45c3d5151e839fd1f0ad31d673a3ee6984db9792cc5a70226e6f6a13be16e0d2e064e8ae200c681 config-postmarketos-mainline.aarch64
|
||||
34e818059bd94b0431f986d7cb63fa779fe2aaa6c2199a054bd6f56a3df037555e80f20eeb78ac2dde5a517fd7dd7385e8be15aa6280685ee02129119638bdea config-postmarketos-mainline.x86_64
|
||||
e0fb34032fe70d9a4713ed521b8a5e29cf7f76cb7c56ceb24ed7206a8445ba743226e4873fa2069077952e21f99fb36eabf7c4daa779f565961f0dded4591887 0001-sony-amami-dts.patch"
|
||||
34e818059bd94b0431f986d7cb63fa779fe2aaa6c2199a054bd6f56a3df037555e80f20eeb78ac2dde5a517fd7dd7385e8be15aa6280685ee02129119638bdea config-postmarketos-mainline.x86_64"
|
||||
|
|
|
@ -4,12 +4,12 @@ _config="config-${_flavor}.${CARCH}"
|
|||
|
||||
pkgname=linux-${_flavor}
|
||||
|
||||
pkgver=4.16.2
|
||||
pkgver=4.18.4
|
||||
case $pkgver in
|
||||
*.*.*) _kernver=${pkgver%.*};;
|
||||
*.*) _kernver=$pkgver;;
|
||||
esac
|
||||
pkgrel=1
|
||||
pkgrel=0
|
||||
|
||||
arch="x86_64 armhf aarch64"
|
||||
pkgdesc="Linux for pmOS supported chipsets (stable)"
|
||||
|
@ -183,8 +183,8 @@ dev() {
|
|||
fi
|
||||
}
|
||||
|
||||
sha512sums="ab47849314b177d0eec9dbf261f33972b0d89fb92fb0650130ffa7abc2f36c0fab2d06317dc1683c51a472a9a631573a9b1e7258d6281a2ee189897827f14662 linux-4.16.tar.xz
|
||||
sha512sums="950eb85ac743b291afe9f21cd174d823e25f11883ee62cecfbfff8fe8c5672aae707654b1b8f29a133b1f2e3529e63b9f7fba4c45d6dacccc8000b3a9a9ae038 linux-4.18.tar.xz
|
||||
a428ce2a9c65bae3e7f88a43b0112e2524298ba068cf85732b25f18c5f92d101089ab3589582050c0dc9fca3571ea7fb89f9398d0c9dede03f1754b3f5fe455c config-postmarketos-stable.armhf
|
||||
b24240f2c8e011ffa1ff141cf8d623dcbe4cbde389322e59e264edf1b01985b3527576a06c1f0d8e5ef67519f95cc9a9ff9f2636178d00e4272cd472e268f1ec config-postmarketos-stable.aarch64
|
||||
77ae0b80272d871475043cc17ae54e20d5456da8c729ea832906c2881389c53e4d800aaeab38090f3f878f15045b2c70dc4912b62742753c40f80ad69ed51599 config-postmarketos-stable.x86_64
|
||||
3b9e2b8019f002443c7cd6510a878ab537351842e522848bdccd185dad6ea2b78a19b5c9179cd10aacccf20941632fd42340a5a3cef48ac875e57bd6cb3d57eb patch-4.16.2.xz"
|
||||
f8a4a1056bd29c29361f5529f711318fdb7546ff7469a3592601ae2d69d84b7d62ff4f75cf9d5aad4c1523ae71a7c1a88d9ee33bfce719e91686ca219ad13ed8 patch-4.18.4.xz"
|
||||
|
|
Loading…
Reference in a new issue