temp/jemalloc: Import jemalloc from upstream aports unmaintained repo (!312)

Taken from upstream aports @ 7af8be0e7aab4a5fe4315fb162850fad66aa7cb0
This commit is contained in:
Robert Yang 2019-01-24 13:55:03 -05:00 committed by Oliver Smith
parent 24814b2ccb
commit d6fdf52351
No known key found for this signature in database
GPG key ID: 5AE7F5513E0885CB
2 changed files with 52 additions and 0 deletions

41
temp/jemalloc/APKBUILD Normal file
View file

@ -0,0 +1,41 @@
# Forked from Alpine, so we can build our qemu fork against jemalloc to
# work around a deadlock while compiling mesa (pmbootstrap#1715)
pkgname=jemalloc
pkgver=5.1.0
pkgrel=0
pkgdesc="A general purpose malloc(3) implementation"
url="http://jemalloc.net/"
arch="all !armv7"
license="BSD-2-Clause"
subpackages="$pkgname-dev $pkgname-doc"
source="$pkgname-$pkgver.tar.bz2::https://github.com/$pkgname/$pkgname/releases/download/$pkgver/$pkgname-$pkgver.tar.bz2
jemalloc-no-pprof.patch
"
options="!check"
build() {
cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
--prefix=/usr \
--sysconfdir=/etc \
--mandir=/usr/share/man \
--infodir=/usr/share/info \
--localstatedir=/var \
--disable-syscall
make
}
check() {
cd "$builddir"
make check
}
package() {
cd "$builddir"
make DESTDIR="$pkgdir" install
}
sha512sums="d9abebe54d303ca931b8c31c1033f23ff5fb060f2377ec8386f4d79c352e65c78ed34f680c352dac14f7d7115d10245782d553d988bc13df2eb34a2f0942ef6f jemalloc-5.1.0.tar.bz2
1e59e6e3bd98be3be12a2619acf213445906c1f70d5e06fbfb98c1409c93486934ab53d58709a05e0c109e5ba9eab16d2110163e173de22ef2dc969d1cde9274 jemalloc-no-pprof.patch"

View file

@ -0,0 +1,11 @@
--- a/Makefile.in
+++ b/Makefile.in
@@ -467,7 +467,7 @@
install_doc: install_doc_html install_doc_man
-install: install_bin install_include install_lib install_doc
+install: install_include install_lib install_doc
tests_unit: $(TESTS_UNIT:$(srcroot)%.c=$(objroot)%$(EXE))
tests_integration: $(TESTS_INTEGRATION:$(srcroot)%.c=$(objroot)%$(EXE)) $(TESTS_INTEGRATION_CPP:$(srcroot)%.cpp=$(objroot)%$(EXE))