temp/qt5-qtdeclarative: fork from Alpine to build with OpenGLES (!1107)
This commit is contained in:
parent
ab5e0528a4
commit
d33cb3de79
2 changed files with 73 additions and 0 deletions
56
temp/qt5-qtdeclarative/APKBUILD
Normal file
56
temp/qt5-qtdeclarative/APKBUILD
Normal file
|
@ -0,0 +1,56 @@
|
|||
# Forked from Alpine to build with OpenGLES
|
||||
pkgname=qt5-qtdeclarative
|
||||
pkgver=9999
|
||||
_pkgver=5.14.1
|
||||
pkgrel=0
|
||||
pkgdesc="Qt5 - QtDeclarative component"
|
||||
# Broken on armhf, upstream bug report https://bugreports.qt.io/browse/QTBUG-65246
|
||||
arch="armv7 aarch64"
|
||||
url="https://www.qt.io/developers/"
|
||||
license="LGPL-2.1-only AND LGPL-3.0-only AND GPL-3.0-only AND Qt-GPL-exception-1.0"
|
||||
makedepends="qt5-qtbase-dev python3 vulkan-headers"
|
||||
subpackages="$pkgname-dev $pkgname-dbg"
|
||||
builddir="$srcdir/qtdeclarative-everywhere-src-$_pkgver"
|
||||
|
||||
case $pkgver in
|
||||
*_beta*|*_rc*) _rel=development_releases;;
|
||||
*) _rel=official_releases;;
|
||||
esac
|
||||
|
||||
source="https://download.qt.io/$_rel/qt/${_pkgver%.*}/$_pkgver/submodules/qtdeclarative-everywhere-src-$_pkgver.tar.xz
|
||||
qt-musl-stackbottom.patch
|
||||
"
|
||||
|
||||
_qt5_prefix=/usr/lib/qt5
|
||||
|
||||
build() {
|
||||
# HACK so calls to "python" get what we want
|
||||
ln -s /usr/bin/python3 python
|
||||
export PATH="$(pwd):$PATH"
|
||||
|
||||
qmake-qt5
|
||||
make
|
||||
}
|
||||
|
||||
check() {
|
||||
make check
|
||||
}
|
||||
|
||||
package() {
|
||||
make install INSTALL_ROOT="$pkgdir"
|
||||
|
||||
mkdir -p "$pkgdir"/usr/bin/
|
||||
for i in "$pkgdir"/"$_qt5_prefix"/bin/*; do
|
||||
ln -s ../lib/qt5/bin/${i##*/} "$pkgdir"/usr/bin/${i##*/}-qt5
|
||||
done
|
||||
|
||||
# Drop QMAKE_PRL_BUILD_DIR because reference the build dir
|
||||
find "$pkgdir/usr/lib" -type f -name '*.prl' \
|
||||
-exec sed -i -e '/^QMAKE_PRL_BUILD_DIR/d' {} \;
|
||||
|
||||
install -d "$pkgdir"/usr/share/licenses
|
||||
ln -s /usr/share/licenses/qt5-base "$pkgdir"/usr/share/licenses/$pkgname
|
||||
}
|
||||
|
||||
sha512sums="70094d24a977a5ae4a3a11ee31e49234592faca1ec8195560977e7834778d1b1fdc2a30e555dc6c43c98cef2a39d5c1bf6351093c0f46b9b22b4127f3bebef58 qtdeclarative-everywhere-src-5.14.1.tar.xz
|
||||
235091cc1da51c31165a99932c95543d999c0f21b2c6b4318306b647662d420f88d7270ec21db7417fe9f8d87bfa3e5f01b6465c3542da024dd1623ef0a87681 qt-musl-stackbottom.patch"
|
17
temp/qt5-qtdeclarative/qt-musl-stackbottom.patch
Normal file
17
temp/qt5-qtdeclarative/qt-musl-stackbottom.patch
Normal file
|
@ -0,0 +1,17 @@
|
|||
For musl libc the stackBottom for the main thread is recalculated
|
||||
just as it is for Android. See: https://bugreports.qt.io/browse/QTBUG-44268
|
||||
|
||||
--- qtdeclarative/src/qml/jsruntime/qv4engine.cpp 2016-02-26 10:34:34.000000000 +0100
|
||||
+++ qtdeclarative/src/qml/jsruntime/qv4engine.cpp 2016-04-04 21:52:43.780823136 +0200
|
||||
@@ -94,6 +94,11 @@
|
||||
#include <valgrind/memcheck.h>
|
||||
#endif
|
||||
|
||||
+#if defined(Q_OS_LINUX) && !defined(__GLIBC__)
|
||||
+#include <sys/syscall.h>
|
||||
+#define gettid() syscall(SYS_gettid)
|
||||
+#endif
|
||||
+
|
||||
QT_BEGIN_NAMESPACE
|
||||
|
||||
using namespace QV4;
|
Loading…
Reference in a new issue