Initial support for Huawei Google Nexus 6P (Angler) (#512)
This uses the LineageOS 14.1 kernel.
This commit is contained in:
parent
13465a27c6
commit
cfb582da65
9 changed files with 4294 additions and 0 deletions
2
device/device-huawei-angler/90-android.rules
Normal file
2
device/device-huawei-angler/90-android.rules
Normal file
|
@ -0,0 +1,2 @@
|
||||||
|
# udev rules file
|
||||||
|
# All device names can be read from weston's logfile (/tmp/weston.log in postmarketOS)
|
27
device/device-huawei-angler/APKBUILD
Normal file
27
device/device-huawei-angler/APKBUILD
Normal file
|
@ -0,0 +1,27 @@
|
||||||
|
pkgname=device-huawei-angler
|
||||||
|
pkgver=1
|
||||||
|
pkgrel=0
|
||||||
|
pkgdesc="Huawei Nexus 6P"
|
||||||
|
url="https://github.com/postmarketOS"
|
||||||
|
arch="noarch"
|
||||||
|
license="MIT"
|
||||||
|
depends="linux-huawei-angler mkbootimg"
|
||||||
|
makedepends=""
|
||||||
|
install=""
|
||||||
|
subpackages=""
|
||||||
|
source="deviceinfo 90-android.rules"
|
||||||
|
options="!check"
|
||||||
|
|
||||||
|
build() {
|
||||||
|
return 0
|
||||||
|
}
|
||||||
|
|
||||||
|
package() {
|
||||||
|
install -D -m644 "$srcdir/deviceinfo" \
|
||||||
|
"$pkgdir/etc/deviceinfo"
|
||||||
|
install -D -m644 "$srcdir"/90-android.rules \
|
||||||
|
"$pkgdir"/etc/udev/rules.d/90-android.rules
|
||||||
|
}
|
||||||
|
|
||||||
|
sha512sums="3bb53698b5fbfdd0522aaaf56966ea228cd79bea05c9af14d988604b1294d93a3a991107d5483845fc0064cf44d9f9ef54f9cbc517959f0327318b1902b9ee86 deviceinfo
|
||||||
|
155aa9c8bd0e202917c7f55312eaaa189114864d89bbf7fdbdcc4fe146af3c7c781a6e76b0030046383dee823465a994d6954408248cc2f43e48af40869d6b25 90-android.rules"
|
32
device/device-huawei-angler/deviceinfo
Normal file
32
device/device-huawei-angler/deviceinfo
Normal file
|
@ -0,0 +1,32 @@
|
||||||
|
# Reference: <https://postmarketos.org/deviceinfo>
|
||||||
|
# Please use double quotes only. You can source this file in shell scripts.
|
||||||
|
|
||||||
|
deviceinfo_format_version="0"
|
||||||
|
deviceinfo_name="Google Nexus 6P"
|
||||||
|
deviceinfo_manufacturer="Huawei"
|
||||||
|
deviceinfo_date=""
|
||||||
|
deviceinfo_keyboard="false"
|
||||||
|
deviceinfo_nonfree="????"
|
||||||
|
deviceinfo_dtb=""
|
||||||
|
deviceinfo_modules_initfs=""
|
||||||
|
deviceinfo_external_disk="false"
|
||||||
|
deviceinfo_external_disk_install="false"
|
||||||
|
deviceinfo_flash_methods="fastboot"
|
||||||
|
deviceinfo_arch="aarch64"
|
||||||
|
|
||||||
|
# Splash screen
|
||||||
|
deviceinfo_screen_width="1440"
|
||||||
|
deviceinfo_screen_height="2560"
|
||||||
|
|
||||||
|
# Fastboot related
|
||||||
|
deviceinfo_generate_bootimg="true"
|
||||||
|
deviceinfo_flash_offset_base="0x00000000"
|
||||||
|
deviceinfo_flash_offset_kernel="0x00008000"
|
||||||
|
deviceinfo_flash_offset_ramdisk="0x02000000"
|
||||||
|
# Angler doesn't have a second in the boot.img. This is a placeholder value for mkbootimg
|
||||||
|
deviceinfo_flash_offset_second="0x00000000"
|
||||||
|
deviceinfo_flash_offset_tags="0x01e00000"
|
||||||
|
deviceinfo_kernel_cmdline="androidboot.hardware=angler androidboot.console=ttyHSL0 msm_rtb.filter=0x37 ehci-hcd.park=3 lpm_levels.sleep_disabled=1 boot_cpus=0-3"
|
||||||
|
deviceinfo_flash_pagesize="4096"
|
||||||
|
|
||||||
|
deviceinfo_weston_core_modules="xwayland.so"
|
4
device/device-huawei-angler/initfs-hook.sh
Normal file
4
device/device-huawei-angler/initfs-hook.sh
Normal file
|
@ -0,0 +1,4 @@
|
||||||
|
#!/bin/sh
|
||||||
|
|
||||||
|
# set framebuffer resolution
|
||||||
|
cat /sys/class/graphics/fb0/modes > /sys/class/graphics/fb0/mode
|
109
device/linux-huawei-angler/APKBUILD
Normal file
109
device/linux-huawei-angler/APKBUILD
Normal file
|
@ -0,0 +1,109 @@
|
||||||
|
# APKBUILD based on linux-vanilla aport. Changes:
|
||||||
|
# - disabled module installation
|
||||||
|
# - add !check !tracedeps
|
||||||
|
# - package: just install zimage and kernel.release, because the kernel config
|
||||||
|
# does not generate modules or dtb files
|
||||||
|
# - do not create -dev subpackage (makes no sense without module support)
|
||||||
|
#
|
||||||
|
# Kernel config based on: arch/arm64/configs/lineageos_angler_defconfig
|
||||||
|
# Changes:
|
||||||
|
# - enable devtmpfs (needed for udev -> touch support in weston)
|
||||||
|
|
||||||
|
_vendor=huawei
|
||||||
|
_flavor=huawei-angler
|
||||||
|
_hash="04d1557af1259b211609fa41adbe852b5f9cf2da"
|
||||||
|
_config="config-${_flavor}.aarch64"
|
||||||
|
|
||||||
|
pkgname=linux-${_flavor}
|
||||||
|
pkgver=3.10.73
|
||||||
|
case $pkgver in
|
||||||
|
*.*.*) _kernver=${pkgver%.*};;
|
||||||
|
*.*) _kernver=$pkgver;;
|
||||||
|
esac
|
||||||
|
pkgrel=0
|
||||||
|
arch="aarch64"
|
||||||
|
pkgdesc="LineageOS kernel for Nexus 6P Angler"
|
||||||
|
url="https://github.com/LineageOS/android_kernel_huawei_angler"
|
||||||
|
depends="postmarketos-mkinitfs"
|
||||||
|
makedepends="perl sed installkernel bash gmp-dev bc linux-headers elfutils-dev python2"
|
||||||
|
options="!strip !check !tracedeps"
|
||||||
|
install=
|
||||||
|
source="
|
||||||
|
$pkgname-$_hash.tar.gz::https://github.com/LineageOS/android_kernel_huawei_angler/archive/${_hash}.tar.gz
|
||||||
|
${_config}
|
||||||
|
compiler-gcc6.h
|
||||||
|
kernel-use-the-gnu89-standard-explicitly.patch
|
||||||
|
"
|
||||||
|
subpackages=""
|
||||||
|
license="GPL2"
|
||||||
|
|
||||||
|
_abi_release=${pkgver}
|
||||||
|
_carch="arm64"
|
||||||
|
HOSTCC="${CC:-gcc}"
|
||||||
|
HOSTCC="${HOSTCC#${CROSS_COMPILE}}"
|
||||||
|
|
||||||
|
ksrcdir="$srcdir/android_kernel_huawei_angler-${_hash}"
|
||||||
|
|
||||||
|
prepare() {
|
||||||
|
local _patch_failed=
|
||||||
|
cd "$ksrcdir"
|
||||||
|
|
||||||
|
# first apply patches in specified order
|
||||||
|
for i in $source; do
|
||||||
|
case $i in
|
||||||
|
*.patch)
|
||||||
|
msg "Applying $i..."
|
||||||
|
if ! patch -s -p1 -N -i "$srcdir"/$i; then
|
||||||
|
echo $i >>failed
|
||||||
|
_patch_failed=1
|
||||||
|
fi
|
||||||
|
;;
|
||||||
|
esac
|
||||||
|
done
|
||||||
|
|
||||||
|
if ! [ -z "$_patch_failed" ]; then
|
||||||
|
error "The following patches failed:"
|
||||||
|
cat failed
|
||||||
|
return 1
|
||||||
|
fi
|
||||||
|
|
||||||
|
# gcc6 support
|
||||||
|
cp -v "$srcdir/compiler-gcc6.h" "$ksrcdir/include/linux/"
|
||||||
|
|
||||||
|
mkdir -p "$srcdir"/build
|
||||||
|
cp "$srcdir"/$_config "$srcdir"/build/.config || return 1
|
||||||
|
echo "--[ silentoldconfig ]--"
|
||||||
|
yes "" | make -C "$ksrcdir" O="$srcdir"/build ARCH="$_carch" HOSTCC="$HOSTCC" \
|
||||||
|
oldconfig
|
||||||
|
}
|
||||||
|
|
||||||
|
|
||||||
|
|
||||||
|
# this is so we can do: 'abuild menuconfig' to reconfigure kernel
|
||||||
|
menuconfig() {
|
||||||
|
cd "$srcdir"/build || return 1
|
||||||
|
echo "--[ menuconfig ]--"
|
||||||
|
make ARCH="$_carch" menuconfig
|
||||||
|
cp .config "$startdir"/$_config
|
||||||
|
}
|
||||||
|
|
||||||
|
build() {
|
||||||
|
cd "$srcdir"/build
|
||||||
|
unset LDFLAGS
|
||||||
|
make ARCH="$_carch" CC="${CC:-gcc}" \
|
||||||
|
KBUILD_BUILD_VERSION="$((pkgrel + 1 ))-Alpine" CONFIG_NO_ERROR_ON_MISMATCH=y \
|
||||||
|
|| return 1
|
||||||
|
}
|
||||||
|
|
||||||
|
package() {
|
||||||
|
install -Dm644 "$srcdir/build/arch/arm64/boot/Image.gz-dtb" \
|
||||||
|
"$pkgdir/boot/vmlinuz-$_flavor"
|
||||||
|
|
||||||
|
install -D "$srcdir/build/include/config/kernel.release" \
|
||||||
|
"$pkgdir/usr/share/kernel/$_flavor/kernel.release"
|
||||||
|
}
|
||||||
|
|
||||||
|
sha512sums="fb4328a3ade80670ca3c2674a61a4c524771d6eaebdc477943f2cc4bb33d845e8bcd7282941db708026bfefe6820cc1010d784d8afed5b91289d4e7e9ea1d7cd linux-huawei-angler-04d1557af1259b211609fa41adbe852b5f9cf2da.tar.gz
|
||||||
|
ca281ff4a694725ebb1a8bad597220d3d74cf40d1037f69236ed3ece58c5246264b9ea7e0e1e46046d8597a4c6582bf24c972990461ab15b0b426606d3aaab9f config-huawei-angler.aarch64
|
||||||
|
d80980e9474c82ba0ef1a6903b434d8bd1b092c40367ba543e72d2c119301c8b2d05265740e4104ca1ac5d15f6c4aa49e8776cb44264a9a28dc551e0d1850dcc compiler-gcc6.h
|
||||||
|
ad0182a483791fc88e058838bc331b2f04a75ba291e763767babdb815efadfc3b4fda97e69e2e3f00a426cabea088e35297a92bd287592597d1e309be68ee92c kernel-use-the-gnu89-standard-explicitly.patch"
|
69
device/linux-huawei-angler/compiler-gcc6.h
Normal file
69
device/linux-huawei-angler/compiler-gcc6.h
Normal file
|
@ -0,0 +1,69 @@
|
||||||
|
// SOURCE:
|
||||||
|
// https://github.com/NextThingCo/CHIP-u-boot/issues/10#issuecomment-287515505
|
||||||
|
|
||||||
|
#ifndef __LINUX_COMPILER_H
|
||||||
|
#error "Please don't include <linux/compiler-gcc6.h> directly, include <linux/compiler.h> instead."
|
||||||
|
#endif
|
||||||
|
|
||||||
|
#define __used __attribute__((__used__))
|
||||||
|
#define __must_check __attribute__((warn_unused_result))
|
||||||
|
#define __compiler_offsetof(a, b) __builtin_offsetof(a, b)
|
||||||
|
|
||||||
|
/* Mark functions as cold. gcc will assume any path leading to a call
|
||||||
|
to them will be unlikely. This means a lot of manual unlikely()s
|
||||||
|
are unnecessary now for any paths leading to the usual suspects
|
||||||
|
like BUG(), printk(), panic() etc. [but let's keep them for now for
|
||||||
|
older compilers]
|
||||||
|
|
||||||
|
Early snapshots of gcc 4.3 don't support this and we can't detect this
|
||||||
|
in the preprocessor, but we can live with this because they're unreleased.
|
||||||
|
Maketime probing would be overkill here.
|
||||||
|
|
||||||
|
gcc also has a __attribute__((__hot__)) to move hot functions into
|
||||||
|
a special section, but I don't see any sense in this right now in
|
||||||
|
the kernel context */
|
||||||
|
#define __cold __attribute__((__cold__))
|
||||||
|
|
||||||
|
#define __UNIQUE_ID(prefix) __PASTE(__PASTE(__UNIQUE_ID_, prefix), __COUNTER__)
|
||||||
|
|
||||||
|
#ifndef __CHECKER__
|
||||||
|
# define __compiletime_warning(message) __attribute__((warning(message)))
|
||||||
|
# define __compiletime_error(message) __attribute__((error(message)))
|
||||||
|
#endif /* __CHECKER__ */
|
||||||
|
|
||||||
|
/*
|
||||||
|
* Mark a position in code as unreachable. This can be used to
|
||||||
|
* suppress control flow warnings after asm blocks that transfer
|
||||||
|
* control elsewhere.
|
||||||
|
*
|
||||||
|
* Early snapshots of gcc 4.5 don't support this and we can't detect
|
||||||
|
* this in the preprocessor, but we can live with this because they're
|
||||||
|
* unreleased. Really, we need to have autoconf for the kernel.
|
||||||
|
*/
|
||||||
|
#define unreachable() __builtin_unreachable()
|
||||||
|
|
||||||
|
/* Mark a function definition as prohibited from being cloned. */
|
||||||
|
#define __noclone __attribute__((__noclone__))
|
||||||
|
|
||||||
|
/*
|
||||||
|
* Tell the optimizer that something else uses this function or variable.
|
||||||
|
*/
|
||||||
|
#define __visible __attribute__((externally_visible))
|
||||||
|
|
||||||
|
/*
|
||||||
|
* GCC 'asm goto' miscompiles certain code sequences:
|
||||||
|
*
|
||||||
|
* http://gcc.gnu.org/bugzilla/show_bug.cgi?id=58670
|
||||||
|
*
|
||||||
|
* Work it around via a compiler barrier quirk suggested by Jakub Jelinek.
|
||||||
|
*
|
||||||
|
* (asm goto is automatically volatile - the naming reflects this.)
|
||||||
|
*/
|
||||||
|
#define asm_volatile_goto(x...) do { asm goto(x); asm (""); } while (0)
|
||||||
|
|
||||||
|
#ifdef CONFIG_ARCH_USE_BUILTIN_BSWAP
|
||||||
|
#define __HAVE_BUILTIN_BSWAP32__
|
||||||
|
#define __HAVE_BUILTIN_BSWAP64__
|
||||||
|
#define __HAVE_BUILTIN_BSWAP16__
|
||||||
|
#endif /* CONFIG_ARCH_USE_BUILTIN_BSWAP */
|
||||||
|
|
3951
device/linux-huawei-angler/config-huawei-angler.aarch64
Normal file
3951
device/linux-huawei-angler/config-huawei-angler.aarch64
Normal file
File diff suppressed because it is too large
Load diff
33
device/linux-huawei-angler/gpu-msm-fix-gcc5-compile.patch
Normal file
33
device/linux-huawei-angler/gpu-msm-fix-gcc5-compile.patch
Normal file
|
@ -0,0 +1,33 @@
|
||||||
|
source:
|
||||||
|
https://github.com/ShinySide/HispAsian_Lollipop_G6/commit/b7756b6fc4bb728722b14d2dfdbaf1dc843812e9
|
||||||
|
|
||||||
|
* These need to be static to avoid these errors:
|
||||||
|
|
||||||
|
drivers/built-in.o: In function `.LANCHOR1':
|
||||||
|
msm_iommu_sec.c:(.data+0x9298): undefined reference to `kgsl_iommu_sync_lock'
|
||||||
|
msm_iommu_sec.c:(.data+0x929c): undefined reference to `kgsl_iommu_sync_unlock'
|
||||||
|
Makefile:877: recipe for target '.tmp_vmlinux1' failed
|
||||||
|
make: *** [.tmp_vmlinux1] Error 1
|
||||||
|
|
||||||
|
Signed-off-by: Chet Kener <Cl3Kener@gmail.com>
|
||||||
|
|
||||||
|
--- a/drivers/gpu/msm/kgsl_iommu.c
|
||||||
|
+++ b/drivers/gpu/msm/kgsl_iommu.c
|
||||||
|
@@ -1010,7 +1010,7 @@ static int kgsl_iommu_init_sync_lock(struct kgsl_mmu *mmu)
|
||||||
|
*
|
||||||
|
* Return - int - number of commands.
|
||||||
|
*/
|
||||||
|
-inline unsigned int kgsl_iommu_sync_lock(struct kgsl_mmu *mmu,
|
||||||
|
+static inline unsigned int kgsl_iommu_sync_lock(struct kgsl_mmu *mmu,
|
||||||
|
unsigned int *cmds)
|
||||||
|
{
|
||||||
|
struct kgsl_device *device = mmu->device;
|
||||||
|
@@ -1080,7 +1080,7 @@ inline unsigned int kgsl_iommu_sync_lock(struct kgsl_mmu *mmu,
|
||||||
|
*
|
||||||
|
* Return - int - number of commands.
|
||||||
|
*/
|
||||||
|
-inline unsigned int kgsl_iommu_sync_unlock(struct kgsl_mmu *mmu,
|
||||||
|
+static inline unsigned int kgsl_iommu_sync_unlock(struct kgsl_mmu *mmu,
|
||||||
|
unsigned int *cmds)
|
||||||
|
{
|
||||||
|
struct kgsl_device *device = mmu->device;
|
|
@ -0,0 +1,67 @@
|
||||||
|
From 51b97e354ba9fce1890cf38ecc754aa49677fc89 Mon Sep 17 00:00:00 2001
|
||||||
|
From: "Kirill A. Shutemov" <kirill@shutemov.name>
|
||||||
|
Date: Mon, 20 Oct 2014 12:23:12 +0300
|
||||||
|
Subject: kernel: use the gnu89 standard explicitly
|
||||||
|
|
||||||
|
From: "Kirill A. Shutemov" <kirill@shutemov.name>
|
||||||
|
|
||||||
|
commit 51b97e354ba9fce1890cf38ecc754aa49677fc89 upstream.
|
||||||
|
|
||||||
|
Sasha Levin reports:
|
||||||
|
"gcc5 changes the default standard to c11, which makes kernel build
|
||||||
|
unhappy
|
||||||
|
|
||||||
|
Explicitly define the kernel standard to be gnu89 which should keep
|
||||||
|
everything working exactly like it was before gcc5"
|
||||||
|
|
||||||
|
There are multiple small issues with the new default, but the biggest
|
||||||
|
issue seems to be that the old - and very useful - GNU extension to
|
||||||
|
allow a cast in front of an initializer has gone away.
|
||||||
|
|
||||||
|
Patch updated by Kirill:
|
||||||
|
"I'm pretty sure all gcc versions you can build kernel with supports
|
||||||
|
-std=gnu89. cc-option is redunrant.
|
||||||
|
|
||||||
|
We also need to adjust HOSTCFLAGS otherwise allmodconfig fails for me"
|
||||||
|
|
||||||
|
Note by Andrew Pinski:
|
||||||
|
"Yes it was reported and both problems relating to this extension has
|
||||||
|
been added to gnu99 and gnu11. Though there are other issues with the
|
||||||
|
kernel dealing with extern inline have different semantics between
|
||||||
|
gnu89 and gnu99/11"
|
||||||
|
|
||||||
|
End result: we may be able to move up to a newer stdc model eventually,
|
||||||
|
but right now the newer models have some annoying deficiencies, so the
|
||||||
|
traditional "gnu89" model ends up being the preferred one.
|
||||||
|
|
||||||
|
Signed-off-by: Sasha Levin <sasha.levin@oracle.com>
|
||||||
|
Singed-off-by: Kirill A. Shutemov <kirill.shutemov@linux.intel.com>
|
||||||
|
Signed-off-by: Linus Torvalds <torvalds@linux-foundation.org>
|
||||||
|
Signed-off-by: Greg Kroah-Hartman <gregkh@linuxfoundation.org>
|
||||||
|
|
||||||
|
---
|
||||||
|
Makefile | 6 ++++--
|
||||||
|
1 file changed, 4 insertions(+), 2 deletions(-)
|
||||||
|
|
||||||
|
--- a/Makefile
|
||||||
|
+++ b/Makefile
|
||||||
|
@@ -241,7 +241,7 @@ CONFIG_SHELL := $(shell if [ -x "$$BASH"
|
||||||
|
|
||||||
|
HOSTCC = gcc
|
||||||
|
HOSTCXX = g++
|
||||||
|
-HOSTCFLAGS = -Wall -Wmissing-prototypes -Wstrict-prototypes -O2 -fomit-frame-pointer
|
||||||
|
+HOSTCFLAGS = -Wall -Wmissing-prototypes -Wstrict-prototypes -O2 -fomit-frame-pointer -std=gnu89
|
||||||
|
HOSTCXXFLAGS = -O2
|
||||||
|
|
||||||
|
# Decide whether to build built-in, modular, or both.
|
||||||
|
@@ -373,7 +373,9 @@ KBUILD_CFLAGS := -Wall -Wundef -Wstric
|
||||||
|
-fno-strict-aliasing -fno-common \
|
||||||
|
-Werror-implicit-function-declaration \
|
||||||
|
-Wno-format-security \
|
||||||
|
- -fno-delete-null-pointer-checks
|
||||||
|
+ -fno-delete-null-pointer-checks \
|
||||||
|
+ -std=gnu89
|
||||||
|
+
|
||||||
|
KBUILD_AFLAGS_KERNEL :=
|
||||||
|
KBUILD_CFLAGS_KERNEL :=
|
||||||
|
KBUILD_AFLAGS := -D__ASSEMBLY__
|
Loading…
Reference in a new issue