temp/gnome-control-center: copy fork from v20.05 branch (MR 1546)
This commit is contained in:
parent
44191c150c
commit
cebea0e543
5 changed files with 131 additions and 0 deletions
82
temp/gnome-control-center/APKBUILD
Normal file
82
temp/gnome-control-center/APKBUILD
Normal file
|
@ -0,0 +1,82 @@
|
|||
# Forked from Alpine to apply Purism's mobile patches
|
||||
pkgname=gnome-control-center
|
||||
pkgver=9999_git20200326
|
||||
pkgrel=0
|
||||
_commit="ec619479bf2805792eae5eda7afde317473015c6"
|
||||
pkgdesc="GNOME control center"
|
||||
url="https://gitlab.gnome.org/GNOME/gnome-control-center"
|
||||
# limited by gnome-online-accounts
|
||||
arch="all !s390x !mips !mips64"
|
||||
license="GPL-2.0-or-later"
|
||||
depends="cups-pk-helper openrc-settingsd dbus:org.freedesktop.Secrets"
|
||||
makedepends="
|
||||
clutter-dev
|
||||
clutter-gtk-dev
|
||||
gnome-desktop-dev
|
||||
gnome-settings-daemon-dev
|
||||
gnome-online-accounts-dev
|
||||
grilo-dev
|
||||
libgtop-dev
|
||||
gnome-bluetooth-dev
|
||||
colord-gtk-dev
|
||||
samba-dev
|
||||
accountsservice-dev
|
||||
libpwquality-dev
|
||||
networkmanager-dev
|
||||
libnma-dev
|
||||
modemmanager-dev
|
||||
krb5-dev
|
||||
itstool
|
||||
libxml2-utils
|
||||
libxslt
|
||||
docbook-xml
|
||||
docbook-xsl
|
||||
pulseaudio-dev
|
||||
udisks2-dev
|
||||
cups-dev
|
||||
meson
|
||||
libsecret-dev
|
||||
gsound-dev
|
||||
libgudev-dev
|
||||
polkit-dev
|
||||
libhandy-dev
|
||||
cheese-dev
|
||||
ibus-dev"
|
||||
options="!check" # needs unpackaged py-dbusmock
|
||||
install="$pkgname.pre-install $pkgname.pre-upgrade"
|
||||
subpackages="$pkgname-dev $pkgname-lang $pkgname-dbg $pkgname-doc $pkgname-bash-completion"
|
||||
source="https://source.puri.sm/Librem5/gnome-control-center/-/archive/$_commit/gnome-control-center-$_commit.tar.gz
|
||||
README.alpine
|
||||
build-fix.patch
|
||||
"
|
||||
builddir="$srcdir/$pkgname-$_commit"
|
||||
|
||||
build() {
|
||||
meson \
|
||||
--prefix=/usr \
|
||||
--sysconfdir=/etc \
|
||||
--mandir=/usr/share/man \
|
||||
--localstatedir=/var \
|
||||
--buildtype=plain \
|
||||
-Dcheese=true \
|
||||
-Dibus=true \
|
||||
. output
|
||||
ninja -C output
|
||||
}
|
||||
|
||||
check() {
|
||||
ninja -C output test
|
||||
}
|
||||
|
||||
package() {
|
||||
DESTDIR="$pkgdir" ninja -C output install
|
||||
|
||||
mkdir -p "$pkgdir"/usr/lib
|
||||
mv "$pkgdir"/usr/share/pkgconfig "$pkgdir"/usr/lib
|
||||
|
||||
install -Dm0644 "$srcdir"/README.alpine -t "$pkgdir"/usr/share/doc/"$pkgname"
|
||||
}
|
||||
|
||||
sha512sums="3c184658a77713680108d5f36236c867ff800beae7658bff651c431587a2f90aac64d9d688f3c94a2b3189acda9a672acfeb635a7e5276496b5988ba03b40d0b gnome-control-center-ec619479bf2805792eae5eda7afde317473015c6.tar.gz
|
||||
350aa443149c71851ad4de0976c7fc5cb626ba0c57a8d41e6ef80da1c65ed84a4dfa2483ae92630a3b611c4bfa9360ded82b55e8cd0e3907294c025e4f6b1671 README.alpine
|
||||
78a87bfddb1a660873ec1380a5f8f0f3ad5ef04dd3414d9a7f25ec55a8d4b653769f8e49f519d45c8b17bb3c6549d855e472a33a61c8cca1f9e18f16a05d1cb8 build-fix.patch"
|
14
temp/gnome-control-center/README.alpine
Normal file
14
temp/gnome-control-center/README.alpine
Normal file
|
@ -0,0 +1,14 @@
|
|||
Note that the privacy settings in GNOME settings isn't respected by geoclue
|
||||
for applications that are not sandboxed (running in flatpak), so it will
|
||||
provide location information to any application that asks it, and will not
|
||||
show any applications BUT ones run via flatpak
|
||||
|
||||
This is working as intended by geoclue upstream[1] and applications that
|
||||
are not sandboxed have other methods of acquiring information provided
|
||||
by geoclue
|
||||
|
||||
GNOME settings also tracks what they want to do with their privacy panel
|
||||
in regards to the problem above here[2]
|
||||
|
||||
[1] https://gitlab.freedesktop.org/geoclue/geoclue/issues/111
|
||||
[2] https://gitlab.gnome.org/GNOME/gnome-control-center/-/issues/805
|
13
temp/gnome-control-center/build-fix.patch
Normal file
13
temp/gnome-control-center/build-fix.patch
Normal file
|
@ -0,0 +1,13 @@
|
|||
diff --git a/panels/background/cc-background-item.c b/panels/background/cc-background-item.c
|
||||
index dc8850b66..50851e17d 100644
|
||||
--- a/panels/background/cc-background-item.c
|
||||
+++ b/panels/background/cc-background-item.c
|
||||
@@ -156,7 +156,7 @@ render_at_size (GnomeBG *bg,
|
||||
GdkPixbuf *pixbuf;
|
||||
|
||||
pixbuf = gdk_pixbuf_new (GDK_COLORSPACE_RGB, FALSE, 8, width, height);
|
||||
- gnome_bg_draw (bg, pixbuf, gdk_screen_get_default (), FALSE);
|
||||
+ gnome_bg_draw (bg, pixbuf);
|
||||
|
||||
return pixbuf;
|
||||
}
|
21
temp/gnome-control-center/gnome-control-center.pre-install
Normal file
21
temp/gnome-control-center/gnome-control-center.pre-install
Normal file
|
@ -0,0 +1,21 @@
|
|||
#!/bin/sh
|
||||
cat << __EOF__
|
||||
*
|
||||
* Note that the privacy settings in GNOME settings isn't respected by geoclue
|
||||
* for applications that are not sandboxed (running in flatpak), so it will
|
||||
* provide location information to any application that asks it, and will not
|
||||
* show any applications BUT ones run via flatpak
|
||||
*
|
||||
* This is working as intended by geoclue upstream[1] and applications that
|
||||
* are not sandboxed have other methods of acquiring information provided
|
||||
* by geoclue
|
||||
*
|
||||
* GNOME settings also tracks what they want to do with their privacy panel
|
||||
* in regards to the problem above here[2]
|
||||
*
|
||||
* [1] https://gitlab.freedesktop.org/geoclue/geoclue/issues/111
|
||||
* [2] https://gitlab.gnome.org/GNOME/gnome-control-center/-/issues/805
|
||||
*
|
||||
__EOF__
|
||||
|
||||
exit 0
|
1
temp/gnome-control-center/gnome-control-center.pre-upgrade
Symbolic link
1
temp/gnome-control-center/gnome-control-center.pre-upgrade
Symbolic link
|
@ -0,0 +1 @@
|
|||
gnome-control-center.pre-install
|
Loading…
Reference in a new issue