phosh/phosh: update to 0.3.0 (!495)
This commit is contained in:
parent
96d2742377
commit
ccfa6e2d8e
3 changed files with 67 additions and 14 deletions
|
@ -1,24 +1,24 @@
|
|||
# Contributor: Bart Ribbers <bribbers@disroot.org>
|
||||
# Maintainer: Bart Ribbers <bribbers@disroot.org>
|
||||
pkgname=phosh
|
||||
pkgver=0.0.2_git20190502
|
||||
pkgver=0.0.3
|
||||
pkgrel=0
|
||||
_commit="38a86e4bb443fbfa87443539f323338b05408472"
|
||||
_gvc_commit="ae1a34aafce7026b8c0f65a43c9192d756fe1057"
|
||||
pkgdesc="A shell PoC for the Librem5"
|
||||
arch="x86 x86_64 aarch64"
|
||||
url="https://source.puri.sm/Librem5/phosh"
|
||||
license="GPL-3.0-only"
|
||||
depends="gtk+3.0 wayland-protocols wlroots gnome-session bash dbus-x11 gnome-settings-daemon virtboard libpulse"
|
||||
makedepends="gtk+3.0-dev meson ninja gnome-desktop-dev libhandy-dev gcr-dev upower-dev linux-pam-dev git cmake pulseaudio-dev networkmanager-dev"
|
||||
depends="gtk+3.0 wayland-protocols phoc gnome-session bash dbus-x11 gnome-settings-daemon virtboard libpulse"
|
||||
makedepends="gtk+3.0-dev meson ninja gnome-desktop-dev libhandy-dev gcr-dev upower-dev linux-pam-dev git cmake pulseaudio-dev networkmanager-dev polkit-elogind-dev"
|
||||
subpackages="$pkgname-lang"
|
||||
source="
|
||||
$pkgname-$_commit.tar.gz::https://source.puri.sm/Librem5/$pkgname/-/archive/$_commit.tar.gz
|
||||
$pkgname-$pkgver.tar.gz::https://source.puri.sm/Librem5/$pkgname/-/archive/v$pkgver/$pkgname-v$pkgver.tar.gz
|
||||
libgvc-$_gvc_commit.tar.gz::https://gitlab.gnome.org/GNOME/libgnome-volume-control/-/archive/$_gvc_commit/libgnome-volume-control-$_gvc_commit.tar.gz
|
||||
stop-hardcoding-resolution.patch
|
||||
phosh.desktop"
|
||||
phosh.desktop
|
||||
polkit-0.114.patch"
|
||||
options="!check" # Needs a running Wayland compositor
|
||||
builddir="$srcdir/$pkgname-$_commit"
|
||||
builddir="$srcdir/$pkgname-v$pkgver"
|
||||
|
||||
prepare() {
|
||||
default_prepare
|
||||
|
@ -43,7 +43,8 @@ package() {
|
|||
"$pkgdir"/usr/share/wayland-sessions/phosh.desktop
|
||||
|
||||
}
|
||||
sha512sums="a34f29ab30daf7e655e60eaf8466420cf2e33d1c984ea7dc9259387a5abeb30e3f68385c15b9ef7cd3865ba307f0c619efc903b651c145d447528aba5abbee7c phosh-38a86e4bb443fbfa87443539f323338b05408472.tar.gz
|
||||
sha512sums="3eb9a98c3d3657c5a18e519a47437b4fb5d3f72656d89b7781fd61fbcb694630756d4dfb853b86fab8252771b4e38efd1566eda80918d10a88e52a9c67f8b908 phosh-0.0.3.tar.gz
|
||||
723334bff55927363dab47ef22c71dcaf94263fe76e49c40f1cbfbd5f86383e68fd4bf2182eb5777dda8e2ede4ee4710e1a7ab1379d3ca40d68f68ff30c62e21 libgvc-ae1a34aafce7026b8c0f65a43c9192d756fe1057.tar.gz
|
||||
8e59a1e592f01c73c32ab75f6608a047a2f90acceed08e78491f8fd2ee2183c4586ec8efc35fb396acffe2e34f5c8bf9bee43767a5a4f7897645e0df3a8107e5 stop-hardcoding-resolution.patch
|
||||
6644870edbbbc6b88d6e19f7771d81dba1a11066c2b34e4c22736db73a2dfd0d4909b4967503059c35385c5139a834a5c06a3c56b148ba1275d7f089c0c5f33c phosh.desktop"
|
||||
93c05f86a314bbd466b083cd9dfe0ba40803020d4865d666f2f67356be41f1769116f34eaade66d19a0f0cec2d79941986fef24a9a2fa19481c769019aef9ba3 stop-hardcoding-resolution.patch
|
||||
6644870edbbbc6b88d6e19f7771d81dba1a11066c2b34e4c22736db73a2dfd0d4909b4967503059c35385c5139a834a5c06a3c56b148ba1275d7f089c0c5f33c phosh.desktop
|
||||
2f8fd7041a14ab50649fb4309c031b0284016dfab52b92e7ad10f6b5f0006ec6772c30954fd79519cc34ad06ad161eafe164b86ac4ff15a0d6f2053de684801b polkit-0.114.patch"
|
||||
|
|
47
phosh/phosh/polkit-0.114.patch
Normal file
47
phosh/phosh/polkit-0.114.patch
Normal file
|
@ -0,0 +1,47 @@
|
|||
From 5cf0b498caa8073674235b1c0166b593744ccae3 Mon Sep 17 00:00:00 2001
|
||||
From: Sebastian Krzyszkowiak <dos@dosowisko.net>
|
||||
Date: Fri, 5 Jul 2019 00:11:46 +0200
|
||||
Subject: [PATCH] PolkitAuthAgent: fix build with Polkit >= 0.114
|
||||
|
||||
Polkit 0.114 introduced bunch of predefined g_autoptr cleanups, which
|
||||
leads to compilation failure due to duplicate cleanup definition for
|
||||
PolkitSubject. Note that even the latest polkit doesn't have a cleanup
|
||||
for PolkitAgentListener defined, so it's left there unguarded.
|
||||
---
|
||||
src/meson.build | 5 +++++
|
||||
src/polkit-auth-agent.h | 2 ++
|
||||
2 files changed, 7 insertions(+)
|
||||
|
||||
diff --git a/src/meson.build b/src/meson.build
|
||||
index 226305d..2097324 100644
|
||||
--- a/src/meson.build
|
||||
+++ b/src/meson.build
|
||||
@@ -101,6 +101,11 @@ phosh_deps = [
|
||||
cc.find_library('rt', required: false),
|
||||
]
|
||||
|
||||
+add_project_arguments([
|
||||
+ '-DPOLKIT_AGENT_MAJOR_VERSION=' + libpolkit_agent_dep.version().split('.')[0],
|
||||
+ '-DPOLKIT_AGENT_MINOR_VERSION=' + libpolkit_agent_dep.version().split('.')[1]
|
||||
+], language: 'c')
|
||||
+
|
||||
phosh = executable('phosh', phosh_sources,
|
||||
include_directories: [root_inc, src_inc],
|
||||
dependencies: phosh_deps,
|
||||
diff --git a/src/polkit-auth-agent.h b/src/polkit-auth-agent.h
|
||||
index 386acc7..0a58202 100644
|
||||
--- a/src/polkit-auth-agent.h
|
||||
+++ b/src/polkit-auth-agent.h
|
||||
@@ -14,7 +14,9 @@
|
||||
G_BEGIN_DECLS
|
||||
|
||||
/* libpolkit lacks these */
|
||||
+#if POLKIT_AGENT_MAJOR_VERSION == 0 && POLKIT_AGENT_MINOR_VERSION < 114
|
||||
G_DEFINE_AUTOPTR_CLEANUP_FUNC(PolkitSubject, g_object_unref)
|
||||
+#endif
|
||||
G_DEFINE_AUTOPTR_CLEANUP_FUNC(PolkitAgentListener, g_object_unref)
|
||||
|
||||
#define PHOSH_TYPE_POLKIT_AUTH_AGENT (phosh_polkit_auth_agent_get_type())
|
||||
--
|
||||
2.18.1
|
||||
|
|
@ -1,8 +1,8 @@
|
|||
diff --git a/data/rootston.ini b/data/rootston.ini
|
||||
index d28f0c1..1ae3883 100644
|
||||
index 7a3b754..1ae3883 100644
|
||||
--- a/data/rootston.ini
|
||||
+++ b/data/rootston.ini
|
||||
@@ -7,17 +7,6 @@ map-to-output:DSI-1
|
||||
@@ -7,22 +7,6 @@ map-to-output:DSI-1
|
||||
[output:DSI-1]
|
||||
scale = 2
|
||||
|
||||
|
@ -13,9 +13,14 @@ index d28f0c1..1ae3883 100644
|
|||
-scale = 2
|
||||
-
|
||||
-[output:X11-1]
|
||||
-mode = 768x1024
|
||||
-mode = 360x720
|
||||
-#rotate = 90
|
||||
-#scale = 2
|
||||
-scale = 1
|
||||
-
|
||||
-[output:WL-1]
|
||||
-mode = 360x720
|
||||
-#rotate = 90
|
||||
-scale = 1
|
||||
-
|
||||
[keyboard]
|
||||
meta-key = Logo
|
||||
|
|
Loading…
Reference in a new issue