klipad-rel: new device (MR 2108)
This commit is contained in:
parent
0e851aadbf
commit
c872ed9fcf
6 changed files with 5007 additions and 0 deletions
27
device/testing/device-klipad-rel/APKBUILD
Normal file
27
device/testing/device-klipad-rel/APKBUILD
Normal file
|
@ -0,0 +1,27 @@
|
|||
# Reference: <https://postmarketos.org/devicepkg>
|
||||
pkgname=device-klipad-rel
|
||||
pkgdesc="KLIPAD Klipad Tablet"
|
||||
pkgver=0.1
|
||||
pkgrel=0
|
||||
url="https://postmarketos.org"
|
||||
license="MIT"
|
||||
arch="armv7"
|
||||
options="!check !archcheck"
|
||||
depends="
|
||||
linux-klipad-rel
|
||||
mesa-dri-gallium
|
||||
postmarketos-base
|
||||
mkbootimg
|
||||
"
|
||||
makedepends="devicepkg-dev"
|
||||
source="deviceinfo"
|
||||
|
||||
build() {
|
||||
devicepkg_build $startdir $pkgname
|
||||
}
|
||||
|
||||
package() {
|
||||
devicepkg_package $startdir $pkgname
|
||||
}
|
||||
|
||||
sha512sums="6622168d2bc68367c8f0e43c7d8eb993c54c7f02d2283eb7d6039b8e2e9ccd38bb6055b390dc84a2976bc4951bedf790bd336e3d02e785da72421d7451214f94 deviceinfo"
|
33
device/testing/device-klipad-rel/deviceinfo
Normal file
33
device/testing/device-klipad-rel/deviceinfo
Normal file
|
@ -0,0 +1,33 @@
|
|||
# Reference: <https://postmarketos.org/deviceinfo>
|
||||
# Please use double quotes only. You can source this file in shell
|
||||
# scripts.
|
||||
|
||||
deviceinfo_format_version="0"
|
||||
deviceinfo_name="KLIPAD Klipad Tablet"
|
||||
deviceinfo_manufacturer="KLIPAD"
|
||||
deviceinfo_codename="klipad-rel"
|
||||
deviceinfo_year="2016"
|
||||
deviceinfo_arch="armv7"
|
||||
|
||||
# Device related
|
||||
deviceinfo_chassis="tablet"
|
||||
deviceinfo_keyboard="true"
|
||||
deviceinfo_external_storage="true"
|
||||
deviceinfo_screen_width="1024"
|
||||
deviceinfo_screen_height="600"
|
||||
|
||||
# Bootloader related
|
||||
deviceinfo_flash_method="none"
|
||||
|
||||
# pmbootstrap bootimg_analyze
|
||||
deviceinfo_kernel_cmdline="buildvariant=user"
|
||||
deviceinfo_generate_bootimg="true"
|
||||
deviceinfo_bootimg_qcdt="false"
|
||||
deviceinfo_bootimg_mtk_mkimage="false"
|
||||
deviceinfo_bootimg_dtb_second="false"
|
||||
deviceinfo_flash_offset_base="0x10000000"
|
||||
deviceinfo_flash_offset_kernel="0x00008000"
|
||||
deviceinfo_flash_offset_ramdisk="0x01000000"
|
||||
deviceinfo_flash_offset_second="0x00f00000"
|
||||
deviceinfo_flash_offset_tags="0x00000100"
|
||||
deviceinfo_flash_pagesize="2048"
|
|
@ -0,0 +1,26 @@
|
|||
diff --git a/scripts/Makefile.lib b/scripts/Makefile.lib
|
||||
index 3fb2aaa0..f9390a06 100644
|
||||
--- a/scripts/Makefile.lib
|
||||
+++ b/scripts/Makefile.lib
|
||||
@@ -362,7 +362,7 @@ cmd_lzma = (cat $(filter-out FORCE,$^) | \
|
||||
|
||||
quiet_cmd_lzo = LZO $@
|
||||
cmd_lzo = (cat $(filter-out FORCE,$^) | \
|
||||
- lzop -9 && $(call size_append, $(filter-out FORCE,$^))) > $@ || \
|
||||
+ lzop -6 && $(call size_append, $(filter-out FORCE,$^))) > $@ || \
|
||||
(rm -f $@ ; false)
|
||||
|
||||
quiet_cmd_lz4 = LZ4 $@
|
||||
diff --git a/scripts/gen_initramfs_list.sh b/scripts/gen_initramfs_list.sh
|
||||
index 17fa9014..39d6f3b0 100755
|
||||
--- a/scripts/gen_initramfs_list.sh
|
||||
+++ b/scripts/gen_initramfs_list.sh
|
||||
@@ -254,7 +254,7 @@ case "$arg" in
|
||||
&& compr="xz --check=crc32 --lzma2=dict=1MiB"
|
||||
echo "$output_file" | grep -q "\.lzo$" \
|
||||
&& [ -x "`which lzop 2> /dev/null`" ] \
|
||||
- && compr="lzop -9 -f"
|
||||
+ && compr="lzop -6 -f"
|
||||
echo "$output_file" | grep -q "\.lz4$" \
|
||||
&& [ -x "`which lz4 2> /dev/null`" ] \
|
||||
&& compr="lz4 -l -9 -f"
|
60
device/testing/linux-klipad-rel/APKBUILD
Normal file
60
device/testing/linux-klipad-rel/APKBUILD
Normal file
|
@ -0,0 +1,60 @@
|
|||
# Reference: <https://postmarketos.org/vendorkernel>
|
||||
# Kernel config based on: config extracted from stock (prebuilt) kernel
|
||||
|
||||
pkgname=linux-klipad-rel
|
||||
pkgver=4.4.167
|
||||
pkgrel=0
|
||||
pkgdesc="KLIPAD Klipad Tablet kernel fork"
|
||||
arch="armv7"
|
||||
_carch="arm"
|
||||
_flavor="klipad-rel"
|
||||
url="https://kernel.org"
|
||||
license="GPL-2.0-only"
|
||||
options="!strip !check !tracedeps pmb:cross-native"
|
||||
makedepends="
|
||||
bash
|
||||
bc
|
||||
bison
|
||||
devicepkg-dev
|
||||
flex
|
||||
openssl-dev
|
||||
perl
|
||||
"
|
||||
|
||||
# Fix Python errors (more recent kernels, not 4.4)
|
||||
# export TEMP_LN_DIR="$(mktemp -d)"
|
||||
# export PATH="$PATH:$TEMP_LN_DIR"
|
||||
# ln -s /usr/bin/python3 "$TEMP_LN_DIR/python"
|
||||
|
||||
# Source
|
||||
_repository="kernel"
|
||||
_commit="27f039b43ada8d0301867505ce9a91d8b5c604bc" # 4.19: "08e8386122b77fdbf16779195cf722f4b8c02384"
|
||||
_config="config-$_flavor.$arch"
|
||||
source="
|
||||
$pkgname-$_commit.tar.gz::https://github.com/rockchip-linux/$_repository/archive/$_commit.tar.gz
|
||||
$_config
|
||||
linux4.2-gcc10-extern_YYLOC_global_declaration.patch
|
||||
02_reduce_lzo_compression.patch
|
||||
"
|
||||
builddir="$srcdir/$_repository-$_commit"
|
||||
_outdir="out"
|
||||
|
||||
prepare() {
|
||||
default_prepare
|
||||
. downstreamkernel_prepare
|
||||
}
|
||||
|
||||
build() {
|
||||
unset LDFLAGS
|
||||
make O="$_outdir" ARCH="$_carch" CC="${CC:-gcc}" \
|
||||
KBUILD_BUILD_VERSION="$((pkgrel + 1 ))-postmarketOS"
|
||||
}
|
||||
|
||||
package() {
|
||||
downstreamkernel_package "$builddir" "$pkgdir" "$_carch" "$_flavor" "$_outdir"
|
||||
}
|
||||
|
||||
sha512sums="a864bab7f7c5fb01322d471d4e3600ab0757a7ece4bb785843225dc54e265934dd5088180b9a17c90479882c6588b6d479bcfea7f986ff4cc349752395c73c2d linux-klipad-rel-27f039b43ada8d0301867505ce9a91d8b5c604bc.tar.gz
|
||||
f042d89749a968b0a7f79faca879335339c7a8f7102794b1f1b0ad3d0ea9c03b26ce8632637153c8da14b335f8f01c05a86ce7e900a137d21b70ee8d1302b159 config-klipad-rel.armv7
|
||||
eaf2e61fcb508cdd239b8fed209d2a09ecac77287f6b46d003918fdf1c6fa2ee63f7390f3ff7c49029b8ed6cbcdd81c7e9a4b1ece9f5060b6fc84e322bd47f41 linux4.2-gcc10-extern_YYLOC_global_declaration.patch
|
||||
0faff5eeb9b121e0a2152108b444337c2ea757dc4cb1d63335038d6a16f1e4281be27dd09a3cf9974352b8cd2b3f20ba9aecb905bd186387929397ad2fdbda50 02_reduce_lzo_compression.patch"
|
4860
device/testing/linux-klipad-rel/config-klipad-rel.armv7
Normal file
4860
device/testing/linux-klipad-rel/config-klipad-rel.armv7
Normal file
File diff suppressed because it is too large
Load diff
|
@ -0,0 +1 @@
|
|||
../../.shared-patches/linux/linux4.2-gcc10-extern_YYLOC_global_declaration.patch
|
Loading…
Reference in a new issue