Add new device: samsung-i747m (Galaxy S3 USA/Canada version) (#877)
* Add samsung-i747m (Galaxy S3 USA/Canada) * Add support for WiFi on i747m
This commit is contained in:
parent
12b5b1ebec
commit
c775d2afd1
13 changed files with 4151 additions and 0 deletions
3
device/device-samsung-i747m/90-android-touch-dev.rules
Normal file
3
device/device-samsung-i747m/90-android-touch-dev.rules
Normal file
|
@ -0,0 +1,3 @@
|
|||
# udev rules file
|
||||
SUBSYSTEM=="input", ATTRS{name}=="sec_touchscreen", \
|
||||
ENV{ID_INPUT}="1", ENV{ID_INPUT_TOUCHSCREEN}="1"
|
23
device/device-samsung-i747m/APKBUILD
Normal file
23
device/device-samsung-i747m/APKBUILD
Normal file
|
@ -0,0 +1,23 @@
|
|||
pkgname="device-samsung-i747m"
|
||||
pkgdesc="Samsing Galaxy SIII (USA/Canada)"
|
||||
pkgver=0.1
|
||||
pkgrel=0
|
||||
url="https://postmarketos.org"
|
||||
license="MIT"
|
||||
arch="noarch"
|
||||
options="!check"
|
||||
depends="linux-samsung-i747m firmware-samsung-i747m mkbootimg"
|
||||
source="deviceinfo 90-android-touch-dev.rules fb.modes"
|
||||
|
||||
package() {
|
||||
install -Dm644 "$srcdir"/deviceinfo \
|
||||
"$pkgdir"/etc/deviceinfo
|
||||
install -Dm644 "$srcdir"/90-android-touch-dev.rules \
|
||||
"$pkgdir"/etc/udev/rules.d/90-android-touch-dev.rules
|
||||
install -Dm644 "$srcdir"/fb.modes \
|
||||
"$pkgdir"/etc/fb.modes
|
||||
}
|
||||
|
||||
sha512sums="c2c4ca148e0a0aad10e1bbfac40271bf6afd0cae35f452846ffa8e2b0e6b76c11d6e7cd2548816a94a26837ccdd0f16a5081179198079502a53252c1b0086f1f deviceinfo
|
||||
1ef4aa9206e6aa61cef80dd4fd4dc2d834e3582e40978d2da8a768964bbaa854a4068fb263e4dcc3cb1a745d42ebf5d457084801dd28fa2de50706ed5a5a9c7c 90-android-touch-dev.rules
|
||||
bd5aba648930678aea38d2a67e584c94f5ab53d235c8f6ce785bc7e31db00e1cdf08fb84fd3fe78bd7b409a4120b2c7beadf77e028ec8580d4df48248a2c414f fb.modes"
|
34
device/device-samsung-i747m/deviceinfo
Normal file
34
device/device-samsung-i747m/deviceinfo
Normal file
|
@ -0,0 +1,34 @@
|
|||
# Reference: <https://postmarketos.org/deviceinfo>
|
||||
# Please use double quotes only. You can source this file in shell scripts.
|
||||
|
||||
deviceinfo_format_version="0"
|
||||
deviceinfo_name="Samsing Galaxy SIII (USA)"
|
||||
deviceinfo_manufacturer="Samsung"
|
||||
deviceinfo_date=""
|
||||
deviceinfo_dtb=""
|
||||
deviceinfo_modules_initfs=""
|
||||
deviceinfo_external_disk_install="false"
|
||||
deviceinfo_arch="armhf"
|
||||
|
||||
# Device related
|
||||
deviceinfo_keyboard="false"
|
||||
deviceinfo_external_disk="true"
|
||||
deviceinfo_screen_width="720"
|
||||
deviceinfo_screen_height="1280"
|
||||
deviceinfo_dev_touchscreen="/dev/input/event4"
|
||||
deviceinfo_dev_keyboard=""
|
||||
|
||||
# Bootloader related
|
||||
deviceinfo_flash_methods="heimdall-bootimg"
|
||||
deviceinfo_kernel_cmdline="androidboot.hardware=qcom user_debug=31 zcache buildvariant=userdebug"
|
||||
deviceinfo_generate_bootimg="true"
|
||||
deviceinfo_flash_offset_base="0x80200000"
|
||||
deviceinfo_flash_offset_kernel="0x00008000"
|
||||
deviceinfo_flash_offset_ramdisk="0x01500000"
|
||||
deviceinfo_flash_offset_second="0x00f00000"
|
||||
deviceinfo_flash_offset_tags="0x00000100"
|
||||
deviceinfo_flash_pagesize="2048"
|
||||
deviceinfo_flash_heimdall_partition_kernel="BOOT"
|
||||
deviceinfo_flash_heimdall_partition_system="SYSTEM"
|
||||
|
||||
deviceinfo_weston_pixman_type="2"
|
8
device/device-samsung-i747m/fb.modes
Normal file
8
device/device-samsung-i747m/fb.modes
Normal file
|
@ -0,0 +1,8 @@
|
|||
mode "720x1280-0"
|
||||
# D: 0.002 MHz, H: 0.002 kHz, V: 0.001 Hz
|
||||
geometry 720 1280 720 1280 16
|
||||
timings 499500000 30 278 2 53 2 1
|
||||
accel false
|
||||
rgba 8/24,8/16,8/8,8/0
|
||||
endmode
|
||||
|
|
@ -0,0 +1,46 @@
|
|||
From bd447b61c49fc26f0299587db3e6d66da49dc529 Mon Sep 17 00:00:00 2001
|
||||
From: Chen Gang <gang.chen.5i5j@gmail.com>
|
||||
Date: Sun, 9 Nov 2014 13:31:11 -0800
|
||||
Subject: [PATCH] Input: lifebook - use "static inline" instead of "inline" in
|
||||
lifebook.h
|
||||
|
||||
For functions defined in header files we should use static inline rather
|
||||
than inline, which breaks under the latest upstream gcc (which is really
|
||||
gcc issue, but static inline is better suited regardless).
|
||||
|
||||
The related error (with allmodconfig under tile):
|
||||
|
||||
MODPOST 4002 modules
|
||||
ERROR: "lifebook_detect" [drivers/input/mouse/psmouse.ko] undefined!
|
||||
|
||||
Signed-off-by: Chen Gang <gang.chen.5i5j@gmail.com>
|
||||
Signed-off-by: Dmitry Torokhov <dmitry.torokhov@gmail.com>
|
||||
---
|
||||
drivers/input/mouse/lifebook.h | 6 +++---
|
||||
1 file changed, 3 insertions(+), 3 deletions(-)
|
||||
|
||||
diff --git a/drivers/input/mouse/lifebook.h b/drivers/input/mouse/lifebook.h
|
||||
index 4c4326c6f504..0baf02a70a99 100644
|
||||
--- a/drivers/input/mouse/lifebook.h
|
||||
+++ b/drivers/input/mouse/lifebook.h
|
||||
@@ -16,14 +16,14 @@ void lifebook_module_init(void);
|
||||
int lifebook_detect(struct psmouse *psmouse, bool set_properties);
|
||||
int lifebook_init(struct psmouse *psmouse);
|
||||
#else
|
||||
-inline void lifebook_module_init(void)
|
||||
+static inline void lifebook_module_init(void)
|
||||
{
|
||||
}
|
||||
-inline int lifebook_detect(struct psmouse *psmouse, bool set_properties)
|
||||
+static inline int lifebook_detect(struct psmouse *psmouse, bool set_properties)
|
||||
{
|
||||
return -ENOSYS;
|
||||
}
|
||||
-inline int lifebook_init(struct psmouse *psmouse)
|
||||
+static inline int lifebook_init(struct psmouse *psmouse)
|
||||
{
|
||||
return -ENOSYS;
|
||||
}
|
||||
--
|
||||
2.14.1
|
||||
|
|
@ -0,0 +1,36 @@
|
|||
From bde304575f3ecaa9570a9329196dffaadf3adafa Mon Sep 17 00:00:00 2001
|
||||
From: Khem Raj <raj.khem@gmail.com>
|
||||
Date: Fri, 22 May 2015 09:56:29 -0700
|
||||
Subject: [PATCH] Input: sentelic - use "static inline" instead of "inline"
|
||||
|
||||
gcc-5 defaults to gnu11 which used c99 inline semantics in c99 'inline' is
|
||||
not externally visible unlike gnu89, therefore we use 'static inline' which
|
||||
has same semantics between gnu89 and c99
|
||||
|
||||
Signed-off-by: Khem Raj <raj.khem@gmail.com>
|
||||
Signed-off-by: Dmitry Torokhov <dmitry.torokhov@gmail.com>
|
||||
---
|
||||
drivers/input/mouse/sentelic.h | 4 ++--
|
||||
1 file changed, 2 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/drivers/input/mouse/sentelic.h b/drivers/input/mouse/sentelic.h
|
||||
index aa697ece405b..42df9e3beae8 100644
|
||||
--- a/drivers/input/mouse/sentelic.h
|
||||
+++ b/drivers/input/mouse/sentelic.h
|
||||
@@ -123,11 +123,11 @@ struct fsp_data {
|
||||
extern int fsp_detect(struct psmouse *psmouse, bool set_properties);
|
||||
extern int fsp_init(struct psmouse *psmouse);
|
||||
#else
|
||||
-inline int fsp_detect(struct psmouse *psmouse, bool set_properties)
|
||||
+static inline int fsp_detect(struct psmouse *psmouse, bool set_properties)
|
||||
{
|
||||
return -ENOSYS;
|
||||
}
|
||||
-inline int fsp_init(struct psmouse *psmouse)
|
||||
+static inline int fsp_init(struct psmouse *psmouse)
|
||||
{
|
||||
return -ENOSYS;
|
||||
}
|
||||
--
|
||||
2.14.1
|
||||
|
49
device/linux-samsung-i747m/00_fix_return_address.patch
Normal file
49
device/linux-samsung-i747m/00_fix_return_address.patch
Normal file
|
@ -0,0 +1,49 @@
|
|||
From aeea3592a13bf12861943e44fc48f1f270941f8d Mon Sep 17 00:00:00 2001
|
||||
From: Behan Webster <behanw@converseincode.com>
|
||||
Date: Wed, 24 Sep 2014 01:06:46 +0100
|
||||
Subject: [PATCH] ARM: 8158/1: LLVMLinux: use static inline in ARM ftrace.h
|
||||
|
||||
With compilers which follow the C99 standard (like modern versions of gcc and
|
||||
clang), "extern inline" does the wrong thing (emits code for an externally
|
||||
linkable version of the inline function). In this case using static inline
|
||||
and removing the NULL version of return_address in return_address.c does
|
||||
the right thing.
|
||||
|
||||
Signed-off-by: Behan Webster <behanw@converseincode.com>
|
||||
Reviewed-by: Mark Charlebois <charlebm@gmail.com>
|
||||
Acked-by: Steven Rostedt <rostedt@goodmis.org>
|
||||
Signed-off-by: Russell King <rmk+kernel@arm.linux.org.uk>
|
||||
---
|
||||
arch/arm/include/asm/ftrace.h | 2 +-
|
||||
arch/arm/kernel/return_address.c | 5 -----
|
||||
2 files changed, 1 insertion(+), 6 deletions(-)
|
||||
|
||||
diff --git a/arch/arm/include/asm/ftrace.h b/arch/arm/include/asm/ftrace.h
|
||||
index 39eb16b0066f2..bfe2a2f5a644e 100644
|
||||
--- a/arch/arm/include/asm/ftrace.h
|
||||
+++ b/arch/arm/include/asm/ftrace.h
|
||||
@@ -45,7 +45,7 @@ void *return_address(unsigned int);
|
||||
|
||||
#else
|
||||
|
||||
-extern inline void *return_address(unsigned int level)
|
||||
+static inline void *return_address(unsigned int level)
|
||||
{
|
||||
return NULL;
|
||||
}
|
||||
diff --git a/arch/arm/kernel/return_address.c b/arch/arm/kernel/return_address.c
|
||||
index fafedd86885dd..f6aa84d5b93c9 100644
|
||||
--- a/arch/arm/kernel/return_address.c
|
||||
+++ b/arch/arm/kernel/return_address.c
|
||||
@@ -63,11 +63,6 @@ void *return_address(unsigned int level)
|
||||
#warning "TODO: return_address should use unwind tables"
|
||||
#endif
|
||||
|
||||
-void *return_address(unsigned int level)
|
||||
-{
|
||||
- return NULL;
|
||||
-}
|
||||
-
|
||||
#endif /* if defined(CONFIG_FRAME_POINTER) && !defined(CONFIG_ARM_UNWIND) / else */
|
||||
|
||||
EXPORT_SYMBOL_GPL(return_address);
|
|
@ -0,0 +1,34 @@
|
|||
From e41494c15d4df342854ac3d2940f5d6ac3158212 Mon Sep 17 00:00:00 2001
|
||||
From: Bryan Huntsman <bryanh@codeaurora.org>
|
||||
Date: Mon, 3 Jun 2013 18:48:08 -0700
|
||||
Subject: [PATCH] msm: fix in-tree compilation for perf_trace_counters
|
||||
|
||||
In-tree compilation for arch/arm/mach-msm/perf_trace_counters.c was
|
||||
hitting this error:
|
||||
|
||||
In file included from arch/arm/mach-msm/perf_trace_counters.h:127:0,
|
||||
from arch/arm/mach-msm/perf_trace_counters.c:14:
|
||||
include/trace/define_trace.h:79:43: fatal error: ./perf_trace_counters.h: No such file or directory
|
||||
|
||||
Instructions for TRACE_INCLUDE_FILE in include/trace/define_trace.h say
|
||||
"the path is relative to define_trace.h, not the file including it".
|
||||
Fix in-tree compilation by making the path relative to define_trace.h.
|
||||
|
||||
Signed-off-by: Bryan Huntsman <bryanh@codeaurora.org>
|
||||
---
|
||||
arch/arm/mach-msm/perf_trace_counters.h | 3 +--
|
||||
1 file changed, 1 insertion(+), 2 deletions(-)
|
||||
|
||||
diff --git a/arch/arm/mach-msm/perf_trace_counters.h b/arch/arm/mach-msm/perf_trace_counters.h
|
||||
index ce7e336aa40d..8f77badf42ac 100644
|
||||
--- a/arch/arm/mach-msm/perf_trace_counters.h
|
||||
+++ b/arch/arm/mach-msm/perf_trace_counters.h
|
||||
@@ -121,7 +121,6 @@ TRACE_EVENT(sched_switch_with_ctrs,
|
||||
|
||||
#endif
|
||||
#undef TRACE_INCLUDE_PATH
|
||||
-#define TRACE_INCLUDE_PATH .
|
||||
+#define TRACE_INCLUDE_PATH ../../arch/arm/mach-msm
|
||||
#define TRACE_INCLUDE_FILE perf_trace_counters
|
||||
#include <trace/define_trace.h>
|
||||
-
|
33
device/linux-samsung-i747m/02_gpu-msm-fix-gcc5-compile.patch
Normal file
33
device/linux-samsung-i747m/02_gpu-msm-fix-gcc5-compile.patch
Normal file
|
@ -0,0 +1,33 @@
|
|||
source:
|
||||
https://github.com/ShinySide/HispAsian_Lollipop_G6/commit/b7756b6fc4bb728722b14d2dfdbaf1dc843812e9
|
||||
|
||||
* These need to be static to avoid these errors:
|
||||
|
||||
drivers/built-in.o: In function `.LANCHOR1':
|
||||
msm_iommu_sec.c:(.data+0x9298): undefined reference to `kgsl_iommu_sync_lock'
|
||||
msm_iommu_sec.c:(.data+0x929c): undefined reference to `kgsl_iommu_sync_unlock'
|
||||
Makefile:877: recipe for target '.tmp_vmlinux1' failed
|
||||
make: *** [.tmp_vmlinux1] Error 1
|
||||
|
||||
Signed-off-by: Chet Kener <Cl3Kener@gmail.com>
|
||||
|
||||
--- a/drivers/gpu/msm/kgsl_iommu.c
|
||||
+++ b/drivers/gpu/msm/kgsl_iommu.c
|
||||
@@ -1010,7 +1010,7 @@ static int kgsl_iommu_init_sync_lock(struct kgsl_mmu *mmu)
|
||||
*
|
||||
* Return - int - number of commands.
|
||||
*/
|
||||
-inline unsigned int kgsl_iommu_sync_lock(struct kgsl_mmu *mmu,
|
||||
+static inline unsigned int kgsl_iommu_sync_lock(struct kgsl_mmu *mmu,
|
||||
unsigned int *cmds)
|
||||
{
|
||||
struct kgsl_device *device = mmu->device;
|
||||
@@ -1080,7 +1080,7 @@ inline unsigned int kgsl_iommu_sync_lock(struct kgsl_mmu *mmu,
|
||||
*
|
||||
* Return - int - number of commands.
|
||||
*/
|
||||
-inline unsigned int kgsl_iommu_sync_unlock(struct kgsl_mmu *mmu,
|
||||
+static inline unsigned int kgsl_iommu_sync_unlock(struct kgsl_mmu *mmu,
|
||||
unsigned int *cmds)
|
||||
{
|
||||
struct kgsl_device *device = mmu->device;
|
93
device/linux-samsung-i747m/APKBUILD
Normal file
93
device/linux-samsung-i747m/APKBUILD
Normal file
|
@ -0,0 +1,93 @@
|
|||
# Kernel config based on: arch/arm/configs/lineageos_d2_defconfig
|
||||
# Changes:
|
||||
# - Added DEVTEMPFS
|
||||
# - Enabled SYSVIPC
|
||||
# - Disabled ANDROID_PARANOID_NETWORK
|
||||
# Patches:
|
||||
# - All simply to allow it to compile under GCC6.
|
||||
|
||||
pkgname="linux-samsung-i747m"
|
||||
pkgver=3.4.112
|
||||
pkgrel=0
|
||||
pkgdesc="Samsung Galaxy SIII (USA/Canada) kernel fork"
|
||||
arch="armhf"
|
||||
_carch="arm"
|
||||
_flavor="samsung-i747m"
|
||||
url="https://kernel.org"
|
||||
license="GPL2"
|
||||
options="!strip !check !tracedeps"
|
||||
makedepends="perl sed installkernel bash gmp-dev bc linux-headers xz elfutils-dev"
|
||||
HOSTCC="${CC:-gcc}"
|
||||
HOSTCC="${HOSTCC#${CROSS_COMPILE}}"
|
||||
|
||||
# Source
|
||||
_repository="android_kernel_samsung_d2"
|
||||
_commit="716f00ee2e86adfd507842c5f193a738b57d3c49"
|
||||
_config="config-${_flavor}.${arch}"
|
||||
source="
|
||||
$pkgname-$_commit.tar.gz::https://github.com/LineageOS/${_repository}/archive/${_commit}.tar.gz
|
||||
$_config
|
||||
compiler-gcc6.h
|
||||
00_fix_return_address.patch
|
||||
00_Input-lifebook-use-static-inline-instead-of-inline-i.patch
|
||||
00_Input-sentelic-use-static-inline-instead-of-inline.patch
|
||||
02_gpu-msm-fix-gcc5-compile.patch
|
||||
"
|
||||
builddir="$srcdir/${_repository}-${_commit}"
|
||||
|
||||
prepare() {
|
||||
default_prepare
|
||||
|
||||
# gcc6 support
|
||||
cp -v "$srcdir/compiler-gcc6.h" "$builddir/include/linux/"
|
||||
|
||||
# Remove -Werror from all makefiles
|
||||
find . -type f -name Makefile -print0 | \
|
||||
xargs -0 sed -i 's/-Werror-/-W/g'
|
||||
find . -type f -name Makefile -print0 | \
|
||||
xargs -0 sed -i 's/-Werror//g'
|
||||
|
||||
# Prepare kernel config ('yes ""' for kernels lacking olddefconfig)
|
||||
cp "$srcdir"/$_config "$builddir"/.config
|
||||
yes "" | make ARCH="$_carch" HOSTCC="$HOSTCC" oldconfig
|
||||
}
|
||||
|
||||
menuconfig() {
|
||||
cd "$builddir"
|
||||
make ARCH="$_carch" menuconfig
|
||||
cp .config "$startdir"/$_config
|
||||
}
|
||||
|
||||
build() {
|
||||
unset LDFLAGS
|
||||
make ARCH="$_carch" CC="${CC:-gcc}" \
|
||||
KBUILD_BUILD_VERSION="$((pkgrel + 1 ))-postmarketOS"
|
||||
}
|
||||
|
||||
package() {
|
||||
# kernel.release
|
||||
install -D "$builddir/include/config/kernel.release" \
|
||||
"$pkgdir/usr/share/kernel/$_flavor/kernel.release"
|
||||
|
||||
# zImage (find the right one)
|
||||
cd "$builddir/arch/$_carch/boot"
|
||||
_target="$pkgdir/boot/vmlinuz-$_flavor"
|
||||
for _zimg in zImage-dtb Image.gz-dtb *zImage Image; do
|
||||
[ -e "$_zimg" ] || continue
|
||||
msg "zImage found: $_zimg"
|
||||
install -Dm644 "$_zimg" "$_target"
|
||||
break
|
||||
done
|
||||
if ! [ -e "$_target" ]; then
|
||||
error "Could not find zImage in $PWD!"
|
||||
return 1
|
||||
fi
|
||||
}
|
||||
|
||||
sha512sums="6850231f0596dd272b4f963d20c77aee6ed16a1ba47261dbafe11ffccac695427db54efa71d070525c519885b795395e9ac6ca97fa06ccc36131aba1f95aa715 linux-samsung-i747m-716f00ee2e86adfd507842c5f193a738b57d3c49.tar.gz
|
||||
7e1173b519c5cb1e175803dcd92bb089ec2e58f07b14db6d657032d7adc4c8e18ff51cd2fda5e4cd74c0cb3cc7829407be9ecbeaa23fb51dffbf1224cad58bfc config-samsung-i747m.armhf
|
||||
d80980e9474c82ba0ef1a6903b434d8bd1b092c40367ba543e72d2c119301c8b2d05265740e4104ca1ac5d15f6c4aa49e8776cb44264a9a28dc551e0d1850dcc compiler-gcc6.h
|
||||
ea1d3b5a234fa565e3c1a792de48f4fc4e6023d281d303c8e319c7ef28edc5739ab0e4dea0139a41f0a5c7d03e27921ccaa214fd0ac5c72245a094ce60128864 00_fix_return_address.patch
|
||||
5c49f6ff6773a7dc3067d2b1359648fe7a9f758b6c068d6fa69d9aaf24a291ba8022c960317d926aabc11d020a71b20c4e81a6fcf9b21ef66d9b6d065bae23e9 00_Input-lifebook-use-static-inline-instead-of-inline-i.patch
|
||||
2d77d90b501aa8afbf81629e73fc0a2055b373942975f58277e43f398d0835b3dbbff4a1118137ec82873ba90a254fea87c1d73ba7708578f1779bd0b4c6ff2d 00_Input-sentelic-use-static-inline-instead-of-inline.patch
|
||||
7be03a9e78b7ac330a54b1f00509caa0621a95c0c55901878ad757f9dd69cc05ba2c8b5ea987063ae1224f92c4d090d515fa5d369e7755181a4871b0d0f82881 02_gpu-msm-fix-gcc5-compile.patch"
|
69
device/linux-samsung-i747m/compiler-gcc6.h
Normal file
69
device/linux-samsung-i747m/compiler-gcc6.h
Normal file
|
@ -0,0 +1,69 @@
|
|||
// SOURCE:
|
||||
// https://github.com/NextThingCo/CHIP-u-boot/issues/10#issuecomment-287515505
|
||||
|
||||
#ifndef __LINUX_COMPILER_H
|
||||
#error "Please don't include <linux/compiler-gcc6.h> directly, include <linux/compiler.h> instead."
|
||||
#endif
|
||||
|
||||
#define __used __attribute__((__used__))
|
||||
#define __must_check __attribute__((warn_unused_result))
|
||||
#define __compiler_offsetof(a, b) __builtin_offsetof(a, b)
|
||||
|
||||
/* Mark functions as cold. gcc will assume any path leading to a call
|
||||
to them will be unlikely. This means a lot of manual unlikely()s
|
||||
are unnecessary now for any paths leading to the usual suspects
|
||||
like BUG(), printk(), panic() etc. [but let's keep them for now for
|
||||
older compilers]
|
||||
|
||||
Early snapshots of gcc 4.3 don't support this and we can't detect this
|
||||
in the preprocessor, but we can live with this because they're unreleased.
|
||||
Maketime probing would be overkill here.
|
||||
|
||||
gcc also has a __attribute__((__hot__)) to move hot functions into
|
||||
a special section, but I don't see any sense in this right now in
|
||||
the kernel context */
|
||||
#define __cold __attribute__((__cold__))
|
||||
|
||||
#define __UNIQUE_ID(prefix) __PASTE(__PASTE(__UNIQUE_ID_, prefix), __COUNTER__)
|
||||
|
||||
#ifndef __CHECKER__
|
||||
# define __compiletime_warning(message) __attribute__((warning(message)))
|
||||
# define __compiletime_error(message) __attribute__((error(message)))
|
||||
#endif /* __CHECKER__ */
|
||||
|
||||
/*
|
||||
* Mark a position in code as unreachable. This can be used to
|
||||
* suppress control flow warnings after asm blocks that transfer
|
||||
* control elsewhere.
|
||||
*
|
||||
* Early snapshots of gcc 4.5 don't support this and we can't detect
|
||||
* this in the preprocessor, but we can live with this because they're
|
||||
* unreleased. Really, we need to have autoconf for the kernel.
|
||||
*/
|
||||
#define unreachable() __builtin_unreachable()
|
||||
|
||||
/* Mark a function definition as prohibited from being cloned. */
|
||||
#define __noclone __attribute__((__noclone__))
|
||||
|
||||
/*
|
||||
* Tell the optimizer that something else uses this function or variable.
|
||||
*/
|
||||
#define __visible __attribute__((externally_visible))
|
||||
|
||||
/*
|
||||
* GCC 'asm goto' miscompiles certain code sequences:
|
||||
*
|
||||
* http://gcc.gnu.org/bugzilla/show_bug.cgi?id=58670
|
||||
*
|
||||
* Work it around via a compiler barrier quirk suggested by Jakub Jelinek.
|
||||
*
|
||||
* (asm goto is automatically volatile - the naming reflects this.)
|
||||
*/
|
||||
#define asm_volatile_goto(x...) do { asm goto(x); asm (""); } while (0)
|
||||
|
||||
#ifdef CONFIG_ARCH_USE_BUILTIN_BSWAP
|
||||
#define __HAVE_BUILTIN_BSWAP32__
|
||||
#define __HAVE_BUILTIN_BSWAP64__
|
||||
#define __HAVE_BUILTIN_BSWAP16__
|
||||
#endif /* CONFIG_ARCH_USE_BUILTIN_BSWAP */
|
||||
|
3699
device/linux-samsung-i747m/config-samsung-i747m.armhf
Normal file
3699
device/linux-samsung-i747m/config-samsung-i747m.armhf
Normal file
File diff suppressed because it is too large
Load diff
24
firmware/firmware-samsung-i747m/APKBUILD
Normal file
24
firmware/firmware-samsung-i747m/APKBUILD
Normal file
|
@ -0,0 +1,24 @@
|
|||
pkgname=firmware-samsung-i747m
|
||||
pkgver=1
|
||||
pkgrel=0
|
||||
pkgdesc="Samsung Galaxy SIII i747m Firmware"
|
||||
url="https://github.com/Zerospeed8/device_samsung_d2att"
|
||||
arch="noarch"
|
||||
license="proprietary"
|
||||
options="!check !strip"
|
||||
|
||||
# Source
|
||||
_commit="15cea7e29a50a85f7cd5ce27e5ff865314467ca3"
|
||||
source=$pkgname-$_commit.tar.gz::$url"/archive/${_commit}.tar.gz"
|
||||
|
||||
package() {
|
||||
cd "$srcdir/device_samsung_d2att-${_commit}/vendor/samsung/d2att/proprietary/"
|
||||
|
||||
# Wifi
|
||||
install -Dm644 "etc/wifi/bcmdhd_sta.bin_b2" \
|
||||
"$pkgdir/lib/firmware/postmarketos/bcmdhd_sta.bin_b2"
|
||||
install -Dm644 "etc/wifi/nvram_net.txt" \
|
||||
"$pkgdir/lib/firmware/postmarketos/nvram_net.txt"
|
||||
}
|
||||
|
||||
sha512sums="b212ab69c782e45e0ee1005bd952ed763437693e769f5309da482b8138a1357d070f60a11185c7c30e61a0841dde08153a4d5a78da3e51ab3aa8ebd5dfddeec7 firmware-samsung-i747m-15cea7e29a50a85f7cd5ce27e5ff865314467ca3.tar.gz"
|
Loading…
Reference in a new issue