linux-postmarketos-amlogic: add support for amediatech-x96-mini (MR 3985)

This commit is contained in:
@exkc 2023-03-31 07:58:51 +08:00 committed by Oliver Smith
parent dfbf4f1c82
commit c34344108f
No known key found for this signature in database
GPG key ID: 5AE7F5513E0885CB
2 changed files with 73 additions and 1 deletions

View file

@ -0,0 +1,70 @@
From e9138e8584286fdc5fe1f9c0c5bb1bc37a6de8b1 Mon Sep 17 00:00:00 2001
From: "@exkc" <exkc@exkc.moe>
Date: Thu, 30 Mar 2023 21:11:41 +0800
Subject: [PATCH] add x96-mini support
---
arch/arm64/boot/dts/amlogic/Makefile | 1 +
.../dts/amlogic/meson-gxl-s905w-x96-mini.dts | 38 +++++++++++++++++++
2 files changed, 39 insertions(+)
create mode 100644 arch/arm64/boot/dts/amlogic/meson-gxl-s905w-x96-mini.dts
diff --git a/arch/arm64/boot/dts/amlogic/Makefile b/arch/arm64/boot/dts/amlogic/Makefile
index e213aeebb..857bb7c00 100644
--- a/arch/arm64/boot/dts/amlogic/Makefile
+++ b/arch/arm64/boot/dts/amlogic/Makefile
@@ -39,6 +39,7 @@ dtb-$(CONFIG_ARCH_MESON) += meson-gxl-s905d-vero4k-plus.dtb
dtb-$(CONFIG_ARCH_MESON) += meson-gxl-s905w-jethome-jethub-j80.dtb
dtb-$(CONFIG_ARCH_MESON) += meson-gxl-s905w-p281.dtb
dtb-$(CONFIG_ARCH_MESON) += meson-gxl-s905w-tx3-mini.dtb
+dtb-$(CONFIG_ARCH_MESON) += meson-gxl-s905w-x96-mini.dtb
dtb-$(CONFIG_ARCH_MESON) += meson-gxl-s905x-hwacom-amazetv.dtb
dtb-$(CONFIG_ARCH_MESON) += meson-gxl-s905x-khadas-vim.dtb
dtb-$(CONFIG_ARCH_MESON) += meson-gxl-s905x-libretech-cc-v2.dtb
diff --git a/arch/arm64/boot/dts/amlogic/meson-gxl-s905w-x96-mini.dts b/arch/arm64/boot/dts/amlogic/meson-gxl-s905w-x96-mini.dts
new file mode 100644
index 000000000..bd69f8897
--- /dev/null
+++ b/arch/arm64/boot/dts/amlogic/meson-gxl-s905w-x96-mini.dts
@@ -0,0 +1,38 @@
+// SPDX-License-Identifier: (GPL-2.0+ OR MIT)
+/*
+ * Copyright (c) 2023 Karl Chan <exxxxkc@getgoogleoff.me>.
+ * Based on meson-gxl-s905w-tx3-mini.dts:
+ *
+ */
+
+/dts-v1/;
+
+#include <dt-bindings/leds/common.h>
+
+#include "meson-gxl-s905x.dtsi"
+#include "meson-gx-p23x-q20x.dtsi"
+
+/ {
+ compatible = "amediatech,x96-mini", "amlogic,s905w", "amlogic,meson-gxl";
+ model = "Shenzhen Amediatech Technology Co., X96 Mini";
+
+ memory@0 {
+ device_type = "memory";
+ reg = <0x0 0x0 0x0 0x40000000>; /* 1 GiB or 2 GiB */
+ };
+
+ leds {
+ compatible = "gpio-leds";
+
+ led-0 {
+ label = "x96-mini:blue:power";
+ gpios = <&gpio GPIODV_24 GPIO_ACTIVE_HIGH>;
+ default-state = "on";
+ };
+ };
+
+};
+
+&usb {
+ dr_mode = "host";
+};
--
2.39.2

View file

@ -4,7 +4,7 @@
# Co-Maintainer: exkc <exxxxkc@getgoogleoff.me>
pkgname=linux-postmarketos-amlogic
pkgver=6.1.10
pkgrel=3
pkgrel=4
pkgdesc="Mainline kernel for Amlogic devices"
arch="aarch64"
_carch="arm64"
@ -38,6 +38,7 @@ source="
0002-WIP-arm64-dts-meson-gxbb-kii-pro-complete-the-blueto.patch
0003-WIP-arm64-dts-meson-gxbb-kii-pro-add-initial-audio-s.patch
0004-add-xiaomi-once-support.patch
0005-add-x96-mini-support.patch
"
builddir="$srcdir/linux-$pkgver"
@ -74,4 +75,5 @@ sha512sums="
2a772de080dda5100a653a9806ee60130228dd2e232055362fa330ee42644374161aa032b1838f12555e952214ac29eb4ef664c587af2363796ba9f70d95dee3 0002-WIP-arm64-dts-meson-gxbb-kii-pro-complete-the-blueto.patch
a497d042112e1f6bf4b4793992907b25b99b9b6d5f77b051261b80ed90ef70022c647ef2db2385bb9dccf31e94b23fa9f3d9bc42b4d1ff1049bcf8cafb7a6b6d 0003-WIP-arm64-dts-meson-gxbb-kii-pro-add-initial-audio-s.patch
9d664c9cc6168a7aa4804662886941744e92c0748e7b7b4fad2472740a4931c89a60cbc4a519913b58933718d02f33f48ff72ea182d912bcd50014ca8d7ff110 0004-add-xiaomi-once-support.patch
3ea569b69297fdb196006b1e1bd82a9dec8d89362ec3ef17918018b6c573143f299a968b8227119660442f6a6e0b795aa4c8a272f6bc23e9622f3fd41ddc97eb 0005-add-x96-mini-support.patch
"