samsung-a5xelte: new device (MR 2413)
[ci:skip-build] already built successfully in CI
This commit is contained in:
parent
59c399b515
commit
c15140f695
14 changed files with 4375 additions and 0 deletions
30
device/testing/device-samsung-a5xelte/APKBUILD
Normal file
30
device/testing/device-samsung-a5xelte/APKBUILD
Normal file
|
@ -0,0 +1,30 @@
|
|||
# Reference: <https://postmarketos.org/devicepkg>
|
||||
pkgname=device-samsung-a5xelte
|
||||
pkgdesc="Samsung Galaxy A5 (2016)"
|
||||
pkgver=0.1
|
||||
pkgrel=0
|
||||
url="https://postmarketos.org"
|
||||
license="MIT"
|
||||
arch="aarch64"
|
||||
options="!check !archcheck"
|
||||
depends="
|
||||
linux-samsung-a5xelte
|
||||
mesa-dri-gallium
|
||||
mkbootimg
|
||||
msm-fb-refresher
|
||||
postmarketos-base
|
||||
"
|
||||
makedepends="devicepkg-dev"
|
||||
source="deviceinfo"
|
||||
|
||||
build() {
|
||||
devicepkg_build $startdir $pkgname
|
||||
}
|
||||
|
||||
package() {
|
||||
devicepkg_package $startdir $pkgname
|
||||
}
|
||||
|
||||
sha512sums="
|
||||
b89e677c79516f784fe5d75059dc7d3b203958932e68cbda7ca5421261c3d5d011968be2d0022d179270781317055d8c25bbe77bc30d423341b293a038575c6b deviceinfo
|
||||
"
|
34
device/testing/device-samsung-a5xelte/deviceinfo
Normal file
34
device/testing/device-samsung-a5xelte/deviceinfo
Normal file
|
@ -0,0 +1,34 @@
|
|||
# Reference: <https://postmarketos.org/deviceinfo>
|
||||
# Please use double quotes only. You can source this file in shell
|
||||
# scripts.
|
||||
|
||||
deviceinfo_format_version="0"
|
||||
deviceinfo_name="Samsung Galaxy A5 (2016)"
|
||||
deviceinfo_manufacturer="Samsung"
|
||||
deviceinfo_codename="samsung-a5xelte"
|
||||
deviceinfo_year="2015"
|
||||
deviceinfo_dtb=""
|
||||
deviceinfo_modules_initfs=""
|
||||
deviceinfo_arch="aarch64"
|
||||
|
||||
# Device related
|
||||
deviceinfo_chassis="handset"
|
||||
deviceinfo_keyboard="false"
|
||||
deviceinfo_external_storage="true"
|
||||
deviceinfo_screen_width="1080"
|
||||
deviceinfo_screen_height="1920"
|
||||
|
||||
# Bootloader related
|
||||
deviceinfo_flash_method="heimdall-bootimg"
|
||||
deviceinfo_generate_bootimg="true"
|
||||
deviceinfo_bootimg_qcdt="true"
|
||||
deviceinfo_bootimg_mtk_mkimage="false"
|
||||
deviceinfo_bootimg_dtb_second="false"
|
||||
deviceinfo_flash_pagesize="2048"
|
||||
deviceinfo_flash_offset_base="0x10000000"
|
||||
deviceinfo_flash_offset_kernel="0x00008000"
|
||||
deviceinfo_flash_offset_ramdisk="0x01000000"
|
||||
deviceinfo_flash_offset_second="0x00f00000"
|
||||
deviceinfo_flash_offset_tags="0x00000100"
|
||||
deviceinfo_flash_heimdall_partition_kernel="BOOT"
|
||||
deviceinfo_flash_heimdall_partition_system="SYSTEM"
|
|
@ -0,0 +1,68 @@
|
|||
This patch was found at https://github.com/LineageOS/android_kernel_samsung_universal7580
|
||||
From 86f1b726b84414148ca2eb81229f8e595d6beacd Mon Sep 17 00:00:00 2001
|
||||
From: Apavayan Sinha <info@apavayan.com>
|
||||
Date: Sun, 24 Jul 2016 15:21:31 +0530
|
||||
Subject: [PATCH] drivers: muic: fix the compile
|
||||
|
||||
Signed-off-by: Apavayan Sinha <info@apavayan.com>
|
||||
---
|
||||
drivers/muic/Makefile | 18 +++++-------------
|
||||
drivers/muic/universal/Makefile | 19 +++++++++++++++++++
|
||||
2 files changed, 24 insertions(+), 13 deletions(-)
|
||||
create mode 100644 drivers/muic/universal/Makefile
|
||||
|
||||
diff --git a/drivers/muic/Makefile b/drivers/muic/Makefile
|
||||
index 86f76acb663..b727ab5a14e 100755
|
||||
--- a/drivers/muic/Makefile
|
||||
+++ b/drivers/muic/Makefile
|
||||
@@ -20,17 +20,9 @@ obj-$(CONFIG_MUIC_SM5705_AFC) += sm5703-muic-afc.o
|
||||
obj-$(CONFIG_MUIC_S2MU005) += s2mu005-muic.o
|
||||
|
||||
# MUIC_UNIVERSAL
|
||||
-obj-$(CONFIG_MUIC_UNIVERSAL) += universal/muic_task.o
|
||||
-obj-$(CONFIG_MUIC_UNIVERSAL) += universal/muic_state.o
|
||||
-obj-$(CONFIG_MUIC_UNIVERSAL) += universal/muic_apis.o
|
||||
-obj-$(CONFIG_MUIC_UNIVERSAL) += universal/muic_sysfs.o
|
||||
-obj-$(CONFIG_MUIC_UNIVERSAL) += universal/muic_debug.o
|
||||
-obj-$(CONFIG_MUIC_UNIVERSAL) += universal/muic_dt.o
|
||||
-obj-$(CONFIG_MUIC_UNIVERSAL) += universal/muic_i2c.o
|
||||
-obj-$(CONFIG_MUIC_UNIVERSAL) += universal/muic_regmap.o
|
||||
-obj-$(CONFIG_MUIC_UNIVERSAL) += universal/muic_vps.o
|
||||
-obj-$(CONFIG_MUIC_UNIVERSAL_SM5703) += universal/muic_regmap_sm5703.o
|
||||
-obj-$(CONFIG_MUIC_UNIVERSAL_SM5705) += universal/muic_regmap_sm5705.o
|
||||
-obj-$(CONFIG_MUIC_UNIVERSAL_SM5705_AFC) += universal/muic_afc.o
|
||||
-obj-$(CONFIG_MUIC_UNIVERSAL_SM5504) += universal/muic_regmap_sm5504.o
|
||||
+obj-$(CONFIG_MUIC_UNIVERSAL) += universal/
|
||||
+obj-$(CONFIG_MUIC_UNIVERSAL_SM5703) += universal/
|
||||
+obj-$(CONFIG_MUIC_UNIVERSAL_SM5705) += universal/
|
||||
+obj-$(CONFIG_MUIC_UNIVERSAL_SM5705_AFC) += universal/
|
||||
+obj-$(CONFIG_MUIC_UNIVERSAL_SM5504) += universal/
|
||||
|
||||
diff --git a/drivers/muic/universal/Makefile b/drivers/muic/universal/Makefile
|
||||
new file mode 100644
|
||||
index 00000000000..adadefa2de1
|
||||
--- /dev/null
|
||||
+++ b/drivers/muic/universal/Makefile
|
||||
@@ -0,0 +1,19 @@
|
||||
+#
|
||||
+# Makefile for muic devices
|
||||
+#
|
||||
+
|
||||
+# MUIC_UNIVERSAL
|
||||
+obj-$(CONFIG_MUIC_UNIVERSAL) += muic_task.o
|
||||
+obj-$(CONFIG_MUIC_UNIVERSAL) += muic_state.o
|
||||
+obj-$(CONFIG_MUIC_UNIVERSAL) += muic_apis.o
|
||||
+obj-$(CONFIG_MUIC_UNIVERSAL) += muic_sysfs.o
|
||||
+obj-$(CONFIG_MUIC_UNIVERSAL) += muic_debug.o
|
||||
+obj-$(CONFIG_MUIC_UNIVERSAL) += muic_dt.o
|
||||
+obj-$(CONFIG_MUIC_UNIVERSAL) += muic_i2c.o
|
||||
+obj-$(CONFIG_MUIC_UNIVERSAL) += muic_regmap.o
|
||||
+obj-$(CONFIG_MUIC_UNIVERSAL) += muic_vps.o
|
||||
+obj-$(CONFIG_MUIC_UNIVERSAL_SM5703) += muic_regmap_sm5703.o
|
||||
+obj-$(CONFIG_MUIC_UNIVERSAL_SM5705) += muic_regmap_sm5705.o
|
||||
+obj-$(CONFIG_MUIC_UNIVERSAL_SM5705_AFC) += muic_afc.o
|
||||
+obj-$(CONFIG_MUIC_UNIVERSAL_SM5504) += muic_regmap_sm5504.o
|
||||
+
|
||||
--
|
||||
2.32.0
|
||||
|
|
@ -0,0 +1,34 @@
|
|||
This patch was found at https://github.com/LineageOS/android_kernel_samsung_universal7580
|
||||
From ac118d424b82200b42290ca855f97804dcf8e897 Mon Sep 17 00:00:00 2001
|
||||
From: Apavayan Sinha <info@apavayan.com>
|
||||
Date: Tue, 21 Feb 2017 07:47:04 +0530
|
||||
Subject: [PATCH] fs: Fix the compile w/o ROOT Restriction enabled
|
||||
|
||||
Change-Id: I2cb687617eb1228ad7f62da25449afeb11cdf701
|
||||
---
|
||||
fs/exec.c | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/fs/exec.c b/fs/exec.c
|
||||
index cb5f418b67b..c4bb850a17a 100644
|
||||
--- a/fs/exec.c
|
||||
+++ b/fs/exec.c
|
||||
@@ -1876,7 +1876,6 @@ SYSCALL_DEFINE3(execve,
|
||||
return -EACCES;
|
||||
}
|
||||
}
|
||||
-#endif // End of CONFIG_SEC_RESTRICT_FORK
|
||||
#ifdef CONFIG_RKP_KDP
|
||||
if(CHECK_ROOT_UID(current) && rkp_cred_enable) {
|
||||
if(rkp_restrict_fork()){
|
||||
@@ -1888,6 +1887,7 @@ SYSCALL_DEFINE3(execve,
|
||||
}
|
||||
}
|
||||
#endif
|
||||
+#endif // End of CONFIG_SEC_RESTRICT_FORK
|
||||
error = do_execve(path->name, argv, envp);
|
||||
putname(path);
|
||||
}
|
||||
--
|
||||
2.32.0
|
||||
|
|
@ -0,0 +1,38 @@
|
|||
From 07b641581bc9678835f912c504017f86a23a8e95 Mon Sep 17 00:00:00 2001
|
||||
From: Apavayan Sinha <info@apavayan.com>
|
||||
Date: Sun, 24 Jul 2016 15:02:04 +0530
|
||||
Subject: [PATCH] security: Fix tima compile
|
||||
|
||||
Signed-off-by: Apavayan Sinha <info@apavayan.com>
|
||||
---
|
||||
security/Makefile | 2 +-
|
||||
security/tima_uevent/Makefile | 2 +-
|
||||
2 files changed, 2 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/security/Makefile b/security/Makefile
|
||||
index 5123df02374..965390f17cc 100644
|
||||
--- a/security/Makefile
|
||||
+++ b/security/Makefile
|
||||
@@ -33,7 +33,7 @@ obj-$(CONFIG_INTEGRITY) += integrity/built-in.o
|
||||
obj-$(CONFIG_MST_LDO) += mstdrv/
|
||||
|
||||
# TIMA uevent
|
||||
-obj-$(CONFIG_TIMA) += tima_uevent/tima_uevent.o
|
||||
+obj-$(CONFIG_TIMA) += tima_uevent/
|
||||
#ICCC
|
||||
obj-$(CONFIG_TZ_ICCC) += tz_iccc/
|
||||
|
||||
diff --git a/security/tima_uevent/Makefile b/security/tima_uevent/Makefile
|
||||
index 4f1ca82645b..1621efaf56d 100644
|
||||
--- a/security/tima_uevent/Makefile
|
||||
+++ b/security/tima_uevent/Makefile
|
||||
@@ -2,5 +2,5 @@
|
||||
# Makefile for TIMA kernel uevent drivers.
|
||||
#
|
||||
|
||||
-#obj-$(CONFIG_TIMA) += tima_uevent.o
|
||||
+obj-$(CONFIG_TIMA) += tima_uevent.o
|
||||
|
||||
--
|
||||
2.32.0
|
||||
|
|
@ -0,0 +1,13 @@
|
|||
Create a symlink to platform.h. Fixes errors regarding about a missing
|
||||
platform.h file.
|
||||
diff --git a/drivers/gud/gud-exynos7580/MobiCoreDriver/platform.h b/drivers/gud/gud-exynos7580/MobiCoreDriver/platform.h
|
||||
new file mode 120000
|
||||
index 00000000..526bc961
|
||||
--- /dev/null
|
||||
+++ b/drivers/gud/gud-exynos7580/MobiCoreDriver/platform.h
|
||||
@@ -0,0 +1 @@
|
||||
+platforms/EXYNOS_7580_STD/platform.h
|
||||
\ No newline at end of file
|
||||
--
|
||||
2.32.0
|
||||
|
16
device/testing/linux-samsung-a5xelte/0004-build-dtb.patch
Normal file
16
device/testing/linux-samsung-a5xelte/0004-build-dtb.patch
Normal file
|
@ -0,0 +1,16 @@
|
|||
diff --git a/arch/arm64/boot/dts/Makefile b/arch/arm64/boot/dts/Makefile
|
||||
index e684367f..86cd49c6 100755
|
||||
--- a/arch/arm64/boot/dts/Makefile
|
||||
+++ b/arch/arm64/boot/dts/Makefile
|
||||
@@ -5,7 +5,7 @@ dtb-$(CONFIG_ARCH_XGENE) += apm-mustang.dtb
|
||||
dtb-$(CONFIG_MACH_ESPRESSO7420) += exynos7420-espresso7420.dtb
|
||||
dtb-$(CONFIG_MACH_UNIVERSAL7420) += exynos7420-universal7420.dtb exynos7420-universal7420-ufs.dtb exynos7420-universal7420-ufs_rev00.dtb
|
||||
dtb-$(CONFIG_MACH_SMDK7580) += exynos7580-smdk7580.dtb
|
||||
-dtb-$(CONFIG_MACH_UNIVERSAL7580) += exynos7580-universal7580.dtb exynos7580-universal7580_rev01.dtb exynos7580-universal7580_q.dtb
|
||||
+dtb-$(CONFIG_MACH_UNIVERSAL7580) += exynos7580-universal7580.dtb exynos7580-universal7580_rev01.dtb exynos7580-universal7580_q.dtb exynos7580-a5xelte_eur_open_00.dtb exynos7580-a5xelte_eur_open_01.dtb
|
||||
|
||||
dtb-$(CONFIG_MACH_UNIVERSAL5433) += exynos5433-universal5433_rev02.dtb exynos5433-universal5433.dtb
|
||||
targets += dtbs
|
||||
--
|
||||
2.32.0
|
||||
|
|
@ -0,0 +1,13 @@
|
|||
diff --git a/init/_vmm.S b/init/_vmm.S
|
||||
index b2ef92fa..1a1d898f 100755
|
||||
--- a/init/_vmm.S
|
||||
+++ b/init/_vmm.S
|
||||
@@ -19,7 +19,7 @@
|
||||
|
||||
#include <linux/vmm.h>
|
||||
|
||||
-#define vmm_ELF_PATH "init/vmm.elf"
|
||||
+#define vmm_ELF_PATH "../init/vmm.elf"
|
||||
|
||||
#define SMC_64BIT_RET_MAGIC 0xC2000401
|
||||
|
81
device/testing/linux-samsung-a5xelte/APKBUILD
Normal file
81
device/testing/linux-samsung-a5xelte/APKBUILD
Normal file
|
@ -0,0 +1,81 @@
|
|||
# Reference: <https://postmarketos.org/vendorkernel>
|
||||
# Kernel config based on: arch/arm64/configs/cosmic_defconfig
|
||||
|
||||
pkgname=linux-samsung-a5xelte
|
||||
pkgver=3.10.107
|
||||
pkgrel=0
|
||||
pkgdesc="Samsung Galaxy A5 (2016) kernel fork"
|
||||
arch="aarch64"
|
||||
_carch="arm64"
|
||||
_flavor="samsung-a5xelte"
|
||||
url="https://kernel.org"
|
||||
license="GPL-2.0-only"
|
||||
options="!strip !check !tracedeps pmb:cross-native"
|
||||
makedepends="
|
||||
bash
|
||||
bc
|
||||
bison
|
||||
devicepkg-dev
|
||||
dtbtool-exynos
|
||||
flex
|
||||
linux-headers
|
||||
openssl-dev
|
||||
perl
|
||||
"
|
||||
|
||||
# Source
|
||||
_repository="android_kernel_samsung_a5xelte"
|
||||
_commit="738375813823cb33918102af385bdd5d82225e17"
|
||||
_config="config-$_flavor.$arch"
|
||||
source="
|
||||
$pkgname-$_commit.tar.gz::https://github.com/Cosmic-Kernel/$_repository/archive/$_commit.tar.gz
|
||||
$_config
|
||||
gcc8-fix-put-user.patch
|
||||
gcc10-extern_YYLOC_global_declaration.patch
|
||||
02-fix-vmm-blob-include.patch
|
||||
0003-create-a-file-platform.h-which-is-a-symlink.patch
|
||||
0004-build-dtb.patch
|
||||
0001-security-Fix-tima-compile.patch
|
||||
0001-drivers-muic-fix-the-compile.patch
|
||||
0001-fs-Fix-the-compile-w-o-ROOT-Restriction-enabled.patch
|
||||
samsung-usb-ethaddr.patch
|
||||
fix-argb.patch
|
||||
"
|
||||
builddir="$srcdir/$_repository-$_commit"
|
||||
_outdir="out"
|
||||
|
||||
prepare() {
|
||||
default_prepare
|
||||
. downstreamkernel_prepare
|
||||
}
|
||||
|
||||
build() {
|
||||
unset LDFLAGS
|
||||
make O="$_outdir" ARCH="$_carch" CC="${CC:-gcc}" \
|
||||
KBUILD_BUILD_VERSION="$((pkgrel + 1 ))-postmarketOS"
|
||||
|
||||
# Master DTB (deviceinfo_bootimg_qcdt)
|
||||
dtbTool-exynos -o "$_outdir/arch/$_carch/boot"/dt.img \
|
||||
$(find "$_outdir/arch/$_carch/boot/dts/" -name *a5xelte*.dtb)
|
||||
}
|
||||
|
||||
package() {
|
||||
downstreamkernel_package "$builddir" "$pkgdir" "$_carch" "$_flavor" "$_outdir"
|
||||
install -Dm644 "$_outdir/arch/$_carch/boot"/dt.img \
|
||||
"$pkgdir"/boot/dt.img
|
||||
}
|
||||
|
||||
sha512sums="
|
||||
62b6012ca49a88d3eb73a3440cba434a54b17ead6c23e7b55f83196fe25bbc351afaf0c8179ca1f8daf01ef7b70d81f9414c0407d08a81bd65722ca04a86b490 linux-samsung-a5xelte-738375813823cb33918102af385bdd5d82225e17.tar.gz
|
||||
d143361b725de6f2755b88e66f2e42f6e11215785a3017142f82294445f823ad9ceb89dc1951b59b0cfd3c87e23da7621f227cb8550baf34d1987b2686cc8f58 config-samsung-a5xelte.aarch64
|
||||
197d40a214ada87fcb2dfc0ae4911704b9a93354b75179cd6b4aadbb627a37ec262cf516921c84a8b1806809b70a7b440cdc8310a4a55fca5d2c0baa988e3967 gcc8-fix-put-user.patch
|
||||
2b48f1bf0e3f70703d2cdafc47d5e615cc7c56c70bec56b2e3297d3fa4a7a1321d649a8679614553dde8fe52ff1051dae38d5990e3744c9ca986d92187dcdbeb gcc10-extern_YYLOC_global_declaration.patch
|
||||
23bf8ef0ad38b38ffa9ddfdee76a32c43b021169c6db6f5b733fd6434169f7c7bb27cdb1232be89475f34f9053211d943e13f5fba565c928256b92b18d636130 02-fix-vmm-blob-include.patch
|
||||
b2b8020948dfa4dc24eec4402aa7c2845ba56e844b2cfb591b4326b372a7748063c9e67d54bf70d841141c7a9203c25766538522d1a6a08e3ca3b8054eface43 0003-create-a-file-platform.h-which-is-a-symlink.patch
|
||||
1e7b01a1620e9a5bf6fafc892a0e8bbc0eab12303c8f8787a4a993bb1e2db2b21102092f3573def4e37e5c64264667f9d5b92445e0a3b1d520bc7720d37343da 0004-build-dtb.patch
|
||||
8f39d0b668cfefb2f1da801a16efe30ee8962c48931b51fac2cac86d1504584af951083b045a20df10bb1d4a8f66d2dc0c4cc39b27f521746c9d64924ae8b88d 0001-security-Fix-tima-compile.patch
|
||||
f6dcf35fdfc0de4f3c30caf3512ad442644c218f2e0a0c3ce0487f83872ed0d49e79cefbd1423690c7134973797113a148620f24a6253dcdf27c06dd753a2b20 0001-drivers-muic-fix-the-compile.patch
|
||||
d58c5f8772435c70713013f63e36913dafb532a16ab68c440f0b2042073ba18d97b67ccaeb00d94b00afc41f132f8b4fdd669f65a6a1068395508751fe0e39ae 0001-fs-Fix-the-compile-w-o-ROOT-Restriction-enabled.patch
|
||||
bfd0332076724bea2d10e96c81fae41eefb60bfc19f7a21ec849cf2a6b48e4cada694ed6b389ed600e182755d6fdb96f12dcbe81c8e691a2b4602f432fae165a samsung-usb-ethaddr.patch
|
||||
aff2f127c44de0fc3e523834766a5851b48ade0e5cd95f594b36fc17adf3fb0549c70e4cba34a4bbea272fca80d61e0f4615a7195662f38794a1cd96213c7ca2 fix-argb.patch
|
||||
"
|
4009
device/testing/linux-samsung-a5xelte/config-samsung-a5xelte.aarch64
Normal file
4009
device/testing/linux-samsung-a5xelte/config-samsung-a5xelte.aarch64
Normal file
File diff suppressed because it is too large
Load diff
19
device/testing/linux-samsung-a5xelte/fix-argb.patch
Normal file
19
device/testing/linux-samsung-a5xelte/fix-argb.patch
Normal file
|
@ -0,0 +1,19 @@
|
|||
Based on Error1001's patch, 02-fix-video-argb-setting.patch
|
||||
diff --git a/drivers/video/exynos/decon_7580/decon-int_drv.c b/drivers/video/exynos/decon_7580/decon-int_drv.c
|
||||
index c37ec143..27375b6f 100755
|
||||
--- a/drivers/video/exynos/decon_7580/decon-int_drv.c
|
||||
+++ b/drivers/video/exynos/decon_7580/decon-int_drv.c
|
||||
@@ -453,11 +453,11 @@ int decon_check_var(struct fb_var_screeninfo *var, struct fb_info *info)
|
||||
case 24:
|
||||
/* our 24bpp is unpacked, so 32bpp */
|
||||
var->bits_per_pixel = 32;
|
||||
- var->red.offset = 16;
|
||||
+ var->red.offset = 0;
|
||||
var->red.length = 8;
|
||||
var->green.offset = 8;
|
||||
var->green.length = 8;
|
||||
- var->blue.offset = 0;
|
||||
+ var->blue.offset = 16;
|
||||
var->blue.length = 8;
|
||||
break;
|
||||
|
|
@ -0,0 +1 @@
|
|||
../../.shared-patches/linux/gcc10-extern_YYLOC_global_declaration.patch
|
1
device/testing/linux-samsung-a5xelte/gcc8-fix-put-user.patch
Symbolic link
1
device/testing/linux-samsung-a5xelte/gcc8-fix-put-user.patch
Symbolic link
|
@ -0,0 +1 @@
|
|||
../../.shared-patches/linux/gcc8-fix-put-user.patch
|
|
@ -0,0 +1,18 @@
|
|||
Based on ../../.shared-patches/linux/samsung-usb-ethaddr.patch
|
||||
|
||||
diff --git a/drivers/usb/gadget/u_ether.c b/drivers/usb/gadget/u_ether.c
|
||||
index 80294f32..d7268e50 100755
|
||||
--- a/drivers/usb/gadget/u_ether.c
|
||||
+++ b/drivers/usb/gadget/u_ether.c
|
||||
@@ -1193,7 +1193,7 @@ struct eth_dev *gether_setup_name(struct usb_gadget *g, u8 ethaddr[ETH_ALEN],
|
||||
if (get_ether_addr(dev_addr, net->dev_addr))
|
||||
dev_warn(&g->dev,
|
||||
"using random %s ethernet address\n", "self");
|
||||
-#ifdef CONFIG_USB_ANDROID_SAMSUNG_COMPOSITE
|
||||
+#if 0
|
||||
memcpy(dev->host_mac, ethaddr, ETH_ALEN);
|
||||
printk(KERN_DEBUG "usb: set unique host mac\n");
|
||||
#else
|
||||
--
|
||||
2.32.0
|
||||
|
Loading…
Reference in a new issue