main/dbus-test-runner: disable Werror (!671)
This commit is contained in:
parent
b064d4e634
commit
bc62c5affd
2 changed files with 89 additions and 3 deletions
|
@ -3,14 +3,15 @@
|
||||||
pkgname=dbus-test-runner
|
pkgname=dbus-test-runner
|
||||||
pkgver=15.04.0_git20180109
|
pkgver=15.04.0_git20180109
|
||||||
_commit="86d63d119566974bd841cacd3202599b3b1a845d"
|
_commit="86d63d119566974bd841cacd3202599b3b1a845d"
|
||||||
pkgrel=0
|
pkgrel=1
|
||||||
pkgdesc="A small little utility to run a couple of executables under a new DBus session for testing"
|
pkgdesc="A small little utility to run a couple of executables under a new DBus session for testing"
|
||||||
url="https://launchpad.net/dbus-test-runner"
|
url="https://launchpad.net/dbus-test-runner"
|
||||||
arch="x86_64"
|
arch="x86_64"
|
||||||
license=GPL-3.0
|
license=GPL-3.0
|
||||||
depends="dbus"
|
depends="dbus"
|
||||||
makedepends="gnome-common automake autoconf intltool libtool dbus-glib-dev"
|
makedepends="gnome-common automake autoconf intltool libtool dbus-glib-dev"
|
||||||
source="$pkgname-$_commit.tar.gz::https://github.com/ubports/dbus-test-runner/archive/$_commit.tar.gz"
|
source="$pkgname-$_commit.tar.gz::https://github.com/ubports/dbus-test-runner/archive/$_commit.tar.gz
|
||||||
|
werror.patch"
|
||||||
options="!check"
|
options="!check"
|
||||||
builddir="$srcdir/$pkgname-$_commit"
|
builddir="$srcdir/$pkgname-$_commit"
|
||||||
|
|
||||||
|
@ -28,4 +29,5 @@ package() {
|
||||||
cd "$builddir"
|
cd "$builddir"
|
||||||
make DESTDIR="$pkgdir/" install
|
make DESTDIR="$pkgdir/" install
|
||||||
}
|
}
|
||||||
sha512sums="89189a6df11a69e7ace97805fe6238515838731fabf00972f0e607612fbd057c5178b5899a93420b89943f39962d2cf8c87d36d439fb06d1c4cd70518cb623ae dbus-test-runner-86d63d119566974bd841cacd3202599b3b1a845d.tar.gz"
|
sha512sums="89189a6df11a69e7ace97805fe6238515838731fabf00972f0e607612fbd057c5178b5899a93420b89943f39962d2cf8c87d36d439fb06d1c4cd70518cb623ae dbus-test-runner-86d63d119566974bd841cacd3202599b3b1a845d.tar.gz
|
||||||
|
89c0ae015b8b691a3874b84faafff17c1a9c371afe9d076aac73ef50eaf91d9f02b87916537deb18f37bf25d1be752a0aca288ad6e0ebb997577b708b4c4c716 werror.patch"
|
||||||
|
|
84
main/dbus-test-runner/werror.patch
Normal file
84
main/dbus-test-runner/werror.patch
Normal file
|
@ -0,0 +1,84 @@
|
||||||
|
diff --git a/libdbustest/Makefile.am b/libdbustest/Makefile.am
|
||||||
|
index d76ff52..d048a83 100644
|
||||||
|
--- a/libdbustest/Makefile.am
|
||||||
|
+++ b/libdbustest/Makefile.am
|
||||||
|
@@ -40,7 +40,7 @@ libdbustest_la_CFLAGS = \
|
||||||
|
-DBUSTLE_DUAL_MONITOR="\"$(pkgdatadir)/dbus-test-bustle-handler\"" \
|
||||||
|
-DWATCHDOG="\"$(pkglibexecdir)/dbus-test-watchdog\"" \
|
||||||
|
-DG_LOG_DOMAIN=\"libdbustest\" \
|
||||||
|
- -Wall -Werror -Wextra
|
||||||
|
+ -Wall -Wextra
|
||||||
|
|
||||||
|
libdbustest_la_LIBADD = \
|
||||||
|
libdbustest-generated.la \
|
||||||
|
@@ -59,7 +59,7 @@ libdbustest_generated_la_CFLAGS = \
|
||||||
|
$(DBUS_TEST_RUNNER_CFLAGS) \
|
||||||
|
-I$(builddir) \
|
||||||
|
-DG_LOG_DOMAIN=\"libdbustest\" \
|
||||||
|
- -Wall -Werror
|
||||||
|
+ -Wall
|
||||||
|
|
||||||
|
libdbustest_generated_la_SOURCES = \
|
||||||
|
dbus-mock-iface.h \
|
||||||
|
diff --git a/src/Makefile.am b/src/Makefile.am
|
||||||
|
index 24a3f1f..7c44544 100644
|
||||||
|
--- a/src/Makefile.am
|
||||||
|
+++ b/src/Makefile.am
|
||||||
|
@@ -6,7 +6,7 @@ dbus_test_runner_CFLAGS = $(DBUS_TEST_RUNNER_CFLAGS) \
|
||||||
|
$(COVERAGE_CFLAGS) \
|
||||||
|
-I$(top_srcdir) \
|
||||||
|
-DDEFAULT_SESSION_CONF="\"$(datadir)/dbus-test-runner/session.conf\"" \
|
||||||
|
- -Wall -Werror -Wextra
|
||||||
|
+ -Wall -Wextra
|
||||||
|
dbus_test_runner_LDADD = $(DBUS_TEST_RUNNER_LIBS) \
|
||||||
|
$(top_builddir)/libdbustest/libdbustest.la
|
||||||
|
dbus_test_runner_LDFLAGS = $(COVERAGE_LDFLAGS)
|
||||||
|
diff --git a/tests/Makefile.am b/tests/Makefile.am
|
||||||
|
index 7eccc63..4f4aad9 100644
|
||||||
|
--- a/tests/Makefile.am
|
||||||
|
+++ b/tests/Makefile.am
|
||||||
|
@@ -245,7 +245,7 @@ test_own_name_SOURCES = \
|
||||||
|
test-own-name.c
|
||||||
|
test_own_name_CFLAGS = \
|
||||||
|
$(DBUS_TEST_RUNNER_CFLAGS) \
|
||||||
|
- -Wall -Werror
|
||||||
|
+ -Wall
|
||||||
|
test_own_name_LDADD = \
|
||||||
|
$(DBUS_TEST_RUNNER_LIBS)
|
||||||
|
|
||||||
|
@@ -253,7 +253,7 @@ test_check_name_SOURCES = \
|
||||||
|
test-check-name.c
|
||||||
|
test_check_name_CFLAGS = \
|
||||||
|
$(DBUS_TEST_RUNNER_CFLAGS) \
|
||||||
|
- -Wall -Werror
|
||||||
|
+ -Wall
|
||||||
|
test_check_name_LDADD = \
|
||||||
|
$(DBUS_TEST_RUNNER_LIBS)
|
||||||
|
|
||||||
|
@@ -351,7 +351,7 @@ test_libdbustest_CFLAGS = \
|
||||||
|
-I$(top_srcdir) \
|
||||||
|
-DSESSION_CONF="\"$(top_srcdir)/data/session.conf\"" \
|
||||||
|
-DGETNAME_PATH="\"$(abs_builddir)/test-libdbustest-getname\"" \
|
||||||
|
- -Wall -Werror
|
||||||
|
+ -Wall
|
||||||
|
test_libdbustest_LDADD = \
|
||||||
|
$(DBUS_TEST_RUNNER_LIBS) \
|
||||||
|
$(top_builddir)/libdbustest/libdbustest.la
|
||||||
|
@@ -360,7 +360,7 @@ test_libdbustest_getname_SOURCES = \
|
||||||
|
test-libdbustest-getname.c
|
||||||
|
test_libdbustest_getname_CFLAGS = \
|
||||||
|
$(DBUS_TEST_RUNNER_CFLAGS) \
|
||||||
|
- -Wall -Werror
|
||||||
|
+ -Wall
|
||||||
|
test_libdbustest_getname_LDADD = \
|
||||||
|
$(DBUS_TEST_RUNNER_LIBS)
|
||||||
|
|
||||||
|
@@ -389,7 +389,7 @@ test_libdbustest_mock_CFLAGS = \
|
||||||
|
-I$(top_srcdir) \
|
||||||
|
-DSESSION_CONF="\"$(top_srcdir)/data/session.conf\"" \
|
||||||
|
-DGETNAME_PATH="\"$(abs_builddir)/test-libdbustest-getname\"" \
|
||||||
|
- -Wall -Werror
|
||||||
|
+ -Wall
|
||||||
|
test_libdbustest_mock_LDADD = \
|
||||||
|
$(DBUS_TEST_RUNNER_LIBS) \
|
||||||
|
$(top_builddir)/libdbustest/libdbustest.la
|
Loading…
Add table
Reference in a new issue