main/telepathy-mission-control: upgrade to 5.16.5 pre-release (!698)
This removes the Python 2 requirement [ci:skip-build]: already built successfully in CI
This commit is contained in:
parent
68fdd20012
commit
b48a1dd527
3 changed files with 189 additions and 30 deletions
|
@ -1,23 +0,0 @@
|
||||||
From 31268fec582776593e54c10c862d9f7af7b3153c Mon Sep 17 00:00:00 2001
|
|
||||||
From: Martin Klapetek <martin.klapetek@gmail.com>
|
|
||||||
Date: Wed, 8 Jul 2015 20:04:57 +0000
|
|
||||||
Subject: [PATCH] Fix autoconnection of accounts with always_dispatch=true
|
|
||||||
|
|
||||||
https://bugs.freedesktop.org/show_bug.cgi?id=91272
|
|
||||||
---
|
|
||||||
src/mcd-account-connection.c | 2 +-
|
|
||||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
||||||
|
|
||||||
diff --git a/src/mcd-account-connection.c b/src/mcd-account-connection.c
|
|
||||||
index 09b3a219..327514de 100644
|
|
||||||
--- a/src/mcd-account-connection.c
|
|
||||||
+++ b/src/mcd-account-connection.c
|
|
||||||
@@ -101,7 +101,7 @@ mcd_account_connection_proceed_with_reason (McdAccount *account,
|
|
||||||
if (success)
|
|
||||||
{
|
|
||||||
if (mcd_connectivity_monitor_is_online (
|
|
||||||
- mcd_account_get_connectivity_monitor (account)))
|
|
||||||
+ mcd_account_get_connectivity_monitor (account)) || _mcd_account_needs_dispatch (account))
|
|
||||||
{
|
|
||||||
DEBUG ("%s wants to connect and we're online - go for it",
|
|
||||||
mcd_account_get_unique_name (account));
|
|
|
@ -1,18 +1,25 @@
|
||||||
# Contributor: Bhushan Shah <bshah@kde.org>
|
# Contributor: Bhushan Shah <bshah@kde.org>
|
||||||
# Maintainer: Bhushan Shah <bshah@kde.org>
|
# Maintainer: Bhushan Shah <bshah@kde.org>
|
||||||
pkgname=telepathy-mission-control
|
pkgname=telepathy-mission-control
|
||||||
pkgver=5.16.4
|
pkgver=5.16.4_git20190707
|
||||||
pkgrel=2
|
pkgrel=0
|
||||||
|
_commit="5de9c50b0353f10b2fd7b1a6980c37bd7cb1b4dc"
|
||||||
arch="all"
|
arch="all"
|
||||||
url="http://telepathy.freedesktop.org/wiki/"
|
url="http://telepathy.freedesktop.org/wiki/"
|
||||||
license="LGPL-2.0-or-later"
|
license="LGPL-2.0-or-later"
|
||||||
pkgdesc="Account Manager and Channel Dispatcher based on telepathy-glib"
|
pkgdesc="Account Manager and Channel Dispatcher based on telepathy-glib"
|
||||||
depends_dev="telepathy-glib-dev gstreamer-dev python2"
|
depends_dev="telepathy-glib-dev gstreamer-dev python2"
|
||||||
makedepends="$depends_dev libxslt-dev dbus"
|
makedepends="$depends_dev libxslt-dev dbus gtk-doc autoconf automake libtool"
|
||||||
source="https://telepathy.freedesktop.org/releases/$pkgname/$pkgname-$pkgver.tar.gz
|
source="$pkgname-$_commit.tar.gz::https://github.com/TelepathyIM/telepathy-mission-control/archive/$_commit.tar.gz"
|
||||||
31268fec582776593e54c10c862d9f7af7b3153c.patch"
|
|
||||||
subpackages="$pkgname-dev $pkgname-doc"
|
subpackages="$pkgname-dev $pkgname-doc"
|
||||||
options="!check" # Requires a running dbus daemon
|
options="!check" # Requires a running dbus daemon
|
||||||
|
builddir="$srcdir/$pkgname-$_commit"
|
||||||
|
|
||||||
|
prepare() {
|
||||||
|
default_prepare
|
||||||
|
|
||||||
|
NOCONFIGURE=1 ./autogen.sh
|
||||||
|
}
|
||||||
|
|
||||||
build() {
|
build() {
|
||||||
PYTHON=/usr/bin/python2 ./configure --prefix=/usr \
|
PYTHON=/usr/bin/python2 ./configure --prefix=/usr \
|
||||||
|
@ -25,5 +32,4 @@ package() {
|
||||||
DESTDIR="$pkgdir" make install
|
DESTDIR="$pkgdir" make install
|
||||||
}
|
}
|
||||||
|
|
||||||
sha512sums="5ed624df2d041554af074c22a18db2405fa5bd41bec40edc574382eb9d8b9f93ff6f4be3042d27f950694a353f4192670e200f5f8865419701ca520a973959ed telepathy-mission-control-5.16.4.tar.gz
|
sha512sums="b07492cf5a70004a5bf1c2bdc0f01018ff4b73f29222f99faf4468d312ced46eb37c462503aebc9579514a391dc407e01bcbebf04e81cd495e6c11fde134a110 telepathy-mission-control-5de9c50b0353f10b2fd7b1a6980c37bd7cb1b4dc.tar.gz"
|
||||||
e6e35f6c5adbf67536fdc83e49f3ab7dbce1725df7363f5c4c5a9a7c5f8cccbf5c9cfd1197627f9a5ace00c06df860646e10ad275a3b448cf936af01650033f6 31268fec582776593e54c10c862d9f7af7b3153c.patch"
|
|
||||||
|
|
176
main/telepathy-mission-control/python3.patch
Normal file
176
main/telepathy-mission-control/python3.patch
Normal file
|
@ -0,0 +1,176 @@
|
||||||
|
diff --git a/configure.ac b/configure.ac
|
||||||
|
index cf9d290f..1bcf8521 100644
|
||||||
|
--- a/configure.ac
|
||||||
|
+++ b/configure.ac
|
||||||
|
@@ -1,7 +1,7 @@
|
||||||
|
dnl Set the version number to e.g. 5.x.y immediately before a release.
|
||||||
|
dnl Set the version number to e.g. 5.x.y+ immediately after (this will
|
||||||
|
dnl enable -Werror).
|
||||||
|
-AC_INIT([telepathy-mission-control], [5.16.4+])
|
||||||
|
+AC_INIT([telepathy-mission-control], [5.16.4])
|
||||||
|
|
||||||
|
AC_CONFIG_MACRO_DIR([m4])
|
||||||
|
AC_CONFIG_AUX_DIR([build-aux])
|
||||||
|
diff --git a/tools/glib-blocking-client-gen.py b/tools/glib-blocking-client-gen.py
|
||||||
|
index c20dcd4a..96eef06e 100644
|
||||||
|
--- a/tools/glib-blocking-client-gen.py
|
||||||
|
+++ b/tools/glib-blocking-client-gen.py
|
||||||
|
@@ -1,4 +1,4 @@
|
||||||
|
-#!/usr/bin/python
|
||||||
|
+#!/usr/bin/python3
|
||||||
|
|
||||||
|
# glib-client-gen.py: "I Can't Believe It's Not dbus-binding-tool"
|
||||||
|
#
|
||||||
|
diff --git a/tools/glib-client-gen.py b/tools/glib-client-gen.py
|
||||||
|
index f8465a62..653e5cab 100644
|
||||||
|
--- a/tools/glib-client-gen.py
|
||||||
|
+++ b/tools/glib-client-gen.py
|
||||||
|
@@ -1,4 +1,4 @@
|
||||||
|
-#!/usr/bin/python
|
||||||
|
+#!/usr/bin/python3
|
||||||
|
|
||||||
|
# glib-client-gen.py: "I Can't Believe It's Not dbus-binding-tool"
|
||||||
|
#
|
||||||
|
diff --git a/tools/glib-client-marshaller-gen.py b/tools/glib-client-marshaller-gen.py
|
||||||
|
index cb27d638..98dd04c0 100644
|
||||||
|
--- a/tools/glib-client-marshaller-gen.py
|
||||||
|
+++ b/tools/glib-client-marshaller-gen.py
|
||||||
|
@@ -1,4 +1,4 @@
|
||||||
|
-#!/usr/bin/python
|
||||||
|
+#!/usr/bin/python3
|
||||||
|
|
||||||
|
import sys
|
||||||
|
import xml.dom.minidom
|
||||||
|
@@ -31,23 +31,23 @@ class Generator(object):
|
||||||
|
for signal in signals:
|
||||||
|
self.do_signal(signal)
|
||||||
|
|
||||||
|
- print 'void'
|
||||||
|
- print '%s_register_dbus_glib_marshallers (void)' % self.prefix
|
||||||
|
- print '{'
|
||||||
|
+ print('void')
|
||||||
|
+ print('%s_register_dbus_glib_marshallers (void)', self.prefix)
|
||||||
|
+ print('{')
|
||||||
|
|
||||||
|
all = self.marshallers.keys()
|
||||||
|
all.sort()
|
||||||
|
for marshaller in all:
|
||||||
|
rhs = self.marshallers[marshaller]
|
||||||
|
|
||||||
|
- print ' dbus_g_object_register_marshaller ('
|
||||||
|
- print ' g_cclosure_marshal_generic,'
|
||||||
|
- print ' G_TYPE_NONE, /* return */'
|
||||||
|
+ print(' dbus_g_object_register_marshaller (')
|
||||||
|
+ print(' g_cclosure_marshal_generic,')
|
||||||
|
+ print(' G_TYPE_NONE, /* return */')
|
||||||
|
for type in rhs:
|
||||||
|
- print ' G_TYPE_%s,' % type.replace('VOID', 'NONE')
|
||||||
|
- print ' G_TYPE_INVALID);'
|
||||||
|
+ print(' G_TYPE_%s,', type.replace('VOID', 'NONE'))
|
||||||
|
+ print(' G_TYPE_INVALID);')
|
||||||
|
|
||||||
|
- print '}'
|
||||||
|
+ print('}')
|
||||||
|
|
||||||
|
|
||||||
|
def types_to_gtypes(types):
|
||||||
|
diff --git a/tools/glib-ginterface-gen.py b/tools/glib-ginterface-gen.py
|
||||||
|
index 6fec0d3c..dd612b1b 100644
|
||||||
|
--- a/tools/glib-ginterface-gen.py
|
||||||
|
+++ b/tools/glib-ginterface-gen.py
|
||||||
|
@@ -1,4 +1,4 @@
|
||||||
|
-#!/usr/bin/python
|
||||||
|
+#!/usr/bin/python3
|
||||||
|
|
||||||
|
# glib-ginterface-gen.py: service-side interface generator
|
||||||
|
#
|
||||||
|
@@ -766,7 +766,7 @@ class Generator(object):
|
||||||
|
file_set_contents(self.basename + '-gtk-doc.h', '\n'.join(self.__docs))
|
||||||
|
|
||||||
|
def cmdline_error():
|
||||||
|
- print """\
|
||||||
|
+ print """
|
||||||
|
usage:
|
||||||
|
gen-ginterface [OPTIONS] xmlfile Prefix_
|
||||||
|
options:
|
||||||
|
diff --git a/tools/glib-gtypes-generator.py b/tools/glib-gtypes-generator.py
|
||||||
|
index 21dfc6aa..9fada94e 100644
|
||||||
|
--- a/tools/glib-gtypes-generator.py
|
||||||
|
+++ b/tools/glib-gtypes-generator.py
|
||||||
|
@@ -1,4 +1,4 @@
|
||||||
|
-#!/usr/bin/python
|
||||||
|
+#!/usr/bin/python3
|
||||||
|
|
||||||
|
# Generate GLib GInterfaces from the Telepathy specification.
|
||||||
|
# The master copy of this program is in the telepathy-glib repository -
|
||||||
|
diff --git a/tools/glib-signals-marshal-gen.py b/tools/glib-signals-marshal-gen.py
|
||||||
|
index 0d02c134..7c90a6de 100644
|
||||||
|
--- a/tools/glib-signals-marshal-gen.py
|
||||||
|
+++ b/tools/glib-signals-marshal-gen.py
|
||||||
|
@@ -1,4 +1,4 @@
|
||||||
|
-#!/usr/bin/python
|
||||||
|
+#!/usr/bin/python3
|
||||||
|
|
||||||
|
import sys
|
||||||
|
import xml.dom.minidom
|
||||||
|
diff --git a/tools/gquark-gen.py b/tools/gquark-gen.py
|
||||||
|
index 37d19e07..707915fb 100644
|
||||||
|
--- a/tools/gquark-gen.py
|
||||||
|
+++ b/tools/gquark-gen.py
|
||||||
|
@@ -1,4 +1,4 @@
|
||||||
|
-#!/usr/bin/python
|
||||||
|
+#!/usr/bin/python3
|
||||||
|
|
||||||
|
# glib-client-gen.py: "I Can't Believe It's Not dbus-binding-tool"
|
||||||
|
#
|
||||||
|
diff --git a/tools/libglibcodegen.py b/tools/libglibcodegen.py
|
||||||
|
index 6a9d2148..4ac459e5 100644
|
||||||
|
--- a/tools/libglibcodegen.py
|
||||||
|
+++ b/tools/libglibcodegen.py
|
||||||
|
@@ -154,7 +154,7 @@ def type_to_gtype(s):
|
||||||
|
return ("GHashTable *", "DBUS_TYPE_G_STRING_STRING_HASHTABLE", "BOXED", False)
|
||||||
|
elif s[:2] == 'a{': #some arbitrary hash tables
|
||||||
|
if s[2] not in ('y', 'b', 'n', 'q', 'i', 'u', 's', 'o', 'g'):
|
||||||
|
- raise Exception, "can't index a hashtable off non-basic type " + s
|
||||||
|
+ raise Exception("can't index a hashtable off non-basic type " + s)
|
||||||
|
first = type_to_gtype(s[2])
|
||||||
|
second = type_to_gtype(s[3:-1])
|
||||||
|
return ("GHashTable *", "(dbus_g_type_get_map (\"GHashTable\", " + first[1] + ", " + second[1] + "))", "BOXED", False)
|
||||||
|
diff --git a/tools/make-release-mail.py b/tools/make-release-mail.py
|
||||||
|
index 2bd7c2bc..7dacbaca 100644
|
||||||
|
--- a/tools/make-release-mail.py
|
||||||
|
+++ b/tools/make-release-mail.py
|
||||||
|
@@ -1,4 +1,4 @@
|
||||||
|
-#!/usr/bin/env python
|
||||||
|
+#!/usr/bin/python3
|
||||||
|
# vim: set fileencoding=utf-8 :
|
||||||
|
#
|
||||||
|
# Hello. This is make-release-mail.py from the Telepathy project. It's
|
||||||
|
@@ -49,7 +49,7 @@ BASE_URL = 'http://telepathy.freedesktop.org/releases'
|
||||||
|
def main(package, version, news_path):
|
||||||
|
release_name, details = extract_description(package, version, news_path)
|
||||||
|
|
||||||
|
- print """
|
||||||
|
+ print("""
|
||||||
|
%(release_name)s
|
||||||
|
|
||||||
|
tarball: %(base_url)s/%(package)s/%(package)s-%(version)s.tar.gz
|
||||||
|
@@ -61,7 +61,7 @@ signature: %(base_url)s/%(package)s/%(package)s-%(version)s.tar.gz.asc
|
||||||
|
'version': version,
|
||||||
|
'release_name': release_name,
|
||||||
|
'details': details,
|
||||||
|
- }
|
||||||
|
+ })
|
||||||
|
|
||||||
|
if __name__ == '__main__':
|
||||||
|
try:
|
||||||
|
@@ -69,8 +69,6 @@ if __name__ == '__main__':
|
||||||
|
|
||||||
|
main(package, version, news_path)
|
||||||
|
except ValueError, e:
|
||||||
|
- sys.stderr.write(
|
||||||
|
- 'Usage: %s package-name package.version.number path/to/NEWS\n' %
|
||||||
|
- sys.argv[0])
|
||||||
|
+ print('Usage: %s package-name package.version.number path/to/NEWS\n', sys.argv[0], file=sys.stderr)
|
||||||
|
sys.stderr.flush()
|
||||||
|
sys.exit(1)
|
Loading…
Reference in a new issue