linux-postmarketos-qcom-sdm660: update to 5.10-rc6 (MR 2003)
This commit is contained in:
parent
af512dbfca
commit
a690b29510
4 changed files with 495 additions and 742 deletions
|
@ -1,519 +0,0 @@
|
|||
From 9dd44ed79e2077eeb88a07f8ef37f70578ca695e Mon Sep 17 00:00:00 2001
|
||||
From: Alexey Min <alexey.min@gmail.com>
|
||||
Date: Wed, 22 Jan 2020 00:55:00 +0300
|
||||
Subject: [PATCH] arm64: dts: qcom: Add sdm630/sdm660 SoC and
|
||||
xiaomi-lavender support
|
||||
|
||||
Initial device tree support for Qualcomm SDM660 SoC and
|
||||
xiaomi-lavender (Redmi Note 7).
|
||||
|
||||
SDM630 is based on SDM660 soc and all SDM660 specific drivers are
|
||||
compatible with it. SDM660 is also based off of MSM8998 so it uses some
|
||||
of its drivers as well.
|
||||
|
||||
The device tree is based on the CAF 4.4 kernel tree.
|
||||
|
||||
The device can be booted into the initrd with a shell over UART and
|
||||
simple-framebuffer display.
|
||||
|
||||
Features:
|
||||
* CPU nodes
|
||||
* Timer nodes
|
||||
* Interrupt controller
|
||||
* Global Clock Controller
|
||||
* Top Level Mode Multiplexer (pin controller)
|
||||
* UART node
|
||||
|
||||
This is inspired by and based on the work of Craig Tatlor in
|
||||
https://patchwork.kernel.org/patch/10563667/
|
||||
|
||||
Signed-off-by: Craig Tatlor <ctatlor97@gmail.com>
|
||||
Signed-off-by: Alexey Minnekhanov <alexey.min@gmail.com>
|
||||
---
|
||||
arch/arm64/boot/dts/qcom/Makefile | 1 +
|
||||
.../boot/dts/qcom/sdm660-xiaomi-lavender.dts | 75 ++++
|
||||
arch/arm64/boot/dts/qcom/sdm660.dtsi | 378 ++++++++++++++++++
|
||||
3 files changed, 454 insertions(+)
|
||||
create mode 100644 arch/arm64/boot/dts/qcom/sdm660-xiaomi-lavender.dts
|
||||
create mode 100644 arch/arm64/boot/dts/qcom/sdm660.dtsi
|
||||
|
||||
diff --git a/arch/arm64/boot/dts/qcom/Makefile b/arch/arm64/boot/dts/qcom/Makefile
|
||||
index cc103f7020fd..0f2c33d611df 100644
|
||||
--- a/arch/arm64/boot/dts/qcom/Makefile
|
||||
+++ b/arch/arm64/boot/dts/qcom/Makefile
|
||||
@@ -16,6 +16,7 @@ dtb-$(CONFIG_ARCH_QCOM) += msm8998-hp-envy-x2.dtb
|
||||
dtb-$(CONFIG_ARCH_QCOM) += msm8998-lenovo-miix-630.dtb
|
||||
dtb-$(CONFIG_ARCH_QCOM) += msm8998-mtp.dtb
|
||||
dtb-$(CONFIG_ARCH_QCOM) += sc7180-idp.dtb
|
||||
+dtb-$(CONFIG_ARCH_QCOM) += sdm660-xiaomi-lavender.dtb
|
||||
dtb-$(CONFIG_ARCH_QCOM) += sdm845-cheza-r1.dtb
|
||||
dtb-$(CONFIG_ARCH_QCOM) += sdm845-cheza-r2.dtb
|
||||
dtb-$(CONFIG_ARCH_QCOM) += sdm845-cheza-r3.dtb
|
||||
diff --git a/arch/arm64/boot/dts/qcom/sdm660-xiaomi-lavender.dts b/arch/arm64/boot/dts/qcom/sdm660-xiaomi-lavender.dts
|
||||
new file mode 100644
|
||||
index 000000000000..5305ef843650
|
||||
--- /dev/null
|
||||
+++ b/arch/arm64/boot/dts/qcom/sdm660-xiaomi-lavender.dts
|
||||
@@ -0,0 +1,75 @@
|
||||
+// SPDX-License-Identifier: GPL-2.0-only
|
||||
+/* Copyright (c) 2019, The Linux Foundation. All rights reserved.
|
||||
+ * Copyright (c) 2020, Aleksey Minnekhanov <alexey.min@gmail.com>
|
||||
+ */
|
||||
+
|
||||
+/dts-v1/;
|
||||
+
|
||||
+#include "sdm660.dtsi"
|
||||
+
|
||||
+/ {
|
||||
+ model = "Xiaomi Redmi Note 7";
|
||||
+ compatible = "xiaomi,lavender", "qcom,sdm660-mtp", "qcom,sdm660", "qcom,mtp";
|
||||
+ /* required for bootloader to select correct board */
|
||||
+ qcom,msm-id = <0x13d 0x0>;
|
||||
+ qcom,board-id = <0x20008 0>;
|
||||
+ qcom,pmic-id = <0x0001001b 0x0101011a 0x0 0x0>,
|
||||
+ <0x0001001b 0x0201011a 0x0 0x0>,
|
||||
+ <0x0001001b 0x0102001a 0x0 0x0>;
|
||||
+
|
||||
+ aliases {
|
||||
+ serial0 = &blsp1_uart2;
|
||||
+ };
|
||||
+
|
||||
+ chosen {
|
||||
+ #address-cells = <2>;
|
||||
+ #size-cells = <2>;
|
||||
+ ranges;
|
||||
+
|
||||
+ stdout-path = "serial0:115200n8";
|
||||
+
|
||||
+ framebuffer@0x9d400000 {
|
||||
+ compatible = "simple-framebuffer";
|
||||
+ reg = <0x0 0x9d400000 0x0 (1080 * 2340 * 4)>;
|
||||
+ width = <1080>;
|
||||
+ height = <2340>;
|
||||
+ stride = <(1080 * 4)>;
|
||||
+ format = "a8r8g8b8";
|
||||
+ };
|
||||
+ };
|
||||
+
|
||||
+ reserved-memory {
|
||||
+ #address-cells = <2>;
|
||||
+ #size-cells = <2>;
|
||||
+ ranges;
|
||||
+
|
||||
+ linux,cma {
|
||||
+ compatible = "shared-dma-pool";
|
||||
+ alloc-ranges = <0 0x00000000 0 0xffffffff>;
|
||||
+ reusable;
|
||||
+ alignment = <0 0x400000>;
|
||||
+ size = <0 0x2c00000>;
|
||||
+ linux,cma-default;
|
||||
+ };
|
||||
+
|
||||
+ framebuffer_region@9d400000 {
|
||||
+ reg = <0x0 0x9d400000 0x0 0x02400000>;
|
||||
+ no-map;
|
||||
+ };
|
||||
+
|
||||
+ ramoops@a0000000 {
|
||||
+ compatible = "ramoops";
|
||||
+ reg = <0x0 0xa0000000 0x0 0x400000>;
|
||||
+ console-size = <0x20000>;
|
||||
+ record-size = <0x20000>;
|
||||
+ ftrace-size = <0x0>;
|
||||
+ pmsg-size = <0x20000>;
|
||||
+ };
|
||||
+ };
|
||||
+};
|
||||
+
|
||||
+&blsp1_uart2 {
|
||||
+ status = "okay";
|
||||
+ pinctrl-names = "default";
|
||||
+ pinctrl-0 = <&uart_console_active>;
|
||||
+};
|
||||
diff --git a/arch/arm64/boot/dts/qcom/sdm660.dtsi b/arch/arm64/boot/dts/qcom/sdm660.dtsi
|
||||
new file mode 100644
|
||||
index 000000000000..97db2017c8c4
|
||||
--- /dev/null
|
||||
+++ b/arch/arm64/boot/dts/qcom/sdm660.dtsi
|
||||
@@ -0,0 +1,378 @@
|
||||
+// SPDX-License-Identifier: GPL-2.0-only
|
||||
+/* Copyright (c) 2018, Craig Tatlor.
|
||||
+ * Copyright (c) 2019, The Linux Foundation. All rights reserved.
|
||||
+ * Copyright (c) 2020, Aleksey Minnekhanov <alexey.min@gmail.com>
|
||||
+ */
|
||||
+
|
||||
+#include <dt-bindings/interrupt-controller/arm-gic.h>
|
||||
+#include <dt-bindings/clock/qcom,gcc-sdm660.h>
|
||||
+
|
||||
+/ {
|
||||
+ model = "Qualcomm Technologies, Inc. SDM 660";
|
||||
+ compatible = "qcom,sdm660-mtp", "qcom,sdm660", "qcom,mtp";
|
||||
+
|
||||
+ interrupt-parent = <&intc>;
|
||||
+
|
||||
+ #address-cells = <2>;
|
||||
+ #size-cells = <2>;
|
||||
+
|
||||
+ chosen { };
|
||||
+
|
||||
+ memory {
|
||||
+ device_type = "memory";
|
||||
+ /* We expect the bootloader to fill in the reg */
|
||||
+ reg = <0 0 0 0>;
|
||||
+ };
|
||||
+
|
||||
+ cpus {
|
||||
+ #address-cells = <2>;
|
||||
+ #size-cells = <0>;
|
||||
+
|
||||
+ CPU0: cpu@100 {
|
||||
+ device_type = "cpu";
|
||||
+ compatible = "arm,armv8";
|
||||
+ reg = <0x0 0x100>;
|
||||
+ enable-method = "psci";
|
||||
+ efficiency = <1126>;
|
||||
+ next-level-cache = <&L2_1>;
|
||||
+ L2_1: l2-cache {
|
||||
+ compatible = "arm,arch-cache";
|
||||
+ cache-level = <2>;
|
||||
+ };
|
||||
+ L1_I_100: l1-icache {
|
||||
+ compatible = "arm,arch-cache";
|
||||
+ };
|
||||
+ L1_D_100: l1-dcache {
|
||||
+ compatible = "arm,arch-cache";
|
||||
+ };
|
||||
+ };
|
||||
+
|
||||
+ CPU1: cpu@101 {
|
||||
+ device_type = "cpu";
|
||||
+ compatible = "arm,armv8";
|
||||
+ reg = <0x0 0x101>;
|
||||
+ enable-method = "psci";
|
||||
+ efficiency = <1126>;
|
||||
+ next-level-cache = <&L2_1>;
|
||||
+ L1_I_101: l1-icache {
|
||||
+ compatible = "arm,arch-cache";
|
||||
+ };
|
||||
+ L1_D_101: l1-dcache {
|
||||
+ compatible = "arm,arch-cache";
|
||||
+ };
|
||||
+ };
|
||||
+
|
||||
+ CPU2: cpu@102 {
|
||||
+ device_type = "cpu";
|
||||
+ compatible = "arm,armv8";
|
||||
+ reg = <0x0 0x102>;
|
||||
+ enable-method = "psci";
|
||||
+ efficiency = <1126>;
|
||||
+ next-level-cache = <&L2_1>;
|
||||
+ L1_I_102: l1-icache {
|
||||
+ compatible = "arm,arch-cache";
|
||||
+ };
|
||||
+ L1_D_102: l1-dcache {
|
||||
+ compatible = "arm,arch-cache";
|
||||
+ };
|
||||
+ };
|
||||
+
|
||||
+ CPU3: cpu@103 {
|
||||
+ device_type = "cpu";
|
||||
+ compatible = "arm,armv8";
|
||||
+ reg = <0x0 0x103>;
|
||||
+ enable-method = "psci";
|
||||
+ efficiency = <1126>;
|
||||
+ next-level-cache = <&L2_1>;
|
||||
+ L1_I_103: l1-icache {
|
||||
+ compatible = "arm,arch-cache";
|
||||
+ };
|
||||
+ L1_D_103: l1-dcache {
|
||||
+ compatible = "arm,arch-cache";
|
||||
+ };
|
||||
+ };
|
||||
+
|
||||
+ CPU4: cpu@0 {
|
||||
+ device_type = "cpu";
|
||||
+ compatible = "arm,armv8";
|
||||
+ reg = <0x0 0x0>;
|
||||
+ enable-method = "psci";
|
||||
+ efficiency = <1024>;
|
||||
+ next-level-cache = <&L2_0>;
|
||||
+ L2_0: l2-cache {
|
||||
+ compatible = "arm,arch-cache";
|
||||
+ cache-level = <2>;
|
||||
+ };
|
||||
+ L1_I_0: l1-icache {
|
||||
+ compatible = "arm,arch-cache";
|
||||
+ };
|
||||
+ L1_D_0: l1-dcache {
|
||||
+ compatible = "arm,arch-cache";
|
||||
+ };
|
||||
+ };
|
||||
+
|
||||
+ CPU5: cpu@1 {
|
||||
+ device_type = "cpu";
|
||||
+ compatible = "arm,armv8";
|
||||
+ reg = <0x0 0x1>;
|
||||
+ enable-method = "psci";
|
||||
+ efficiency = <1024>;
|
||||
+ next-level-cache = <&L2_0>;
|
||||
+ L1_I_1: l1-icache {
|
||||
+ compatible = "arm,arch-cache";
|
||||
+ };
|
||||
+ L1_D_1: l1-dcache {
|
||||
+ compatible = "arm,arch-cache";
|
||||
+ };
|
||||
+ };
|
||||
+
|
||||
+ CPU6: cpu@2 {
|
||||
+ device_type = "cpu";
|
||||
+ compatible = "arm,armv8";
|
||||
+ reg = <0x0 0x2>;
|
||||
+ enable-method = "psci";
|
||||
+ efficiency = <1024>;
|
||||
+ next-level-cache = <&L2_0>;
|
||||
+ L1_I_2: l1-icache {
|
||||
+ compatible = "arm,arch-cache";
|
||||
+ };
|
||||
+ L1_D_2: l1-dcache {
|
||||
+ compatible = "arm,arch-cache";
|
||||
+ };
|
||||
+ };
|
||||
+
|
||||
+ CPU7: cpu@3 {
|
||||
+ device_type = "cpu";
|
||||
+ compatible = "arm,armv8";
|
||||
+ reg = <0x0 0x3>;
|
||||
+ enable-method = "psci";
|
||||
+ efficiency = <1024>;
|
||||
+ next-level-cache = <&L2_0>;
|
||||
+ L1_I_3: l1-icache {
|
||||
+ compatible = "arm,arch-cache";
|
||||
+ };
|
||||
+ L1_D_3: l1-dcache {
|
||||
+ compatible = "arm,arch-cache";
|
||||
+ };
|
||||
+ };
|
||||
+
|
||||
+ cpu-map {
|
||||
+ cluster0 {
|
||||
+ core0 {
|
||||
+ cpu = <&CPU4>;
|
||||
+ };
|
||||
+
|
||||
+ core1 {
|
||||
+ cpu = <&CPU5>;
|
||||
+ };
|
||||
+
|
||||
+ core2 {
|
||||
+ cpu = <&CPU6>;
|
||||
+ };
|
||||
+
|
||||
+ core3 {
|
||||
+ cpu = <&CPU7>;
|
||||
+ };
|
||||
+ };
|
||||
+
|
||||
+ cluster1 {
|
||||
+ core0 {
|
||||
+ cpu = <&CPU0>;
|
||||
+ };
|
||||
+
|
||||
+ core1 {
|
||||
+ cpu = <&CPU1>;
|
||||
+ };
|
||||
+
|
||||
+ core2 {
|
||||
+ cpu = <&CPU2>;
|
||||
+ };
|
||||
+
|
||||
+ core3 {
|
||||
+ cpu = <&CPU3>;
|
||||
+ };
|
||||
+ };
|
||||
+ };
|
||||
+ };
|
||||
+
|
||||
+ psci {
|
||||
+ compatible = "arm,psci-1.0";
|
||||
+ method = "smc";
|
||||
+ };
|
||||
+
|
||||
+ firmware {
|
||||
+ scm {
|
||||
+ compatible = "qcom,scm";
|
||||
+ };
|
||||
+ };
|
||||
+
|
||||
+
|
||||
+ timer {
|
||||
+ compatible = "arm,armv8-timer";
|
||||
+ interrupts = <GIC_PPI 1 IRQ_TYPE_LEVEL_LOW>,
|
||||
+ <GIC_PPI 2 IRQ_TYPE_LEVEL_LOW>,
|
||||
+ <GIC_PPI 3 IRQ_TYPE_LEVEL_LOW>,
|
||||
+ <GIC_PPI 0 IRQ_TYPE_LEVEL_LOW>;
|
||||
+ };
|
||||
+
|
||||
+ clocks {
|
||||
+ xo_board {
|
||||
+ compatible = "fixed-clock";
|
||||
+ #clock-cells = <0>;
|
||||
+ clock-frequency = <19200000>;
|
||||
+ clock-output-names = "xo_board";
|
||||
+ };
|
||||
+
|
||||
+ sleep_clk {
|
||||
+ compatible = "fixed-clock";
|
||||
+ #clock-cells = <0>;
|
||||
+ clock-frequency = <32764>;
|
||||
+ clock-output-names = "sleep_clk";
|
||||
+ };
|
||||
+ };
|
||||
+
|
||||
+ soc: soc {
|
||||
+ #address-cells = <1>;
|
||||
+ #size-cells = <1>;
|
||||
+ ranges = <0 0 0 0xffffffff>;
|
||||
+ compatible = "simple-bus";
|
||||
+
|
||||
+ intc: interrupt-controller@17a00000 {
|
||||
+ compatible = "arm,gic-v3";
|
||||
+ // ^^ sdm630 should propbably add "qcom,msm8996-gic-v3"
|
||||
+ reg = <0x17a00000 0x10000>,
|
||||
+ <0x17b00000 0x100000>;
|
||||
+ #interrupt-cells = <3>;
|
||||
+ #address-cells = <1>;
|
||||
+ #size-cells = <1>;
|
||||
+ ranges;
|
||||
+ interrupt-controller;
|
||||
+ #redistributor-regions = <1>;
|
||||
+ redistributor-stride = <0x0 0x20000>;
|
||||
+ interrupts = <GIC_PPI 9 IRQ_TYPE_LEVEL_HIGH>;
|
||||
+ };
|
||||
+
|
||||
+ timer@17920000 {
|
||||
+ #address-cells = <1>;
|
||||
+ #size-cells = <1>;
|
||||
+ ranges;
|
||||
+ compatible = "arm,armv7-timer-mem";
|
||||
+ reg = <0x17920000 0x1000>;
|
||||
+
|
||||
+ frame@17921000 {
|
||||
+ frame-number = <0>;
|
||||
+ interrupts = <GIC_SPI 8 IRQ_TYPE_LEVEL_HIGH>,
|
||||
+ <GIC_SPI 7 IRQ_TYPE_LEVEL_HIGH>;
|
||||
+ reg = <0x17921000 0x1000>,
|
||||
+ <0x17922000 0x1000>;
|
||||
+ };
|
||||
+
|
||||
+ frame@17923000 {
|
||||
+ frame-number = <1>;
|
||||
+ interrupts = <GIC_SPI 9 IRQ_TYPE_LEVEL_HIGH>;
|
||||
+ reg = <0x17923000 0x1000>;
|
||||
+ status = "disabled";
|
||||
+ };
|
||||
+
|
||||
+ frame@17924000 {
|
||||
+ frame-number = <2>;
|
||||
+ interrupts = <GIC_SPI 10 IRQ_TYPE_LEVEL_HIGH>;
|
||||
+ reg = <0x17924000 0x1000>;
|
||||
+ status = "disabled";
|
||||
+ };
|
||||
+
|
||||
+ frame@17925000 {
|
||||
+ frame-number = <3>;
|
||||
+ interrupts = <GIC_SPI 11 IRQ_TYPE_LEVEL_HIGH>;
|
||||
+ reg = <0x17925000 0x1000>;
|
||||
+ status = "disabled";
|
||||
+ };
|
||||
+
|
||||
+ frame@17926000 {
|
||||
+ frame-number = <4>;
|
||||
+ interrupts = <GIC_SPI 12 IRQ_TYPE_LEVEL_HIGH>;
|
||||
+ reg = <0x17926000 0x1000>;
|
||||
+ status = "disabled";
|
||||
+ };
|
||||
+
|
||||
+ frame@17927000 {
|
||||
+ frame-number = <5>;
|
||||
+ interrupts = <GIC_SPI 13 IRQ_TYPE_LEVEL_HIGH>;
|
||||
+ reg = <0x17927000 0x1000>;
|
||||
+ status = "disabled";
|
||||
+ };
|
||||
+
|
||||
+ frame@17928000 {
|
||||
+ frame-number = <6>;
|
||||
+ interrupts = <GIC_SPI 14 IRQ_TYPE_LEVEL_HIGH>;
|
||||
+ reg = <0x17928000 0x1000>;
|
||||
+ status = "disabled";
|
||||
+ };
|
||||
+ };
|
||||
+
|
||||
+ gcc: clock-controller@100000 {
|
||||
+ compatible = "qcom,gcc-sdm660";
|
||||
+ #clock-cells = <1>;
|
||||
+ #reset-cells = <1>;
|
||||
+ #power-domain-cells = <1>;
|
||||
+ reg = <0x100000 0x94000>;
|
||||
+ };
|
||||
+
|
||||
+ tlmm: pinctrl@3100000 {
|
||||
+ compatible = "qcom,sdm660-pinctrl";
|
||||
+ reg = <0x3100000 0x400000>,
|
||||
+ <0x3500000 0x400000>,
|
||||
+ <0x3900000 0x400000>;
|
||||
+ reg-names = "south", "center", "north";
|
||||
+ interrupts = <GIC_SPI 208 IRQ_TYPE_LEVEL_HIGH>;
|
||||
+ gpio-controller;
|
||||
+ gpio-ranges = <&tlmm 0 0 114>;
|
||||
+ gpio-reserved-ranges = <8 4>;
|
||||
+ #gpio-cells = <2>;
|
||||
+ interrupt-controller;
|
||||
+ #interrupt-cells = <2>;
|
||||
+
|
||||
+ uart_console_active: uart_console_active {
|
||||
+ pinmux {
|
||||
+ pins = "gpio4", "gpio5";
|
||||
+ function = "blsp_uart2";
|
||||
+ };
|
||||
+
|
||||
+ pinconf {
|
||||
+ pins = "gpio4", "gpio5";
|
||||
+ drive-strength = <2>;
|
||||
+ bias-disable;
|
||||
+ };
|
||||
+ };
|
||||
+ };
|
||||
+
|
||||
+ blsp1_uart2: serial@c170000 {
|
||||
+ compatible = "qcom,msm-uartdm-v1.4", "qcom,msm-uartdm";
|
||||
+ reg = <0xc170000 0x1000>;
|
||||
+ interrupts = <GIC_SPI 108 IRQ_TYPE_LEVEL_HIGH>;
|
||||
+ clocks = <&gcc GCC_BLSP1_UART2_APPS_CLK>,
|
||||
+ <&gcc GCC_BLSP1_AHB_CLK>;
|
||||
+ clock-names = "core", "iface";
|
||||
+ status = "disabled";
|
||||
+ };
|
||||
+
|
||||
+ spmi_bus: qcom,spmi@800f000 {
|
||||
+ compatible = "qcom,spmi-pmic-arb";
|
||||
+ reg = <0x800f000 0x1000>,
|
||||
+ <0x8400000 0x1000000>,
|
||||
+ <0x9400000 0x1000000>,
|
||||
+ <0xa400000 0x220000>,
|
||||
+ <0x800a000 0x3000>;
|
||||
+ reg-names = "core", "chnls", "obsrvr", "intr", "cnfg";
|
||||
+ interrupt-names = "periph_irq";
|
||||
+ interrupts = <GIC_SPI 326 IRQ_TYPE_LEVEL_HIGH>;
|
||||
+ qcom,ee = <0>;
|
||||
+ qcom,channel = <0>;
|
||||
+ #address-cells = <2>;
|
||||
+ #size-cells = <0>;
|
||||
+ interrupt-controller;
|
||||
+ #interrupt-cells = <4>;
|
||||
+ cell-index = <0>;
|
||||
+ };
|
||||
+ };
|
||||
+};
|
||||
--
|
||||
2.20.1
|
||||
|
|
@ -3,23 +3,21 @@
|
|||
|
||||
_flavor="postmarketos-qcom-sdm660"
|
||||
pkgname=linux-$_flavor
|
||||
pkgver=5.6_rc1
|
||||
pkgrel=2
|
||||
pkgdesc="QCOM group's fork of mainline linux"
|
||||
arch="aarch64" # sdm660 is arm64 only
|
||||
pkgver=5.10_rc6
|
||||
pkgrel=0
|
||||
pkgdesc="Close to mainline linux kernel for Qualcomm Snapdragon 660 SoC"
|
||||
arch="aarch64"
|
||||
url="https://kernel.org/"
|
||||
license="GPL-2.0-only"
|
||||
options="!strip !check !tracedeps pmb:cross-native"
|
||||
makedepends="bison findutils flex installkernel openssl-dev perl"
|
||||
|
||||
_repo="linux-postmarketos"
|
||||
_commit="8dc3769c8a680bfc1f38221e68d3fd994f490970"
|
||||
_commit="5e9195254ef8c6c6f4870aa77057577f0c17d007"
|
||||
|
||||
source="
|
||||
$_repo-$_commit.tar.bz2::https://gitlab.com/postmarketOS/$_repo/-/archive/$_commit/$_repo-$_commit.tar.bz2
|
||||
config-$_flavor.aarch64
|
||||
0001-arm64-dts-qcom-Add-sdm630-sdm660-SoC-and-xiaomi-lave.patch
|
||||
linux4.17-gcc10-extern_YYLOC_global_declaration.patch
|
||||
"
|
||||
|
||||
_carch="arm64"
|
||||
|
@ -48,10 +46,9 @@ package() {
|
|||
make modules_install dtbs_install \
|
||||
ARCH="$_carch" \
|
||||
INSTALL_MOD_PATH="$pkgdir" \
|
||||
INSTALL_MOD_STRIP=1 \
|
||||
INSTALL_DTBS_PATH="$pkgdir/usr/share/dtb"
|
||||
}
|
||||
|
||||
sha512sums="b53b17709eea1b8cd8fc9158762f0e2fefad7baa383dbee2ba758e9aed89cf411b2bd65386823821b877ced5f0b525f5ddc67cd048fddf47c9104eea42ab81f0 linux-postmarketos-8dc3769c8a680bfc1f38221e68d3fd994f490970.tar.bz2
|
||||
1872304ae2cf9003c7cac98debb7940e94def436330b5da960f82befec9a57dcb2cbfff34bd92b559e3fd37be44da9c4a69c1dbebc8ac402235d0b491e452cb3 config-postmarketos-qcom-sdm660.aarch64
|
||||
a5c4036e916716a66277c40d2adfc526401c7abdfe5222e237deb585bd4081cb36023696e794e0531413caf1296b88072f3506086dee99e1388e2874d72880bc 0001-arm64-dts-qcom-Add-sdm630-sdm660-SoC-and-xiaomi-lave.patch
|
||||
27827877040007fc1c4c719f7e2e19e5c272d44972415cfc53feba0313d87e4074f8204bdb13cbc5fe21ea61bf595314b68f10c081e7b7bac3c888b60f008acf linux4.17-gcc10-extern_YYLOC_global_declaration.patch"
|
||||
sha512sums="4a55855e60de655a77c43cbd4a08b611a7142235dbf5501007d734426e3d08291b8101b2e3e6e22306af8da52709fa4466c1ede6a0cd7b9d8d02eb250a09f5af linux-postmarketos-5e9195254ef8c6c6f4870aa77057577f0c17d007.tar.bz2
|
||||
8e12dca570e8b12f0fa7349943babc61e9f2827cea61bc9f2f2c0fb2553e2e8a8fcfb623dcd46d9ff9d99f8596c4197a5b321bf43a99197bef30f554244eb4aa config-postmarketos-qcom-sdm660.aarch64"
|
||||
|
|
File diff suppressed because it is too large
Load diff
|
@ -1 +0,0 @@
|
|||
../../device/.shared-patches/linux/linux4.17-gcc10-extern_YYLOC_global_declaration.patch
|
Loading…
Reference in a new issue