Add linux-postmarketos-mainline aport (#799)
* Rename linux-postmarketos to linux-postmarketos-stable * Adjust all device-* packages using linux-postmarketos and bump pkgrel
This commit is contained in:
parent
a88c8c918c
commit
a31d168635
14 changed files with 17039 additions and 22 deletions
|
@ -1,11 +1,11 @@
|
|||
pkgname=device-nokia-rx51
|
||||
pkgver=1
|
||||
pkgrel=24
|
||||
pkgrel=25
|
||||
pkgdesc="Nokia N900"
|
||||
url="https://github.com/postmarketOS"
|
||||
arch="noarch"
|
||||
license="MIT"
|
||||
depends="linux-postmarketos uboot-tools linux-firmware kbd kbd-bkeymaps ofono"
|
||||
depends="linux-postmarketos-stable uboot-tools linux-firmware kbd kbd-bkeymaps ofono"
|
||||
makedepends="uboot-tools kbd kbd-bkeymaps"
|
||||
install="$pkgname.post-install"
|
||||
subpackages="$pkgname-weston:weston"
|
||||
|
|
|
@ -1,11 +1,11 @@
|
|||
pkgname=device-qemu-aarch64
|
||||
pkgver=1
|
||||
pkgrel=4
|
||||
pkgrel=5
|
||||
pkgdesc="Simulated device in qemu with vexpress soc"
|
||||
url="https://github.com/postmarketOS"
|
||||
arch="noarch"
|
||||
license="MIT"
|
||||
depends="linux-postmarketos"
|
||||
depends="linux-postmarketos-stable"
|
||||
makedepends=""
|
||||
subpackages=""
|
||||
source="deviceinfo interfaces"
|
||||
|
|
|
@ -1,11 +1,11 @@
|
|||
pkgname=device-qemu-amd64
|
||||
pkgver=1
|
||||
pkgrel=7
|
||||
pkgrel=8
|
||||
pkgdesc="Simulated device in qemu with an x86 platform"
|
||||
url="https://github.com/postmarketOS"
|
||||
arch="noarch"
|
||||
license="MIT"
|
||||
depends="linux-postmarketos"
|
||||
depends="linux-postmarketos-stable"
|
||||
makedepends=""
|
||||
subpackages="$pkgname-mesa $pkgname-x11 $pkgname-weston"
|
||||
source="deviceinfo interfaces weston.ini"
|
||||
|
|
|
@ -1,11 +1,11 @@
|
|||
pkgname=device-qemu-vexpress
|
||||
pkgver=1
|
||||
pkgrel=11
|
||||
pkgrel=12
|
||||
pkgdesc="Simulated device in qemu with vexpress soc"
|
||||
url="https://github.com/postmarketOS"
|
||||
arch="noarch"
|
||||
license="MIT"
|
||||
depends="linux-postmarketos"
|
||||
depends="linux-postmarketos-stable"
|
||||
makedepends=""
|
||||
subpackages=""
|
||||
source="deviceinfo interfaces"
|
||||
|
|
440
main/linux-postmarketos-mainline/001-sony-amami-dts.patch
Normal file
440
main/linux-postmarketos-mainline/001-sony-amami-dts.patch
Normal file
|
@ -0,0 +1,440 @@
|
|||
diff --git a/arch/arm/boot/dts/Makefile b/arch/arm/boot/dts/Makefile
|
||||
index faf46aba..1d846974 100644
|
||||
--- a/arch/arm/boot/dts/Makefile
|
||||
+++ b/arch/arm/boot/dts/Makefile
|
||||
@@ -701,6 +701,7 @@ dtb-$(CONFIG_ARCH_QCOM) += \
|
||||
qcom-msm8660-surf.dtb \
|
||||
qcom-msm8960-cdp.dtb \
|
||||
qcom-msm8974-lge-nexus5-hammerhead.dtb \
|
||||
+ qcom-msm8974-sony-xperia-amami.dtb \
|
||||
qcom-msm8974-sony-xperia-honami.dtb \
|
||||
qcom-mdm9615-wp8548-mangoh-green.dtb
|
||||
dtb-$(CONFIG_ARCH_REALVIEW) += \
|
||||
diff --git a/arch/arm/boot/dts/qcom-msm8974-sony-xperia-amami.dts b/arch/arm/boot/dts/qcom-msm8974-sony-xperia-amami.dts
|
||||
index e69de29b..fa6beb54 100644
|
||||
--- a/arch/arm/boot/dts/qcom-msm8974-sony-xperia-amami.dts
|
||||
+++ b/arch/arm/boot/dts/qcom-msm8974-sony-xperia-amami.dts
|
||||
@@ -0,0 +1,423 @@
|
||||
+#include "qcom-msm8974.dtsi"
|
||||
+#include "qcom-pm8841.dtsi"
|
||||
+#include "qcom-pm8941.dtsi"
|
||||
+#include <dt-bindings/gpio/gpio.h>
|
||||
+#include <dt-bindings/input/input.h>
|
||||
+#include <dt-bindings/pinctrl/qcom,pmic-gpio.h>
|
||||
+
|
||||
+/ {
|
||||
+ model = "Sony Xperia Z1 Compact";
|
||||
+ compatible = "sony,xperia-amami", "qcom,msm8974";
|
||||
+
|
||||
+ aliases {
|
||||
+ serial0 = &blsp1_uart2;
|
||||
+ };
|
||||
+
|
||||
+ chosen {
|
||||
+ stdout-path = "serial0:115200n8";
|
||||
+ };
|
||||
+
|
||||
+ gpio-keys {
|
||||
+ compatible = "gpio-keys";
|
||||
+ input-name = "gpio-keys";
|
||||
+
|
||||
+ pinctrl-names = "default";
|
||||
+ pinctrl-0 = <&gpio_keys_pin_a>;
|
||||
+
|
||||
+ volume-down {
|
||||
+ label = "volume_down";
|
||||
+ gpios = <&pm8941_gpios 2 GPIO_ACTIVE_LOW>;
|
||||
+ linux,input-type = <1>;
|
||||
+ linux,code = <KEY_VOLUMEDOWN>;
|
||||
+ };
|
||||
+
|
||||
+ camera-snapshot {
|
||||
+ label = "camera_snapshot";
|
||||
+ gpios = <&pm8941_gpios 3 GPIO_ACTIVE_LOW>;
|
||||
+ linux,input-type = <1>;
|
||||
+ linux,code = <KEY_CAMERA>;
|
||||
+ };
|
||||
+
|
||||
+ camera-focus {
|
||||
+ label = "camera_focus";
|
||||
+ gpios = <&pm8941_gpios 4 GPIO_ACTIVE_LOW>;
|
||||
+ linux,input-type = <1>;
|
||||
+ linux,code = <KEY_CAMERA_FOCUS>;
|
||||
+ };
|
||||
+
|
||||
+ volume-up {
|
||||
+ label = "volume_up";
|
||||
+ gpios = <&pm8941_gpios 5 GPIO_ACTIVE_LOW>;
|
||||
+ linux,input-type = <1>;
|
||||
+ linux,code = <KEY_VOLUMEUP>;
|
||||
+ };
|
||||
+ };
|
||||
+
|
||||
+ memory@0 {
|
||||
+ reg = <0 0x40000000>, <0x40000000 0x40000000>;
|
||||
+ device_type = "memory";
|
||||
+ };
|
||||
+
|
||||
+ smd {
|
||||
+ rpm {
|
||||
+ rpm_requests {
|
||||
+ pm8841-regulators {
|
||||
+ s1 {
|
||||
+ regulator-min-microvolt = <675000>;
|
||||
+ regulator-max-microvolt = <1050000>;
|
||||
+ };
|
||||
+
|
||||
+ s2 {
|
||||
+ regulator-min-microvolt = <500000>;
|
||||
+ regulator-max-microvolt = <1050000>;
|
||||
+ };
|
||||
+
|
||||
+ s3 {
|
||||
+ regulator-min-microvolt = <500000>;
|
||||
+ regulator-max-microvolt = <1050000>;
|
||||
+ };
|
||||
+
|
||||
+ s4 {
|
||||
+ regulator-min-microvolt = <500000>;
|
||||
+ regulator-max-microvolt = <1050000>;
|
||||
+ };
|
||||
+ };
|
||||
+
|
||||
+ pm8941-regulators {
|
||||
+ vdd_l1_l3-supply = <&pm8941_s1>;
|
||||
+ vdd_l2_lvs1_2_3-supply = <&pm8941_s3>;
|
||||
+ vdd_l4_l11-supply = <&pm8941_s1>;
|
||||
+ vdd_l5_l7-supply = <&pm8941_s2>;
|
||||
+ vdd_l6_l12_l14_l15-supply = <&pm8941_s2>;
|
||||
+ vdd_l9_l10_l17_l22-supply = <&vreg_boost>;
|
||||
+ vdd_l13_l20_l23_l24-supply = <&vreg_boost>;
|
||||
+ vdd_l21-supply = <&vreg_boost>;
|
||||
+
|
||||
+ s1 {
|
||||
+ regulator-min-microvolt = <1300000>;
|
||||
+ regulator-max-microvolt = <1300000>;
|
||||
+ regulator-always-on;
|
||||
+ regulator-boot-on;
|
||||
+ };
|
||||
+
|
||||
+ s2 {
|
||||
+ regulator-min-microvolt = <2150000>;
|
||||
+ regulator-max-microvolt = <2150000>;
|
||||
+ regulator-boot-on;
|
||||
+ };
|
||||
+
|
||||
+ s3 {
|
||||
+ regulator-min-microvolt = <1800000>;
|
||||
+ regulator-max-microvolt = <1800000>;
|
||||
+ regulator-always-on;
|
||||
+ regulator-boot-on;
|
||||
+ };
|
||||
+
|
||||
+ s4 {
|
||||
+ regulator-min-microvolt = <5000000>;
|
||||
+ regulator-max-microvolt = <5000000>;
|
||||
+ };
|
||||
+
|
||||
+ l1 {
|
||||
+ regulator-min-microvolt = <1225000>;
|
||||
+ regulator-max-microvolt = <1225000>;
|
||||
+
|
||||
+ regulator-always-on;
|
||||
+ regulator-boot-on;
|
||||
+ };
|
||||
+
|
||||
+ l2 {
|
||||
+ regulator-min-microvolt = <1200000>;
|
||||
+ regulator-max-microvolt = <1200000>;
|
||||
+ };
|
||||
+
|
||||
+ l3 {
|
||||
+ regulator-min-microvolt = <1200000>;
|
||||
+ regulator-max-microvolt = <1200000>;
|
||||
+ };
|
||||
+
|
||||
+ l4 {
|
||||
+ regulator-min-microvolt = <1225000>;
|
||||
+ regulator-max-microvolt = <1225000>;
|
||||
+ };
|
||||
+
|
||||
+ l5 {
|
||||
+ regulator-min-microvolt = <1800000>;
|
||||
+ regulator-max-microvolt = <1800000>;
|
||||
+ };
|
||||
+
|
||||
+ l6 {
|
||||
+ regulator-min-microvolt = <1800000>;
|
||||
+ regulator-max-microvolt = <1800000>;
|
||||
+
|
||||
+ regulator-boot-on;
|
||||
+ };
|
||||
+
|
||||
+ l7 {
|
||||
+ regulator-min-microvolt = <1800000>;
|
||||
+ regulator-max-microvolt = <1800000>;
|
||||
+
|
||||
+ regulator-boot-on;
|
||||
+ };
|
||||
+
|
||||
+ l8 {
|
||||
+ regulator-min-microvolt = <1800000>;
|
||||
+ regulator-max-microvolt = <1800000>;
|
||||
+ };
|
||||
+
|
||||
+ l9 {
|
||||
+ regulator-min-microvolt = <1800000>;
|
||||
+ regulator-max-microvolt = <2950000>;
|
||||
+ };
|
||||
+
|
||||
+ l11 {
|
||||
+ regulator-min-microvolt = <1300000>;
|
||||
+ regulator-max-microvolt = <1350000>;
|
||||
+ };
|
||||
+
|
||||
+ l12 {
|
||||
+ regulator-min-microvolt = <1800000>;
|
||||
+ regulator-max-microvolt = <1800000>;
|
||||
+
|
||||
+ regulator-always-on;
|
||||
+ regulator-boot-on;
|
||||
+ };
|
||||
+
|
||||
+ l13 {
|
||||
+ regulator-min-microvolt = <1800000>;
|
||||
+ regulator-max-microvolt = <2950000>;
|
||||
+
|
||||
+ regulator-boot-on;
|
||||
+ };
|
||||
+
|
||||
+ l14 {
|
||||
+ regulator-min-microvolt = <1800000>;
|
||||
+ regulator-max-microvolt = <1800000>;
|
||||
+ };
|
||||
+
|
||||
+ l15 {
|
||||
+ regulator-min-microvolt = <2050000>;
|
||||
+ regulator-max-microvolt = <2050000>;
|
||||
+ };
|
||||
+
|
||||
+ l16 {
|
||||
+ regulator-min-microvolt = <2700000>;
|
||||
+ regulator-max-microvolt = <2700000>;
|
||||
+ };
|
||||
+
|
||||
+ l17 {
|
||||
+ regulator-min-microvolt = <2700000>;
|
||||
+ regulator-max-microvolt = <2700000>;
|
||||
+ };
|
||||
+
|
||||
+ l18 {
|
||||
+ regulator-min-microvolt = <2850000>;
|
||||
+ regulator-max-microvolt = <2850000>;
|
||||
+ };
|
||||
+
|
||||
+ l19 {
|
||||
+ regulator-min-microvolt = <3300000>;
|
||||
+ regulator-max-microvolt = <3300000>;
|
||||
+ };
|
||||
+
|
||||
+ l20 {
|
||||
+ regulator-min-microvolt = <2950000>;
|
||||
+ regulator-max-microvolt = <2950000>;
|
||||
+
|
||||
+ regulator-allow-set-load;
|
||||
+ regulator-boot-on;
|
||||
+ regulator-system-load = <200000>;
|
||||
+ };
|
||||
+
|
||||
+ l21 {
|
||||
+ regulator-min-microvolt = <2950000>;
|
||||
+ regulator-max-microvolt = <2950000>;
|
||||
+
|
||||
+ regulator-boot-on;
|
||||
+ };
|
||||
+
|
||||
+ l22 {
|
||||
+ regulator-min-microvolt = <3000000>;
|
||||
+ regulator-max-microvolt = <3000000>;
|
||||
+ };
|
||||
+
|
||||
+ l23 {
|
||||
+ regulator-min-microvolt = <2800000>;
|
||||
+ regulator-max-microvolt = <2800000>;
|
||||
+ };
|
||||
+
|
||||
+ l24 {
|
||||
+ regulator-min-microvolt = <3075000>;
|
||||
+ regulator-max-microvolt = <3075000>;
|
||||
+
|
||||
+ regulator-boot-on;
|
||||
+ };
|
||||
+ };
|
||||
+ };
|
||||
+ };
|
||||
+ };
|
||||
+};
|
||||
+
|
||||
+&soc {
|
||||
+ sdhci@f9824900 {
|
||||
+ status = "ok";
|
||||
+
|
||||
+ vmmc-supply = <&pm8941_l20>;
|
||||
+ vqmmc-supply = <&pm8941_s3>;
|
||||
+
|
||||
+ bus-width = <8>;
|
||||
+ non-removable;
|
||||
+
|
||||
+ pinctrl-names = "default";
|
||||
+ pinctrl-0 = <&sdhc1_pin_a>;
|
||||
+ };
|
||||
+
|
||||
+ sdhci@f98a4900 {
|
||||
+ status = "ok";
|
||||
+
|
||||
+ bus-width = <4>;
|
||||
+
|
||||
+ vmmc-supply = <&pm8941_l21>;
|
||||
+ vqmmc-supply = <&pm8941_l13>;
|
||||
+
|
||||
+ cd-gpios = <&msmgpio 62 GPIO_ACTIVE_LOW>;
|
||||
+
|
||||
+ pinctrl-names = "default";
|
||||
+ pinctrl-0 = <&sdhc2_pin_a>, <&sdhc2_cd_pin_a>;
|
||||
+ };
|
||||
+
|
||||
+ serial@f991e000 {
|
||||
+ status = "ok";
|
||||
+
|
||||
+ pinctrl-names = "default";
|
||||
+ pinctrl-0 = <&blsp1_uart2_pin_a>;
|
||||
+ };
|
||||
+
|
||||
+
|
||||
+ pinctrl@fd510000 {
|
||||
+ blsp1_uart2_pin_a: blsp1-uart2-pin-active {
|
||||
+ rx {
|
||||
+ pins = "gpio5";
|
||||
+ function = "blsp_uart2";
|
||||
+
|
||||
+ drive-strength = <2>;
|
||||
+ bias-pull-up;
|
||||
+ };
|
||||
+
|
||||
+ tx {
|
||||
+ pins = "gpio4";
|
||||
+ function = "blsp_uart2";
|
||||
+
|
||||
+ drive-strength = <4>;
|
||||
+ bias-disable;
|
||||
+ };
|
||||
+ };
|
||||
+
|
||||
+ i2c2_pins: i2c2 {
|
||||
+ mux {
|
||||
+ pins = "gpio6", "gpio7";
|
||||
+ function = "blsp_i2c2";
|
||||
+
|
||||
+ drive-strength = <2>;
|
||||
+ bias-disable;
|
||||
+ };
|
||||
+ };
|
||||
+
|
||||
+ sdhc1_pin_a: sdhc1-pin-active {
|
||||
+ clk {
|
||||
+ pins = "sdc1_clk";
|
||||
+ drive-strength = <16>;
|
||||
+ bias-disable;
|
||||
+ };
|
||||
+
|
||||
+ cmd-data {
|
||||
+ pins = "sdc1_cmd", "sdc1_data";
|
||||
+ drive-strength = <10>;
|
||||
+ bias-pull-up;
|
||||
+ };
|
||||
+ };
|
||||
+
|
||||
+ sdhc2_cd_pin_a: sdhc2-cd-pin-active {
|
||||
+ pins = "gpio62";
|
||||
+ function = "gpio";
|
||||
+
|
||||
+ drive-strength = <2>;
|
||||
+ bias-disable;
|
||||
+ };
|
||||
+
|
||||
+ sdhc2_pin_a: sdhc2-pin-active {
|
||||
+ clk {
|
||||
+ pins = "sdc2_clk";
|
||||
+ drive-strength = <10>;
|
||||
+ bias-disable;
|
||||
+ };
|
||||
+
|
||||
+ cmd-data {
|
||||
+ pins = "sdc2_cmd", "sdc2_data";
|
||||
+ drive-strength = <6>;
|
||||
+ bias-pull-up;
|
||||
+ };
|
||||
+ };
|
||||
+ };
|
||||
+
|
||||
+ dma-controller@f9944000 {
|
||||
+ qcom,controlled-remotely;
|
||||
+ };
|
||||
+
|
||||
+ usb@f9a55000 {
|
||||
+ status = "ok";
|
||||
+
|
||||
+ phys = <&usb_hs1_phy>;
|
||||
+ phy-select = <&tcsr 0xb000 0>;
|
||||
+ extcon = <&smbb>, <&usb_id>;
|
||||
+ vbus-supply = <&chg_otg>;
|
||||
+
|
||||
+ hnp-disable;
|
||||
+ srp-disable;
|
||||
+ adp-disable;
|
||||
+
|
||||
+ ulpi {
|
||||
+ phy@a {
|
||||
+ status = "ok";
|
||||
+
|
||||
+ v1p8-supply = <&pm8941_l6>;
|
||||
+ v3p3-supply = <&pm8941_l24>;
|
||||
+
|
||||
+ extcon = <&smbb>;
|
||||
+ qcom,init-seq = /bits/ 8 <0x1 0x64>;
|
||||
+ };
|
||||
+ };
|
||||
+ };
|
||||
+};
|
||||
+
|
||||
+&spmi_bus {
|
||||
+ pm8941@0 {
|
||||
+ charger@1000 {
|
||||
+ qcom,fast-charge-safe-current = <1300000>;
|
||||
+ qcom,fast-charge-current-limit = <1300000>;
|
||||
+ qcom,dc-current-limit = <1300000>;
|
||||
+ qcom,fast-charge-safe-voltage = <4400000>;
|
||||
+ qcom,fast-charge-high-threshold-voltage = <4350000>;
|
||||
+ qcom,fast-charge-low-threshold-voltage = <3400000>;
|
||||
+ qcom,auto-recharge-threshold-voltage = <4200000>;
|
||||
+ qcom,minimum-input-voltage = <4300000>;
|
||||
+ };
|
||||
+
|
||||
+ gpios@c000 {
|
||||
+ gpio_keys_pin_a: gpio-keys-active {
|
||||
+ pins = "gpio2", "gpio3", "gpio4", "gpio5";
|
||||
+ function = "normal";
|
||||
+
|
||||
+ bias-pull-up;
|
||||
+ power-source = <PM8941_GPIO_S3>;
|
||||
+ };
|
||||
+ };
|
||||
+
|
||||
+ coincell@2800 {
|
||||
+ status = "ok";
|
||||
+ qcom,rset-ohms = <2100>;
|
||||
+ qcom,vset-millivolts = <3000>;
|
||||
+ };
|
||||
+ };
|
||||
+
|
||||
+};
|
179
main/linux-postmarketos-mainline/APKBUILD
Normal file
179
main/linux-postmarketos-mainline/APKBUILD
Normal file
|
@ -0,0 +1,179 @@
|
|||
_flavor=postmarketos-mainline
|
||||
_config="config-${_flavor}.${CARCH}"
|
||||
|
||||
pkgname=linux-${_flavor}
|
||||
|
||||
pkgver=4.14-rc6
|
||||
_kernver=${pkgver%-rc*}
|
||||
_mainver=${_kernver%.*}
|
||||
_patchlevel=${_kernver/$_mainver./}
|
||||
_basever=${_mainver}.$((_patchlevel-1))
|
||||
pkgrel=0
|
||||
|
||||
arch="all"
|
||||
pkgdesc="Linux for pmOS supported chipsets (mainline, more bleeding-edge than stable)"
|
||||
url="https://kernel.org/"
|
||||
depends="postmarketos-mkinitfs"
|
||||
makedepends="perl sed installkernel bash gmp-dev bc linux-headers elfutils-dev openssl-dev busybox-static-armhf"
|
||||
options="!strip !check !tracedeps"
|
||||
install=
|
||||
source="
|
||||
https://cdn.kernel.org/pub/linux/kernel/v$_mainver.x/linux-$_basever.tar.xz
|
||||
$pkgname-$_kernver-rc1.patch::https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/rawdiff/?id=v$_kernver-rc1&id2=v$_basever
|
||||
$pkgname-$pkgver.patch::https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/rawdiff/?id=v$pkgver&id2=v$_kernver-rc1
|
||||
config-${_flavor}.armhf
|
||||
config-${_flavor}.aarch64
|
||||
config-${_flavor}.x86_64
|
||||
001-sony-amami-dts.patch
|
||||
"
|
||||
|
||||
subpackages="$pkgname-dev::$CBUILD_ARCH"
|
||||
|
||||
license="GPL2"
|
||||
_abi_release=${pkgver}
|
||||
_carch=${CARCH}
|
||||
case "$_carch" in
|
||||
aarch64*) _carch="arm64" ;;
|
||||
arm*) _carch="arm" ;;
|
||||
ppc*) _carch="powerpc" ;;
|
||||
s390*) _carch="s390" ;;
|
||||
esac
|
||||
|
||||
HOSTCC="${CC:-gcc}"
|
||||
HOSTCC="${HOSTCC#${CROSS_COMPILE}}"
|
||||
|
||||
ksrcdir="$srcdir/linux-$_basever"
|
||||
|
||||
prepare() {
|
||||
local _patch_failed=
|
||||
cd "$ksrcdir"
|
||||
# first apply patches in specified order
|
||||
for i in $source; do
|
||||
case $i in
|
||||
*.patch|*.patch::*)
|
||||
_patch=${i%::*}
|
||||
msg "Applying $_patch..."
|
||||
if ! patch -s -p1 -N -i "$srcdir"/$_patch; then
|
||||
echo $_patch >>failed
|
||||
_patch_failed=1
|
||||
fi
|
||||
;;
|
||||
esac
|
||||
done
|
||||
|
||||
if ! [ -z "$_patch_failed" ]; then
|
||||
error "The following patches failed:"
|
||||
cat failed
|
||||
return 1
|
||||
fi
|
||||
|
||||
mkdir -p "$srcdir"/build
|
||||
cp -v "$srcdir"/$_config "$srcdir"/build/.config
|
||||
make -C "$ksrcdir" O="$srcdir"/build ARCH="$_carch" HOSTCC="$HOSTCC" \
|
||||
olddefconfig
|
||||
}
|
||||
|
||||
|
||||
|
||||
# this is so we can do: 'abuild menuconfig' to reconfigure kernel
|
||||
menuconfig() {
|
||||
cd "$srcdir"/build
|
||||
make ARCH="$_carch" menuconfig
|
||||
cp .config "$startdir"/$_config
|
||||
}
|
||||
|
||||
build() {
|
||||
cd "$srcdir"/build
|
||||
unset LDFLAGS
|
||||
make ARCH="$_carch" CC="${CC:-gcc}" \
|
||||
KBUILD_BUILD_VERSION="$((pkgrel + 1 ))-${_flavor}" \
|
||||
CFLAGS_MODULE=-fno-pic
|
||||
}
|
||||
|
||||
package() {
|
||||
cd "$srcdir/build/arch/${_carch}/boot"
|
||||
|
||||
if [ "$CARCH" == "aarch64" ]; then
|
||||
install -Dm644 "$srcdir/build/arch/${_carch}/boot/Image" \
|
||||
"$pkgdir/boot/vmlinuz-$_flavor"
|
||||
else
|
||||
install -Dm644 "$srcdir/build/arch/${_carch}/boot/"*zImage \
|
||||
"$pkgdir/boot/vmlinuz-$_flavor"
|
||||
fi
|
||||
|
||||
install -D "$srcdir/build/include/config/kernel.release" \
|
||||
"$pkgdir/usr/share/kernel/$_flavor/kernel.release"
|
||||
|
||||
cd "$srcdir"/build
|
||||
|
||||
local _install
|
||||
case "$CARCH" in
|
||||
aarch64*|arm*) _install="modules_install dtbs_install" ;;
|
||||
*) _install="modules_install" ;;
|
||||
esac
|
||||
|
||||
make -j1 $_install \
|
||||
ARCH="$_carch" \
|
||||
INSTALL_MOD_PATH="$pkgdir" \
|
||||
INSTALL_DTBS_PATH="$pkgdir/usr/share/dtb"
|
||||
}
|
||||
|
||||
|
||||
dev() {
|
||||
# copy the only the parts that we really need for build 3rd party
|
||||
# kernel modules and install those as /usr/src/linux-headers,
|
||||
# simlar to what ubuntu does
|
||||
#
|
||||
# this way you dont need to install the 300-400 kernel sources to
|
||||
# build a tiny kernel module
|
||||
#
|
||||
pkgdesc="Headers and script for third party modules for postmarketos kernel"
|
||||
depends="gmp-dev bash perl"
|
||||
local dir="$subpkgdir"/usr/src/linux-headers-${_abi_release}
|
||||
|
||||
# first we import config, run prepare to set up for building
|
||||
# external modules, and create the scripts
|
||||
mkdir -p "$dir"
|
||||
cp "$srcdir"/$_config "$dir"/.config
|
||||
make -j1 -C "$ksrcdir" O="$dir" ARCH="$_carch" HOSTCC="$HOSTCC" \
|
||||
olddefconfig prepare modules_prepare scripts
|
||||
|
||||
# needed for 3rd party modules
|
||||
# https://bugzilla.kernel.org/show_bug.cgi?id=11143
|
||||
case "$CARCH" in
|
||||
ppc*) (cd "$dir" && make arch/powerpc/lib/crtsavres.o);;
|
||||
esac
|
||||
|
||||
# remove the stuff that points to real sources. we want 3rd party
|
||||
# modules to believe this is the soruces
|
||||
rm "$dir"/Makefile "$dir"/source
|
||||
|
||||
# copy the needed stuff from real sources
|
||||
#
|
||||
# this is taken from ubuntu kernel build script
|
||||
# http://kernel.ubuntu.com/git/ubuntu/ubuntu-zesty.git/tree/debian/rules.d/3-binary-indep.mk
|
||||
|
||||
cd "$ksrcdir"
|
||||
find . -path './include/*' -prune \
|
||||
-o -path './scripts/*' -prune -o -type f \
|
||||
\( -name 'Makefile*' -o -name 'Kconfig*' -o -name 'Kbuild*' -o \
|
||||
-name '*.sh' -o -name '*.pl' -o -name '*.lds' \) \
|
||||
-print | cpio -pdm "$dir"
|
||||
cp -a scripts include "$dir"
|
||||
find $(find arch -name include -type d -print) -type f \
|
||||
| cpio -pdm "$dir"
|
||||
|
||||
install -Dm644 "$srcdir"/build/Module.symvers \
|
||||
"$dir"/Module.symvers
|
||||
|
||||
mkdir -p "$subpkgdir"/lib/modules/${_abi_release}
|
||||
ln -sf /usr/src/linux-headers-${_abi_release} \
|
||||
"$subpkgdir"/lib/modules/${_abi_release}/build
|
||||
}
|
||||
sha512sums="a557c2f0303ae618910b7106ff63d9978afddf470f03cb72aa748213e099a0ecd5f3119aea6cbd7b61df30ca6ef3ec57044d524b7babbaabddf8b08b8bafa7d2 linux-4.13.tar.xz
|
||||
ec42158f59f105995a3ccde025085343b5e6ba60de778c14cacf9aa34c40ae2e23058a03a1e6545f174c694620bbb0e423947f784c43e1474adfdcb7f866b3b6 linux-postmarketos-mainline-4.14-rc1.patch
|
||||
7e6034f6375f4e592e535c6bbb8a833ff444c2ae3281adb72a801a9eb2ea9d7e65151d9e06594607f04790eb08d05fb0d4c244c54d95b09396069cb1a4279aac linux-postmarketos-mainline-4.14-rc6.patch
|
||||
a75225750193cf31c8b6c15e7748699f842ecadc9ed573f0b10f42bb5343b4e092bcb65b359d170a42a102a4ddfe09d63c1d67550f4b99c29295fa22e1d7b995 config-postmarketos-mainline.armhf
|
||||
6310035a0a4c028cc98cab92919cca54be9b79ee9fe63211e7a05876d7befdbd8506a2f80548e228e014e99b0f91f63946352789d8d2f2134c66914163f66ab3 config-postmarketos-mainline.aarch64
|
||||
3d42c60061d12a436d19ffdf00623ea71ca31f16f690ae82ebf872d35177c283b4038cd5e270f4e610d6cf6861cef73ac63c995f1f4cfe9d6f2a4a8648ba28fb config-postmarketos-mainline.x86_64
|
||||
e34315167868c2539b2cb548b4305a5e16527b8d5b39843945bf3b0c2a67d70f7d9c93443bac2d28a744aa85012c241c68c5a4f09f0ad3e35ba8945bdaed2e2d 001-sony-amami-dts.patch"
|
File diff suppressed because it is too large
Load diff
4909
main/linux-postmarketos-mainline/config-postmarketos-mainline.armhf
Normal file
4909
main/linux-postmarketos-mainline/config-postmarketos-mainline.armhf
Normal file
File diff suppressed because it is too large
Load diff
5526
main/linux-postmarketos-mainline/config-postmarketos-mainline.x86_64
Normal file
5526
main/linux-postmarketos-mainline/config-postmarketos-mainline.x86_64
Normal file
File diff suppressed because it is too large
Load diff
|
@ -1,13 +1,4 @@
|
|||
# APKBUILD loosely based on linux-vanilla aport. Changes:
|
||||
#
|
||||
# - Use new kernel config for the postmarketos device support
|
||||
# - Package the device tree files
|
||||
#
|
||||
# Kernel config based on: arch/arm/configs/lineageos_mako_defconfig
|
||||
# Changes:
|
||||
# - enable devtmpfs (needed for udev -> touch support in weston)
|
||||
|
||||
_flavor=postmarketos
|
||||
_flavor=postmarketos-stable
|
||||
_hash="7b6fbfd899b4133e4f789843e5967beb139ec4d2"
|
||||
_config="config-${_flavor}.${CARCH}"
|
||||
|
||||
|
@ -21,7 +12,7 @@ esac
|
|||
pkgrel=0
|
||||
|
||||
arch="all"
|
||||
pkgdesc="Mainline Linux for pmOS supported chipsets (OMAP)"
|
||||
pkgdesc="Linux for pmOS supported chipsets (stable)"
|
||||
url="https://kernel.org/"
|
||||
depends="postmarketos-mkinitfs"
|
||||
makedepends="perl sed installkernel bash gmp-dev bc linux-headers elfutils-dev"
|
||||
|
@ -188,8 +179,8 @@ dev() {
|
|||
}
|
||||
|
||||
sha512sums="a557c2f0303ae618910b7106ff63d9978afddf470f03cb72aa748213e099a0ecd5f3119aea6cbd7b61df30ca6ef3ec57044d524b7babbaabddf8b08b8bafa7d2 linux-4.13.tar.xz
|
||||
2dbcf4eae8297b8a3bf2e886bcdba350918b2f7575a3ff8d7789f2729784c2002273acc559adff7f0577c18d8470ed1a11f67ea8a134971bc9cd63e312d9866f config-postmarketos.armhf
|
||||
d49d5d01adb7f314d5649cf8d7e917eeca9ec286eff2687c6865a7fac46e18227e278ca8965ad29bd99320a676e167256dc1b4212c5702f819e4cd2cf40c33c9 config-postmarketos.aarch64
|
||||
c1dc9a02bbe5bb047051ee4cda2454fab3c4c06a05abc86107948dd63da7b6c90dc35f48c27f04338673a49b246246f67c7b19ac942354a73058cc4088744120 config-postmarketos.x86_64
|
||||
2dbcf4eae8297b8a3bf2e886bcdba350918b2f7575a3ff8d7789f2729784c2002273acc559adff7f0577c18d8470ed1a11f67ea8a134971bc9cd63e312d9866f config-postmarketos-stable.armhf
|
||||
d49d5d01adb7f314d5649cf8d7e917eeca9ec286eff2687c6865a7fac46e18227e278ca8965ad29bd99320a676e167256dc1b4212c5702f819e4cd2cf40c33c9 config-postmarketos-stable.aarch64
|
||||
c1dc9a02bbe5bb047051ee4cda2454fab3c4c06a05abc86107948dd63da7b6c90dc35f48c27f04338673a49b246246f67c7b19ac942354a73058cc4088744120 config-postmarketos-stable.x86_64
|
||||
17c48bb7b4218297bd2be6faa5b6570ce1560a33385237a9962c0884d782c9a722a25a30077b6721d2943a9b98c29dcad6adfef718b0163c559c19a79519319b 0001-rx51-drm-regression-workaround.patch
|
||||
3046ee2ef416e0f75908063192eae076d9018cba3f87b9eb1734df6a0f0d12fe79b6bda5d7713c3d663c8f418d3db1bdb64fb88f76660345911dcb2d857f41f7 patch-4.13.9.xz"
|
Loading…
Reference in a new issue