temp/gnome-session: fork to enable aarch64 (!414)
This commit is contained in:
parent
5b77b0ff25
commit
a238ca4ff1
3 changed files with 86 additions and 0 deletions
36
temp/gnome-session/APKBUILD
Normal file
36
temp/gnome-session/APKBUILD
Normal file
|
@ -0,0 +1,36 @@
|
|||
# Forked from alpine to enable aarch64
|
||||
pkgname=gnome-session
|
||||
pkgver=3.32.0
|
||||
pkgrel=1
|
||||
pkgdesc="GNOME session manager"
|
||||
url="https://www.gnome.org/"
|
||||
arch="all !armhf !armv7 !s390x !ppc64le" # ppc64le limited by mutter
|
||||
license="GPL-2.0-or-later"
|
||||
depends="gnome-shell polkit alsa-plugins-pulse dconf pulseaudio-alsa"
|
||||
makedepends="gnome-settings-daemon-dev libsm-dev
|
||||
elogind-dev itstool libxslt libxml2-utils json-glib-dev gnome-desktop-dev
|
||||
gtk+3.0-dev startup-notification-dev upower-dev meson py3-setuptools xmlto
|
||||
docbook-xml"
|
||||
options="!check" #no tests
|
||||
subpackages="$pkgname-lang $pkgname-doc"
|
||||
source="https://download.gnome.org/sources/gnome-session/${pkgver%.*}/gnome-session-$pkgver.tar.xz"
|
||||
|
||||
build() {
|
||||
meson \
|
||||
--prefix=/usr \
|
||||
--sysconfdir=/etc \
|
||||
--localstatedir=/var \
|
||||
-Dsystemd_journal=true \
|
||||
. output
|
||||
ninja -C output
|
||||
}
|
||||
|
||||
check() {
|
||||
ninja -C output test
|
||||
}
|
||||
|
||||
package() {
|
||||
DESTDIR="$pkgdir" ninja -C output install
|
||||
}
|
||||
|
||||
sha512sums="53d5f84ba8ddbac5cfe0e4e3115c76008a3571779cad62a5fe064a409a507497a9ab93a46d6ba7ee4238ac0efb2f2c1379647855ac8058a945350c88400daf34 gnome-session-3.32.0.tar.xz"
|
35
temp/gnome-session/fail-whale-dialog.patch
Normal file
35
temp/gnome-session/fail-whale-dialog.patch
Normal file
|
@ -0,0 +1,35 @@
|
|||
$OpenBSD: patch-gnome-session_gsm-fail-whale-dialog_c,v 1.1 2017/05/30 18:14:03 ajacoutot Exp $
|
||||
|
||||
https://bugzilla.gnome.org/show_bug.cgi?id=775463
|
||||
|
||||
Index: gnome-session/gsm-fail-whale-dialog.c
|
||||
--- a/gnome-session/gsm-fail-whale-dialog.c.orig
|
||||
+++ b/gnome-session/gsm-fail-whale-dialog.c
|
||||
@@ -371,13 +371,20 @@ int main (int argc, char *argv[])
|
||||
bind_textdomain_codeset (GETTEXT_PACKAGE, "UTF-8");
|
||||
textdomain (GETTEXT_PACKAGE);
|
||||
|
||||
- gtk_init_with_args (&argc, &argv, " - fail whale",
|
||||
- entries, GETTEXT_PACKAGE,
|
||||
- &error);
|
||||
- if (error != NULL) {
|
||||
- g_warning ("%s", error->message);
|
||||
- exit (1);
|
||||
- }
|
||||
+ if (!gtk_init_with_args (&argc, &argv, " - fail whale",
|
||||
+ entries, GETTEXT_PACKAGE,
|
||||
+ &error)) {
|
||||
+ if (error != NULL) {
|
||||
+ g_warning ("%s", error->message);
|
||||
+ exit (1);
|
||||
+ }
|
||||
+
|
||||
+ /* display server probably went away. Could be for legitimate reasons, could be for
|
||||
+ * unexpected reasons. If it went away unexpectantly, that's logged elsewhere, so
|
||||
+ * let's not add noise by logging here.
|
||||
+ */
|
||||
+ return 0;
|
||||
+ }
|
||||
|
||||
fail_dialog = g_object_new (GSM_TYPE_FAIL_WHALE_DIALOG, NULL);
|
||||
fail_dialog->priv->debug_mode = debug_mode;
|
15
temp/gnome-session/no-rpmatch.patch
Normal file
15
temp/gnome-session/no-rpmatch.patch
Normal file
|
@ -0,0 +1,15 @@
|
|||
$OpenBSD: patch-gnome-session_main_c,v 1.19 2017/04/17 10:51:02 ajacoutot Exp $
|
||||
|
||||
XXX no rpmatch(3) on OpenBSD
|
||||
|
||||
--- a/gnome-session/main.c.orig Wed Apr 12 16:35:48 2017
|
||||
+++ b/gnome-session/main.c Mon Apr 17 12:40:35 2017
|
||||
@@ -311,7 +311,7 @@ main (int argc, char **argv)
|
||||
|
||||
debug_string = g_getenv ("GNOME_SESSION_DEBUG");
|
||||
if (debug_string != NULL) {
|
||||
- debug = rpmatch (debug_string) == TRUE || atoi (debug_string) == 1;
|
||||
+ debug = atoi (debug_string) == 1;
|
||||
}
|
||||
|
||||
error = NULL;
|
Loading…
Reference in a new issue