linux-purism-librem5: upgrade to 5.11.0pureos1 (MR 1960)
Purism has changed the kernel name they used, so that's reflected in the apkbuild. This kernel includes patches for renaming the audio device, and requires a corresponding upgrade to the device package to bring in the new ucm2 config changes for that.
This commit is contained in:
parent
625a71bf25
commit
9ebdbd023c
3 changed files with 397 additions and 91 deletions
|
@ -0,0 +1,188 @@
|
|||
From e691d9c22c580e1ac7096dd7aca1663a8d9e8ab6 Mon Sep 17 00:00:00 2001
|
||||
From: Clayton Craft <clayton@craftyguy.net>
|
||||
Date: Fri, 19 Feb 2021 21:12:31 -0800
|
||||
Subject: [PATCH] Revert "arm64: dts: librem5: Drop separte DP device tree"
|
||||
|
||||
This reverts commit 25c600f6659cece477d4ce1fbfd219713430a327, which
|
||||
breaks kwin.
|
||||
|
||||
---
|
||||
arch/arm64/boot/dts/freescale/Makefile | 2 ++
|
||||
.../dts/freescale/imx8mq-librem5-r3-dp.dts | 36 +++++++++++++++++++
|
||||
.../boot/dts/freescale/imx8mq-librem5-r3.dts | 24 -------------
|
||||
.../dts/freescale/imx8mq-librem5-r4-dp.dts | 35 ++++++++++++++++++
|
||||
.../boot/dts/freescale/imx8mq-librem5-r4.dts | 24 -------------
|
||||
5 files changed, 73 insertions(+), 48 deletions(-)
|
||||
create mode 100644 arch/arm64/boot/dts/freescale/imx8mq-librem5-r3-dp.dts
|
||||
create mode 100644 arch/arm64/boot/dts/freescale/imx8mq-librem5-r4-dp.dts
|
||||
|
||||
diff --git a/arch/arm64/boot/dts/freescale/Makefile b/arch/arm64/boot/dts/freescale/Makefile
|
||||
index 8c4b8487e80a..5395e39a1208 100644
|
||||
--- a/arch/arm64/boot/dts/freescale/Makefile
|
||||
+++ b/arch/arm64/boot/dts/freescale/Makefile
|
||||
@@ -39,7 +39,9 @@ dtb-$(CONFIG_ARCH_MXC) += imx8mq-librem5.dtb
|
||||
dtb-$(CONFIG_ARCH_MXC) += imx8mq-librem5-devkit.dtb
|
||||
dtb-$(CONFIG_ARCH_MXC) += imx8mq-librem5-r2.dtb
|
||||
dtb-$(CONFIG_ARCH_MXC) += imx8mq-librem5-r3.dtb
|
||||
+dtb-$(CONFIG_ARCH_MXC) += imx8mq-librem5-r3-dp.dtb
|
||||
dtb-$(CONFIG_ARCH_MXC) += imx8mq-librem5-r4.dtb
|
||||
+dtb-$(CONFIG_ARCH_MXC) += imx8mq-librem5-r4-dp.dtb
|
||||
dtb-$(CONFIG_ARCH_MXC) += imx8mq-nitrogen.dtb
|
||||
dtb-$(CONFIG_ARCH_MXC) += imx8mq-phanbell.dtb
|
||||
dtb-$(CONFIG_ARCH_MXC) += imx8mq-pico-pi.dtb
|
||||
diff --git a/arch/arm64/boot/dts/freescale/imx8mq-librem5-r3-dp.dts b/arch/arm64/boot/dts/freescale/imx8mq-librem5-r3-dp.dts
|
||||
new file mode 100644
|
||||
index 000000000000..931ded5fc6e2
|
||||
--- /dev/null
|
||||
+++ b/arch/arm64/boot/dts/freescale/imx8mq-librem5-r3-dp.dts
|
||||
@@ -0,0 +1,36 @@
|
||||
+// SPDX-License-Identifier: GPL-2.0+
|
||||
+/*
|
||||
+ * Copyright 2020 Purism SPC
|
||||
+ */
|
||||
+
|
||||
+/dts-v1/;
|
||||
+
|
||||
+#include "imx8mq-librem5-r3.dts"
|
||||
+
|
||||
+&usb_dwc3_0 {
|
||||
+ dr_mode = "host";
|
||||
+};
|
||||
+
|
||||
+/delete-node/ &dcss_dsi_out;
|
||||
+/delete-node/ &mipi_dsi_dcss_in;
|
||||
+&dcss {
|
||||
+ status = "okay";
|
||||
+
|
||||
+ port@0 {
|
||||
+ dcss_dp_out: endpoint {
|
||||
+ remote-endpoint = <&hdmi_in>;
|
||||
+ };
|
||||
+ };
|
||||
+};
|
||||
+
|
||||
+&hdmi {
|
||||
+ compatible = "nxp,imx8mq-cdns-dp";
|
||||
+ extcon = <&tps65982>;
|
||||
+ lane-mapping = <0xc6>;
|
||||
+ status = "okay";
|
||||
+ port@1 {
|
||||
+ hdmi_in: endpoint {
|
||||
+ remote-endpoint = <&dcss_dp_out>;
|
||||
+ };
|
||||
+ };
|
||||
+};
|
||||
diff --git a/arch/arm64/boot/dts/freescale/imx8mq-librem5-r3.dts b/arch/arm64/boot/dts/freescale/imx8mq-librem5-r3.dts
|
||||
index 973e6bccb928..16e09c8851b1 100644
|
||||
--- a/arch/arm64/boot/dts/freescale/imx8mq-librem5-r3.dts
|
||||
+++ b/arch/arm64/boot/dts/freescale/imx8mq-librem5-r3.dts
|
||||
@@ -61,30 +61,6 @@ &camera_front {
|
||||
vdd1-supply = <®_camera1_pwr_en>;
|
||||
};
|
||||
|
||||
-/delete-node/ &dcss_dsi_out;
|
||||
-/delete-node/ &mipi_dsi_dcss_in;
|
||||
-&dcss {
|
||||
- status = "okay";
|
||||
-
|
||||
- port@0 {
|
||||
- dcss_dp_out: endpoint {
|
||||
- remote-endpoint = <&hdmi_in>;
|
||||
- };
|
||||
- };
|
||||
-};
|
||||
-
|
||||
-&hdmi {
|
||||
- compatible = "nxp,imx8mq-cdns-dp";
|
||||
- extcon = <&tps65982>;
|
||||
- lane-mapping = <0xc6>;
|
||||
- status = "okay";
|
||||
- port@1 {
|
||||
- hdmi_in: endpoint {
|
||||
- remote-endpoint = <&dcss_dp_out>;
|
||||
- };
|
||||
- };
|
||||
-};
|
||||
-
|
||||
&iomuxc {
|
||||
pinctrl_r3_camera_pwr: r3camerapwrgrp {
|
||||
fsl,pins = <
|
||||
diff --git a/arch/arm64/boot/dts/freescale/imx8mq-librem5-r4-dp.dts b/arch/arm64/boot/dts/freescale/imx8mq-librem5-r4-dp.dts
|
||||
new file mode 100644
|
||||
index 000000000000..97a14e0891e4
|
||||
--- /dev/null
|
||||
+++ b/arch/arm64/boot/dts/freescale/imx8mq-librem5-r4-dp.dts
|
||||
@@ -0,0 +1,35 @@
|
||||
+// SPDX-License-Identifier: GPL-2.0+
|
||||
+/*
|
||||
+ * Copyright 2020 Purism SPC
|
||||
+ */
|
||||
+
|
||||
+/dts-v1/;
|
||||
+
|
||||
+#include "imx8mq-librem5-r4.dts"
|
||||
+
|
||||
+&usb_dwc3_0 {
|
||||
+ dr_mode = "host";
|
||||
+};
|
||||
+
|
||||
+/delete-node/ &dcss_dsi_out;
|
||||
+/delete-node/ &mipi_dsi_dcss_in;
|
||||
+&dcss {
|
||||
+ status = "okay";
|
||||
+
|
||||
+ port@0 {
|
||||
+ dcss_dp_out: endpoint {
|
||||
+ remote-endpoint = <&hdmi_in>;
|
||||
+ };
|
||||
+ };
|
||||
+};
|
||||
+
|
||||
+&hdmi {
|
||||
+ compatible = "nxp,imx8mq-cdns-dp";
|
||||
+ lane-mapping = <0xc6>;
|
||||
+ status = "okay";
|
||||
+ port@1 {
|
||||
+ hdmi_in: endpoint {
|
||||
+ remote-endpoint = <&dcss_dp_out>;
|
||||
+ };
|
||||
+ };
|
||||
+};
|
||||
diff --git a/arch/arm64/boot/dts/freescale/imx8mq-librem5-r4.dts b/arch/arm64/boot/dts/freescale/imx8mq-librem5-r4.dts
|
||||
index 301b5a0e57c2..ea10d0f34d54 100644
|
||||
--- a/arch/arm64/boot/dts/freescale/imx8mq-librem5-r4.dts
|
||||
+++ b/arch/arm64/boot/dts/freescale/imx8mq-librem5-r4.dts
|
||||
@@ -52,30 +52,6 @@ &camera_front {
|
||||
vdd1-supply = <®_camera1_pwr_en>;
|
||||
};
|
||||
|
||||
-/delete-node/ &dcss_dsi_out;
|
||||
-/delete-node/ &mipi_dsi_dcss_in;
|
||||
-&dcss {
|
||||
- status = "okay";
|
||||
-
|
||||
- port@0 {
|
||||
- dcss_dp_out: endpoint {
|
||||
- remote-endpoint = <&hdmi_in>;
|
||||
- };
|
||||
- };
|
||||
-};
|
||||
-
|
||||
-&hdmi {
|
||||
- compatible = "nxp,imx8mq-cdns-dp";
|
||||
- extcon = <&tps65982>;
|
||||
- lane-mapping = <0xc6>;
|
||||
- status = "okay";
|
||||
- port@1 {
|
||||
- hdmi_in: endpoint {
|
||||
- remote-endpoint = <&dcss_dp_out>;
|
||||
- };
|
||||
- };
|
||||
-};
|
||||
-
|
||||
&iomuxc {
|
||||
pinctrl_r4_camera_pwr: r4camerapwrgrp {
|
||||
fsl,pins = <
|
||||
--
|
||||
2.30.1
|
||||
|
|
@ -1,11 +1,11 @@
|
|||
# Reference: <https://postmarketos.org/vendorkernel>
|
||||
# Maintainer: Clayton Craft <clayton@craftyguy.net>
|
||||
pkgname=linux-purism-librem5
|
||||
pkgver=5.9.16
|
||||
pkgver=5.11.0
|
||||
pkgrel=0
|
||||
_purismrel=2
|
||||
_purismrel=1
|
||||
# <kernel ver>.<purism kernel release>
|
||||
_purismver=${pkgver}+librem5.$_purismrel
|
||||
_purismver=${pkgver}pureos$_purismrel
|
||||
pkgdesc="Purism Librem 5 phone kernel fork"
|
||||
arch="aarch64"
|
||||
_carch="arm64"
|
||||
|
@ -36,6 +36,7 @@ _config="config-$_flavor.$arch"
|
|||
source="
|
||||
$pkgname-$_purismver.tar.gz::https://source.puri.sm/Librem5/$_repository/-/archive/pureos/$_purismver/$_repository-pureos-$_purismver.tar.gz
|
||||
8f11380ec32912370b8ae9134a0387a6f18862f7.patch
|
||||
0001-Revert-arm64-dts-librem5-Drop-separte-DP-device-tree.patch
|
||||
$_config
|
||||
"
|
||||
builddir="$srcdir/$_repository-pureos-$_purismver"
|
||||
|
@ -62,6 +63,7 @@ package() {
|
|||
INSTALL_DTBS_PATH="$pkgdir/usr/share/dtb"
|
||||
|
||||
}
|
||||
sha512sums="9f1a05574c9e121ac4bd083a9951af53e454d53a7e5a72d928ca8196134d906cdda16d48a2fd6beaa7451598faf00031e19fe1926960c92e1fbfb3df1f778b94 linux-purism-librem5-5.9.16+librem5.2.tar.gz
|
||||
sha512sums="9e50bb6a443c63c1989484e1e7e6428482ee31b378965044828ea2aed604c631f14eedce7f54fc01b48ce1275912a84251484ac373e3385f515e6a54bc508582 linux-purism-librem5-5.11.0pureos1.tar.gz
|
||||
9870bff4b187188b519b23264c2634ee4232011fed6d2f66a7b4971db354ac3dffa0e1552bd0dc953c66ec622e18ce8899fdbcfba94f60867fc5004d6da96753 8f11380ec32912370b8ae9134a0387a6f18862f7.patch
|
||||
845c7af0aae1c02dfb670b2935ccb39fae9b37212c8d5de4e0b8d12f670a45924150bcf6bcf0021d9219a954fc5ff54d5d6c4a119db3fdf26a15cccdd82b850f config-purism-librem5.aarch64"
|
||||
5baae99010bde62e253fdd56f21ba096c217ba2ab9c367c80b34bc0f445a79a8fb8b5d14682f71ad6061d73c81fc16a608f4be037d792978dbbaf74267844260 0001-Revert-arm64-dts-librem5-Drop-separte-DP-device-tree.patch
|
||||
b41dc60afab81f9f7c7f4788bf9554cecd7e5da8f1ada502e2097667769437340112a8b5f77199bc28f627343558386aae08586fcdb977b76c3b677f24eba782 config-purism-librem5.aarch64"
|
||||
|
|
File diff suppressed because it is too large
Load diff
Loading…
Add table
Reference in a new issue