main/abuild-sign-noinclude: upgrade to 3.4.0
Upgrade and add depends to static libraries to make it build again. When the package was added initially, the static libraries were part of the respective -dev packages.
This commit is contained in:
parent
2c57359b8a
commit
9e94a89cb4
2 changed files with 5 additions and 38 deletions
|
@ -1,33 +0,0 @@
|
|||
From d4d3f5bcfcc9a11aadc3de3199dd681b195ec574 Mon Sep 17 00:00:00 2001
|
||||
From: pmb-test <pmb-test@pmb-test>
|
||||
Date: Thu, 22 Nov 2018 09:06:45 +0100
|
||||
Subject: [PATCH 1/3] fix abuild-tar.static target
|
||||
|
||||
---
|
||||
Makefile | 3 ++-
|
||||
1 file changed, 2 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/Makefile b/Makefile
|
||||
index b5997a4..d2445f3 100644
|
||||
--- a/Makefile
|
||||
+++ b/Makefile
|
||||
@@ -47,6 +47,7 @@ OBJS-abuild-tar = abuild-tar.o
|
||||
CFLAGS-abuild-tar.o = $(SSL_CFLAGS)
|
||||
LDFLAGS-abuild-tar = $(SSL_LDFLAGS)
|
||||
LIBS-abuild-tar = $(SSL_LIBS)
|
||||
+LIBS-abuild-tar.static = $(LIBS-abuild-tar)
|
||||
|
||||
OBJS-abuild-gzsplit = abuild-gzsplit.o
|
||||
LDFLAGS-abuild-gzsplit = $(ZLIB_LIBS)
|
||||
@@ -86,7 +87,7 @@ abuild-gzsplit: abuild-gzsplit.o
|
||||
$(LINK)
|
||||
|
||||
abuild-tar.static: abuild-tar.o
|
||||
- $(CC) $(CPPFLAGS) $(CFLAGS) $(CFLAGS-$@) -o $@ -static $(LIBS-$@) $^
|
||||
+ $(CC) -static $(CPPFLAGS) $(CFLAGS) $(CFLAGS-$@) $^ -o $@ $(LIBS-$@)
|
||||
|
||||
help:
|
||||
@echo "$(P) makefile"
|
||||
--
|
||||
2.17.2
|
||||
|
|
@ -1,17 +1,18 @@
|
|||
# Maintainer: Oliver Smith <ollieparanoid@postmarketos.org>
|
||||
# Contributor: Oliver Smith <ollieparanoid@postmarketos.org>
|
||||
pkgname=abuild-sign-noinclude
|
||||
pkgver=3.3.0_pre1
|
||||
pkgver=3.4.0
|
||||
pkgrel=0
|
||||
pkgdesc="self-contained abuild-sign to be used by non-Alpine systems"
|
||||
url="https://git.alpinelinux.org/cgit/abuild/"
|
||||
arch="x86_64"
|
||||
license="GPL-2.0"
|
||||
makedepends="openssl-dev zlib-dev pkgconf"
|
||||
makedepends="openssl-dev openssl-libs-static zlib-dev zlib-static pkgconf"
|
||||
options="!check"
|
||||
|
||||
# first patch is being upstreamed here:
|
||||
# https://github.com/alpinelinux/abuild/pull/49
|
||||
source="https://dev.alpinelinux.org/archive/abuild/abuild-${pkgver}.tar.xz
|
||||
0001-fix-abuild-tar.static-target.patch
|
||||
0002-add-abuild-sign.noinclude-target.patch
|
||||
0003-use-abuild-tar.static-from-script-directory.patch"
|
||||
builddir="$srcdir/abuild-$pkgver"
|
||||
|
@ -34,7 +35,6 @@ package() {
|
|||
install -Dm755 abuild-sign.noinclude "$pkgdir"/usr/bin/abuild-sign.noinclude
|
||||
}
|
||||
|
||||
sha512sums="5d3c2c04a7d6ede2c08b524423f9594ced42d4d67f10327996a38e0782fc2de1f8086187aa9a9072df5c1aced540bdcf1b8002b832df4cf2c6a56f6f89657aa7 abuild-3.3.0_pre1.tar.xz
|
||||
29aa05c145ac02fbb6be7378c8ba3cf25ec8f49898a6d755cd9cefa4ff1416914f03ca92320b06b602161e549bcfe376f059477eb9fc0722e9f634abf5d60a24 0001-fix-abuild-tar.static-target.patch
|
||||
sha512sums="0ddf1cef2e79628a4de06015ba217432711ee76751ccc487fd3b1af9cae37ed1b8c5afdc0b916322472314ccee8a6d1c17ccb5b55f6eebfb54444199d2281d3e abuild-3.4.0.tar.xz
|
||||
a7a207094a80856e0aa10591611ee6b7c235df165791574acbb010a3c7d593d8a918f157bbff2e885ffa159e5c777ab9bf4475447a846d78cd6ca81112ea271d 0002-add-abuild-sign.noinclude-target.patch
|
||||
3253540dc0def37c31ace080e2e78a10516c903ed96eba950895e99e5143cd7d58ddbbfcfae2be37be8d31a53578291cac8fca8b6270faea630889646f31b2fd 0003-use-abuild-tar.static-from-script-directory.patch"
|
||||
|
|
Loading…
Reference in a new issue