[GitLab reopen] New device: Sony Xperia M (sony-nicki)
This commit is contained in:
parent
758c056002
commit
99ead15ee1
15 changed files with 4664 additions and 0 deletions
8
device/device-sony-nicki/90-android-touch-dev.rules
Normal file
8
device/device-sony-nicki/90-android-touch-dev.rules
Normal file
|
@ -0,0 +1,8 @@
|
|||
# udev rules file
|
||||
# All device names can be read from weston's logfile
|
||||
|
||||
# Touchscreen (use 'weston-calibrator' to calibrate)
|
||||
SUBSYSTEM=="input", ATTRS{name}=="synaptics_dsx_i2c", \
|
||||
ENV{ID_INPUT}="1", ENV{ID_INPUT_TOUCHSCREEN}="1" \
|
||||
ENV{WL_CALIBRATION}="1.013786 0.035310 -24.920929 -0.008370 0.990421 12.094299"
|
||||
|
38
device/device-sony-nicki/APKBUILD
Executable file
38
device/device-sony-nicki/APKBUILD
Executable file
|
@ -0,0 +1,38 @@
|
|||
# Reference: <https://postmarketos.org/devicepkg>
|
||||
pkgname="device-sony-nicki"
|
||||
pkgdesc="Sony Xperia M"
|
||||
pkgver=0.1
|
||||
pkgrel=0
|
||||
url="https://postmarketos.org"
|
||||
license="MIT"
|
||||
arch="noarch"
|
||||
options="!check"
|
||||
depends="postmarketos-base linux-sony-nicki mkbootimg mesa-dri-swrast mdss-fb-init-hack msm-fb-refresher"
|
||||
makedepends="devicepkg-dev"
|
||||
source="deviceinfo 90-android-touch-dev.rules screen-workaround.sh fb.modes pointercal"
|
||||
|
||||
build() {
|
||||
devicepkg_build $startdir $pkgname
|
||||
}
|
||||
|
||||
package() {
|
||||
devicepkg_package $startdir $pkgname
|
||||
install -D -m644 "$srcdir"/90-android-touch-dev.rules \
|
||||
"$pkgdir"/etc/udev/rules.d/90-android-touch-dev.rules
|
||||
install -D -m644 "$srcdir"/screen-workaround.sh \
|
||||
"$pkgdir"/etc/profile.d/screen-workaround.sh
|
||||
install -D -m644 "$srcdir"/fb.modes \
|
||||
"$pkgdir"/etc/fb.modes
|
||||
install -D -m644 "$srcdir"/pointercal \
|
||||
"$pkgdir"/etc/pointercal
|
||||
|
||||
#I have no idea what it does but it's included in sony-yuga and
|
||||
#if I do same on here, segfaults stop appearing in dmesg
|
||||
ln -s /dev/null "$pkgdir"/etc/udev/rules.d/60-persistent-v4l.rules
|
||||
}
|
||||
|
||||
sha512sums="ca821636f50ad0991ce24aa25edd6b961be747941de234d5190d08dc4962815ade591a5fd648ce6476512d37f7373ab4b2d3ff76d6783af81eaa66e487c14dde deviceinfo
|
||||
a3d3a0cf43c5f216279666143d6042f2669dbe3dc5ecec2817b6118a0c122f5b927799b37432bee3167359c118d0142fd8e8e8d67374e8ab1d837673f217e1ae 90-android-touch-dev.rules
|
||||
8cecfb3c726a59ebdf2a9e53df11e784d662329b50f288344121e7774368ee782c27229d94aee1f2f4d43eb6ef764ccb63af547beb43438b9750b2b888be61ff screen-workaround.sh
|
||||
aac9a5d4c856b6feaf4f2961251fbc81d9173e24c3b20806e803711b40e388a173abf2651d5d828d36a504ef2de12c1c1eacea1f1b9479e31f55234012140405 fb.modes
|
||||
016111b7618e2509186fd91dd238cdfb51c37a02af98ba01d3cf27358ff901f71f7ff5e798752334e720bf8108b907a31e9242085c8c915748f2d9391f86dfc4 pointercal"
|
34
device/device-sony-nicki/deviceinfo
Executable file
34
device/device-sony-nicki/deviceinfo
Executable file
|
@ -0,0 +1,34 @@
|
|||
# Reference: <https://postmarketos.org/deviceinfo>
|
||||
# Please use double quotes only. You can source this file in shell scripts.
|
||||
|
||||
deviceinfo_format_version="0"
|
||||
deviceinfo_name="Sony Xperia M"
|
||||
deviceinfo_manufacturer="Sony"
|
||||
deviceinfo_date=""
|
||||
deviceinfo_dtb=""
|
||||
deviceinfo_modules_initfs=""
|
||||
deviceinfo_arch="armhf"
|
||||
|
||||
# Device related
|
||||
deviceinfo_keyboard="false"
|
||||
deviceinfo_external_storage="true"
|
||||
deviceinfo_screen_width="480"
|
||||
deviceinfo_screen_height="854"
|
||||
deviceinfo_dev_touchscreen="/dev/input/event1"
|
||||
deviceinfo_dev_touchscreen_calibration=""
|
||||
deviceinfo_dev_keyboard=""
|
||||
|
||||
# Bootloader related
|
||||
deviceinfo_flash_method="fastboot"
|
||||
deviceinfo_kernel_cmdline="panic=3 console=ttyHSL0,115200,n8 androidboot.hardware=qcom user_debug=31 msm_rtb.filter=0x3F ehci-hcd.park=3"
|
||||
deviceinfo_generate_bootimg="true"
|
||||
deviceinfo_bootimg_qcdt="false"
|
||||
deviceinfo_flash_offset_base="0x80200000"
|
||||
deviceinfo_flash_offset_kernel="0x00008000"
|
||||
deviceinfo_flash_offset_ramdisk="0x02000000"
|
||||
deviceinfo_flash_offset_second="0x00f00000"
|
||||
deviceinfo_flash_offset_tags="0x00000100"
|
||||
deviceinfo_flash_pagesize="4096"
|
||||
|
||||
#weston
|
||||
deviceinfo_weston_pixman_type="2"
|
7
device/device-sony-nicki/fb.modes
Normal file
7
device/device-sony-nicki/fb.modes
Normal file
|
@ -0,0 +1,7 @@
|
|||
mode "480x854-0"
|
||||
# D: 0.003 MHz, H: 0.004 kHz, V: 0.005 Hz
|
||||
geometry 480 854 480 854 16
|
||||
timings 400000000 44 46 16 15 4 1
|
||||
accel false
|
||||
rgba 8/0,8/8,8/16,8/24
|
||||
endmode
|
1
device/device-sony-nicki/pointercal
Normal file
1
device/device-sony-nicki/pointercal
Normal file
|
@ -0,0 +1 @@
|
|||
31536 130 -845876 82 55830 -1337000 65536 480 854
|
10
device/device-sony-nicki/screen-workaround.sh
Normal file
10
device/device-sony-nicki/screen-workaround.sh
Normal file
|
@ -0,0 +1,10 @@
|
|||
main() {
|
||||
# Wait untill graphical enviroment is running
|
||||
sleep 5
|
||||
# Workaround for buggy graphics driver
|
||||
for i in 1 2
|
||||
do
|
||||
echo 255 > /sys/class/leds/lcd-backlight/brightness
|
||||
done
|
||||
}
|
||||
|
49
device/linux-sony-nicki/00_fix_return_address.patch
Normal file
49
device/linux-sony-nicki/00_fix_return_address.patch
Normal file
|
@ -0,0 +1,49 @@
|
|||
From aeea3592a13bf12861943e44fc48f1f270941f8d Mon Sep 17 00:00:00 2001
|
||||
From: Behan Webster <behanw@converseincode.com>
|
||||
Date: Wed, 24 Sep 2014 01:06:46 +0100
|
||||
Subject: [PATCH] ARM: 8158/1: LLVMLinux: use static inline in ARM ftrace.h
|
||||
|
||||
With compilers which follow the C99 standard (like modern versions of gcc and
|
||||
clang), "extern inline" does the wrong thing (emits code for an externally
|
||||
linkable version of the inline function). In this case using static inline
|
||||
and removing the NULL version of return_address in return_address.c does
|
||||
the right thing.
|
||||
|
||||
Signed-off-by: Behan Webster <behanw@converseincode.com>
|
||||
Reviewed-by: Mark Charlebois <charlebm@gmail.com>
|
||||
Acked-by: Steven Rostedt <rostedt@goodmis.org>
|
||||
Signed-off-by: Russell King <rmk+kernel@arm.linux.org.uk>
|
||||
---
|
||||
arch/arm/include/asm/ftrace.h | 2 +-
|
||||
arch/arm/kernel/return_address.c | 5 -----
|
||||
2 files changed, 1 insertion(+), 6 deletions(-)
|
||||
|
||||
diff --git a/arch/arm/include/asm/ftrace.h b/arch/arm/include/asm/ftrace.h
|
||||
index 39eb16b0066f2..bfe2a2f5a644e 100644
|
||||
--- a/arch/arm/include/asm/ftrace.h
|
||||
+++ b/arch/arm/include/asm/ftrace.h
|
||||
@@ -45,7 +45,7 @@ void *return_address(unsigned int);
|
||||
|
||||
#else
|
||||
|
||||
-extern inline void *return_address(unsigned int level)
|
||||
+static inline void *return_address(unsigned int level)
|
||||
{
|
||||
return NULL;
|
||||
}
|
||||
diff --git a/arch/arm/kernel/return_address.c b/arch/arm/kernel/return_address.c
|
||||
index fafedd86885dd..f6aa84d5b93c9 100644
|
||||
--- a/arch/arm/kernel/return_address.c
|
||||
+++ b/arch/arm/kernel/return_address.c
|
||||
@@ -63,11 +63,6 @@ void *return_address(unsigned int level)
|
||||
#warning "TODO: return_address should use unwind tables"
|
||||
#endif
|
||||
|
||||
-void *return_address(unsigned int level)
|
||||
-{
|
||||
- return NULL;
|
||||
-}
|
||||
-
|
||||
#endif /* if defined(CONFIG_FRAME_POINTER) && !defined(CONFIG_ARM_UNWIND) / else */
|
||||
|
||||
EXPORT_SYMBOL_GPL(return_address);
|
91
device/linux-sony-nicki/01_fix_video_argb_setting.patch
Normal file
91
device/linux-sony-nicki/01_fix_video_argb_setting.patch
Normal file
|
@ -0,0 +1,91 @@
|
|||
From 79f928baf4e7b0fa8f36276b2f877da2d46a50d0 Mon Sep 17 00:00:00 2001
|
||||
From: Thadeu Lima de Souza Cascardo <cascardo@canonical.com>
|
||||
Date: Mon, 11 Dec 2017 11:00:24 -0200
|
||||
Subject: [PATCH] fix video argb setting
|
||||
|
||||
---
|
||||
drivers/video/msm/msm_fb.c | 34 +++++++++++++++++-----------------
|
||||
1 file changed, 17 insertions(+), 17 deletions(-)
|
||||
|
||||
diff --git a/drivers/video/msm/msm_fb.c b/drivers/video/msm/msm_fb.c
|
||||
index 251a5cbb753d..dcd9262a88f4 100644
|
||||
--- a/drivers/video/msm/msm_fb.c
|
||||
+++ b/drivers/video/msm/msm_fb.c
|
||||
@@ -1342,16 +1342,16 @@ static int msm_fb_register(struct msm_fb_data_type *mfd)
|
||||
fix->xpanstep = 1;
|
||||
fix->ypanstep = 1;
|
||||
var->vmode = FB_VMODE_NONINTERLACED;
|
||||
- var->blue.offset = 0;
|
||||
- var->green.offset = 8;
|
||||
- var->red.offset = 16;
|
||||
+ var->blue.offset = 24;
|
||||
+ var->green.offset = 16;
|
||||
+ var->red.offset = 8;
|
||||
var->blue.length = 8;
|
||||
var->green.length = 8;
|
||||
var->red.length = 8;
|
||||
var->blue.msb_right = 0;
|
||||
var->green.msb_right = 0;
|
||||
var->red.msb_right = 0;
|
||||
- var->transp.offset = 24;
|
||||
+ var->transp.offset = 0;
|
||||
var->transp.length = 8;
|
||||
bpp = 4;
|
||||
break;
|
||||
@@ -1361,16 +1361,16 @@ static int msm_fb_register(struct msm_fb_data_type *mfd)
|
||||
fix->xpanstep = 1;
|
||||
fix->ypanstep = 1;
|
||||
var->vmode = FB_VMODE_NONINTERLACED;
|
||||
- var->blue.offset = 8;
|
||||
- var->green.offset = 16;
|
||||
- var->red.offset = 24;
|
||||
+ var->blue.offset = 16;
|
||||
+ var->green.offset = 8;
|
||||
+ var->red.offset = 0;
|
||||
var->blue.length = 8;
|
||||
var->green.length = 8;
|
||||
var->red.length = 8;
|
||||
var->blue.msb_right = 0;
|
||||
var->green.msb_right = 0;
|
||||
var->red.msb_right = 0;
|
||||
- var->transp.offset = 0;
|
||||
+ var->transp.offset = 24;
|
||||
var->transp.length = 8;
|
||||
bpp = 4;
|
||||
break;
|
||||
@@ -2260,15 +2260,15 @@ static int msm_fb_check_var(struct fb_var_screeninfo *var, struct fb_info *info)
|
||||
/* Figure out if the user meant RGBA or ARGB
|
||||
and verify the position of the RGB components */
|
||||
|
||||
- if (var->transp.offset == 24) {
|
||||
- if ((var->blue.offset != 0) ||
|
||||
- (var->green.offset != 8) ||
|
||||
- (var->red.offset != 16))
|
||||
- return -EINVAL;
|
||||
- } else if (var->transp.offset == 0) {
|
||||
- if ((var->blue.offset != 8) ||
|
||||
+ if (var->transp.offset == 0) {
|
||||
+ if ((var->blue.offset != 24) ||
|
||||
(var->green.offset != 16) ||
|
||||
- (var->red.offset != 24))
|
||||
+ (var->red.offset != 8))
|
||||
+ return -EINVAL;
|
||||
+ } else if (var->transp.offset == 24) {
|
||||
+ if ((var->blue.offset != 16) ||
|
||||
+ (var->green.offset != 8) ||
|
||||
+ (var->red.offset != 0))
|
||||
return -EINVAL;
|
||||
} else
|
||||
return -EINVAL;
|
||||
@@ -2365,7 +2365,7 @@ static int msm_fb_set_par(struct fb_info *info)
|
||||
break;
|
||||
|
||||
case 32:
|
||||
- if (var->transp.offset == 24)
|
||||
+ if (var->transp.offset == 0)
|
||||
mfd->fb_imgType = MDP_ARGB_8888;
|
||||
else
|
||||
mfd->fb_imgType = MDP_RGBA_8888;
|
||||
--
|
||||
2.14.1
|
||||
|
13
device/linux-sony-nicki/02_mdss_fb_refresh_rate.patch
Normal file
13
device/linux-sony-nicki/02_mdss_fb_refresh_rate.patch
Normal file
|
@ -0,0 +1,13 @@
|
|||
diff --git a/drivers/video/msm/mdss/mdss_fb.c b/drivers/video/msm/mdss/mdss_fb.c
|
||||
index b37fd1e07ac1..1f091a261d22 100644
|
||||
--- a/drivers/video/msm/mdss/mdss_fb.c
|
||||
+++ b/drivers/video/msm/mdss/mdss_fb.c
|
||||
@@ -2668,7 +2668,7 @@ static int mdss_fb_register(struct msm_fb_data_type *mfd)
|
||||
var->left_margin = panel_info->lcdc.h_back_porch;
|
||||
var->right_margin = panel_info->lcdc.h_front_porch;
|
||||
var->hsync_len = panel_info->lcdc.h_pulse_width;
|
||||
- var->pixclock = panel_info->clk_rate / 1000;
|
||||
+ var->pixclock = 1000000 / 60;
|
||||
|
||||
/*
|
||||
* Store the cont splash state in the var reserved[3] field.
|
40
device/linux-sony-nicki/03_kgsl_iommu_sync_lock.patch
Normal file
40
device/linux-sony-nicki/03_kgsl_iommu_sync_lock.patch
Normal file
|
@ -0,0 +1,40 @@
|
|||
From 2853d750d5051be484a94406e8614b2fe5fc2d76 Mon Sep 17 00:00:00 2001
|
||||
From: Chet Kener <Cl3Kener@gmail.com>
|
||||
Date: Tue, 21 Oct 2014 18:41:36 -0400
|
||||
Subject: [PATCH] gcc5: gpu: msm: fix 5.0 compile
|
||||
|
||||
* These need to be static to avoid these errors:
|
||||
|
||||
drivers/built-in.o: In function `.LANCHOR1':
|
||||
msm_iommu_sec.c:(.data+0x9298): undefined reference to `kgsl_iommu_sync_lock'
|
||||
msm_iommu_sec.c:(.data+0x929c): undefined reference to `kgsl_iommu_sync_unlock'
|
||||
Makefile:877: recipe for target '.tmp_vmlinux1' failed
|
||||
make: *** [.tmp_vmlinux1] Error 1
|
||||
|
||||
Signed-off-by: Chet Kener <Cl3Kener@gmail.com>
|
||||
---
|
||||
drivers/gpu/msm/kgsl_iommu.c | 4 ++--
|
||||
1 file changed, 2 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/drivers/gpu/msm/kgsl_iommu.c b/drivers/gpu/msm/kgsl_iommu.c
|
||||
index f76c95204a2..caf75592a2a 100755
|
||||
--- a/drivers/gpu/msm/kgsl_iommu.c
|
||||
+++ b/drivers/gpu/msm/kgsl_iommu.c
|
||||
@@ -1019,7 +1019,7 @@ static int kgsl_iommu_init_sync_lock(struct kgsl_mmu *mmu)
|
||||
*
|
||||
* Return - int - number of commands.
|
||||
*/
|
||||
-inline unsigned int kgsl_iommu_sync_lock(struct kgsl_mmu *mmu,
|
||||
+static inline unsigned int kgsl_iommu_sync_lock(struct kgsl_mmu *mmu,
|
||||
unsigned int *cmds)
|
||||
{
|
||||
struct kgsl_device *device = mmu->device;
|
||||
@@ -1089,7 +1089,7 @@ inline unsigned int kgsl_iommu_sync_lock(struct kgsl_mmu *mmu,
|
||||
*
|
||||
* Return - int - number of commands.
|
||||
*/
|
||||
-inline unsigned int kgsl_iommu_sync_unlock(struct kgsl_mmu *mmu,
|
||||
+static inline unsigned int kgsl_iommu_sync_unlock(struct kgsl_mmu *mmu,
|
||||
unsigned int *cmds)
|
||||
{
|
||||
struct kgsl_device *device = mmu->device;
|
106
device/linux-sony-nicki/04_psmouse_base.patch
Normal file
106
device/linux-sony-nicki/04_psmouse_base.patch
Normal file
|
@ -0,0 +1,106 @@
|
|||
From ae4fef6fc558b0621532d0de6ebaaeaabe861792 Mon Sep 17 00:00:00 2001
|
||||
From: sub77 <sub77@ymail.com>
|
||||
Date: Fri, 31 Jul 2015 17:47:45 +0200
|
||||
Subject: [PATCH] fix build error: PS2MOUSE fsp_detect & lifebook
|
||||
|
||||
---
|
||||
drivers/input/mouse/psmouse-base.c | 62 +++++++++++++++++++-------------------
|
||||
1 file changed, 31 insertions(+), 31 deletions(-)
|
||||
|
||||
diff --git a/drivers/input/mouse/psmouse-base.c b/drivers/input/mouse/psmouse-base.c
|
||||
index a19c183557d..ad3d2e861d0 100644
|
||||
--- a/drivers/input/mouse/psmouse-base.c
|
||||
+++ b/drivers/input/mouse/psmouse-base.c
|
||||
@@ -708,14 +708,14 @@ static int psmouse_extensions(struct psmouse *psmouse,
|
||||
/*
|
||||
* We always check for lifebook because it does not disturb mouse
|
||||
* (it only checks DMI information).
|
||||
+ *
|
||||
+ * if (psmouse_do_detect(lifebook_detect, psmouse, set_properties) == 0) {
|
||||
+ * if (max_proto > PSMOUSE_IMEX) {
|
||||
+ * if (!set_properties || lifebook_init(psmouse) == 0)
|
||||
+ * return PSMOUSE_LIFEBOOK;
|
||||
+ * }
|
||||
+ * }
|
||||
*/
|
||||
- if (psmouse_do_detect(lifebook_detect, psmouse, set_properties) == 0) {
|
||||
- if (max_proto > PSMOUSE_IMEX) {
|
||||
- if (!set_properties || lifebook_init(psmouse) == 0)
|
||||
- return PSMOUSE_LIFEBOOK;
|
||||
- }
|
||||
- }
|
||||
-
|
||||
/*
|
||||
* Try Kensington ThinkingMouse (we try first, because synaptics probe
|
||||
* upsets the thinkingmouse).
|
||||
@@ -821,19 +821,19 @@ static int psmouse_extensions(struct psmouse *psmouse,
|
||||
/*
|
||||
* Try Finger Sensing Pad. We do it here because its probe upsets
|
||||
* Trackpoint devices (causing TP_READ_ID command to time out).
|
||||
- */
|
||||
- if (max_proto > PSMOUSE_IMEX) {
|
||||
- if (psmouse_do_detect(fsp_detect,
|
||||
- psmouse, set_properties) == 0) {
|
||||
- if (!set_properties || fsp_init(psmouse) == 0)
|
||||
- return PSMOUSE_FSP;
|
||||
-/*
|
||||
+ *
|
||||
+ * if (max_proto > PSMOUSE_IMEX) {
|
||||
+ * if (psmouse_do_detect(fsp_detect,
|
||||
+ * psmouse, set_properties) == 0) {
|
||||
+ * if (!set_properties || fsp_init(psmouse) == 0)
|
||||
+ * return PSMOUSE_FSP;
|
||||
+ *
|
||||
* Init failed, try basic relative protocols
|
||||
+ *
|
||||
+ * max_proto = PSMOUSE_IMEX;
|
||||
+ * }
|
||||
+ * }
|
||||
*/
|
||||
- max_proto = PSMOUSE_IMEX;
|
||||
- }
|
||||
- }
|
||||
-
|
||||
/*
|
||||
* Reset to defaults in case the device got confused by extended
|
||||
* protocol probes. Note that we follow up with full reset because
|
||||
@@ -944,12 +944,12 @@ static const struct psmouse_protocol psmouse_protocols[] = {
|
||||
},
|
||||
#endif
|
||||
#ifdef CONFIG_MOUSE_PS2_LIFEBOOK
|
||||
- {
|
||||
- .type = PSMOUSE_LIFEBOOK,
|
||||
- .name = "LBPS/2",
|
||||
- .alias = "lifebook",
|
||||
- .init = lifebook_init,
|
||||
- },
|
||||
+/* {
|
||||
+* .type = PSMOUSE_LIFEBOOK,
|
||||
+* .name = "LBPS/2",
|
||||
+* .alias = "lifebook",
|
||||
+* .init = lifebook_init,
|
||||
+* },*/
|
||||
#endif
|
||||
#ifdef CONFIG_MOUSE_PS2_TRACKPOINT
|
||||
{
|
||||
@@ -985,13 +985,13 @@ static const struct psmouse_protocol psmouse_protocols[] = {
|
||||
},
|
||||
#endif
|
||||
#ifdef CONFIG_MOUSE_PS2_SENTELIC
|
||||
- {
|
||||
- .type = PSMOUSE_FSP,
|
||||
- .name = "FSPPS/2",
|
||||
- .alias = "fsp",
|
||||
- .detect = fsp_detect,
|
||||
- .init = fsp_init,
|
||||
- },
|
||||
+/* {
|
||||
+* .type = PSMOUSE_FSP,
|
||||
+* .name = "FSPPS/2",
|
||||
+* .alias = "fsp",
|
||||
+* .detect = fsp_detect,
|
||||
+* .init = fsp_init,
|
||||
+* },*/
|
||||
#endif
|
||||
{
|
||||
.type = PSMOUSE_CORTRON,
|
25
device/linux-sony-nicki/05_try_to_make_kgsl_work.patch
Normal file
25
device/linux-sony-nicki/05_try_to_make_kgsl_work.patch
Normal file
|
@ -0,0 +1,25 @@
|
|||
From fda935f1472cf056e47b15f04a3fae13fac36d25 Mon Sep 17 00:00:00 2001
|
||||
From: Konrad Dybcio <ewentualxpl@gmail.com>
|
||||
Date: Mon, 2 Jul 2018 20:51:18 +0200
|
||||
Subject: [PATCH] try to make kgsl work
|
||||
|
||||
---
|
||||
drivers/video/msm/mdss/mdss_fb.c | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/drivers/video/msm/mdss/mdss_fb.c b/drivers/video/msm/mdss/mdss_fb.c
|
||||
index f6bb3357f54..31cf5b1e6cc 100644
|
||||
--- a/drivers/video/msm/mdss/mdss_fb.c
|
||||
+++ b/drivers/video/msm/mdss/mdss_fb.c
|
||||
@@ -1208,7 +1208,7 @@ int mdss_register_panel(struct mdss_panel_data *pdata)
|
||||
return -EINVAL;
|
||||
|
||||
mfd->on_fnc = mdss_mdp_ctl_on;
|
||||
- mfd->off_fnc = mdss_mdp_ctl_off;
|
||||
+ mfd->off_fnc = NULL;
|
||||
|
||||
rc = mdss_mdp_overlay_init(mfd);
|
||||
if (rc)
|
||||
--
|
||||
2.17.1
|
||||
|
89
device/linux-sony-nicki/APKBUILD
Normal file
89
device/linux-sony-nicki/APKBUILD
Normal file
|
@ -0,0 +1,89 @@
|
|||
# Kernel config based on: arch/arm/configs/lineageos_nicki_defconfig
|
||||
|
||||
pkgname="linux-sony-nicki"
|
||||
pkgver=3.4.0
|
||||
pkgrel=0
|
||||
pkgdesc="Sony Xperia M kernel fork"
|
||||
arch="armhf"
|
||||
_carch="arm"
|
||||
_flavor="sony-nicki"
|
||||
url="https://kernel.org"
|
||||
license="GPL2"
|
||||
options="!strip !check !tracedeps"
|
||||
makedepends="perl sed installkernel bash gmp-dev bc linux-headers elfutils-dev"
|
||||
HOSTCC="${CC:-gcc}"
|
||||
HOSTCC="${HOSTCC#${CROSS_COMPILE}}"
|
||||
|
||||
# Source
|
||||
_repository="android_kernel_sony_msm8x27"
|
||||
_commit="627687e4625d208248fe5fa40dcaaeb3363dfce7"
|
||||
_config="config-${_flavor}.${arch}"
|
||||
source="
|
||||
$pkgname-$_commit.tar.gz::https://github.com/LineageOS/${_repository}/archive/${_commit}.tar.gz
|
||||
$_config
|
||||
00_fix_return_address.patch
|
||||
01_fix_video_argb_setting.patch
|
||||
02_mdss_fb_refresh_rate.patch
|
||||
03_kgsl_iommu_sync_lock.patch
|
||||
04_psmouse_base.patch
|
||||
05_try_to_make_kgsl_work.patch
|
||||
compiler-gcc6.h
|
||||
"
|
||||
builddir="$srcdir/${_repository}-${_commit}"
|
||||
|
||||
prepare() {
|
||||
default_prepare
|
||||
|
||||
# gcc6 support
|
||||
cp -v "$srcdir/compiler-gcc6.h" "$builddir/include/linux/"
|
||||
|
||||
# Remove -Werror from all makefiles
|
||||
local i
|
||||
local makefiles="$(find . -type f -name Makefile)
|
||||
$(find . -type f -name Kbuild)"
|
||||
for i in $makefiles; do
|
||||
sed -i 's/-Werror-/-W/g' "$i"
|
||||
sed -i 's/-Werror//g' "$i"
|
||||
done
|
||||
|
||||
# Prepare kernel config ('yes ""' for kernels lacking olddefconfig)
|
||||
mkdir -p "$srcdir"/build
|
||||
cp "$srcdir"/$_config "$builddir"/.config
|
||||
yes "" | make O="$srcdir"/build ARCH="$_carch" HOSTCC="$HOSTCC" oldconfig
|
||||
}
|
||||
|
||||
build() {
|
||||
unset LDFLAGS
|
||||
make ARCH="$_carch" CC="${CC:-gcc}" \
|
||||
KBUILD_BUILD_VERSION="$((pkgrel + 1 ))-postmarketOS"
|
||||
}
|
||||
|
||||
package() {
|
||||
# kernel.release
|
||||
install -D "$builddir/include/config/kernel.release" \
|
||||
"$pkgdir/usr/share/kernel/$_flavor/kernel.release"
|
||||
|
||||
# zImage (find the right one)
|
||||
cd "$builddir/arch/$_carch/boot"
|
||||
_target="$pkgdir/boot/vmlinuz-$_flavor"
|
||||
for _zimg in zImage-dtb Image.gz-dtb *zImage Image; do
|
||||
[ -e "$_zimg" ] || continue
|
||||
msg "zImage found: $_zimg"
|
||||
install -Dm644 "$_zimg" "$_target"
|
||||
break
|
||||
done
|
||||
if ! [ -e "$_target" ]; then
|
||||
error "Could not find zImage in $PWD!"
|
||||
return 1
|
||||
fi
|
||||
}
|
||||
|
||||
sha512sums="cb1132c1add4c87490889ca20924f92bc89d646b2efefe023802c22e0167a2cfd39fdcbf7316f957ba4c93fe7318079df8dea5657aac92710ddcd45bfa7977f8 linux-sony-nicki-627687e4625d208248fe5fa40dcaaeb3363dfce7.tar.gz
|
||||
935391d48e4880f76acb90525c2455c07e14b6e90c73c4334c735ac03e79de93e909705b3a3700443964594c8b06ea619f80271d2ea51e2590b567d78d780417 config-sony-nicki.armhf
|
||||
ea1d3b5a234fa565e3c1a792de48f4fc4e6023d281d303c8e319c7ef28edc5739ab0e4dea0139a41f0a5c7d03e27921ccaa214fd0ac5c72245a094ce60128864 00_fix_return_address.patch
|
||||
e3083c260ed9c4fc0d83f43106700b6173876dbfae072f6e6696ac6785a4dc17771fbcb3e21601e04ed29a11bf0f7a2a09ad549375e0c34cea245c7f2e2bcbbd 01_fix_video_argb_setting.patch
|
||||
a8c955bf718f155011e980f3d0948be98e1fee5649f418299a4851780543019daf7afa406aa7b0829375645107e4e6fbf241026b0cabe2b2ac895a47df83d2d8 02_mdss_fb_refresh_rate.patch
|
||||
448bad436377a22c93ac401b9aecb504fe8e84b9511a3dd28f3cc125f3725cc1168ef03dee9f8f1085a9fbb7910b9e75cd25a382ccce626b427c8e27f7c17ffc 03_kgsl_iommu_sync_lock.patch
|
||||
f7e31cfe422696922aec52002e56c58103183966edee3bb8e1995d33f8d37b07c32280a8ecc213874e358a6ff367418556a4542fba7e3c17e4b8e82e05c3a543 04_psmouse_base.patch
|
||||
270aa134a7040409cf2ec5502939b8aa68470c47eeb2bef8f378aa2758a8b546b79018298a81625351f1c06241d8f76bf016793474f58b888db7871a5d745801 05_try_to_make_kgsl_work.patch
|
||||
d80980e9474c82ba0ef1a6903b434d8bd1b092c40367ba543e72d2c119301c8b2d05265740e4104ca1ac5d15f6c4aa49e8776cb44264a9a28dc551e0d1850dcc compiler-gcc6.h"
|
69
device/linux-sony-nicki/compiler-gcc6.h
Normal file
69
device/linux-sony-nicki/compiler-gcc6.h
Normal file
|
@ -0,0 +1,69 @@
|
|||
// SOURCE:
|
||||
// https://github.com/NextThingCo/CHIP-u-boot/issues/10#issuecomment-287515505
|
||||
|
||||
#ifndef __LINUX_COMPILER_H
|
||||
#error "Please don't include <linux/compiler-gcc6.h> directly, include <linux/compiler.h> instead."
|
||||
#endif
|
||||
|
||||
#define __used __attribute__((__used__))
|
||||
#define __must_check __attribute__((warn_unused_result))
|
||||
#define __compiler_offsetof(a, b) __builtin_offsetof(a, b)
|
||||
|
||||
/* Mark functions as cold. gcc will assume any path leading to a call
|
||||
to them will be unlikely. This means a lot of manual unlikely()s
|
||||
are unnecessary now for any paths leading to the usual suspects
|
||||
like BUG(), printk(), panic() etc. [but let's keep them for now for
|
||||
older compilers]
|
||||
|
||||
Early snapshots of gcc 4.3 don't support this and we can't detect this
|
||||
in the preprocessor, but we can live with this because they're unreleased.
|
||||
Maketime probing would be overkill here.
|
||||
|
||||
gcc also has a __attribute__((__hot__)) to move hot functions into
|
||||
a special section, but I don't see any sense in this right now in
|
||||
the kernel context */
|
||||
#define __cold __attribute__((__cold__))
|
||||
|
||||
#define __UNIQUE_ID(prefix) __PASTE(__PASTE(__UNIQUE_ID_, prefix), __COUNTER__)
|
||||
|
||||
#ifndef __CHECKER__
|
||||
# define __compiletime_warning(message) __attribute__((warning(message)))
|
||||
# define __compiletime_error(message) __attribute__((error(message)))
|
||||
#endif /* __CHECKER__ */
|
||||
|
||||
/*
|
||||
* Mark a position in code as unreachable. This can be used to
|
||||
* suppress control flow warnings after asm blocks that transfer
|
||||
* control elsewhere.
|
||||
*
|
||||
* Early snapshots of gcc 4.5 don't support this and we can't detect
|
||||
* this in the preprocessor, but we can live with this because they're
|
||||
* unreleased. Really, we need to have autoconf for the kernel.
|
||||
*/
|
||||
#define unreachable() __builtin_unreachable()
|
||||
|
||||
/* Mark a function definition as prohibited from being cloned. */
|
||||
#define __noclone __attribute__((__noclone__))
|
||||
|
||||
/*
|
||||
* Tell the optimizer that something else uses this function or variable.
|
||||
*/
|
||||
#define __visible __attribute__((externally_visible))
|
||||
|
||||
/*
|
||||
* GCC 'asm goto' miscompiles certain code sequences:
|
||||
*
|
||||
* http://gcc.gnu.org/bugzilla/show_bug.cgi?id=58670
|
||||
*
|
||||
* Work it around via a compiler barrier quirk suggested by Jakub Jelinek.
|
||||
*
|
||||
* (asm goto is automatically volatile - the naming reflects this.)
|
||||
*/
|
||||
#define asm_volatile_goto(x...) do { asm goto(x); asm (""); } while (0)
|
||||
|
||||
#ifdef CONFIG_ARCH_USE_BUILTIN_BSWAP
|
||||
#define __HAVE_BUILTIN_BSWAP32__
|
||||
#define __HAVE_BUILTIN_BSWAP64__
|
||||
#define __HAVE_BUILTIN_BSWAP16__
|
||||
#endif /* CONFIG_ARCH_USE_BUILTIN_BSWAP */
|
||||
|
4084
device/linux-sony-nicki/config-sony-nicki.armhf
Normal file
4084
device/linux-sony-nicki/config-sony-nicki.armhf
Normal file
File diff suppressed because it is too large
Load diff
Loading…
Reference in a new issue