lenovo-tb8504f: new device (Lenovo Tab 4 8) (TB-8504F) (MR 2048)
[ci:skip-build] Already built in CI
This commit is contained in:
parent
88da612343
commit
9738f61aa5
6 changed files with 4862 additions and 0 deletions
22
device/testing/device-lenovo-tb8504f/APKBUILD
Normal file
22
device/testing/device-lenovo-tb8504f/APKBUILD
Normal file
|
@ -0,0 +1,22 @@
|
|||
# Reference: <https://postmarketos.org/devicepkg>
|
||||
pkgname=device-lenovo-tb8504f
|
||||
pkgdesc="Lenovo Tab 4 8"
|
||||
pkgver=0.1
|
||||
pkgrel=0
|
||||
url="https://postmarketos.org"
|
||||
license="MIT"
|
||||
arch="aarch64"
|
||||
options="!check !archcheck"
|
||||
depends="postmarketos-base linux-lenovo-tb8504f mkbootimg mdss-fb-init-hack mesa-dri-gallium"
|
||||
makedepends="devicepkg-dev"
|
||||
source="deviceinfo"
|
||||
|
||||
build() {
|
||||
devicepkg_build $startdir $pkgname
|
||||
}
|
||||
|
||||
package() {
|
||||
devicepkg_package $startdir $pkgname
|
||||
}
|
||||
|
||||
sha512sums="fc8382a04a111eb0eb15ceda98e73c9a101f5d19cfd69b7803e719dcfedb3a4c32834d59101f37a42db4389ddad51c47964d5ce5621939788af8230a03482452 deviceinfo"
|
33
device/testing/device-lenovo-tb8504f/deviceinfo
Normal file
33
device/testing/device-lenovo-tb8504f/deviceinfo
Normal file
|
@ -0,0 +1,33 @@
|
|||
# Reference: <https://postmarketos.org/deviceinfo>
|
||||
# Please use double quotes only. You can source this file in shell
|
||||
# scripts.
|
||||
|
||||
deviceinfo_format_version="0"
|
||||
deviceinfo_name="Lenovo Tab 4 8"
|
||||
deviceinfo_manufacturer="Lenovo"
|
||||
deviceinfo_codename="lenovo-tb8504f"
|
||||
deviceinfo_year="2017"
|
||||
deviceinfo_dtb=""
|
||||
deviceinfo_modules_initfs=""
|
||||
deviceinfo_arch="aarch64"
|
||||
|
||||
# Device related
|
||||
deviceinfo_chassis="tablet"
|
||||
deviceinfo_keyboard="false"
|
||||
deviceinfo_external_storage="true"
|
||||
deviceinfo_screen_width="800"
|
||||
deviceinfo_screen_height="1280"
|
||||
|
||||
# Bootloader related
|
||||
deviceinfo_flash_method="fastboot"
|
||||
deviceinfo_kernel_cmdline="console=null androidboot.hardware=qcom msm_rtb.filter=0x237 ehci-hcd.park=3 lpm_levels.sleep_disabled=1 androidboot.bootdevice=7824900.sdhci loop.max_part=7 firmware_class.path=/vendor/firmware_mnt/image buildvariant=userdebug"
|
||||
deviceinfo_generate_bootimg="true"
|
||||
deviceinfo_bootimg_qcdt="false"
|
||||
deviceinfo_bootimg_mtk_mkimage="false"
|
||||
deviceinfo_bootimg_dtb_second="false"
|
||||
deviceinfo_flash_offset_base="0x80000000"
|
||||
deviceinfo_flash_offset_kernel="0x00008000"
|
||||
deviceinfo_flash_offset_ramdisk="0x01000000"
|
||||
deviceinfo_flash_offset_second="0x00f00000"
|
||||
deviceinfo_flash_offset_tags="0x00000100"
|
||||
deviceinfo_flash_pagesize="2048"
|
53
device/testing/linux-lenovo-tb8504f/APKBUILD
Normal file
53
device/testing/linux-lenovo-tb8504f/APKBUILD
Normal file
|
@ -0,0 +1,53 @@
|
|||
# Reference: <https://postmarketos.org/vendorkernel>
|
||||
# Kernel config based on: arch/arm64/configs/lineageos_tb8504_defconfig
|
||||
|
||||
pkgname=linux-lenovo-tb8504f
|
||||
pkgver=3.18.140
|
||||
pkgrel=0
|
||||
pkgdesc="Lenovo Tab 4 8 kernel fork"
|
||||
arch="aarch64"
|
||||
_carch="arm64"
|
||||
_flavor="lenovo-tb8504f"
|
||||
url="https://kernel.org"
|
||||
license="GPL-2.0-only"
|
||||
options="!strip !check !tracedeps pmb:cross-native"
|
||||
makedepends="bash bc bison devicepkg-dev flex openssl-dev perl gcc6"
|
||||
|
||||
if [ "${CC:0:5}" != "gcc6-" ]; then
|
||||
CC="gcc6-$CC"
|
||||
HOSTCC="gcc6-gcc"
|
||||
CROSS_COMPILE="gcc6-$CROSS_COMPILE"
|
||||
fi
|
||||
|
||||
# Source
|
||||
_repository="android_kernel_lenovo_msm8953"
|
||||
_commit="070b6a871761481c2284ae2f862adaeb9b4d9d2f"
|
||||
_config="config-$_flavor.$arch"
|
||||
source="
|
||||
$pkgname-$_commit.tar.gz::https://github.com/lenovo-devs/$_repository/archive/$_commit.tar.gz
|
||||
$_config
|
||||
gcc10-extern_YYLOC_global_declaration.patch
|
||||
struct-rndis-incomplete-type.patch
|
||||
"
|
||||
builddir="$srcdir/$_repository-$_commit"
|
||||
_outdir="out"
|
||||
|
||||
prepare() {
|
||||
default_prepare
|
||||
. downstreamkernel_prepare
|
||||
}
|
||||
|
||||
build() {
|
||||
unset LDFLAGS
|
||||
make O="$_outdir" ARCH="$_carch" CC="${CC:-gcc}" \
|
||||
KBUILD_BUILD_VERSION="$((pkgrel + 1 ))-postmarketOS"
|
||||
}
|
||||
|
||||
package() {
|
||||
downstreamkernel_package "$builddir" "$pkgdir" "$_carch" "$_flavor" "$_outdir"
|
||||
}
|
||||
|
||||
sha512sums="cf456f1319dda22693bb70e8445bd9b3642f49e384ecb8ad8d51b985aafa41404c17773b328292c7562e54d2facd072d77aad836c4cf6c4a9592316bc44aada8 linux-lenovo-tb8504f-070b6a871761481c2284ae2f862adaeb9b4d9d2f.tar.gz
|
||||
32eb248fd7954034cfcd94b00adee5f62f93509fdcc4b43cccea0c30c65d2813bd73dfc2c78cfddcd630f9218e72c47da55e91a79fa7343375edec9a4d8796ad config-lenovo-tb8504f.aarch64
|
||||
2b48f1bf0e3f70703d2cdafc47d5e615cc7c56c70bec56b2e3297d3fa4a7a1321d649a8679614553dde8fe52ff1051dae38d5990e3744c9ca986d92187dcdbeb gcc10-extern_YYLOC_global_declaration.patch
|
||||
c64c63702c1638987640cf80dc8c36488ad0bc1c4ce6a875b9b98f3de1f1ae1435be7ff7f8b0b164f28ac79a22cf70f3d3fb6c28d8c162b7162ef8ac6f95e02d struct-rndis-incomplete-type.patch"
|
4738
device/testing/linux-lenovo-tb8504f/config-lenovo-tb8504f.aarch64
Normal file
4738
device/testing/linux-lenovo-tb8504f/config-lenovo-tb8504f.aarch64
Normal file
File diff suppressed because it is too large
Load diff
|
@ -0,0 +1 @@
|
|||
../../.shared-patches/linux/gcc10-extern_YYLOC_global_declaration.patch
|
|
@ -0,0 +1,15 @@
|
|||
Include needed header to fix invalid application of `sizeof' to incomplete type
|
||||
---
|
||||
diff --git a/drivers/usb/gadget/function/u_ether.c b/drivers/usb/gadget/function/u_ether.c
|
||||
index fbf3cd19ee63..a575ff81f6f7 100644
|
||||
--- a/drivers/usb/gadget/function/u_ether.c
|
||||
+++ b/drivers/usb/gadget/function/u_ether.c
|
||||
@@ -28,6 +28,7 @@
|
||||
#include <linux/notifier.h>
|
||||
#include <linux/cpufreq.h>
|
||||
#include "u_ether.h"
|
||||
+#include "rndis.h"
|
||||
|
||||
|
||||
/*
|
||||
|
Loading…
Reference in a new issue