Initial n900 commit
This commit is contained in:
parent
ea00652f69
commit
8f676acd33
8 changed files with 4694 additions and 0 deletions
30
device-nokia-rx51/APKBUILD
Normal file
30
device-nokia-rx51/APKBUILD
Normal file
|
@ -0,0 +1,30 @@
|
||||||
|
pkgname=device-nokia-rx51
|
||||||
|
pkgver=1
|
||||||
|
pkgrel=1
|
||||||
|
pkgdesc="Nokia N900"
|
||||||
|
url="https://github.com/postmarketOS"
|
||||||
|
arch="noarch"
|
||||||
|
license="MIT"
|
||||||
|
depends="linux-nokia-rx51"
|
||||||
|
makedepends=""
|
||||||
|
install=""
|
||||||
|
subpackages=""
|
||||||
|
source="deviceinfo initfs-hook.sh profile.sh"
|
||||||
|
options="!check"
|
||||||
|
|
||||||
|
build() {
|
||||||
|
return 0
|
||||||
|
}
|
||||||
|
|
||||||
|
package() {
|
||||||
|
install -D -m644 "$srcdir"/deviceinfo \
|
||||||
|
"$pkgdir"/etc/deviceinfo
|
||||||
|
install -D -m644 "$srcdir"/initfs-hook.sh \
|
||||||
|
"$pkgdir"/etc/postmarketos-mkinitfs/hooks/00-${pkgname}.sh
|
||||||
|
install -D -m644 "$srcdir"/profile.sh \
|
||||||
|
"$pkgdir"/etc/profile.d/00-$pkgname.sh
|
||||||
|
}
|
||||||
|
|
||||||
|
sha512sums="d9b34cde62f1de25a8635012ce1cc3a623a238ffb2237c997b74645d4e0df98f98f589c1f9c9f8d2519718d9345dee24b969b6efaa3533e5928a69272d9d997f deviceinfo
|
||||||
|
8590967fa10388a890fdfafdb1070b9ab22dc89e06a3a8834806c772191e3b67de7b914b0d68e5ddf581cee715cb90f3f24abcb8762c415ff328c6da23e55d52 initfs-hook.sh
|
||||||
|
c3d0182161c33047e0af4fd7cc557037e10380896a771446f055a13813e50e4e6c9d5992de7b275a8373a053cca02cb96bcb50c732709a2e9909f903b5fba249 profile.sh"
|
28
device-nokia-rx51/deviceinfo
Normal file
28
device-nokia-rx51/deviceinfo
Normal file
|
@ -0,0 +1,28 @@
|
||||||
|
# This document format is a draft.
|
||||||
|
# You can source it in shell scripts.
|
||||||
|
# Use only double quotes.
|
||||||
|
|
||||||
|
deviceinfo_format_version="0"
|
||||||
|
deviceinfo_name="Google Nexus 5"
|
||||||
|
deviceinfo_manufacturer="LG"
|
||||||
|
deviceinfo_date=""
|
||||||
|
deviceinfo_keyboard="false"
|
||||||
|
deviceinfo_nonfree="????"
|
||||||
|
deviceinfo_dtb=""
|
||||||
|
deviceinfo_modules=""
|
||||||
|
deviceinfo_modules_initfs=""
|
||||||
|
deviceinfo_external_disk="false"
|
||||||
|
deviceinfo_external_disk_install="false"
|
||||||
|
deviceinfo_flash_methods="fastboot"
|
||||||
|
deviceinfo_arch="armhf"
|
||||||
|
|
||||||
|
|
||||||
|
# You can for example extract these from an existing boot.img
|
||||||
|
deviceinfo_flash_offset_base="0"
|
||||||
|
deviceinfo_flash_offset_kernel="0x00008000"
|
||||||
|
deviceinfo_flash_offset_ramdisk="0x2900000"
|
||||||
|
deviceinfo_flash_offset_second="0x00f00000"
|
||||||
|
deviceinfo_flash_offset_tags="0x02700000"
|
||||||
|
deviceinfo_flash_cmdline="console=ttyHSL0,115200,n8 androidboot.hardware=hammerhead user_debug=31 maxcpus=2 msm_watchdog_v2.enable=1"
|
||||||
|
deviceinfo_flash_pagesize="2048"
|
||||||
|
|
4
device-nokia-rx51/initfs-hook.sh
Normal file
4
device-nokia-rx51/initfs-hook.sh
Normal file
|
@ -0,0 +1,4 @@
|
||||||
|
#!/bin/sh
|
||||||
|
|
||||||
|
# set framebuffer resolution
|
||||||
|
cat /sys/class/graphics/fb0/modes > /sys/class/graphics/fb0/mode
|
30
device-nokia-rx51/profile.sh
Normal file
30
device-nokia-rx51/profile.sh
Normal file
|
@ -0,0 +1,30 @@
|
||||||
|
#!/bin/sh
|
||||||
|
|
||||||
|
# Dirty hacks, necessary to get a working demo...
|
||||||
|
if [ -e /etc/xdg/weston/weston.ini ]; then
|
||||||
|
rm /etc/xdg/weston/weston.ini
|
||||||
|
echo "WARNING: xwayland does not work yet on lg-mako (probably"
|
||||||
|
echo "because of bad framebuffer drivers)"
|
||||||
|
echo "=> Deleted /etc/xdg/weston/weston.ini as workaround"
|
||||||
|
fi
|
||||||
|
if [ -e /lib/udev/v4l_id ]; then
|
||||||
|
mv /lib/udev/v4l_id /lib/udev/v4l_id_
|
||||||
|
echo "WARNING: v4l_id hangs with the current kernel."
|
||||||
|
echo "=> Moved it from /lib/udev/v4l_id to /lib/udev/v4l_id_"
|
||||||
|
fi
|
||||||
|
|
||||||
|
|
||||||
|
# Run a few weston demos, because the postmarketos-demos program depends
|
||||||
|
# on xwayland for now (Alpine's GTK3 isn't configured for Wayland
|
||||||
|
# support yet.)
|
||||||
|
if [ $(tty) = "/dev/tty1" ]; then
|
||||||
|
(
|
||||||
|
sleep 3;
|
||||||
|
export XDG_RUNTIME_DIR=/tmp/0-runtime-dir
|
||||||
|
weston-smoke &
|
||||||
|
weston-simple-damage &
|
||||||
|
weston-editor &
|
||||||
|
weston-terminal --shell=/usr/bin/htop &
|
||||||
|
) > /dev/null &
|
||||||
|
fi
|
||||||
|
|
101
linux-nokia-rx51/APKBUILD
Normal file
101
linux-nokia-rx51/APKBUILD
Normal file
|
@ -0,0 +1,101 @@
|
||||||
|
# APKBUILD based on linux-vanilla aport. Changes:
|
||||||
|
# - disabled module installation
|
||||||
|
# - add !check !tracedeps
|
||||||
|
# - package: just install zimage and kernel.release, because the kernel config
|
||||||
|
# does not generate modules or dtb files
|
||||||
|
# - do not create -dev subpackage (makes no sense without module support)
|
||||||
|
#
|
||||||
|
# Kernel config based on: arch/arm/configs/lineageos_mako_defconfig
|
||||||
|
# Changes:
|
||||||
|
# - enable devtmpfs (needed for udev -> touch support in weston)
|
||||||
|
|
||||||
|
_vendor=nokia
|
||||||
|
_flavor=nokia-rx51
|
||||||
|
_hash="7b6fbfd899b4133e4f789843e5967beb139ec4d2"
|
||||||
|
_config="config-${_flavor}.armhf"
|
||||||
|
|
||||||
|
pkgname=linux-${_flavor}
|
||||||
|
pkgver=4.6
|
||||||
|
case $pkgver in
|
||||||
|
*.*.*) _kernver=${pkgver%.*};;
|
||||||
|
*.*) _kernver=$pkgver;;
|
||||||
|
esac
|
||||||
|
pkgrel=1
|
||||||
|
arch="armhf"
|
||||||
|
pkgdesc="Mainline Linux for the Nokia N900"
|
||||||
|
url="https://github.com/pali/linux-n900"
|
||||||
|
depends="postmarketos-mkinitfs"
|
||||||
|
makedepends="perl sed installkernel bash gmp-dev bc linux-headers elfutils-dev"
|
||||||
|
options="!strip !check !tracedeps"
|
||||||
|
install=
|
||||||
|
source="
|
||||||
|
$pkgname-$_hash.tar.gz::https://github.com/pali/linux-n900/archive/${_hash}.tar.gz
|
||||||
|
$_config
|
||||||
|
"
|
||||||
|
subpackages=""
|
||||||
|
license="GPL2"
|
||||||
|
|
||||||
|
_abi_release=${pkgver}
|
||||||
|
_carch="arm"
|
||||||
|
HOSTCC="${CC:-gcc}"
|
||||||
|
HOSTCC="${HOSTCC#${CROSS_COMPILE}}"
|
||||||
|
|
||||||
|
ksrcdir="$srcdir/linux-n900-${_hash}"
|
||||||
|
|
||||||
|
prepare() {
|
||||||
|
local _patch_failed=
|
||||||
|
cd "$ksrcdir"
|
||||||
|
|
||||||
|
# first apply patches in specified order
|
||||||
|
for i in $source; do
|
||||||
|
case $i in
|
||||||
|
*.patch)
|
||||||
|
msg "Applying $i..."
|
||||||
|
if ! patch -s -p1 -N -i "$srcdir"/$i; then
|
||||||
|
echo $i >>failed
|
||||||
|
_patch_failed=1
|
||||||
|
fi
|
||||||
|
;;
|
||||||
|
esac
|
||||||
|
done
|
||||||
|
|
||||||
|
if ! [ -z "$_patch_failed" ]; then
|
||||||
|
error "The following patches failed:"
|
||||||
|
cat failed
|
||||||
|
return 1
|
||||||
|
fi
|
||||||
|
|
||||||
|
mkdir -p "$srcdir"/build
|
||||||
|
cp "$srcdir"/$_config "$srcdir"/build/.config || return 1
|
||||||
|
make -C "$ksrcdir" O="$srcdir"/build ARCH="$_carch" HOSTCC="$HOSTCC" \
|
||||||
|
silentoldconfig
|
||||||
|
}
|
||||||
|
|
||||||
|
|
||||||
|
|
||||||
|
# this is so we can do: 'abuild menuconfig' to reconfigure kernel
|
||||||
|
menuconfig() {
|
||||||
|
cd "$srcdir"/build || return 1
|
||||||
|
make ARCH="$_carch" menuconfig
|
||||||
|
cp .config "$startdir"/$_config
|
||||||
|
}
|
||||||
|
|
||||||
|
build() {
|
||||||
|
cd "$srcdir"/build
|
||||||
|
unset LDFLAGS
|
||||||
|
make ARCH="$_carch" CC="${CC:-gcc}" \
|
||||||
|
KBUILD_BUILD_VERSION="$((pkgrel + 1 ))-Alpine" \
|
||||||
|
zImage modules omap3-n900.dtb \
|
||||||
|
|| return 1
|
||||||
|
}
|
||||||
|
|
||||||
|
package() {
|
||||||
|
install -Dm644 "$srcdir/build/arch/arm/boot/zImage" \
|
||||||
|
"$pkgdir/boot/vmlinuz-$_flavor"
|
||||||
|
|
||||||
|
install -D "$srcdir/build/include/config/kernel.release" \
|
||||||
|
"$pkgdir/usr/share/kernel/$_flavor/kernel.release"
|
||||||
|
}
|
||||||
|
|
||||||
|
sha512sums="ad1288233893ce3de9c81f4672f4f2439c8d6665a0a0289f5cbe826fd08c69292de02a2fd9856dcd6d91c7f6930273319e1888bf0a146aee3a4e1ff50f6f7b19 linux-nokia-rx51-7b6fbfd899b4133e4f789843e5967beb139ec4d2.tar.gz
|
||||||
|
6bdc31f83806cb1398bf9304755a3c35dd60be35d424149118ddbe72c78ad4ffa7296a9d5f141a1c68865e673aa2d9ba370223b0460b4ea202a476cb7ed99771 config-nokia-rx51.armhf"
|
69
linux-nokia-rx51/compiler-gcc6.h
Normal file
69
linux-nokia-rx51/compiler-gcc6.h
Normal file
|
@ -0,0 +1,69 @@
|
||||||
|
// SOURCE:
|
||||||
|
// https://github.com/NextThingCo/CHIP-u-boot/issues/10#issuecomment-287515505
|
||||||
|
|
||||||
|
#ifndef __LINUX_COMPILER_H
|
||||||
|
#error "Please don't include <linux/compiler-gcc6.h> directly, include <linux/compiler.h> instead."
|
||||||
|
#endif
|
||||||
|
|
||||||
|
#define __used __attribute__((__used__))
|
||||||
|
#define __must_check __attribute__((warn_unused_result))
|
||||||
|
#define __compiler_offsetof(a, b) __builtin_offsetof(a, b)
|
||||||
|
|
||||||
|
/* Mark functions as cold. gcc will assume any path leading to a call
|
||||||
|
to them will be unlikely. This means a lot of manual unlikely()s
|
||||||
|
are unnecessary now for any paths leading to the usual suspects
|
||||||
|
like BUG(), printk(), panic() etc. [but let's keep them for now for
|
||||||
|
older compilers]
|
||||||
|
|
||||||
|
Early snapshots of gcc 4.3 don't support this and we can't detect this
|
||||||
|
in the preprocessor, but we can live with this because they're unreleased.
|
||||||
|
Maketime probing would be overkill here.
|
||||||
|
|
||||||
|
gcc also has a __attribute__((__hot__)) to move hot functions into
|
||||||
|
a special section, but I don't see any sense in this right now in
|
||||||
|
the kernel context */
|
||||||
|
#define __cold __attribute__((__cold__))
|
||||||
|
|
||||||
|
#define __UNIQUE_ID(prefix) __PASTE(__PASTE(__UNIQUE_ID_, prefix), __COUNTER__)
|
||||||
|
|
||||||
|
#ifndef __CHECKER__
|
||||||
|
# define __compiletime_warning(message) __attribute__((warning(message)))
|
||||||
|
# define __compiletime_error(message) __attribute__((error(message)))
|
||||||
|
#endif /* __CHECKER__ */
|
||||||
|
|
||||||
|
/*
|
||||||
|
* Mark a position in code as unreachable. This can be used to
|
||||||
|
* suppress control flow warnings after asm blocks that transfer
|
||||||
|
* control elsewhere.
|
||||||
|
*
|
||||||
|
* Early snapshots of gcc 4.5 don't support this and we can't detect
|
||||||
|
* this in the preprocessor, but we can live with this because they're
|
||||||
|
* unreleased. Really, we need to have autoconf for the kernel.
|
||||||
|
*/
|
||||||
|
#define unreachable() __builtin_unreachable()
|
||||||
|
|
||||||
|
/* Mark a function definition as prohibited from being cloned. */
|
||||||
|
#define __noclone __attribute__((__noclone__))
|
||||||
|
|
||||||
|
/*
|
||||||
|
* Tell the optimizer that something else uses this function or variable.
|
||||||
|
*/
|
||||||
|
#define __visible __attribute__((externally_visible))
|
||||||
|
|
||||||
|
/*
|
||||||
|
* GCC 'asm goto' miscompiles certain code sequences:
|
||||||
|
*
|
||||||
|
* http://gcc.gnu.org/bugzilla/show_bug.cgi?id=58670
|
||||||
|
*
|
||||||
|
* Work it around via a compiler barrier quirk suggested by Jakub Jelinek.
|
||||||
|
*
|
||||||
|
* (asm goto is automatically volatile - the naming reflects this.)
|
||||||
|
*/
|
||||||
|
#define asm_volatile_goto(x...) do { asm goto(x); asm (""); } while (0)
|
||||||
|
|
||||||
|
#ifdef CONFIG_ARCH_USE_BUILTIN_BSWAP
|
||||||
|
#define __HAVE_BUILTIN_BSWAP32__
|
||||||
|
#define __HAVE_BUILTIN_BSWAP64__
|
||||||
|
#define __HAVE_BUILTIN_BSWAP16__
|
||||||
|
#endif /* CONFIG_ARCH_USE_BUILTIN_BSWAP */
|
||||||
|
|
4399
linux-nokia-rx51/config-nokia-rx51.armhf
Normal file
4399
linux-nokia-rx51/config-nokia-rx51.armhf
Normal file
File diff suppressed because it is too large
Load diff
33
linux-nokia-rx51/gpu-msm-fix-gcc5-compile.patch
Normal file
33
linux-nokia-rx51/gpu-msm-fix-gcc5-compile.patch
Normal file
|
@ -0,0 +1,33 @@
|
||||||
|
source:
|
||||||
|
https://github.com/ShinySide/HispAsian_Lollipop_G6/commit/b7756b6fc4bb728722b14d2dfdbaf1dc843812e9
|
||||||
|
|
||||||
|
* These need to be static to avoid these errors:
|
||||||
|
|
||||||
|
drivers/built-in.o: In function `.LANCHOR1':
|
||||||
|
msm_iommu_sec.c:(.data+0x9298): undefined reference to `kgsl_iommu_sync_lock'
|
||||||
|
msm_iommu_sec.c:(.data+0x929c): undefined reference to `kgsl_iommu_sync_unlock'
|
||||||
|
Makefile:877: recipe for target '.tmp_vmlinux1' failed
|
||||||
|
make: *** [.tmp_vmlinux1] Error 1
|
||||||
|
|
||||||
|
Signed-off-by: Chet Kener <Cl3Kener@gmail.com>
|
||||||
|
|
||||||
|
--- a/drivers/gpu/msm/kgsl_iommu.c
|
||||||
|
+++ b/drivers/gpu/msm/kgsl_iommu.c
|
||||||
|
@@ -1010,7 +1010,7 @@ static int kgsl_iommu_init_sync_lock(struct kgsl_mmu *mmu)
|
||||||
|
*
|
||||||
|
* Return - int - number of commands.
|
||||||
|
*/
|
||||||
|
-inline unsigned int kgsl_iommu_sync_lock(struct kgsl_mmu *mmu,
|
||||||
|
+static inline unsigned int kgsl_iommu_sync_lock(struct kgsl_mmu *mmu,
|
||||||
|
unsigned int *cmds)
|
||||||
|
{
|
||||||
|
struct kgsl_device *device = mmu->device;
|
||||||
|
@@ -1080,7 +1080,7 @@ inline unsigned int kgsl_iommu_sync_lock(struct kgsl_mmu *mmu,
|
||||||
|
*
|
||||||
|
* Return - int - number of commands.
|
||||||
|
*/
|
||||||
|
-inline unsigned int kgsl_iommu_sync_unlock(struct kgsl_mmu *mmu,
|
||||||
|
+static inline unsigned int kgsl_iommu_sync_unlock(struct kgsl_mmu *mmu,
|
||||||
|
unsigned int *cmds)
|
||||||
|
{
|
||||||
|
struct kgsl_device *device = mmu->device;
|
Loading…
Reference in a new issue