kde/itinerary: drop, upstreamed to Alpine

This commit is contained in:
Bart Ribbers 2021-01-24 14:33:26 +01:00
parent e3e31a5617
commit 8d5d3c9ef2
No known key found for this signature in database
GPG key ID: 699D16185DAFAE61
2 changed files with 0 additions and 73 deletions

View file

@ -1,26 +0,0 @@
From b2579cc5674ee7aedefcac3ec3c710473265c3fa Mon Sep 17 00:00:00 2001
From: Volker Krause <vkrause@kde.org>
Date: Sun, 26 Apr 2020 11:00:42 +0200
Subject: [PATCH] Remove unnecessary forward declaration
With this gone we can rename the departure types in KPublicTransport
without breaking source compatibility.
---
src/app/livedatamanager.h | 1 -
1 file changed, 1 deletion(-)
diff --git a/src/app/livedatamanager.h b/src/app/livedatamanager.h
index 902d3c9..c1b07ac 100644
--- a/src/app/livedatamanager.h
+++ b/src/app/livedatamanager.h
@@ -32,7 +32,6 @@ class TrainTrip;
}
namespace KPublicTransport {
-class Departure;
class Manager;
}
--
2.27.0

View file

@ -1,47 +0,0 @@
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=itinerary
pkgver=0_git20200401
_commit="33e7602d04e281b6021972e750d498e40ee1b980"
pkgrel=0
pkgdesc="Application to assist with usage of Travel Reservations"
url="https://github.com/KDE/itinerary"
arch="all !armhf"
license="LGPL-2.0-or-later"
depends="kirigami2 prison"
makedepends="extra-cmake-modules qt5-qtbase-dev qt5-qtquickcontrols2-dev
qt5-qtlocation-dev ki18n-dev kcontacts-dev kpkpass-dev kitinerary-dev
kpublictransport-dev kdbusaddons-dev solid-dev shared-mime-info
kholidays-dev knotifications-dev"
source="$pkgname-$_commit.tar.gz::https://github.com/KDE/itinerary/archive/$_commit.tar.gz
0001-Remove-unnecessary-forward-declaration.patch"
builddir="$srcdir/$pkgname-$_commit"
options="!check" # Tests require newest version of kitinerary
prepare() {
default_prepare
# qmlplugindump fails for armv7+qemu (pmb#1970). This is purely for
# packager knowledge and doesn't affect runtime, so we can disable it.
if [ "$CARCH" = "armv7" ]; then
sed -i "s/ecm_find_qmlmodule/# ecm_find_qmlmodule/g" CMakeLists.txt
fi
}
build() {
cmake -B build \
-DCMAKE_BUILD_TYPE=None \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib
make -C build
}
check() {
cd build
CTEST_OUTPUT_ON_FAILURE=TRUE ctest
}
package() {
DESTDIR="$pkgdir" make -C build install
}
sha512sums="133844df20d4ac657458aa0e6f5686f6aa0735085c76202f1fa1ccae840ebff90ec874f5ddbf10a93470cc68a3517db99134db7c91fbfc2219b119004e24e71d itinerary-33e7602d04e281b6021972e750d498e40ee1b980.tar.gz
858ea5391098e1fcc701004b2b632f939ce96207ef086398138f70a1fc073c314bacadcbf5e880c09c730e0fa8067dc18f0d007d69bf5ea14fca52a625d723a1 0001-Remove-unnecessary-forward-declaration.patch"