unity8/mir: update to 1.1.2, update related pkgs (!276)
Mir 1.1.2 builds without any out-of-tree patches, which is great. I've updated a few other unity8-related packages too. [ci:skip-build]: ollieparanoid made sure, that everything builds.
This commit is contained in:
parent
411746babf
commit
8b9998fc64
13 changed files with 12 additions and 480 deletions
|
@ -1,8 +1,8 @@
|
|||
# Contributor: Bart Ribbers <bribbers@disroot.org>
|
||||
# Maintainer: Luca Weiss <luca@z3ntu.xyz>
|
||||
pkgname=qt5-qtpim
|
||||
pkgver=0_git20181129
|
||||
_commit="380605ef048372a40587f0231ba00df146bc070e"
|
||||
pkgver=0_git20190227
|
||||
_commit="0b4522ae19d560881fdf85e8762c0d7f28310d50"
|
||||
pkgrel=0
|
||||
arch="x86_64"
|
||||
url='http://qt-project.org/'
|
||||
|
@ -39,4 +39,4 @@ package() {
|
|||
install -d "$pkgdir"/usr/share/licenses
|
||||
ln -s /usr/share/licenses/qt5-base "$pkgdir"/usr/share/licenses/$pkgname
|
||||
}
|
||||
sha512sums="dadd6484b34540b5f47f39b1a09e404384b1a22d8c757a56f9ce1efbf047a1ece556fb3b1fe32dfe54c82985023776d182420f55576c9d87f1267c94b144ad77 qt5-qtpim-380605ef048372a40587f0231ba00df146bc070e.tar.gz"
|
||||
sha512sums="e4304c6d67b12d48321510cf6e9f5efebdf8134dc58fb4a06a1ee07a1b52c55aed1e4e99a914e2cd0fd9bf0d47c1c376fca694e88d70405cc9a7b700aba4c22d qt5-qtpim-0b4522ae19d560881fdf85e8762c0d7f28310d50.tar.gz"
|
||||
|
|
|
@ -1,8 +1,8 @@
|
|||
# Contributor: Bart Ribbers <bribbers@disroot.org>
|
||||
# Maintainer: Luca Weiss <luca@z3ntu.xyz>
|
||||
pkgname=cmake-extras
|
||||
pkgver=0_git20181002
|
||||
_commit="f50570d01861ddd38e3eba32fedd870ca1fa6afc"
|
||||
pkgver=0_git20190219
|
||||
_commit="365500ed7903180d034b64e06d0c0cdd9de2162f"
|
||||
pkgrel=0
|
||||
pkgdesc="A collection of add-ons for the CMake build tool"
|
||||
url="https://github.com/ubports/cmake-extras"
|
||||
|
@ -26,6 +26,6 @@ package() {
|
|||
cd "$builddir"
|
||||
make DESTDIR="$pkgdir" install
|
||||
}
|
||||
sha512sums="a440fb3aaa9a3ada069439e74eebc72811ff994509f71b765fffe4e1a9d925a213bfebd90408d103e0ec476a858d889fed1578ee3c8347f5e1945e4f58c5e2f3 cmake-extras-f50570d01861ddd38e3eba32fedd870ca1fa6afc.tar.gz
|
||||
sha512sums="79c8224fd96368ca68534c90178c16178e668bc0655ea42d139fcee4a995c92bc9b6c20f2b6cd0df2bc38cc009f9e15306513d06a3f095c5f344994cae4cb01c cmake-extras-365500ed7903180d034b64e06d0c0cdd9de2162f.tar.gz
|
||||
996334490e062868b2dd24a0d2d688d95877343ae2db6a06efc580d14ffe1d00f0c9277be0929b9c7c859aef2dea0be68ddc49a7495ad16eaa0a156838f8bca9 Use_gtest_cmake_from_mir.patch
|
||||
e55bd3ae7372b33534d239f7e959af0eba5687aba0386613381e4f9fc840f89213f5ae92544b7e969943d46e815d49c66fd24c29c44fd4166bb3a6bf81e1ac7e qmlplugindump_path.patch"
|
||||
|
|
|
@ -1,24 +0,0 @@
|
|||
From 5cb89550f709c911f28bb4f50f32598ceb8f11cd Mon Sep 17 00:00:00 2001
|
||||
From: Luca Weiss <luca@z3ntu.xyz>
|
||||
Date: Mon, 7 Jan 2019 17:26:54 +0100
|
||||
Subject: [PATCH 1/7] Add missing include (#681)
|
||||
|
||||
---
|
||||
tests/include/mir_test_framework/open_wrapper.h | 1 +
|
||||
1 file changed, 1 insertion(+)
|
||||
|
||||
diff --git a/tests/include/mir_test_framework/open_wrapper.h b/tests/include/mir_test_framework/open_wrapper.h
|
||||
index 560f911298..cc4a4a4ce7 100644
|
||||
--- a/tests/include/mir_test_framework/open_wrapper.h
|
||||
+++ b/tests/include/mir_test_framework/open_wrapper.h
|
||||
@@ -21,6 +21,7 @@
|
||||
#include <functional>
|
||||
#include <memory>
|
||||
#include <experimental/optional>
|
||||
+#include <sys/stat.h>
|
||||
|
||||
namespace mir_test_framework
|
||||
{
|
||||
--
|
||||
2.20.1
|
||||
|
|
@ -1,46 +0,0 @@
|
|||
From 2abb20e48c245e41934f77c2917e8cb90ad890db Mon Sep 17 00:00:00 2001
|
||||
From: Alan Griffiths <alan@octopull.co.uk>
|
||||
Date: Sat, 12 Jan 2019 14:54:30 +0100
|
||||
Subject: [PATCH 2/7] Don't hardcode request type for ioctl()
|
||||
|
||||
---
|
||||
.../privileged-tests/ui_get_sysname_ioctl_override.cpp | 10 ++++++++--
|
||||
1 file changed, 8 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/tests/privileged-tests/ui_get_sysname_ioctl_override.cpp b/tests/privileged-tests/ui_get_sysname_ioctl_override.cpp
|
||||
index 89d9f2cc9e..98b2c7d3db 100644
|
||||
--- a/tests/privileged-tests/ui_get_sysname_ioctl_override.cpp
|
||||
+++ b/tests/privileged-tests/ui_get_sysname_ioctl_override.cpp
|
||||
@@ -43,6 +43,8 @@
|
||||
#include <string>
|
||||
#include <iostream>
|
||||
|
||||
+#include <sys/ioctl.h>
|
||||
+#include <linux/ioctl.h>
|
||||
#include <linux/uinput.h>
|
||||
#include <dlfcn.h>
|
||||
#include <dirent.h>
|
||||
@@ -91,14 +93,18 @@ bool request_is_ui_get_sysname(unsigned long int request)
|
||||
static_cast<unsigned long>(UI_GET_SYSNAME(0));
|
||||
}
|
||||
|
||||
+template<typename Param1>
|
||||
+auto request_param_type(int (*ioctl)(int, Param1, ...)) -> Param1;
|
||||
}
|
||||
|
||||
-extern "C" int ioctl(int fd, unsigned long int request, ...) __THROW
|
||||
+using ioctl_request_t = decltype(request_param_type(&ioctl));
|
||||
+
|
||||
+extern "C" int ioctl(int fd, ioctl_request_t request, ...) noexcept
|
||||
{
|
||||
va_list vargs;
|
||||
va_start(vargs, request);
|
||||
|
||||
- using ioctl_func = int(*)(int, unsigned long int, void*);
|
||||
+ using ioctl_func = decltype(&ioctl);
|
||||
static ioctl_func const real_ioctl =
|
||||
reinterpret_cast<ioctl_func>(dlsym(RTLD_NEXT, "ioctl"));
|
||||
|
||||
--
|
||||
2.20.1
|
||||
|
|
@ -1,44 +0,0 @@
|
|||
From cc862ef9a703782f7fc8a9a20dbfde882776b9b7 Mon Sep 17 00:00:00 2001
|
||||
From: Alan Griffiths <alan@octopull.co.uk>
|
||||
Date: Wed, 9 Jan 2019 10:35:34 +0100
|
||||
Subject: [PATCH 3/7] Suppress the compiler diagnostic on Alpine Linux caused
|
||||
by a mismatch between the signed type of the ioctl() request parameter and
|
||||
the unsigned type returned by EVIOCGPROP. (See #692)
|
||||
|
||||
---
|
||||
src/platforms/evdev/evdev_device_detection.cpp | 12 +++++++++++-
|
||||
1 file changed, 11 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/src/platforms/evdev/evdev_device_detection.cpp b/src/platforms/evdev/evdev_device_detection.cpp
|
||||
index f771f1f234..cf844a7f83 100644
|
||||
--- a/src/platforms/evdev/evdev_device_detection.cpp
|
||||
+++ b/src/platforms/evdev/evdev_device_detection.cpp
|
||||
@@ -48,6 +48,16 @@ struct DeviceInfo
|
||||
uint8_t property_bit_mask[(INPUT_PROP_MAX+1)/8];
|
||||
};
|
||||
|
||||
+namespace
|
||||
+{
|
||||
+// On Alpine Linux there's a mismatch between the signed type of the ioctl() request parameter and the
|
||||
+// unsigned type returned by EVIOCGPROP. (See #692)
|
||||
+// We use a bit of magic to suppress the compiler diagnostic.
|
||||
+template<typename Param1>
|
||||
+auto request_param_type(int (*ioctl)(int, Param1, ...)) -> Param1;
|
||||
+using ioctl_request_t = decltype(request_param_type(&ioctl));
|
||||
+}
|
||||
+
|
||||
DeviceInfo::DeviceInfo(mir::Fd const& fd)
|
||||
{
|
||||
auto const get_bitmask = [&](int bit, size_t size, uint8_t* buf) -> void
|
||||
@@ -62,7 +72,7 @@ DeviceInfo::DeviceInfo(mir::Fd const& fd)
|
||||
get_bitmask(EV_ABS, sizeof abs_bit_mask, abs_bit_mask);
|
||||
get_bitmask(EV_SW, sizeof sw_bit_mask, sw_bit_mask);
|
||||
|
||||
- if (ioctl(fd, EVIOCGPROP(sizeof property_bit_mask), property_bit_mask) < 1)
|
||||
+ if (ioctl(fd, static_cast<ioctl_request_t>(EVIOCGPROP(sizeof property_bit_mask)), property_bit_mask) < 1)
|
||||
BOOST_THROW_EXCEPTION(
|
||||
std::system_error(std::error_code(errno, std::system_category()), "Failed to query devices properties"));
|
||||
}
|
||||
--
|
||||
2.20.1
|
||||
|
|
@ -1,25 +0,0 @@
|
|||
From 65849eebc52c5712a966242bbd5eebcbba4238dd Mon Sep 17 00:00:00 2001
|
||||
From: Luca Weiss <luca@z3ntu.xyz>
|
||||
Date: Wed, 9 Jan 2019 17:05:47 +0100
|
||||
Subject: [PATCH 4/7] <sys/poll.h> include is incorrect, use <poll.h>
|
||||
|
||||
---
|
||||
examples/example-server-lib/decoration_provider.cpp | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/examples/example-server-lib/decoration_provider.cpp b/examples/example-server-lib/decoration_provider.cpp
|
||||
index 7fbcbb6772..4458f57316 100644
|
||||
--- a/examples/example-server-lib/decoration_provider.cpp
|
||||
+++ b/examples/example-server-lib/decoration_provider.cpp
|
||||
@@ -25,7 +25,7 @@
|
||||
#include <ft2build.h>
|
||||
#include FT_FREETYPE_H
|
||||
|
||||
-#include <sys/poll.h>
|
||||
+#include <poll.h>
|
||||
#include <sys/eventfd.h>
|
||||
#include <locale>
|
||||
#include <codecvt>
|
||||
--
|
||||
2.20.1
|
||||
|
|
@ -1,25 +0,0 @@
|
|||
From 100cbb05ba1f30b800c67bacbb7dc104f6a44194 Mon Sep 17 00:00:00 2001
|
||||
From: Luca Weiss <luca@z3ntu.xyz>
|
||||
Date: Thu, 10 Jan 2019 09:09:17 +0000
|
||||
Subject: [PATCH 5/7] Fix "unused parameter 'type'" warning/error on musl
|
||||
|
||||
---
|
||||
src/common/posix_rw_mutex.cpp | 2 ++
|
||||
1 file changed, 2 insertions(+)
|
||||
|
||||
diff --git a/src/common/posix_rw_mutex.cpp b/src/common/posix_rw_mutex.cpp
|
||||
index f52c423480..4e26ee6a56 100644
|
||||
--- a/src/common/posix_rw_mutex.cpp
|
||||
+++ b/src/common/posix_rw_mutex.cpp
|
||||
@@ -100,6 +100,8 @@ mir::PosixRWMutex::PosixRWMutex(Type type)
|
||||
std::system_category(),
|
||||
"Failed to set preferred rw-lock mode"}));
|
||||
}
|
||||
+#else
|
||||
+ (void)type;
|
||||
#endif
|
||||
|
||||
err = pthread_rwlock_init(&mutex, &attr);
|
||||
--
|
||||
2.20.1
|
||||
|
|
@ -1,83 +0,0 @@
|
|||
From 90ed6b991b0cf11599ac6ede2e03d952368d588d Mon Sep 17 00:00:00 2001
|
||||
From: William Wold <wm@wmww.sh>
|
||||
Date: Sat, 12 Jan 2019 14:58:44 +0100
|
||||
Subject: [PATCH 6/7] William enters the dlvsym fray
|
||||
|
||||
---
|
||||
src/common/sharedlibrary/CMakeLists.txt | 27 +++++++++++++++++++++
|
||||
src/common/sharedlibrary/shared_library.cpp | 9 +++++++
|
||||
2 files changed, 36 insertions(+)
|
||||
|
||||
diff --git a/src/common/sharedlibrary/CMakeLists.txt b/src/common/sharedlibrary/CMakeLists.txt
|
||||
index 0889ccc2f3..27436c5701 100644
|
||||
--- a/src/common/sharedlibrary/CMakeLists.txt
|
||||
+++ b/src/common/sharedlibrary/CMakeLists.txt
|
||||
@@ -14,6 +14,33 @@
|
||||
#
|
||||
# Authored by: Alexandros Frantzis <alexandros.frantzis@canonical.com>
|
||||
|
||||
+include(CheckCXXSymbolExists)
|
||||
+
|
||||
+list(APPEND CMAKE_REQUIRED_LIBRARIES dl)
|
||||
+list(APPEND CMAKE_REQUIRED_DEFINITIONS -D_GNU_SOURCE)
|
||||
+
|
||||
+check_cxx_symbol_exists("dlvsym" "dlfcn.h" HAS_DLVSYM)
|
||||
+check_cxx_symbol_exists("dlsym" "dlfcn.h" HAS_DLSYM)
|
||||
+
|
||||
+if (NOT HAS_DLVSYM)
|
||||
+ if (NOT HAS_DLSYM)
|
||||
+ message(
|
||||
+ FATAL_ERROR
|
||||
+ "Could not detect dlvsym or dlsym"
|
||||
+ )
|
||||
+ endif()
|
||||
+
|
||||
+ set_source_files_properties (
|
||||
+ "shared_library.cpp"
|
||||
+ PROPERTIES COMPILE_DEFINITIONS MIR_DONT_USE_DLVSYM="1"
|
||||
+ )
|
||||
+
|
||||
+ message(
|
||||
+ WARNING
|
||||
+ "dlvsym() not supported by libc. Mir may attempt to load ABI-incompatible platform modules"
|
||||
+ )
|
||||
+endif()
|
||||
+
|
||||
add_library(mirsharedsharedlibrary OBJECT
|
||||
module_deleter.cpp
|
||||
shared_library.cpp
|
||||
diff --git a/src/common/sharedlibrary/shared_library.cpp b/src/common/sharedlibrary/shared_library.cpp
|
||||
index c97e26b040..80cbdb4186 100644
|
||||
--- a/src/common/sharedlibrary/shared_library.cpp
|
||||
+++ b/src/common/sharedlibrary/shared_library.cpp
|
||||
@@ -17,6 +17,7 @@
|
||||
*/
|
||||
|
||||
#include "mir/shared_library.h"
|
||||
+#include <mir/log.h>
|
||||
|
||||
#include <boost/throw_exception.hpp>
|
||||
#include <boost/exception/info.hpp>
|
||||
@@ -56,6 +57,13 @@ void* mir::SharedLibrary::load_symbol(char const* function_name) const
|
||||
|
||||
void* mir::SharedLibrary::load_symbol(char const* function_name, char const* version) const
|
||||
{
|
||||
+ // Some libc implementations (such as musl) do not support dlvsym
|
||||
+
|
||||
+#ifdef MIR_DONT_USE_DLVSYM
|
||||
+ // Load the function without checking the version
|
||||
+ log_debug("Cannot check \"%s\" symbol version is \"%s\": dlvsym() is unavailable", function_name, version);
|
||||
+ return load_symbol(function_name);
|
||||
+#else
|
||||
if (void* result = dlvsym(so, function_name, version))
|
||||
{
|
||||
return result;
|
||||
@@ -64,4 +72,5 @@ void* mir::SharedLibrary::load_symbol(char const* function_name, char const* ver
|
||||
{
|
||||
BOOST_THROW_EXCEPTION(std::runtime_error(dlerror()));
|
||||
}
|
||||
+#endif
|
||||
}
|
||||
--
|
||||
2.20.1
|
||||
|
|
@ -1,166 +0,0 @@
|
|||
From ab4b2a5863f475a39485cf1a6931418c2510981a Mon Sep 17 00:00:00 2001
|
||||
From: Alan Griffiths <alan@octopull.co.uk>
|
||||
Date: Sat, 12 Jan 2019 14:59:59 +0100
|
||||
Subject: [PATCH 7/7] ifdef pthread_getname_np as musl doesn't have it
|
||||
|
||||
---
|
||||
tests/CMakeLists.txt | 7 +++++++
|
||||
tests/mir_test/CMakeLists.txt | 6 ++++++
|
||||
tests/mir_test/current_thread_name.cpp | 5 +++++
|
||||
tests/unit-tests/CMakeLists.txt | 18 +++++++++++++++++-
|
||||
.../dispatch/test_threaded_dispatcher.cpp | 9 ++++++---
|
||||
.../frontend/test_basic_connector.cpp | 4 ++++
|
||||
6 files changed, 45 insertions(+), 4 deletions(-)
|
||||
|
||||
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
|
||||
index 2f4b848a59..05f9e596ea 100644
|
||||
--- a/tests/CMakeLists.txt
|
||||
+++ b/tests/CMakeLists.txt
|
||||
@@ -105,6 +105,13 @@ endif()
|
||||
set (CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -fno-lto")
|
||||
set (CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -fno-lto")
|
||||
|
||||
+include(CheckSymbolExists)
|
||||
+list(APPEND CMAKE_REQUIRED_DEFINITIONS -D_GNU_SOURCE)
|
||||
+list(APPEND CMAKE_REQUIRED_LIBRARIES "-lpthread")
|
||||
+string(REPLACE " -Werror " " " CMAKE_C_FLAGS ${CMAKE_C_FLAGS}) # This flag breaks check_symbol_exists()
|
||||
+check_symbol_exists(pthread_getname_np pthread.h HAVE_PTHREAD_GETNAME_NP)
|
||||
+list(REMOVE_ITEM CMAKE_REQUIRED_LIBRARIES "-lpthread")
|
||||
+
|
||||
if (MIR_BUILD_PLATFORM_MESA_KMS)
|
||||
add_definitions(-DMIR_BUILD_PLATFORM_MESA_KMS)
|
||||
endif()
|
||||
diff --git a/tests/mir_test/CMakeLists.txt b/tests/mir_test/CMakeLists.txt
|
||||
index 4eb15aefed..1f9a464abd 100644
|
||||
--- a/tests/mir_test/CMakeLists.txt
|
||||
+++ b/tests/mir_test/CMakeLists.txt
|
||||
@@ -23,3 +23,9 @@ add_library(mir-test-static STATIC
|
||||
wait_object.cpp
|
||||
$<TARGET_OBJECTS:mir-public-test>
|
||||
)
|
||||
+
|
||||
+if (NOT HAVE_PTHREAD_GETNAME_NP)
|
||||
+ set_source_files_properties (current_thread_name.cpp PROPERTIES COMPILE_DEFINITIONS MIR_DONT_USE_PTHREAD_GETNAME_NP
|
||||
+ )
|
||||
+ message(WARNING "pthread_getname_np() not supported by libc. Stubbing out mir::test::current_thread_name() that relies on it")
|
||||
+endif()
|
||||
diff --git a/tests/mir_test/current_thread_name.cpp b/tests/mir_test/current_thread_name.cpp
|
||||
index 26edf0a708..a3c05e36cc 100644
|
||||
--- a/tests/mir_test/current_thread_name.cpp
|
||||
+++ b/tests/mir_test/current_thread_name.cpp
|
||||
@@ -19,13 +19,18 @@
|
||||
#include "mir/test/current_thread_name.h"
|
||||
|
||||
#include <pthread.h>
|
||||
+#include <stdexcept>
|
||||
|
||||
std::string mir::test::current_thread_name()
|
||||
{
|
||||
+#ifndef MIR_DONT_USE_PTHREAD_GETNAME_NP
|
||||
static size_t const max_thread_name_size = 16;
|
||||
char thread_name[max_thread_name_size];
|
||||
|
||||
pthread_getname_np(pthread_self(), thread_name, sizeof thread_name);
|
||||
|
||||
return {thread_name};
|
||||
+#else
|
||||
+ throw std::logic_error("mir::test::current_thread_name() is not supported on this system");
|
||||
+#endif
|
||||
}
|
||||
diff --git a/tests/unit-tests/CMakeLists.txt b/tests/unit-tests/CMakeLists.txt
|
||||
index 5bfd401cdc..23e801b03f 100644
|
||||
--- a/tests/unit-tests/CMakeLists.txt
|
||||
+++ b/tests/unit-tests/CMakeLists.txt
|
||||
@@ -61,7 +61,6 @@ set(
|
||||
shared_library_test.cpp
|
||||
test_raii.cpp
|
||||
test_variable_length_array.cpp
|
||||
- test_thread_name.cpp
|
||||
test_default_emergency_cleanup.cpp
|
||||
test_thread_safe_list.cpp
|
||||
test_fatal.cpp
|
||||
@@ -77,6 +76,12 @@ set(
|
||||
test_edid.cpp
|
||||
)
|
||||
|
||||
+if (HAVE_PTHREAD_GETNAME_NP)
|
||||
+ list(APPEND UNIT_TEST_SOURCES test_thread_name.cpp)
|
||||
+else()
|
||||
+ message(WARNING "pthread_getname_np() not supported: Omitting test_thread_name.cpp which relies on it")
|
||||
+endif()
|
||||
+
|
||||
CMAKE_DEPENDENT_OPTION(
|
||||
MIR_RUN_UNIT_TESTS
|
||||
"Run unit tests as part of default testing"
|
||||
@@ -101,6 +106,17 @@ add_subdirectory(dispatch/)
|
||||
add_subdirectory(renderers/gl)
|
||||
add_subdirectory(wayland/)
|
||||
|
||||
+if (NOT HAVE_PTHREAD_GETNAME_NP)
|
||||
+ set_source_files_properties (
|
||||
+ ${CMAKE_CURRENT_SOURCE_DIR}/dispatch/test_threaded_dispatcher.cpp
|
||||
+ ${CMAKE_CURRENT_SOURCE_DIR}/frontend/test_basic_connector.cpp
|
||||
+
|
||||
+ PROPERTIES COMPILE_DEFINITIONS MIR_DONT_USE_PTHREAD_GETNAME_NP
|
||||
+ )
|
||||
+ message(WARNING "pthread_getname_np() not supported: Disabling test_threaded_dispatcher.cpp tests that rely on it")
|
||||
+ message(WARNING "pthread_getname_np() not supported: Disabling test_basic_connector.cpp tests that rely on it")
|
||||
+endif()
|
||||
+
|
||||
link_directories(${CMAKE_LIBRARY_OUTPUT_DIRECTORY})
|
||||
|
||||
mir_add_wrapped_executable(mir_unit_tests NOINSTALL
|
||||
diff --git a/tests/unit-tests/dispatch/test_threaded_dispatcher.cpp b/tests/unit-tests/dispatch/test_threaded_dispatcher.cpp
|
||||
index 2ac50b1002..382699ab35 100644
|
||||
--- a/tests/unit-tests/dispatch/test_threaded_dispatcher.cpp
|
||||
+++ b/tests/unit-tests/dispatch/test_threaded_dispatcher.cpp
|
||||
@@ -19,6 +19,7 @@
|
||||
#include "mir/dispatch/threaded_dispatcher.h"
|
||||
#include "mir/dispatch/dispatchable.h"
|
||||
#include "mir/fd.h"
|
||||
+#include "mir/test/current_thread_name.h"
|
||||
#include "mir/test/death.h"
|
||||
#include "mir/test/pipe.h"
|
||||
#include "mir/test/signal.h"
|
||||
@@ -278,7 +279,11 @@ TEST_F(ThreadedDispatcherDeathTest, exceptions_in_threadpool_trigger_termination
|
||||
}, KilledBySignal(SIGABRT), (std::string{".*"} + exception_msg + ".*").c_str());
|
||||
}
|
||||
|
||||
+#ifndef MIR_DONT_USE_PTHREAD_GETNAME_NP
|
||||
TEST_F(ThreadedDispatcherTest, sets_thread_names_appropriately)
|
||||
+#else
|
||||
+TEST_F(ThreadedDispatcherTest, DISABLED_sets_thread_names_appropriately)
|
||||
+#endif
|
||||
{
|
||||
using namespace testing;
|
||||
using namespace std::chrono_literals;
|
||||
@@ -290,9 +295,7 @@ TEST_F(ThreadedDispatcherTest, sets_thread_names_appropriately)
|
||||
|
||||
auto dispatchable = std::make_shared<mt::TestDispatchable>([dispatched, &dispatch_count]()
|
||||
{
|
||||
- char buffer[80] = {0};
|
||||
- pthread_getname_np(pthread_self(), buffer, sizeof(buffer));
|
||||
- EXPECT_THAT(buffer, StartsWith(threadname_base));
|
||||
+ EXPECT_THAT(mt::current_thread_name(), StartsWith(threadname_base));
|
||||
|
||||
if (++dispatch_count == threadcount)
|
||||
{
|
||||
diff --git a/tests/unit-tests/frontend/test_basic_connector.cpp b/tests/unit-tests/frontend/test_basic_connector.cpp
|
||||
index 5c553c91d8..623cf98184 100644
|
||||
--- a/tests/unit-tests/frontend/test_basic_connector.cpp
|
||||
+++ b/tests/unit-tests/frontend/test_basic_connector.cpp
|
||||
@@ -41,7 +41,11 @@ struct StubConnectorReport : mir::report::null::ConnectorReport
|
||||
|
||||
}
|
||||
|
||||
+#ifndef MIR_DONT_USE_PTHREAD_GETNAME_NP
|
||||
TEST(BasicConnector, names_ipc_threads)
|
||||
+#else
|
||||
+TEST(BasicConnector, DISABLED_names_ipc_threads)
|
||||
+#endif
|
||||
{
|
||||
using namespace testing;
|
||||
|
||||
--
|
||||
2.20.1
|
||||
|
|
@ -1,7 +1,7 @@
|
|||
# Contributor: Bart Ribbers <bribbers@disroot.org>
|
||||
# Maintainer: Luca Weiss <luca@z3ntu.xyz>
|
||||
pkgname=mir
|
||||
pkgver=1.1.0
|
||||
pkgver=1.1.2
|
||||
pkgrel=0
|
||||
pkgdesc="Canonical's display server"
|
||||
url="https://mir-server.io"
|
||||
|
@ -11,16 +11,7 @@ depends="xkeyboard-config dmz-cursor-theme ttf-freefont"
|
|||
depends_dev="boost-dev mesa-dev glm-dev protobuf-dev glog-dev gflags-dev eudev-dev glib-dev wayland-dev libepoxy-dev nettle-dev libinput-dev
|
||||
capnproto-dev libxml++-2.6-dev py3-pillow freetype-dev libevdev-dev umockdev-dev lttng-ust-dev yaml-cpp-dev libxcursor-dev"
|
||||
makedepends="$depends_dev cmake libxkbcommon-dev gtest-dev gmock clang-dev"
|
||||
source="https://github.com/MirServer/mir/releases/download/v$pkgver/mir-$pkgver.tar.xz
|
||||
0001-Add-missing-include-681.patch
|
||||
0002-Don-t-hardcode-request-type-for-ioctl.patch
|
||||
0003-Suppress-the-compiler-diagnostic-on-Alpine-Linux-cau.patch
|
||||
0004-sys-poll.h-include-is-incorrect-use-poll.h.patch
|
||||
0005-Fix-unused-parameter-type-warning-error-on-musl.patch
|
||||
0006-William-enters-the-dlvsym-fray.patch
|
||||
0007-ifdef-pthread_getname_np-as-musl-doesn-t-have-it.patch
|
||||
no-werror.patch
|
||||
ioctl_clang.patch"
|
||||
source="https://github.com/MirServer/mir/releases/download/v$pkgver/mir-$pkgver.tar.xz"
|
||||
subpackages="$pkgname-dev"
|
||||
options="!check" # Some tests fail
|
||||
|
||||
|
@ -46,13 +37,4 @@ package() {
|
|||
cd "$builddir"
|
||||
make DESTDIR="$pkgdir/" install
|
||||
}
|
||||
sha512sums="6120ee84a0261a672e800d12e8836fc32f2bd24eb85bea703dc32adf1af94ef07b81a2e9d67d9687c68406392e249987d70987a80014bf8010c855002660cee4 mir-1.1.0.tar.xz
|
||||
9141613b5078cdce5b57a2f9e2c1bfec53996cf93e58a5522340420b9eba9c85e5cf72428e6bac0da886f27e32bb850ef468077b9f3814f6b87d427b7b9333a3 0001-Add-missing-include-681.patch
|
||||
737f6dcc91ce6fd94059c08e481b5e54e81207019ffb86c8c8de237c4632edb7842a05297d25e38aa71e9ef0993c9be8a650030d9a7f328ee6f6618be7cf03ed 0002-Don-t-hardcode-request-type-for-ioctl.patch
|
||||
4881969d4c373461d08df39d94d38a14e8a9b5ad4bf37bde4f3d7a3ef87d7df5342a35d98e564961158b5811ce293bff7c780fd98c333787c1914ab9d6cc4bec 0003-Suppress-the-compiler-diagnostic-on-Alpine-Linux-cau.patch
|
||||
561d80f7f40acd8cd92aa22bcd2d5537f3d686d1d4b77209e8633980b593a2103c4a0d1e4ccfeab34c31d7578013f52d705a933e79ef23c9944d133e93342c85 0004-sys-poll.h-include-is-incorrect-use-poll.h.patch
|
||||
26b14f5fd1a340a2163dc97d1be84d457022c4aaf2b6c25163a88cf21fb755ee87a95dd3dde02647fcece3ddc00f4542e89358ad2cdb782c6579255a10744210 0005-Fix-unused-parameter-type-warning-error-on-musl.patch
|
||||
b8aedaf28ba7bb06823628cb3428ec4acd8da0955ace5d022423db0537ce5db568e016c1c6e6df808d2c7b10bf0fb2fc850788bcf90c8ca6411fe28b4843e4e9 0006-William-enters-the-dlvsym-fray.patch
|
||||
6b974cc9beb50c2700cce70a615040d6e2639c921019ce801d0cb1e850454951df0e49509d5b4252180d7dc016389177e2703cc034824e3b1971d7dbe1a9e0b0 0007-ifdef-pthread_getname_np-as-musl-doesn-t-have-it.patch
|
||||
6369c55842c5c2a4eb4970dcafa7f09c36bb1bcaf85d20f3e021f741e7097def3685a96841e9d0a9bd5fdfdfc3016192fdacc751d3e861b51689940fc079e054 no-werror.patch
|
||||
31e87b7dafcb7e59c420b5ebc1cc6f8002f3491a89f38ee7c1aa31fe7f9c667080e15ef69bed10ba5408ef98bae0454e077b0ba67ededa3199801aa32f1e5166 ioctl_clang.patch"
|
||||
sha512sums="4431615d795b93239a83a197d61a5900f094a2108933be4e4da09220bd20e2b031e5232174805216a964279fcf8786672d5c40c3be83856d1903f128b7b814b7 mir-1.1.2.tar.xz"
|
||||
|
|
|
@ -1,13 +0,0 @@
|
|||
diff --git a/tests/privileged-tests/ui_get_sysname_ioctl_override.cpp b/tests/privileged-tests/ui_get_sysname_ioctl_override.cpp
|
||||
index 98b2c7d3db..a4760875d6 100644
|
||||
--- a/tests/privileged-tests/ui_get_sysname_ioctl_override.cpp
|
||||
+++ b/tests/privileged-tests/ui_get_sysname_ioctl_override.cpp
|
||||
@@ -99,7 +99,7 @@ auto request_param_type(int (*ioctl)(int, Param1, ...)) -> Param1;
|
||||
|
||||
using ioctl_request_t = decltype(request_param_type(&ioctl));
|
||||
|
||||
-extern "C" int ioctl(int fd, ioctl_request_t request, ...) noexcept
|
||||
+extern "C" int ioctl(int fd, ioctl_request_t request, ...)
|
||||
{
|
||||
va_list vargs;
|
||||
va_start(vargs, request);
|
|
@ -1,24 +0,0 @@
|
|||
From 5568035c1b6fd208716787e242ef5cfd32caae7e Mon Sep 17 00:00:00 2001
|
||||
From: Luca Weiss <luca@z3ntu.xyz>
|
||||
Date: Thu, 27 Sep 2018 11:49:06 +0200
|
||||
Subject: [PATCH] Remove -Werror from CMakeLists.txt
|
||||
|
||||
---
|
||||
CMakeLists.txt | 4 ++--
|
||||
1 file changed, 2 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
||||
index 4879c94b8c..da9a14b50d 100644
|
||||
--- a/CMakeLists.txt
|
||||
+++ b/CMakeLists.txt
|
||||
@@ -66,8 +66,8 @@ set(CMAKE_CXX_STANDARD 14)
|
||||
set(CMAKE_CXX_EXTENSIONS OFF)
|
||||
set(CMAKE_CXX_STANDARD_REQUIRED ON)
|
||||
|
||||
-set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -pthread -g -Werror -Wall -pedantic -Wextra -fPIC")
|
||||
-set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -pthread -g -std=c++14 -Werror -Wall -fno-strict-aliasing -pedantic -Wnon-virtual-dtor -Wextra -fPIC")
|
||||
+set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -pthread -g -Wall -pedantic -Wextra -fPIC")
|
||||
+set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -pthread -g -std=c++14 -Wall -fno-strict-aliasing -pedantic -Wnon-virtual-dtor -Wextra -fPIC")
|
||||
set(CMAKE_SHARED_LINKER_FLAGS "${CMAKE_SHARED_LINKER_FLAGS} -Wl,--as-needed")
|
||||
set(CMAKE_MODULE_LINKER_FLAGS "${CMAKE_MODULE_LINKER_FLAGS} -Wl,--as-needed")
|
||||
set(CMAKE_EXE_LINKER_FLAGS "${CMAKE_EXE_LINKER_FLAGS} -Wl,--as-needed")
|
|
@ -1,8 +1,8 @@
|
|||
# Contributor: Bart Ribbers <bribbers@disroot.org>
|
||||
# Maintainer: Luca Weiss <luca@z3ntu.xyz>
|
||||
pkgname=qtmir
|
||||
pkgver=0_git20190129
|
||||
_commit="7ba43e5310f39219ee01e73976d44e4b581fc4df"
|
||||
pkgver=0_git20190222
|
||||
_commit="1bddb8c2331f990a53286aeeb070ed384850b52e"
|
||||
pkgrel=0
|
||||
pkgdesc="QPA plugin to make Qt a Mir server"
|
||||
arch="x86_64"
|
||||
|
@ -40,4 +40,4 @@ package() {
|
|||
make DESTDIR="$pkgdir" install
|
||||
}
|
||||
|
||||
sha512sums="69df637dbe88041468609ccdf9d428f5ca9fb0a67bb2b566f9827d49e47857242525b576ca8e528a374435c6dfadc3e2aa190d5dbb305f04d013c9cb981cac3b qtmir-7ba43e5310f39219ee01e73976d44e4b581fc4df.tar.gz"
|
||||
sha512sums="36492fc7ffe0937abb343e9ab816b7194636a4fb8e946f25a3113639460e0c79f8449c05d8fe4b44e4e30167fa39dd8c054bd4df536e21926b73b855212db9eb qtmir-1bddb8c2331f990a53286aeeb070ed384850b52e.tar.gz"
|
||||
|
|
Loading…
Reference in a new issue