kde/trainer: new aport (MR 1335)
This commit is contained in:
parent
57fa113854
commit
8b6590a46b
2 changed files with 50 additions and 0 deletions
34
kde/trainer/APKBUILD
Normal file
34
kde/trainer/APKBUILD
Normal file
|
@ -0,0 +1,34 @@
|
|||
# Maintainer: Bart Ribbers <bribbers@disroot.org>
|
||||
pkgname=trainer
|
||||
pkgver=0_git20200623
|
||||
pkgrel=0
|
||||
_commit="ec505f334188a2d1e2be492c1fad86735f03d96b"
|
||||
pkgdesc="Application to help you practice sport exercises with a description and duration"
|
||||
url="https://invent.kde.org/plasma-mobile/trainer"
|
||||
arch="all !armhf" # armhf blocked by qt5-qtdeclarative
|
||||
license="GPL-3.0-or-later AND CC0-1.0"
|
||||
depends="kirigami2"
|
||||
makedepends="extra-cmake-modules qt5-qtbase-dev qt5-qtdeclarative-dev qt5-qtmultimedia-dev qt5-qtquickcontrols2-dev qt5-qtspeech-dev kirigami2-dev ki18n-dev kdeclarative-dev kconfig-dev kcrash-dev"
|
||||
checkdepends="xvfb-run"
|
||||
source="https://invent.kde.org/plasma-mobile/trainer/-/archive/$_commit/trainer-$_commit.tar.gz"
|
||||
options="!check" # Broken tests https://invent.kde.org/plasma-mobile/trainer/-/issues/1
|
||||
builddir="$srcdir/$pkgname-$_commit"
|
||||
|
||||
build() {
|
||||
cmake -B build \
|
||||
-DCMAKE_BUILD_TYPE=None \
|
||||
-DCMAKE_INSTALL_PREFIX=/usr \
|
||||
-DCMAKE_INSTALL_LIBDIR=lib
|
||||
cmake --build build
|
||||
}
|
||||
|
||||
check() {
|
||||
cd build
|
||||
CTEST_OUTPUT_ON_FAILURE=TRUE xvfb-run ctest
|
||||
}
|
||||
|
||||
package() {
|
||||
DESTDIR="$pkgdir" cmake --build build --target install
|
||||
}
|
||||
|
||||
sha512sums="1a35b776d4f6ef2e92ccdc46e943e6ad6198932ca92f64e4c2d06c0e611b792bd24698b899271bf667a53b66e4429857d39e87006090a088067ded9cbd6402ee trainer-ec505f334188a2d1e2be492c1fad86735f03d96b.tar.gz"
|
16
kde/trainer/install-executable.patch
Normal file
16
kde/trainer/install-executable.patch
Normal file
|
@ -0,0 +1,16 @@
|
|||
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
||||
index 921f876..0a2c668 100644
|
||||
--- a/CMakeLists.txt
|
||||
+++ b/CMakeLists.txt
|
||||
@@ -73,6 +73,11 @@ if (BUILD_TESTING)
|
||||
add_subdirectory(autotests)
|
||||
endif()
|
||||
|
||||
+install(
|
||||
+ TARGETS trainer
|
||||
+ ${INSTALL_TARGETS_DEFAULT_ARGS}
|
||||
+)
|
||||
+
|
||||
install(
|
||||
PROGRAMS org.kde.trainer.desktop
|
||||
DESTINATION ${XDG_APPS_INSTALL_DIR}
|
Loading…
Reference in a new issue