Support for sony-yuga (#500)
This commit is contained in:
parent
71ad48a487
commit
8576b3eabd
12 changed files with 4720 additions and 0 deletions
8
device/device-sony-yuga/90-android.rules
Normal file
8
device/device-sony-yuga/90-android.rules
Normal file
|
@ -0,0 +1,8 @@
|
|||
# udev rules file
|
||||
# All device names can be read from weston's logfile (/tmp/weston.log in postmarketOS)
|
||||
|
||||
# Touchscreen (use 'weston-calibrator' to calibrate)
|
||||
SUBSYSTEM=="input", ATTRS{name}=="clearpad", \
|
||||
ENV{ID_INPUT}="1", ENV{ID_INPUT_TOUCHSCREEN}="1" \
|
||||
ENV{WL_CALIBRATION}="1.013786 0.035310 -24.920929 -0.008370 0.990421 12.094299"
|
||||
|
33
device/device-sony-yuga/APKBUILD
Normal file
33
device/device-sony-yuga/APKBUILD
Normal file
|
@ -0,0 +1,33 @@
|
|||
pkgname=device-sony-yuga
|
||||
pkgver=1
|
||||
pkgrel=1
|
||||
pkgdesc="Sony Xperia Z"
|
||||
url="https://github.com/postmarketOS"
|
||||
arch="noarch"
|
||||
license="MIT"
|
||||
depends="linux-sony-yuga mkbootimg"
|
||||
makedepends=""
|
||||
install=""
|
||||
subpackages=""
|
||||
source="deviceinfo 90-android.rules fb-workaround.sh udev-hack.sh"
|
||||
options="!check"
|
||||
|
||||
build() {
|
||||
return 0
|
||||
}
|
||||
|
||||
package() {
|
||||
install -D -m644 "$srcdir/deviceinfo" \
|
||||
"$pkgdir/etc/deviceinfo"
|
||||
install -D -m644 "$srcdir"/90-android.rules \
|
||||
"$pkgdir"/etc/udev/rules.d/90-android.rules
|
||||
install -D -m644 "$srcdir"/fb-workaround.sh \
|
||||
"$pkgdir"/etc/profile.d/fb-workaround.sh
|
||||
install -D -m644 "$srcdir"/udev-hack.sh \
|
||||
"$pkgdir"/etc/profile.d/00-udev-hack.sh
|
||||
}
|
||||
|
||||
sha512sums="36cd49c24305e86601124c70f9bbc990866dcffa2202956a450ab4049b7a00e23c93ae6869f094a9e2a5b42ce7a1407d0f73341e0c07b2e695295cc50fefa81e deviceinfo
|
||||
1dd1196aa9abe0308a0841147e7e5c6eb50da742cfc3194b90ef22a62d034b43ddade70384b78ab38fa0177da5a822f2a40f1386f4ecd591e2ecc80cb679133a 90-android.rules
|
||||
281937447a73c18e8eec195cbf485fcd513aec20b8df559c26b89fbefa5872c41865cba2440e2cc8a9cc76801bca9ab61f9562c536c6f5f10c925e3ca7f372f3 fb-workaround.sh
|
||||
4f528656c4febb18742e89552dfe7fdc824ed4ad6ad2777d20b4f55040edd93d8e3ea657baabcdbe77bd0fb4bd3d23e5e0b2dae574f0df6723b2e26216ee81e1 udev-hack.sh"
|
33
device/device-sony-yuga/deviceinfo
Normal file
33
device/device-sony-yuga/deviceinfo
Normal file
|
@ -0,0 +1,33 @@
|
|||
# Reference: <https://postmarketos.org/deviceinfo>
|
||||
# Please use double quotes only. You can source this file in shell scripts.
|
||||
|
||||
deviceinfo_format_version="0"
|
||||
deviceinfo_name="Xperia Z"
|
||||
deviceinfo_manufacturer="Sony"
|
||||
deviceinfo_date=""
|
||||
deviceinfo_keyboard="false"
|
||||
deviceinfo_nonfree="????"
|
||||
deviceinfo_dtb=""
|
||||
deviceinfo_modules_initfs=""
|
||||
deviceinfo_external_disk="true"
|
||||
deviceinfo_external_disk_install="true"
|
||||
deviceinfo_flash_methods="fastboot"
|
||||
deviceinfo_arch="armhf"
|
||||
deviceinfo_generate_bootimg="true"
|
||||
|
||||
# Splash screen
|
||||
deviceinfo_screen_width="1080"
|
||||
deviceinfo_screen_height="1920"
|
||||
|
||||
# Fastboot related
|
||||
deviceinfo_flash_offset_base="0x80200000"
|
||||
deviceinfo_flash_offset_kernel="0x00008000"
|
||||
deviceinfo_flash_offset_ramdisk="0x02000000"
|
||||
deviceinfo_flash_offset_second="0x00f00000"
|
||||
deviceinfo_flash_offset_tags="0x00000100"
|
||||
deviceinfo_flash_pagesize="2048"
|
||||
deviceinfo_kernel_cmdline="console=ttyHSL0,115200,n8 androidboot.hardware=qcom user_debug=31 msm_rtb.filter=0x3F ehci-hcd.park=3 maxcpus=2 androidboot.selinux=permissive"
|
||||
|
||||
# Weston red screen workaround (see issue #54)
|
||||
deviceinfo_weston_pixman_type="2"
|
||||
deviceinfo_weston_core_modules="xwayland.so"
|
15
device/device-sony-yuga/fb-workaround.sh
Normal file
15
device/device-sony-yuga/fb-workaround.sh
Normal file
|
@ -0,0 +1,15 @@
|
|||
main() {
|
||||
# Wait untill graphical enviroment is running
|
||||
sleep 5
|
||||
# Workaround for buggy graphics driver
|
||||
for i in 1 2
|
||||
do
|
||||
echo "0,0" > /sys/class/graphics/fb0/pan
|
||||
done
|
||||
}
|
||||
|
||||
# tty1 autologin
|
||||
if [ $(tty) = "/dev/tty1" ]; then
|
||||
# Run in background, to make /etc/profile not wait for it to finish
|
||||
main &
|
||||
fi
|
7
device/device-sony-yuga/udev-hack.sh
Normal file
7
device/device-sony-yuga/udev-hack.sh
Normal file
|
@ -0,0 +1,7 @@
|
|||
#!/bin/sh
|
||||
|
||||
if [ -e /lib/udev/v4l_id ]; then
|
||||
mv /lib/udev/v4l_id /lib/udev/v4l_id_
|
||||
echo "WARNING: v4l_id hangs with the current kernel."
|
||||
echo "=> Moved it from /lib/udev/v4l_id to /lib/udev/v4l_id_"
|
||||
fi
|
114
device/linux-sony-yuga/APKBUILD
Normal file
114
device/linux-sony-yuga/APKBUILD
Normal file
|
@ -0,0 +1,114 @@
|
|||
# APKBUILD based on linux-vanilla aport. Changes:
|
||||
# - disabled module installation
|
||||
# - add !check !tracedeps
|
||||
# - package: just install zImage and kernel.release, because the kernel config
|
||||
# does not generate modules or dtb files
|
||||
# - do not create -dev subpackage (makes no sense without module support)
|
||||
#
|
||||
# Kernel config changes, based on: arch/arm/configs/fusion3_yuga_defconfig
|
||||
# - enable devtmpfs (needed for udev -> touch support in weston)
|
||||
# - set CONFIG_USB_ETH=y and CONFIG_USB_ETH_RNDIS=y (needed for ethernet over USB (rndis))
|
||||
|
||||
_vendor=sony
|
||||
_flavor=sony-yuga
|
||||
_hash="f164c6d1016cb34ac90c053acbebe6e47fdd400f"
|
||||
_config="config-${_flavor}.armhf"
|
||||
|
||||
pkgname=linux-${_flavor}
|
||||
pkgver=3.4.0
|
||||
case $pkgver in
|
||||
*.*.*) _kernver=${pkgver%.*};;
|
||||
*.*) _kernver=$pkgver;;
|
||||
esac
|
||||
pkgrel=1
|
||||
arch="armhf"
|
||||
pkgdesc="Sony Xperia Z kernel"
|
||||
url="https://github.com/LineageOS/android_kernel_sony_apq8064"
|
||||
depends="postmarketos-mkinitfs"
|
||||
makedepends="perl sed installkernel bash gmp-dev bc linux-headers elfutils-dev"
|
||||
options="!strip !check !tracedeps"
|
||||
install=
|
||||
source="
|
||||
$pkgname-$_hash.tar.gz::https://github.com/LineageOS/android_kernel_sony_apq8064/archive/$_hash.tar.gz
|
||||
$_config
|
||||
compiler-gcc6.h
|
||||
aeea3592a13bf12861943e44fc48f1f270941f8d.patch
|
||||
psmouse_base.patch
|
||||
kgsl_iommu_sync_lock.patch
|
||||
reduce_lzo_compression.patch
|
||||
"
|
||||
subpackages=""
|
||||
license="GPL2"
|
||||
|
||||
_abi_release=${pkgver}
|
||||
_carch="arm"
|
||||
HOSTCC="${CC:-gcc}"
|
||||
HOSTCC="${HOSTCC#${CROSS_COMPILE}}"
|
||||
|
||||
ksrcdir="$srcdir/android_kernel_sony_apq8064-${_hash}"
|
||||
|
||||
prepare() {
|
||||
local _patch_failed=
|
||||
cd "$ksrcdir"
|
||||
|
||||
# first apply patches in specified order
|
||||
for i in $source; do
|
||||
case $i in
|
||||
*.patch)
|
||||
msg "Applying $i..."
|
||||
if ! patch -s -p1 -N -i "$srcdir"/$i; then
|
||||
echo $i >>failed
|
||||
_patch_failed=1
|
||||
fi
|
||||
;;
|
||||
esac
|
||||
done
|
||||
|
||||
if ! [ -z "$_patch_failed" ]; then
|
||||
error "The following patches failed:"
|
||||
cat failed
|
||||
return 1
|
||||
fi
|
||||
|
||||
# gcc6 support
|
||||
cp -v "$srcdir/compiler-gcc6.h" "$ksrcdir/include/linux/" || return 1
|
||||
|
||||
mkdir -p "$srcdir"/build
|
||||
cp "$srcdir"/$_config "$srcdir"/build/.config || return 1
|
||||
make -C "$ksrcdir" O="$srcdir"/build ARCH="$_carch" HOSTCC="$HOSTCC" \
|
||||
silentoldconfig
|
||||
}
|
||||
|
||||
|
||||
|
||||
# this is so we can do: 'abuild menuconfig' to reconfigure kernel
|
||||
menuconfig() {
|
||||
cd "$srcdir"/build || return 1
|
||||
make ARCH="$_carch" menuconfig
|
||||
cp .config "$startdir"/$_config
|
||||
}
|
||||
|
||||
build() {
|
||||
cd "$srcdir"/build
|
||||
unset LDFLAGS
|
||||
|
||||
make ARCH="$_carch" CC="${CC:-gcc}" \
|
||||
KBUILD_BUILD_VERSION="$((pkgrel + 1 ))-Alpine" \
|
||||
|| return 1
|
||||
}
|
||||
|
||||
package() {
|
||||
install -Dm644 "$srcdir/build/arch/arm/boot/zImage" \
|
||||
"$pkgdir/boot/vmlinuz-$_flavor"
|
||||
|
||||
install -D "$srcdir/build/include/config/kernel.release" \
|
||||
"$pkgdir/usr/share/kernel/$_flavor/kernel.release"
|
||||
}
|
||||
|
||||
sha512sums="18f083088d8dd09263677c47d96802596bcf70e9e37cf8c9a886afd68225d573a5bef39fba155a9b1ba2074a45258a14aad720fe6af077278a49e40c747d817f linux-sony-yuga-f164c6d1016cb34ac90c053acbebe6e47fdd400f.tar.gz
|
||||
fdb80d0b4c45fbd5e492abb9946752d834a4238e341aa57323e0b28f4a77fdbe5801ad8511c38c8b81ec6b364859f40496060dcca7e7306a0e95e522dcffbb94 config-sony-yuga.armhf
|
||||
d80980e9474c82ba0ef1a6903b434d8bd1b092c40367ba543e72d2c119301c8b2d05265740e4104ca1ac5d15f6c4aa49e8776cb44264a9a28dc551e0d1850dcc compiler-gcc6.h
|
||||
ea1d3b5a234fa565e3c1a792de48f4fc4e6023d281d303c8e319c7ef28edc5739ab0e4dea0139a41f0a5c7d03e27921ccaa214fd0ac5c72245a094ce60128864 aeea3592a13bf12861943e44fc48f1f270941f8d.patch
|
||||
f7e31cfe422696922aec52002e56c58103183966edee3bb8e1995d33f8d37b07c32280a8ecc213874e358a6ff367418556a4542fba7e3c17e4b8e82e05c3a543 psmouse_base.patch
|
||||
448bad436377a22c93ac401b9aecb504fe8e84b9511a3dd28f3cc125f3725cc1168ef03dee9f8f1085a9fbb7910b9e75cd25a382ccce626b427c8e27f7c17ffc kgsl_iommu_sync_lock.patch
|
||||
ef5b912c26fea4ab882592bdf7487942c64b123de8d25d08d976f29743f311742ee2f773bf2d110ddb5095f254dbb0bd4487c5cfce77311929082599199e7ebd reduce_lzo_compression.patch"
|
|
@ -0,0 +1,49 @@
|
|||
From aeea3592a13bf12861943e44fc48f1f270941f8d Mon Sep 17 00:00:00 2001
|
||||
From: Behan Webster <behanw@converseincode.com>
|
||||
Date: Wed, 24 Sep 2014 01:06:46 +0100
|
||||
Subject: [PATCH] ARM: 8158/1: LLVMLinux: use static inline in ARM ftrace.h
|
||||
|
||||
With compilers which follow the C99 standard (like modern versions of gcc and
|
||||
clang), "extern inline" does the wrong thing (emits code for an externally
|
||||
linkable version of the inline function). In this case using static inline
|
||||
and removing the NULL version of return_address in return_address.c does
|
||||
the right thing.
|
||||
|
||||
Signed-off-by: Behan Webster <behanw@converseincode.com>
|
||||
Reviewed-by: Mark Charlebois <charlebm@gmail.com>
|
||||
Acked-by: Steven Rostedt <rostedt@goodmis.org>
|
||||
Signed-off-by: Russell King <rmk+kernel@arm.linux.org.uk>
|
||||
---
|
||||
arch/arm/include/asm/ftrace.h | 2 +-
|
||||
arch/arm/kernel/return_address.c | 5 -----
|
||||
2 files changed, 1 insertion(+), 6 deletions(-)
|
||||
|
||||
diff --git a/arch/arm/include/asm/ftrace.h b/arch/arm/include/asm/ftrace.h
|
||||
index 39eb16b0066f2..bfe2a2f5a644e 100644
|
||||
--- a/arch/arm/include/asm/ftrace.h
|
||||
+++ b/arch/arm/include/asm/ftrace.h
|
||||
@@ -45,7 +45,7 @@ void *return_address(unsigned int);
|
||||
|
||||
#else
|
||||
|
||||
-extern inline void *return_address(unsigned int level)
|
||||
+static inline void *return_address(unsigned int level)
|
||||
{
|
||||
return NULL;
|
||||
}
|
||||
diff --git a/arch/arm/kernel/return_address.c b/arch/arm/kernel/return_address.c
|
||||
index fafedd86885dd..f6aa84d5b93c9 100644
|
||||
--- a/arch/arm/kernel/return_address.c
|
||||
+++ b/arch/arm/kernel/return_address.c
|
||||
@@ -63,11 +63,6 @@ void *return_address(unsigned int level)
|
||||
#warning "TODO: return_address should use unwind tables"
|
||||
#endif
|
||||
|
||||
-void *return_address(unsigned int level)
|
||||
-{
|
||||
- return NULL;
|
||||
-}
|
||||
-
|
||||
#endif /* if defined(CONFIG_FRAME_POINTER) && !defined(CONFIG_ARM_UNWIND) / else */
|
||||
|
||||
EXPORT_SYMBOL_GPL(return_address);
|
69
device/linux-sony-yuga/compiler-gcc6.h
Normal file
69
device/linux-sony-yuga/compiler-gcc6.h
Normal file
|
@ -0,0 +1,69 @@
|
|||
// SOURCE:
|
||||
// https://github.com/NextThingCo/CHIP-u-boot/issues/10#issuecomment-287515505
|
||||
|
||||
#ifndef __LINUX_COMPILER_H
|
||||
#error "Please don't include <linux/compiler-gcc6.h> directly, include <linux/compiler.h> instead."
|
||||
#endif
|
||||
|
||||
#define __used __attribute__((__used__))
|
||||
#define __must_check __attribute__((warn_unused_result))
|
||||
#define __compiler_offsetof(a, b) __builtin_offsetof(a, b)
|
||||
|
||||
/* Mark functions as cold. gcc will assume any path leading to a call
|
||||
to them will be unlikely. This means a lot of manual unlikely()s
|
||||
are unnecessary now for any paths leading to the usual suspects
|
||||
like BUG(), printk(), panic() etc. [but let's keep them for now for
|
||||
older compilers]
|
||||
|
||||
Early snapshots of gcc 4.3 don't support this and we can't detect this
|
||||
in the preprocessor, but we can live with this because they're unreleased.
|
||||
Maketime probing would be overkill here.
|
||||
|
||||
gcc also has a __attribute__((__hot__)) to move hot functions into
|
||||
a special section, but I don't see any sense in this right now in
|
||||
the kernel context */
|
||||
#define __cold __attribute__((__cold__))
|
||||
|
||||
#define __UNIQUE_ID(prefix) __PASTE(__PASTE(__UNIQUE_ID_, prefix), __COUNTER__)
|
||||
|
||||
#ifndef __CHECKER__
|
||||
# define __compiletime_warning(message) __attribute__((warning(message)))
|
||||
# define __compiletime_error(message) __attribute__((error(message)))
|
||||
#endif /* __CHECKER__ */
|
||||
|
||||
/*
|
||||
* Mark a position in code as unreachable. This can be used to
|
||||
* suppress control flow warnings after asm blocks that transfer
|
||||
* control elsewhere.
|
||||
*
|
||||
* Early snapshots of gcc 4.5 don't support this and we can't detect
|
||||
* this in the preprocessor, but we can live with this because they're
|
||||
* unreleased. Really, we need to have autoconf for the kernel.
|
||||
*/
|
||||
#define unreachable() __builtin_unreachable()
|
||||
|
||||
/* Mark a function definition as prohibited from being cloned. */
|
||||
#define __noclone __attribute__((__noclone__))
|
||||
|
||||
/*
|
||||
* Tell the optimizer that something else uses this function or variable.
|
||||
*/
|
||||
#define __visible __attribute__((externally_visible))
|
||||
|
||||
/*
|
||||
* GCC 'asm goto' miscompiles certain code sequences:
|
||||
*
|
||||
* http://gcc.gnu.org/bugzilla/show_bug.cgi?id=58670
|
||||
*
|
||||
* Work it around via a compiler barrier quirk suggested by Jakub Jelinek.
|
||||
*
|
||||
* (asm goto is automatically volatile - the naming reflects this.)
|
||||
*/
|
||||
#define asm_volatile_goto(x...) do { asm goto(x); asm (""); } while (0)
|
||||
|
||||
#ifdef CONFIG_ARCH_USE_BUILTIN_BSWAP
|
||||
#define __HAVE_BUILTIN_BSWAP32__
|
||||
#define __HAVE_BUILTIN_BSWAP64__
|
||||
#define __HAVE_BUILTIN_BSWAP16__
|
||||
#endif /* CONFIG_ARCH_USE_BUILTIN_BSWAP */
|
||||
|
4220
device/linux-sony-yuga/config-sony-yuga.armhf
Normal file
4220
device/linux-sony-yuga/config-sony-yuga.armhf
Normal file
File diff suppressed because it is too large
Load diff
40
device/linux-sony-yuga/kgsl_iommu_sync_lock.patch
Normal file
40
device/linux-sony-yuga/kgsl_iommu_sync_lock.patch
Normal file
|
@ -0,0 +1,40 @@
|
|||
From 2853d750d5051be484a94406e8614b2fe5fc2d76 Mon Sep 17 00:00:00 2001
|
||||
From: Chet Kener <Cl3Kener@gmail.com>
|
||||
Date: Tue, 21 Oct 2014 18:41:36 -0400
|
||||
Subject: [PATCH] gcc5: gpu: msm: fix 5.0 compile
|
||||
|
||||
* These need to be static to avoid these errors:
|
||||
|
||||
drivers/built-in.o: In function `.LANCHOR1':
|
||||
msm_iommu_sec.c:(.data+0x9298): undefined reference to `kgsl_iommu_sync_lock'
|
||||
msm_iommu_sec.c:(.data+0x929c): undefined reference to `kgsl_iommu_sync_unlock'
|
||||
Makefile:877: recipe for target '.tmp_vmlinux1' failed
|
||||
make: *** [.tmp_vmlinux1] Error 1
|
||||
|
||||
Signed-off-by: Chet Kener <Cl3Kener@gmail.com>
|
||||
---
|
||||
drivers/gpu/msm/kgsl_iommu.c | 4 ++--
|
||||
1 file changed, 2 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/drivers/gpu/msm/kgsl_iommu.c b/drivers/gpu/msm/kgsl_iommu.c
|
||||
index f76c95204a2..caf75592a2a 100755
|
||||
--- a/drivers/gpu/msm/kgsl_iommu.c
|
||||
+++ b/drivers/gpu/msm/kgsl_iommu.c
|
||||
@@ -1019,7 +1019,7 @@ static int kgsl_iommu_init_sync_lock(struct kgsl_mmu *mmu)
|
||||
*
|
||||
* Return - int - number of commands.
|
||||
*/
|
||||
-inline unsigned int kgsl_iommu_sync_lock(struct kgsl_mmu *mmu,
|
||||
+static inline unsigned int kgsl_iommu_sync_lock(struct kgsl_mmu *mmu,
|
||||
unsigned int *cmds)
|
||||
{
|
||||
struct kgsl_device *device = mmu->device;
|
||||
@@ -1089,7 +1089,7 @@ inline unsigned int kgsl_iommu_sync_lock(struct kgsl_mmu *mmu,
|
||||
*
|
||||
* Return - int - number of commands.
|
||||
*/
|
||||
-inline unsigned int kgsl_iommu_sync_unlock(struct kgsl_mmu *mmu,
|
||||
+static inline unsigned int kgsl_iommu_sync_unlock(struct kgsl_mmu *mmu,
|
||||
unsigned int *cmds)
|
||||
{
|
||||
struct kgsl_device *device = mmu->device;
|
106
device/linux-sony-yuga/psmouse_base.patch
Normal file
106
device/linux-sony-yuga/psmouse_base.patch
Normal file
|
@ -0,0 +1,106 @@
|
|||
From ae4fef6fc558b0621532d0de6ebaaeaabe861792 Mon Sep 17 00:00:00 2001
|
||||
From: sub77 <sub77@ymail.com>
|
||||
Date: Fri, 31 Jul 2015 17:47:45 +0200
|
||||
Subject: [PATCH] fix build error: PS2MOUSE fsp_detect & lifebook
|
||||
|
||||
---
|
||||
drivers/input/mouse/psmouse-base.c | 62 +++++++++++++++++++-------------------
|
||||
1 file changed, 31 insertions(+), 31 deletions(-)
|
||||
|
||||
diff --git a/drivers/input/mouse/psmouse-base.c b/drivers/input/mouse/psmouse-base.c
|
||||
index a19c183557d..ad3d2e861d0 100644
|
||||
--- a/drivers/input/mouse/psmouse-base.c
|
||||
+++ b/drivers/input/mouse/psmouse-base.c
|
||||
@@ -708,14 +708,14 @@ static int psmouse_extensions(struct psmouse *psmouse,
|
||||
/*
|
||||
* We always check for lifebook because it does not disturb mouse
|
||||
* (it only checks DMI information).
|
||||
+ *
|
||||
+ * if (psmouse_do_detect(lifebook_detect, psmouse, set_properties) == 0) {
|
||||
+ * if (max_proto > PSMOUSE_IMEX) {
|
||||
+ * if (!set_properties || lifebook_init(psmouse) == 0)
|
||||
+ * return PSMOUSE_LIFEBOOK;
|
||||
+ * }
|
||||
+ * }
|
||||
*/
|
||||
- if (psmouse_do_detect(lifebook_detect, psmouse, set_properties) == 0) {
|
||||
- if (max_proto > PSMOUSE_IMEX) {
|
||||
- if (!set_properties || lifebook_init(psmouse) == 0)
|
||||
- return PSMOUSE_LIFEBOOK;
|
||||
- }
|
||||
- }
|
||||
-
|
||||
/*
|
||||
* Try Kensington ThinkingMouse (we try first, because synaptics probe
|
||||
* upsets the thinkingmouse).
|
||||
@@ -821,19 +821,19 @@ static int psmouse_extensions(struct psmouse *psmouse,
|
||||
/*
|
||||
* Try Finger Sensing Pad. We do it here because its probe upsets
|
||||
* Trackpoint devices (causing TP_READ_ID command to time out).
|
||||
- */
|
||||
- if (max_proto > PSMOUSE_IMEX) {
|
||||
- if (psmouse_do_detect(fsp_detect,
|
||||
- psmouse, set_properties) == 0) {
|
||||
- if (!set_properties || fsp_init(psmouse) == 0)
|
||||
- return PSMOUSE_FSP;
|
||||
-/*
|
||||
+ *
|
||||
+ * if (max_proto > PSMOUSE_IMEX) {
|
||||
+ * if (psmouse_do_detect(fsp_detect,
|
||||
+ * psmouse, set_properties) == 0) {
|
||||
+ * if (!set_properties || fsp_init(psmouse) == 0)
|
||||
+ * return PSMOUSE_FSP;
|
||||
+ *
|
||||
* Init failed, try basic relative protocols
|
||||
+ *
|
||||
+ * max_proto = PSMOUSE_IMEX;
|
||||
+ * }
|
||||
+ * }
|
||||
*/
|
||||
- max_proto = PSMOUSE_IMEX;
|
||||
- }
|
||||
- }
|
||||
-
|
||||
/*
|
||||
* Reset to defaults in case the device got confused by extended
|
||||
* protocol probes. Note that we follow up with full reset because
|
||||
@@ -944,12 +944,12 @@ static const struct psmouse_protocol psmouse_protocols[] = {
|
||||
},
|
||||
#endif
|
||||
#ifdef CONFIG_MOUSE_PS2_LIFEBOOK
|
||||
- {
|
||||
- .type = PSMOUSE_LIFEBOOK,
|
||||
- .name = "LBPS/2",
|
||||
- .alias = "lifebook",
|
||||
- .init = lifebook_init,
|
||||
- },
|
||||
+/* {
|
||||
+* .type = PSMOUSE_LIFEBOOK,
|
||||
+* .name = "LBPS/2",
|
||||
+* .alias = "lifebook",
|
||||
+* .init = lifebook_init,
|
||||
+* },*/
|
||||
#endif
|
||||
#ifdef CONFIG_MOUSE_PS2_TRACKPOINT
|
||||
{
|
||||
@@ -985,13 +985,13 @@ static const struct psmouse_protocol psmouse_protocols[] = {
|
||||
},
|
||||
#endif
|
||||
#ifdef CONFIG_MOUSE_PS2_SENTELIC
|
||||
- {
|
||||
- .type = PSMOUSE_FSP,
|
||||
- .name = "FSPPS/2",
|
||||
- .alias = "fsp",
|
||||
- .detect = fsp_detect,
|
||||
- .init = fsp_init,
|
||||
- },
|
||||
+/* {
|
||||
+* .type = PSMOUSE_FSP,
|
||||
+* .name = "FSPPS/2",
|
||||
+* .alias = "fsp",
|
||||
+* .detect = fsp_detect,
|
||||
+* .init = fsp_init,
|
||||
+* },*/
|
||||
#endif
|
||||
{
|
||||
.type = PSMOUSE_CORTRON,
|
26
device/linux-sony-yuga/reduce_lzo_compression.patch
Normal file
26
device/linux-sony-yuga/reduce_lzo_compression.patch
Normal file
|
@ -0,0 +1,26 @@
|
|||
diff --git a/scripts/Makefile.lib b/scripts/Makefile.lib
|
||||
index a7ca009..808091b 100644
|
||||
--- a/scripts/Makefile.lib
|
||||
+++ b/scripts/Makefile.lib
|
||||
@@ -259,7 +259,7 @@ cmd_lzma = (cat $(filter-out FORCE,$^) | \
|
||||
|
||||
quiet_cmd_lzo = LZO $@
|
||||
cmd_lzo = (cat $(filter-out FORCE,$^) | \
|
||||
- lzop -9 && $(call size_append, $(filter-out FORCE,$^))) > $@ || \
|
||||
+ lzop -6 && $(call size_append, $(filter-out FORCE,$^))) > $@ || \
|
||||
(rm -f $@ ; false)
|
||||
|
||||
# XZ
|
||||
diff --git a/scripts/gen_initramfs_list.sh b/scripts/gen_initramfs_list.sh
|
||||
index b482f16..c4e08c5 100644
|
||||
--- a/scripts/gen_initramfs_list.sh
|
||||
+++ b/scripts/gen_initramfs_list.sh
|
||||
@@ -245,7 +245,7 @@ case "$arg" in
|
||||
echo "$output_file" | grep -q "\.lzma$" && compr="lzma -9 -f"
|
||||
echo "$output_file" | grep -q "\.xz$" && \
|
||||
compr="xz --check=crc32 --lzma2=dict=1MiB"
|
||||
- echo "$output_file" | grep -q "\.lzo$" && compr="lzop -9 -f"
|
||||
+ echo "$output_file" | grep -q "\.lzo$" && compr="lzop -6 -f"
|
||||
echo "$output_file" | grep -q "\.cpio$" && compr="cat"
|
||||
shift
|
||||
;;
|
Loading…
Reference in a new issue