lg-madai: new device (LG Fx0) (MR 3276)
Because I don't have access to the serial port yet, I begin with the vendor kernel. * Make display work by setting to 16bpp [ci:skip-build]: already built successfully in CI
This commit is contained in:
parent
0c4b793bc8
commit
8302ff553a
11 changed files with 3936 additions and 0 deletions
32
device/testing/device-lg-madai/APKBUILD
Normal file
32
device/testing/device-lg-madai/APKBUILD
Normal file
|
@ -0,0 +1,32 @@
|
|||
# Reference: <https://postmarketos.org/devicepkg>
|
||||
pkgname=device-lg-madai
|
||||
pkgdesc="LG Fx0"
|
||||
pkgver=0.1
|
||||
pkgrel=0
|
||||
url="https://postmarketos.org"
|
||||
license="MIT"
|
||||
arch="armv7"
|
||||
options="!check !archcheck"
|
||||
depends="
|
||||
linux-lg-madai
|
||||
mesa-dri-gallium
|
||||
mkbootimg
|
||||
postmarketos-base
|
||||
msm-fb-refresher
|
||||
mdss-fb-init-hack
|
||||
wcnss-wlan
|
||||
"
|
||||
makedepends="devicepkg-dev"
|
||||
source="deviceinfo"
|
||||
|
||||
build() {
|
||||
devicepkg_build $startdir $pkgname
|
||||
}
|
||||
|
||||
package() {
|
||||
devicepkg_package $startdir $pkgname
|
||||
}
|
||||
|
||||
sha512sums="
|
||||
08a8ccb85acce23196b6439ec599cf530da679f1dc68df69b1237f6c7a59b62cc47eb9e40086dbddbed1e28e66da0ceae58d2bdd12aa17236b65c52cab68ec3b deviceinfo
|
||||
"
|
31
device/testing/device-lg-madai/deviceinfo
Normal file
31
device/testing/device-lg-madai/deviceinfo
Normal file
|
@ -0,0 +1,31 @@
|
|||
# Reference: <https://postmarketos.org/deviceinfo>
|
||||
# Please use double quotes only. You can source this file in shell
|
||||
# scripts.
|
||||
|
||||
deviceinfo_format_version="0"
|
||||
deviceinfo_name="LG Fx0"
|
||||
deviceinfo_manufacturer="LG"
|
||||
deviceinfo_codename="lg-madai"
|
||||
deviceinfo_year="2014"
|
||||
deviceinfo_arch="armv7"
|
||||
|
||||
# Device related
|
||||
deviceinfo_chassis="handset"
|
||||
deviceinfo_keyboard="false"
|
||||
deviceinfo_external_storage="true"
|
||||
deviceinfo_screen_width="720"
|
||||
deviceinfo_screen_height="1280"
|
||||
|
||||
# Bootloader related
|
||||
deviceinfo_flash_method="fastboot"
|
||||
deviceinfo_kernel_cmdline="console=ttyHSL0,115200,n8 androidboot.console=ttyHSL0 androidboot.hardware=madai user_debug=31 msm_rtb.filter=0x37"
|
||||
deviceinfo_generate_bootimg="true"
|
||||
deviceinfo_bootimg_qcdt="true"
|
||||
deviceinfo_bootimg_mtk_mkimage="false"
|
||||
deviceinfo_bootimg_dtb_second="false"
|
||||
deviceinfo_flash_pagesize="2048"
|
||||
deviceinfo_flash_offset_base="0x00000000"
|
||||
deviceinfo_flash_offset_kernel="0x00008000"
|
||||
deviceinfo_flash_offset_ramdisk="0x02000000"
|
||||
deviceinfo_flash_offset_second="0x00f00000"
|
||||
deviceinfo_flash_offset_tags="0x01e00000"
|
|
@ -0,0 +1,31 @@
|
|||
From 8722cd082aff5d3afae4ea7f7d631dd76d616aff Mon Sep 17 00:00:00 2001
|
||||
From: bjorn3 <17426603+bjorn3@users.noreply.github.com>
|
||||
Date: Wed, 22 Jun 2022 13:01:01 +0200
|
||||
Subject: [PATCH] Fix signature mismatch for msm_pm_boot_init
|
||||
|
||||
This previously caused msm_pm_boot_init to incorrectly get handled as
|
||||
__init function when it needs to be an __devinit function as it is
|
||||
called by msm_pm_boot_probe, which is an __devinit function.
|
||||
---
|
||||
arch/arm/mach-msm/pm-boot.h | 4 ++--
|
||||
1 file changed, 2 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/arch/arm/mach-msm/pm-boot.h b/arch/arm/mach-msm/pm-boot.h
|
||||
index 2d5110d306..8b5f69e423 100644
|
||||
--- a/arch/arm/mach-msm/pm-boot.h
|
||||
+++ b/arch/arm/mach-msm/pm-boot.h
|
||||
@@ -31,9 +31,9 @@ struct msm_pm_boot_platform_data {
|
||||
};
|
||||
|
||||
#ifdef CONFIG_PM
|
||||
-int __init msm_pm_boot_init(struct msm_pm_boot_platform_data *pdata);
|
||||
+int __devinit msm_pm_boot_init(struct msm_pm_boot_platform_data *pdata);
|
||||
#else
|
||||
-static inline int __init msm_pm_boot_init(
|
||||
+static inline int __devinit msm_pm_boot_init(
|
||||
struct msm_pm_boot_platform_data *pdata)
|
||||
{
|
||||
return 0;
|
||||
--
|
||||
2.26.2.7.g19db9cfb68
|
||||
|
|
@ -0,0 +1,13 @@
|
|||
diff --git a/drivers/video/msm/mdss/mdss_fb.c b/drivers/video/msm/mdss/mdss_fb.c
|
||||
index c3967c26192..197f0f423d0 100644
|
||||
--- a/drivers/video/msm/mdss/mdss_fb.c
|
||||
+++ b/drivers/video/msm/mdss/mdss_fb.c
|
||||
@@ -503,7 +503,7 @@ static int mdss_fb_probe(struct platform_device *pdev)
|
||||
mfd->bl_level = 0;
|
||||
mfd->bl_scale = 1024;
|
||||
mfd->bl_min_lvl = 30;
|
||||
- mfd->fb_imgType = MDP_RGBA_8888;
|
||||
+ mfd->fb_imgType = MDP_RGB_565;
|
||||
|
||||
mfd->pdev = pdev;
|
||||
if (pdata->next)
|
75
device/testing/linux-lg-madai/APKBUILD
Normal file
75
device/testing/linux-lg-madai/APKBUILD
Normal file
|
@ -0,0 +1,75 @@
|
|||
# Reference: <https://postmarketos.org/vendorkernel>
|
||||
# Kernel config based on: arch/arm/configs/madai-perf_defconfig
|
||||
|
||||
pkgname=linux-lg-madai
|
||||
pkgver=3.4.0
|
||||
pkgrel=0
|
||||
pkgdesc="LG Fx0 kernel fork"
|
||||
arch="armv7"
|
||||
_carch="arm"
|
||||
_flavor="lg-madai"
|
||||
url="https://kernel.org"
|
||||
license="GPL-2.0-only"
|
||||
options="!strip !check !tracedeps pmb:cross-native"
|
||||
makedepends="
|
||||
bash
|
||||
bc
|
||||
bison
|
||||
devicepkg-dev
|
||||
dtbtool
|
||||
flex
|
||||
openssl-dev
|
||||
perl
|
||||
"
|
||||
|
||||
# Source
|
||||
_repository="android-kernel-lg-madai"
|
||||
_commit="03aba4427a7666d57b5ae06d375e259ea337f351"
|
||||
_config="config-$_flavor.$arch"
|
||||
source="
|
||||
$pkgname-$_commit.tar.gz::https://github.com/peremen/$_repository/archive/$_commit.tar.gz
|
||||
$_config
|
||||
gcc7-give-up-on-ilog2-const-optimizations.patch
|
||||
gcc8-fix-put-user.patch
|
||||
gcc10-extern_YYLOC_global_declaration.patch
|
||||
kernel-use-the-gnu89-standard-explicitly.patch
|
||||
timeconst.pl-Eliminate-Perl-warning.patch
|
||||
0001-Fix-signature-mismatch-for-msm_pm_boot_init.patch
|
||||
0004-fix_mdss_fb_rgb_mode.patch
|
||||
"
|
||||
builddir="$srcdir/$_repository-$_commit"
|
||||
_outdir="out"
|
||||
|
||||
prepare() {
|
||||
default_prepare
|
||||
. downstreamkernel_prepare
|
||||
}
|
||||
|
||||
build() {
|
||||
unset LDFLAGS
|
||||
make O="$_outdir" ARCH="$_carch" CC="${CC:-gcc}" \
|
||||
KBUILD_BUILD_VERSION="$((pkgrel + 1 ))-postmarketOS"
|
||||
|
||||
# Master DTB (deviceinfo_bootimg_qcdt)
|
||||
dtbTool -o "$_outdir/arch/$_carch/boot"/dt.img \
|
||||
"$_outdir/arch/$_carch/boot/"
|
||||
}
|
||||
|
||||
package() {
|
||||
downstreamkernel_package "$builddir" "$pkgdir" "$_carch" \
|
||||
"$_flavor" "$_outdir"
|
||||
install -Dm644 "$_outdir/arch/$_carch/boot"/dt.img \
|
||||
"$pkgdir"/boot/dt.img
|
||||
}
|
||||
|
||||
sha512sums="
|
||||
025b4b63c2ff316ad67c07c078ee5b4ed3ab49f04c335eb7b69bd16d8b1345c5652b77a41dd63630708a4807fe9bfc9e121fb0e0471d922f974eeadc06a3a6f6 linux-lg-madai-03aba4427a7666d57b5ae06d375e259ea337f351.tar.gz
|
||||
64e5ae42927a3aa58f8436ff1279ef36b0c778078f16a4fbd94cbc3fa6b0d339205a72b4bbdb239b6a185c3e95297d50979e202cb00e1d8778f16a4df2ea9893 config-lg-madai.armv7
|
||||
77eba606a71eafb36c32e9c5fe5e77f5e4746caac292440d9fb720763d766074a964db1c12bc76fe583c5d1a5c864219c59941f5e53adad182dbc70bf2bc14a7 gcc7-give-up-on-ilog2-const-optimizations.patch
|
||||
197d40a214ada87fcb2dfc0ae4911704b9a93354b75179cd6b4aadbb627a37ec262cf516921c84a8b1806809b70a7b440cdc8310a4a55fca5d2c0baa988e3967 gcc8-fix-put-user.patch
|
||||
2b48f1bf0e3f70703d2cdafc47d5e615cc7c56c70bec56b2e3297d3fa4a7a1321d649a8679614553dde8fe52ff1051dae38d5990e3744c9ca986d92187dcdbeb gcc10-extern_YYLOC_global_declaration.patch
|
||||
ad0182a483791fc88e058838bc331b2f04a75ba291e763767babdb815efadfc3b4fda97e69e2e3f00a426cabea088e35297a92bd287592597d1e309be68ee92c kernel-use-the-gnu89-standard-explicitly.patch
|
||||
1fcfb5f06a2bfdcc55d53054ca80d1b989599a39a5379d057a0724fc405187d74da4309a650e70b9c79d39444e81923cfc5c9199ed8c0a77c83dcd7998446bb7 timeconst.pl-Eliminate-Perl-warning.patch
|
||||
25217ec622dbcb811c9a7375c6e360f313e58c8433a300c9a9afd3f17712ec0d322e16501c72c49fef9e38a2d3a69718401bf4269977fccd075a4a57d8458c5d 0001-Fix-signature-mismatch-for-msm_pm_boot_init.patch
|
||||
39cf0f311fc9e86bab163b1ecfda70a1059ca8c811c72a0704271e63d73e98b8f84e59a8c161d7799d06b6f7d9786e8ccf5d28d2369e446897812d77fa85f67f 0004-fix_mdss_fb_rgb_mode.patch
|
||||
"
|
3749
device/testing/linux-lg-madai/config-lg-madai.armv7
Normal file
3749
device/testing/linux-lg-madai/config-lg-madai.armv7
Normal file
File diff suppressed because it is too large
Load diff
|
@ -0,0 +1 @@
|
|||
../../.shared-patches/linux/gcc10-extern_YYLOC_global_declaration.patch
|
|
@ -0,0 +1 @@
|
|||
../../.shared-patches/linux/gcc7-give-up-on-ilog2-const-optimizations.patch
|
1
device/testing/linux-lg-madai/gcc8-fix-put-user.patch
Symbolic link
1
device/testing/linux-lg-madai/gcc8-fix-put-user.patch
Symbolic link
|
@ -0,0 +1 @@
|
|||
../../.shared-patches/linux/gcc8-fix-put-user.patch
|
|
@ -0,0 +1 @@
|
|||
../../.shared-patches/linux/kernel-use-the-gnu89-standard-explicitly.patch
|
|
@ -0,0 +1 @@
|
|||
../../.shared-patches/linux/timeconst.pl-Eliminate-Perl-warning.patch
|
Loading…
Reference in a new issue