add support for xiaomi-ido (Xiaomi Redmi 3 [Pro]) (#1043)
Device boots, weston starts, ssh works, osk-sdl works
This commit is contained in:
parent
083e21bcef
commit
8297ed30b7
8 changed files with 4322 additions and 0 deletions
29
device/device-xiaomi-ido/APKBUILD
Normal file
29
device/device-xiaomi-ido/APKBUILD
Normal file
|
@ -0,0 +1,29 @@
|
||||||
|
# Reference: <https://postmarketos.org/devicepkg>
|
||||||
|
pkgname="device-xiaomi-ido"
|
||||||
|
pkgdesc="Xiaomi Xiaomi RedMi 3"
|
||||||
|
pkgver=0.1
|
||||||
|
pkgrel=0
|
||||||
|
url="https://postmarketos.org"
|
||||||
|
license="MIT"
|
||||||
|
arch="noarch"
|
||||||
|
options="!check"
|
||||||
|
depends="linux-xiaomi-ido mkbootimg"
|
||||||
|
makedepends="devicepkg-dev"
|
||||||
|
source="deviceinfo
|
||||||
|
fb.modes
|
||||||
|
initfs-hook.sh"
|
||||||
|
|
||||||
|
build() {
|
||||||
|
devicepkg_build $startdir $pkgname
|
||||||
|
}
|
||||||
|
|
||||||
|
package() {
|
||||||
|
devicepkg_package $startdir $pkgname
|
||||||
|
install -Dm644 "$srcdir"/fb.modes "$pkgdir"/etc/fb.modes
|
||||||
|
install -Dm644 "$srcdir"/initfs-hook.sh "$pkgdir"/etc/postmarketos-mkinitfs/hooks/00-${pkgname}.sh
|
||||||
|
|
||||||
|
}
|
||||||
|
|
||||||
|
sha512sums="71067cb3a218b9d3055b241c3fce6ef8b487fda9c415d9d0b94ee793886c8ff57cc4d174f6cd655cc3d034b08a6496b606657cac1dd2000eb4c110ef62e00bfd deviceinfo
|
||||||
|
8a72f8d34fd0a8c7b6de0a2ab16e255b3fe28993e1aef7c25c3c4becc5851e51f5dcc3814acc75c8bb829bc02d180d976ee3877a98982d29cfc5cb7ea84f1c32 fb.modes
|
||||||
|
3b46dfab8465935349a8775e0247a3ea4274c16a9f526f17e1397ae2f6bdef11d9cbd969dc630a7d647e4130f5a2f1a8e85357fc34a5b1900411f9219a62b38e initfs-hook.sh"
|
33
device/device-xiaomi-ido/deviceinfo
Normal file
33
device/device-xiaomi-ido/deviceinfo
Normal file
|
@ -0,0 +1,33 @@
|
||||||
|
# Reference: <https://postmarketos.org/deviceinfo>
|
||||||
|
# Please use double quotes only. You can source this file in shell scripts.
|
||||||
|
|
||||||
|
deviceinfo_format_version="0"
|
||||||
|
deviceinfo_name="Xiaomi RedMi 3"
|
||||||
|
deviceinfo_manufacturer="Xiaomi"
|
||||||
|
deviceinfo_date=""
|
||||||
|
deviceinfo_dtb=""
|
||||||
|
deviceinfo_modules_initfs=""
|
||||||
|
deviceinfo_external_disk_install="false"
|
||||||
|
deviceinfo_arch="aarch64"
|
||||||
|
|
||||||
|
# Device related
|
||||||
|
deviceinfo_keyboard="false"
|
||||||
|
deviceinfo_external_disk="true"
|
||||||
|
deviceinfo_screen_width="720"
|
||||||
|
deviceinfo_screen_height="1080"
|
||||||
|
deviceinfo_dev_touchscreen="/dev/input/event0"
|
||||||
|
deviceinfo_dev_touchscreen_calibration=""
|
||||||
|
deviceinfo_dev_keyboard=""
|
||||||
|
|
||||||
|
# Bootloader related
|
||||||
|
deviceinfo_flash_method="fastboot"
|
||||||
|
deviceinfo_kernel_cmdline="console=none androidboot.hardware=qcom ehci-hcd.park=3 androidboot.bootdevice=7824900.sdhci lpm_levels.sleep_disabled=1 buildvariant=userdebug"
|
||||||
|
deviceinfo_generate_bootimg="true"
|
||||||
|
deviceinfo_bootimg_qcdt="true"
|
||||||
|
deviceinfo_flash_offset_base="0x80000000"
|
||||||
|
deviceinfo_flash_offset_kernel="0x00008000"
|
||||||
|
deviceinfo_flash_offset_ramdisk="0x01000000"
|
||||||
|
deviceinfo_flash_offset_second="0x00f00000"
|
||||||
|
deviceinfo_flash_offset_tags="0x00000100"
|
||||||
|
deviceinfo_flash_pagesize="2048"
|
||||||
|
|
9
device/device-xiaomi-ido/fb.modes
Normal file
9
device/device-xiaomi-ido/fb.modes
Normal file
|
@ -0,0 +1,9 @@
|
||||||
|
|
||||||
|
mode "720x1280-1"
|
||||||
|
# D: 1.991 MHz, H: 1.872 kHz, V: 1.428 Hz
|
||||||
|
geometry 720 1280 720 1280 16
|
||||||
|
timings 502165 160 160 12 15 24 4
|
||||||
|
accel false
|
||||||
|
rgba 8/0,8/8,8/16,8/24
|
||||||
|
endmode
|
||||||
|
|
20
device/device-xiaomi-ido/initfs-hook.sh
Normal file
20
device/device-xiaomi-ido/initfs-hook.sh
Normal file
|
@ -0,0 +1,20 @@
|
||||||
|
#!/bin/sh
|
||||||
|
|
||||||
|
# postmarketos-mkinitfs's init script does already have a framebuffer workaround script
|
||||||
|
# but that script checks if fb0/mode is empty. in our case, it already has the correct value
|
||||||
|
# but the framebuffer is nevertheless not doing anything.
|
||||||
|
# additionally if we set the mode again the at time the postmarketos init script does,
|
||||||
|
# absolutely nothing happens. It seems to work if we sleep 5 seconds to give whatever needs
|
||||||
|
# more time, more time and then set the framebuffer mode again.
|
||||||
|
|
||||||
|
|
||||||
|
set_xiaomi_ido_framebuffer_mode() {
|
||||||
|
[ -e "/sys/class/graphics/fb0/modes" ] || return
|
||||||
|
[ -e "/sys/class/graphics/fb0/mode" ] || return
|
||||||
|
|
||||||
|
_mode="$(cat /sys/class/graphics/fb0/modes)"
|
||||||
|
echo "Setting framebuffer mode to: $_mode"
|
||||||
|
echo "$_mode" > /sys/class/graphics/fb0/mode
|
||||||
|
}
|
||||||
|
|
||||||
|
sleep 5 && set_xiaomi_ido_framebuffer_mode &
|
68
device/linux-xiaomi-ido/01_fix_gcc6_errors.patch
Normal file
68
device/linux-xiaomi-ido/01_fix_gcc6_errors.patch
Normal file
|
@ -0,0 +1,68 @@
|
||||||
|
From 44f841be2a223d672eaf9fa3029fd9249aeca583 Mon Sep 17 00:00:00 2001
|
||||||
|
From: MOVZX <movzx@yahoo.com>
|
||||||
|
Date: Tue, 25 Apr 2017 17:04:40 +0300
|
||||||
|
Subject: [PATCH] prima: Fix GCC6 Warnings
|
||||||
|
|
||||||
|
Signed-off-by: MOVZX <movzx@yahoo.com>
|
||||||
|
---
|
||||||
|
drivers/staging/prima/CORE/MAC/src/include/utilsApi.h | 2 +-
|
||||||
|
drivers/staging/prima/CORE/MAC/src/pe/sch/schBeaconGen.c | 2 +-
|
||||||
|
drivers/staging/prima/CORE/SME/src/csr/csrApiScan.c | 2 +-
|
||||||
|
drivers/staging/prima/CORE/VOSS/src/wlan_nv_template_builtin.c | 5 ++---
|
||||||
|
4 files changed, 5 insertions(+), 6 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/drivers/staging/prima/CORE/MAC/src/include/utilsApi.h b/drivers/staging/prima/CORE/MAC/src/include/utilsApi.h
|
||||||
|
index 3a175473378..798a05cd2b4 100644
|
||||||
|
--- a/drivers/staging/prima/CORE/MAC/src/include/utilsApi.h
|
||||||
|
+++ b/drivers/staging/prima/CORE/MAC/src/include/utilsApi.h
|
||||||
|
@@ -705,7 +705,7 @@ halRoundS32(tANI_S32 p)
|
||||||
|
else
|
||||||
|
k = p;
|
||||||
|
|
||||||
|
- return(k);
|
||||||
|
+ return(k);
|
||||||
|
}
|
||||||
|
|
||||||
|
// New functions for endianess conversion
|
||||||
|
diff --git a/drivers/staging/prima/CORE/MAC/src/pe/sch/schBeaconGen.c b/drivers/staging/prima/CORE/MAC/src/pe/sch/schBeaconGen.c
|
||||||
|
index 0fc798995ae..6427a04e108 100644
|
||||||
|
--- a/drivers/staging/prima/CORE/MAC/src/pe/sch/schBeaconGen.c
|
||||||
|
+++ b/drivers/staging/prima/CORE/MAC/src/pe/sch/schBeaconGen.c
|
||||||
|
@@ -60,7 +60,7 @@
|
||||||
|
// Temporarily (maybe for all of Alpha-1), assuming TIM = 0
|
||||||
|
//
|
||||||
|
|
||||||
|
-const tANI_U8 P2pOui[] = {0x50, 0x6F, 0x9A, 0x9};
|
||||||
|
+tANI_U8 P2pOui[] = {0x50, 0x6F, 0x9A, 0x9};
|
||||||
|
|
||||||
|
|
||||||
|
tSirRetStatus schGetP2pIeOffset(tANI_U8 *pExtraIe, tANI_U32 extraIeLen, tANI_U16 *pP2pIeOffset)
|
||||||
|
diff --git a/drivers/staging/prima/CORE/SME/src/csr/csrApiScan.c b/drivers/staging/prima/CORE/SME/src/csr/csrApiScan.c
|
||||||
|
index 23ab858c355..b4f26def1d1 100644
|
||||||
|
--- a/drivers/staging/prima/CORE/SME/src/csr/csrApiScan.c
|
||||||
|
+++ b/drivers/staging/prima/CORE/SME/src/csr/csrApiScan.c
|
||||||
|
@@ -5698,7 +5698,7 @@ static tANI_BOOLEAN csrScanProcessScanResults( tpAniSirGlobal pMac, tSmeCmd *pCo
|
||||||
|
if (eHAL_STATUS_SUCCESS != status)
|
||||||
|
smsLog(pMac, LOGE,
|
||||||
|
FL( "failed to update the supported channel list"));
|
||||||
|
- pMac->scan.defer_update_channel_list = false;
|
||||||
|
+ pMac->scan.defer_update_channel_list = false;
|
||||||
|
}
|
||||||
|
|
||||||
|
#ifdef WLAN_AP_STA_CONCURRENCY
|
||||||
|
diff --git a/drivers/staging/prima/CORE/VOSS/src/wlan_nv_template_builtin.c b/drivers/staging/prima/CORE/VOSS/src/wlan_nv_template_builtin.c
|
||||||
|
index 14c6eadf524..e26b697f793 100644
|
||||||
|
--- a/drivers/staging/prima/CORE/VOSS/src/wlan_nv_template_builtin.c
|
||||||
|
+++ b/drivers/staging/prima/CORE/VOSS/src/wlan_nv_template_builtin.c
|
||||||
|
@@ -587,9 +587,8 @@ _NV_TEMPLATE_TABLE NvTablesBuiltIn[/*TABLES_MAX*/][TABLE_ENTRIES_MAX] = {
|
||||||
|
((char *)&(nvDefaults.tables.hwCalValues.calData.psSlpTimeOvrHdxLNA5G) -
|
||||||
|
(char *)&nvDefaults.tables.hwCalValues.calData),"psSlpTimeOvrHdxLNA5G"},
|
||||||
|
{"ed",_ID_U8,SINGULAR,0,0,0,
|
||||||
|
- (((char *)&(nvDefaults.tables.hwCalValues.calData.psSlpTimeOvrHdxLNA5G) +
|
||||||
|
- sizeof(uint16)) - (char *)&nvDefaults.tables.hwCalValues.calData),
|
||||||
|
- "nv_TxBBFSel9MHz"},
|
||||||
|
+ ((char *)&(nvDefaults.tables.hwCalValues.calData.psSlpTimeOvrHdxLNA5G) -
|
||||||
|
+ (char *)&nvDefaults.tables.hwCalValues.calData),"nv_TxBBFSel9MHz"},
|
||||||
|
{"ee",_ID_U8,SINGULAR,0,0,0,
|
||||||
|
((char *)&(nvDefaults.tables.hwCalValues.calData.hwParam2) -
|
||||||
|
(char *)&nvDefaults.tables.hwCalValues.calData),"hwParam2"},
|
83
device/linux-xiaomi-ido/APKBUILD
Normal file
83
device/linux-xiaomi-ido/APKBUILD
Normal file
|
@ -0,0 +1,83 @@
|
||||||
|
# Kernel config based on: arch/arm64/configs/lineage_ido_defconfig
|
||||||
|
|
||||||
|
pkgname="linux-xiaomi-ido"
|
||||||
|
pkgver=3.10.107
|
||||||
|
pkgrel=2
|
||||||
|
pkgdesc="Xiaomi Xiaomi RedMi 3 kernel fork"
|
||||||
|
arch="aarch64"
|
||||||
|
_carch="arm64"
|
||||||
|
_flavor="xiaomi-ido"
|
||||||
|
url="https://kernel.org"
|
||||||
|
license="GPL2"
|
||||||
|
options="!strip !check !tracedeps"
|
||||||
|
makedepends="perl sed installkernel bash gmp-dev bc linux-headers elfutils-dev dtbtool python"
|
||||||
|
HOSTCC="${CC:-gcc}"
|
||||||
|
HOSTCC="${HOSTCC#${CROSS_COMPILE}}"
|
||||||
|
|
||||||
|
# Source
|
||||||
|
_repository="android_kernel_xiaomi_msm8916"
|
||||||
|
_commit="8f4c7c59fb3a29344af202150030ae712f801d6b"
|
||||||
|
_config="config-${_flavor}.${arch}"
|
||||||
|
source="
|
||||||
|
$pkgname-$_commit.tar.gz::https://github.com/LineageOS/${_repository}/archive/${_commit}.tar.gz
|
||||||
|
$_config
|
||||||
|
compiler-gcc6.h
|
||||||
|
01_fix_gcc6_errors.patch
|
||||||
|
"
|
||||||
|
builddir="$srcdir/${_repository}-${_commit}"
|
||||||
|
|
||||||
|
prepare() {
|
||||||
|
default_prepare
|
||||||
|
|
||||||
|
# gcc6 support
|
||||||
|
cp -v "$srcdir/compiler-gcc6.h" "$builddir/include/linux/"
|
||||||
|
|
||||||
|
# Remove -Werror from all makefiles
|
||||||
|
find . -type f -name Makefile -print0 | \
|
||||||
|
xargs -0 sed -i 's/-Werror-/-W/g'
|
||||||
|
find . -type f -name Makefile -print0 | \
|
||||||
|
xargs -0 sed -i 's/-Werror//g'
|
||||||
|
|
||||||
|
# Prepare kernel config ('yes ""' for kernels lacking olddefconfig)
|
||||||
|
cp "$srcdir"/$_config "$builddir"/.config
|
||||||
|
yes "" | make ARCH="$_carch" HOSTCC="$HOSTCC" oldconfig
|
||||||
|
}
|
||||||
|
|
||||||
|
menuconfig() {
|
||||||
|
cd "$builddir"
|
||||||
|
make ARCH="$_carch" menuconfig
|
||||||
|
cp .config "$startdir"/$_config
|
||||||
|
}
|
||||||
|
|
||||||
|
build() {
|
||||||
|
unset LDFLAGS
|
||||||
|
make ARCH="$_carch" CC="${CC:-gcc}" \
|
||||||
|
KBUILD_BUILD_VERSION="$((pkgrel + 1 ))-postmarketOS"
|
||||||
|
dtbTool -s 2048 -p "scripts/dtc/" -o "arch/arm/boot/dt.img" "arch/arm/boot/"
|
||||||
|
}
|
||||||
|
|
||||||
|
package() {
|
||||||
|
# kernel.release
|
||||||
|
install -D "$builddir/include/config/kernel.release" \
|
||||||
|
"$pkgdir/usr/share/kernel/$_flavor/kernel.release"
|
||||||
|
|
||||||
|
# zImage (find the right one)
|
||||||
|
cd "$builddir/arch/$_carch/boot"
|
||||||
|
_target="$pkgdir/boot/vmlinuz-$_flavor"
|
||||||
|
for _zimg in zImage-dtb Image.gz-dtb *zImage Image; do
|
||||||
|
[ -e "$_zimg" ] || continue
|
||||||
|
msg "zImage found: $_zimg"
|
||||||
|
install -Dm644 "$_zimg" "$_target"
|
||||||
|
break
|
||||||
|
done
|
||||||
|
if ! [ -e "$_target" ]; then
|
||||||
|
error "Could not find zImage in $PWD!"
|
||||||
|
return 1
|
||||||
|
fi
|
||||||
|
install -Dm644 "$builddir/arch/arm/boot/dt.img" "$pkgdir/boot/dt.img"
|
||||||
|
}
|
||||||
|
|
||||||
|
sha512sums="e22e3cff0819edd2d9f0f16bc952a97773a8b4b36394ab6acf61fd619988d6d0bf1f7d29cba904a09ca0c63209fcedcdf65ee522646193980c5ac6c60e1c3a97 linux-xiaomi-ido-8f4c7c59fb3a29344af202150030ae712f801d6b.tar.gz
|
||||||
|
c7b9c2900c7d9fa49ea8ceb511092e58aa57e3cf6808e0c9130fac5a5619c7e67b7292e5c4dd23b0a9d3f14f73ba26cbc6c926d5947974395fd602c65324cc1d config-xiaomi-ido.aarch64
|
||||||
|
d80980e9474c82ba0ef1a6903b434d8bd1b092c40367ba543e72d2c119301c8b2d05265740e4104ca1ac5d15f6c4aa49e8776cb44264a9a28dc551e0d1850dcc compiler-gcc6.h
|
||||||
|
972e98523d6ef06342e69a09e979bdd86904cf7f9a843b519b37791e531b680182564a2ab537c94629c3589f4e775b2c39de04c64e210a0f8b6f10745c3596f1 01_fix_gcc6_errors.patch"
|
69
device/linux-xiaomi-ido/compiler-gcc6.h
Normal file
69
device/linux-xiaomi-ido/compiler-gcc6.h
Normal file
|
@ -0,0 +1,69 @@
|
||||||
|
// SOURCE:
|
||||||
|
// https://github.com/NextThingCo/CHIP-u-boot/issues/10#issuecomment-287515505
|
||||||
|
|
||||||
|
#ifndef __LINUX_COMPILER_H
|
||||||
|
#error "Please don't include <linux/compiler-gcc6.h> directly, include <linux/compiler.h> instead."
|
||||||
|
#endif
|
||||||
|
|
||||||
|
#define __used __attribute__((__used__))
|
||||||
|
#define __must_check __attribute__((warn_unused_result))
|
||||||
|
#define __compiler_offsetof(a, b) __builtin_offsetof(a, b)
|
||||||
|
|
||||||
|
/* Mark functions as cold. gcc will assume any path leading to a call
|
||||||
|
to them will be unlikely. This means a lot of manual unlikely()s
|
||||||
|
are unnecessary now for any paths leading to the usual suspects
|
||||||
|
like BUG(), printk(), panic() etc. [but let's keep them for now for
|
||||||
|
older compilers]
|
||||||
|
|
||||||
|
Early snapshots of gcc 4.3 don't support this and we can't detect this
|
||||||
|
in the preprocessor, but we can live with this because they're unreleased.
|
||||||
|
Maketime probing would be overkill here.
|
||||||
|
|
||||||
|
gcc also has a __attribute__((__hot__)) to move hot functions into
|
||||||
|
a special section, but I don't see any sense in this right now in
|
||||||
|
the kernel context */
|
||||||
|
#define __cold __attribute__((__cold__))
|
||||||
|
|
||||||
|
#define __UNIQUE_ID(prefix) __PASTE(__PASTE(__UNIQUE_ID_, prefix), __COUNTER__)
|
||||||
|
|
||||||
|
#ifndef __CHECKER__
|
||||||
|
# define __compiletime_warning(message) __attribute__((warning(message)))
|
||||||
|
# define __compiletime_error(message) __attribute__((error(message)))
|
||||||
|
#endif /* __CHECKER__ */
|
||||||
|
|
||||||
|
/*
|
||||||
|
* Mark a position in code as unreachable. This can be used to
|
||||||
|
* suppress control flow warnings after asm blocks that transfer
|
||||||
|
* control elsewhere.
|
||||||
|
*
|
||||||
|
* Early snapshots of gcc 4.5 don't support this and we can't detect
|
||||||
|
* this in the preprocessor, but we can live with this because they're
|
||||||
|
* unreleased. Really, we need to have autoconf for the kernel.
|
||||||
|
*/
|
||||||
|
#define unreachable() __builtin_unreachable()
|
||||||
|
|
||||||
|
/* Mark a function definition as prohibited from being cloned. */
|
||||||
|
#define __noclone __attribute__((__noclone__))
|
||||||
|
|
||||||
|
/*
|
||||||
|
* Tell the optimizer that something else uses this function or variable.
|
||||||
|
*/
|
||||||
|
#define __visible __attribute__((externally_visible))
|
||||||
|
|
||||||
|
/*
|
||||||
|
* GCC 'asm goto' miscompiles certain code sequences:
|
||||||
|
*
|
||||||
|
* http://gcc.gnu.org/bugzilla/show_bug.cgi?id=58670
|
||||||
|
*
|
||||||
|
* Work it around via a compiler barrier quirk suggested by Jakub Jelinek.
|
||||||
|
*
|
||||||
|
* (asm goto is automatically volatile - the naming reflects this.)
|
||||||
|
*/
|
||||||
|
#define asm_volatile_goto(x...) do { asm goto(x); asm (""); } while (0)
|
||||||
|
|
||||||
|
#ifdef CONFIG_ARCH_USE_BUILTIN_BSWAP
|
||||||
|
#define __HAVE_BUILTIN_BSWAP32__
|
||||||
|
#define __HAVE_BUILTIN_BSWAP64__
|
||||||
|
#define __HAVE_BUILTIN_BSWAP16__
|
||||||
|
#endif /* CONFIG_ARCH_USE_BUILTIN_BSWAP */
|
||||||
|
|
4011
device/linux-xiaomi-ido/config-xiaomi-ido.aarch64
Normal file
4011
device/linux-xiaomi-ido/config-xiaomi-ido.aarch64
Normal file
File diff suppressed because it is too large
Load diff
Loading…
Reference in a new issue