main/linux-postmarketos-allwinner: use rtl8723cs driver from kernel tree (!1002)
We'll use the new RTL8723CS driver in the kernel tree instead of using the one that we have to fetch from GitHub. Signed-off-by: Danct12 <danct12@disroot.org> Signed-off-by: Asriel Dreemurr <asriel.danctnix@gmail.com> [ci:skip-build]: already built successfully in CI
This commit is contained in:
parent
dafe96e37e
commit
7f64e287e7
4 changed files with 24 additions and 42 deletions
|
@ -1,23 +1,21 @@
|
||||||
_flavor=postmarketos-allwinner
|
_flavor=postmarketos-allwinner
|
||||||
_config="config-$_flavor.$CARCH"
|
_config="config-$_flavor.$CARCH"
|
||||||
|
|
||||||
pkgname=linux-$_flavor
|
pkgname=linux-$_flavor
|
||||||
pkgver=5.5.0_git20200225
|
pkgver=5.5.0_git20200319
|
||||||
pkgrel=3
|
pkgrel=0
|
||||||
|
|
||||||
arch="aarch64"
|
arch="aarch64"
|
||||||
pkgdesc="Kernel fork with Pine64 patches"
|
pkgdesc="Kernel fork with Pine64 patches"
|
||||||
url="https://gitlab.com/pine64-org/linux/"
|
url="https://gitlab.com/pine64-org/linux/"
|
||||||
license="GPL2"
|
license="GPL-2.0-only"
|
||||||
makedepends="devicepkg-dev perl sed installkernel bash gmp-dev bc linux-headers elfutils-dev openssl-dev file bison flex rsync"
|
makedepends="devicepkg-dev perl sed installkernel bash gmp-dev bc linux-headers elfutils-dev openssl-dev file bison flex rsync"
|
||||||
options="!strip !check !tracedeps"
|
options="!strip !check !tracedeps"
|
||||||
_commit="ec1031d53ba4de194eab86f2cc2e5cb3f8fe6e81"
|
_commit="94cf851f0f4443c771a926102dee497def319b49"
|
||||||
_commit_rtl8723cs="1c9c0cb9d335626a66d8063399c6e16751ecc1a8"
|
|
||||||
source="
|
source="
|
||||||
$pkgname-$_commit.tar.gz::https://gitlab.com/pine64-org/linux/-/archive/$_commit/linux-$_commit.tar.gz
|
$pkgname-$_commit.tar.gz::https://gitlab.com/pine64-org/linux/-/archive/$_commit/linux-$_commit.tar.gz
|
||||||
rtl8723cs-$_commit_rtl8723cs.tar.gz::https://github.com/Icenowy/rtl8723cs/archive/$_commit_rtl8723cs.tar.gz
|
|
||||||
config-$_flavor.aarch64
|
config-$_flavor.aarch64
|
||||||
|
disable-power-save.patch
|
||||||
touch-dts.patch
|
touch-dts.patch
|
||||||
rtl8723cs.patch
|
|
||||||
"
|
"
|
||||||
|
|
||||||
subpackages="$pkgname-dev"
|
subpackages="$pkgname-dev"
|
||||||
|
@ -35,8 +33,6 @@ builddir="$srcdir/linux-$_commit"
|
||||||
prepare() {
|
prepare() {
|
||||||
default_prepare
|
default_prepare
|
||||||
|
|
||||||
cp -rv "$srcdir"/rtl8723cs-${_commit_rtl8723cs} "$builddir"/drivers/staging/rtl8723cs
|
|
||||||
|
|
||||||
REPLACE_GCCH=0 \
|
REPLACE_GCCH=0 \
|
||||||
. downstreamkernel_prepare
|
. downstreamkernel_prepare
|
||||||
}
|
}
|
||||||
|
@ -69,8 +65,7 @@ dev() {
|
||||||
INSTALL_HDR_PATH="$subpkgdir"/usr
|
INSTALL_HDR_PATH="$subpkgdir"/usr
|
||||||
}
|
}
|
||||||
|
|
||||||
sha512sums="e534f16f308cdce4dec45c5cd89aa9336f6f77fb2610ded9796fde5bec78201ee62f56615de2e93be9cac69a3bfda06e28acd59f46234e360c61c8b1709b9d1c linux-postmarketos-allwinner-ec1031d53ba4de194eab86f2cc2e5cb3f8fe6e81.tar.gz
|
sha512sums="cfaaf2334691105be22275c13c6f82d8630b070d0cdeb0e33e5c545d3673c8acce2ead6c2d0a1b7318414f12b50cc0aa3641842e05f4cc8187a690be13852341 linux-postmarketos-allwinner-94cf851f0f4443c771a926102dee497def319b49.tar.gz
|
||||||
e4e585ce787301eeee07ff8e45a97343456808a47ed237053f0c83a49b4958a75514def4c5263f4507a282ea90bd2bb3f8f468839f7e5fd05ae947a796c8c6b9 rtl8723cs-1c9c0cb9d335626a66d8063399c6e16751ecc1a8.tar.gz
|
b79e73d7508ccb93f1d01d3b43753e3d4d14fdf6144d5f6dfb9c6db3aaaf80b69bdc0285fe7c79786863507027399b7410c15ec3e88239ff626b6e07eb47698e config-postmarketos-allwinner.aarch64
|
||||||
946ee0840f54050ee56bb3a35ef4fcb5d53cdb7c3db9cfb9ac0e5e2a3e0ca27f6e65e79fa077430945b2df4bb47afc77b4519c015d6ba2c909eb09ad720864c6 config-postmarketos-allwinner.aarch64
|
8cdfb6d8a894e610c261446663dfbe34c01612a091fa029645e86913634de4394db0d1ab7dedb190052dff82330f0ddabe31860bbf7cd6fe0cdf23e37d0a6ca6 disable-power-save.patch
|
||||||
5f403bb1e3e7528954adcba4429768ce26bf13382dc6325ced245babcfb5252d515bea812b9df16d0e5370c9d4e07b4e0267f4c750281faf3cb6ffb29906700c touch-dts.patch
|
5f403bb1e3e7528954adcba4429768ce26bf13382dc6325ced245babcfb5252d515bea812b9df16d0e5370c9d4e07b4e0267f4c750281faf3cb6ffb29906700c touch-dts.patch"
|
||||||
bf06f931fb543f4bf2f0567902c3021de237fc9684f92af2ed3e956f869d907c9cff1cf3e11a72eb97bda47c8f8b28aff226634f641bdffa04b08d434f419faa rtl8723cs.patch"
|
|
||||||
|
|
|
@ -4381,7 +4381,6 @@ CONFIG_STAGING=y
|
||||||
# CONFIG_COMEDI is not set
|
# CONFIG_COMEDI is not set
|
||||||
# CONFIG_RTLLIB is not set
|
# CONFIG_RTLLIB is not set
|
||||||
CONFIG_RTL8723BS=m
|
CONFIG_RTL8723BS=m
|
||||||
CONFIG_RTL8723CS=m
|
|
||||||
# CONFIG_R8712U is not set
|
# CONFIG_R8712U is not set
|
||||||
# CONFIG_R8188EU is not set
|
# CONFIG_R8188EU is not set
|
||||||
# CONFIG_VT6656 is not set
|
# CONFIG_VT6656 is not set
|
||||||
|
@ -4488,7 +4487,7 @@ CONFIG_ASHMEM=y
|
||||||
# CONFIG_UWB is not set
|
# CONFIG_UWB is not set
|
||||||
# CONFIG_EXFAT_FS is not set
|
# CONFIG_EXFAT_FS is not set
|
||||||
# CONFIG_WFX is not set
|
# CONFIG_WFX is not set
|
||||||
# CONFIG_RTL8723CS_NEW is not set
|
CONFIG_RTL8723CS_NEW=m
|
||||||
# CONFIG_GOLDFISH is not set
|
# CONFIG_GOLDFISH is not set
|
||||||
# CONFIG_MFD_CROS_EC is not set
|
# CONFIG_MFD_CROS_EC is not set
|
||||||
# CONFIG_CHROME_PLATFORMS is not set
|
# CONFIG_CHROME_PLATFORMS is not set
|
||||||
|
|
13
main/linux-postmarketos-allwinner/disable-power-save.patch
Normal file
13
main/linux-postmarketos-allwinner/disable-power-save.patch
Normal file
|
@ -0,0 +1,13 @@
|
||||||
|
diff --git a/drivers/staging/rtl8723cs-new/Makefile b/drivers/staging/rtl8723cs-new/Makefile
|
||||||
|
index 17e66758e6fb..626119f460be 100644
|
||||||
|
--- a/drivers/staging/rtl8723cs-new/Makefile
|
||||||
|
+++ b/drivers/staging/rtl8723cs-new/Makefile
|
||||||
|
@@ -48,7 +48,7 @@ CONFIG_SDIO_HCI = y
|
||||||
|
CONFIG_GSPI_HCI = n
|
||||||
|
########################## Features ###########################
|
||||||
|
CONFIG_MP_INCLUDED = y
|
||||||
|
-CONFIG_POWER_SAVING = y
|
||||||
|
+CONFIG_POWER_SAVING = n
|
||||||
|
CONFIG_USB_AUTOSUSPEND = n
|
||||||
|
CONFIG_HW_PWRP_DETECTION = n
|
||||||
|
CONFIG_WIFI_TEST = n
|
|
@ -1,25 +0,0 @@
|
||||||
diff --git a/drivers/staging/Kconfig b/drivers/staging/Kconfig
|
|
||||||
index 7c96a01eef6c..e9b849ecbc80 100644
|
|
||||||
--- a/drivers/staging/Kconfig
|
|
||||||
+++ b/drivers/staging/Kconfig
|
|
||||||
@@ -36,6 +36,8 @@ source "drivers/staging/rtl8192e/Kconfig"
|
|
||||||
|
|
||||||
source "drivers/staging/rtl8723bs/Kconfig"
|
|
||||||
|
|
||||||
+source "drivers/staging/rtl8723cs/Kconfig"
|
|
||||||
+
|
|
||||||
source "drivers/staging/rtl8712/Kconfig"
|
|
||||||
|
|
||||||
source "drivers/staging/rtl8188eu/Kconfig"
|
|
||||||
diff --git a/drivers/staging/Makefile b/drivers/staging/Makefile
|
|
||||||
index fcaac9693b83..dfc287028474 100644
|
|
||||||
--- a/drivers/staging/Makefile
|
|
||||||
+++ b/drivers/staging/Makefile
|
|
||||||
@@ -8,6 +8,7 @@ obj-$(CONFIG_FB_OLPC_DCON) += olpc_dcon/
|
|
||||||
obj-$(CONFIG_RTL8192U) += rtl8192u/
|
|
||||||
obj-$(CONFIG_RTL8192E) += rtl8192e/
|
|
||||||
obj-$(CONFIG_RTL8723BS) += rtl8723bs/
|
|
||||||
+obj-$(CONFIG_RTL8723CS) += rtl8723cs/
|
|
||||||
obj-$(CONFIG_R8712U) += rtl8712/
|
|
||||||
obj-$(CONFIG_R8188EU) += rtl8188eu/
|
|
||||||
obj-$(CONFIG_RTS5208) += rts5208/
|
|
Loading…
Reference in a new issue